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1 Using the Manual

This manual uses the following abbreviations:

Abbreviations PI Place of Immission

SIM Shadow Impact Module

WTG Wind Turbine Generator

This manual uses the following terms:

Term Drag&Drop

Refers to a feature where you left-click an object, drag it to another area 
while keeping the mouse button clicked, and than release the mouse 
button in order to paste the object.

The following navigation features are available:

Hyper links If you read this manual on-screen, you may use cross references (e.g. 
“For further information, please refer to 3.2 Log Columns”) as hyper 
links. 

To get to the destination of the reference, simply click the respective 
link.
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2 Introduction

Thank you for purchasing our Shadow Memory software. 

Purpose of the 
software

Using the Log

Shadow Memory is used for Reading out the Shadow Memory Log 
from Shadow Impact Modules to a PC. The shadow impact data is 
output in a table format as shown in the example below.

View, print or filter the data retrieved according to various types of 
information and conditions as desired.

Can the log be 
modified?

In order to ensure the probative force of the log data, modifying the 
shadow impact logs is not possible.

Shadow Memory 4 window
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2.1 Technical Requirements

Before you use Shadow Memory to read out the shadow impact log, 
ensure that the following technical requirements are met:

SIM SIM ZM 3.0 or later

PC •OS Microsoft Windows 98 or later

•at least 64 MB RAM 

•2 MB of at least free hard disk space

•CD-ROM or DVD drive

Connection Shadow Impact Module 3.0 and 3.1

The data must be read out on site via a serial interface (COM port). You 
will need a serial cable (Rx and Tx not crossed over, 9 pin plug).

Shadow Impact Module 3.5 or later

The data must be read out using a network connection. Connect to the 
SIM via WLAN or using a network cable (crossed Ethernet cable).
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2.2 Software Installation

How to install Shadow Memory

1. Exit all other applications.

2. Insert the Shadow Memory CD-ROM into a CD-ROM or DVD drive. 
After a few seconds, the installation routine will start automatically. 

OR

Double-click the file Setup Shadow Memory 4.1.0.4.exe located on 
your PC.

3. Choose an installation language (Dansk/Deutsch/English).

4. Follow the on-screen instructions.

After a few minutes, the installation process is finished, and Shadow 
Memory is ready to be used.
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2.3 Before reading out the log

The steps to be performed prior to reading out the log depend on the 
type of read-out process used as follows:

For serial connection 
(SIM 3.0 + SIM 3.1)

Steps to be performed prior to reading out via serial interface 
(SIM 3.0 und SIM 3.1)

Use a serial (Rx and Tx not crossed over, 9 pin plug) to connect COM 
port 1 of the Shadow Impact Module to a COM port of your 
computer.

Only qualified personnel is allowed to open the 
cabinet. The high voltage present inside the cabinet 
may cause serious injury or even death!

Now perform the following steps on the SIM in order to set the SIM to 
read-out mode:

1. Press the Enter button.

2. Press 2 to select the Settings menu.

3. Enter the four-digit password and press Enter.

4. Press 2 to select the Data menu.

5. In the Data menu press 5 to select the Log data submenu.

When the SIM is ready for the log transmission, the following will be 
displayed on the SIM display:

waiting for query

The SIM is now ready to transmit the log.

Note: The SIM will wait 5 minutes for a log request from the connected 
computer. If the shadow impact module does not receive a request 
within this time range, it will return to normal operation automatically.
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For network connection 
(SWM 3.5 or later)

Steps to be performed prior to reading out via network connection 
(SIM 3.5 or later)

There are two ways to set up a network connection between the 
computer and the SIM:

•direct connection to the SIM via crossed Ethernet cable.

•WLAN connection to the SIM 

Connection via 
Ethernet cable

Use a crossed Ethernet cable to connect the Ethernet port of the SIM 
to the Ethernet port of your computer.

Only qualified personnel is allowed to open the cabinet. 
Some of the components in the cabinet carry high 
voltages that may cause serious injuries or death!

WLAN connection If your read out the log via WLAN connection, there are no preparational 
steps to be performed on the SIM.
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Settings in Shadow 
Memory 4

2.4 Reading out the log

To read out the log, perform the following steps on your computer. 

•Start Shadow Memory 4.

•Select Options > Communication. The Communication window 
will be opened:

Communication window

Reading out via serial 
interface

Reading out via 
network connection

1. Under COM port settings select Active. Then, under ComPort 
select the COM port on your computer to which you have connected 
the serial cable.

OR

Under TCP/IP settings select Active and set the parameters as 
follows:

IP address 198.168.001.001 (IP address of the SIM)
Port 8000 (always)

Attention: 
If the data are read out using a direct Ethernet cable connection, the 
first three number sets of the IP address (“198.168.001” in the 
above example) must match the first three number sets of the IP 
address of the computer, whereas the last number set (“001” in the 
above example) must not match.

Port must always be set to 8000.
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2. Under TimeOut you can set the number of seconds, the computer 
will try to connect to the SIM.

3. Please click OK. 

4. In the lower left of the software window, set the period of which the 
data will be shown by entering or selecting the desired dates under 
From and Until.

5. Please click Read out. Shadow Memory will now read out the log 
and show the retrieved data in a table.
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3 The Log Data

After you have read out the data as described in Chapter 1, you will see 
a shadow impact log similar to the following.

  

Example of a read-out shadow impact log

A This line shows the name of the SIM, its location and the software 
version of the Shadow Impact Module.

B This line shows the log column headers. In the View menu, you can 
show or hide the available columns. For a list of available log 
columns with descriptions, please refer to "3.1 Log Columns" on 
page 13.

C In this area, you will see the log data read out from the SIM.
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3.1 Log Columns

Default Columns

If you have not yet changed the view of your shadow impact module, 
the screen will show the following default columns.

Shadow impact module in default view

Log column Explanation

Position Serial number of the log entry

Date Date of creation of the entry by the SIM

Time Time of creation of the entry by the SIM

PI Number of place of imission where the shadow impact event occurred

WTG Number of the wind turbine generator

Dayounter Indicates the period over which actual shadow impact has already 
taken place in the PI on the respective day (hh:mm:ss).

Yearcounter Indicates the period over which actual shadow impact has already 
taken place in the PI during the respective year (hh:mm:ss).

State WTG Indicates the status of the WTG as follows: 
1= WTG is running   OR   0 = WTG stopped.

Event Type of event, e. g. “Shadow impact end” or “Stop WTG”. For a detailed 
list of possible events, refer to "3.3 Shadow Impact Events" on page 18.
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Other Log Columns

In the View menu, you can show or hide the log columns listed as 
follows by activating or deactivating the respective check box.

Wind direction Wind direction at the location of the WTG

Wind speed Wind direction at the location of the WTG

Rotorspeed Rotational speed of the WTG in rpm

Nacelle position Indicated in degrees 

(0 ° = North, 90 ° = East, 180 ° = South, 270 ° = West)

Power Power of the WTG in kW

Temperature Temperature at the location of the WTG in °Celsius
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3.2 Customising the Log View

You can customise the view of your log. The customising options are 
described in the following.

Show/hide columns in 
the View menu

In the View menu, you can show or hide the available columns. For a 
list of available log columns with descriptions, please refer to "3.1 Log
Columns" on page 13.

To show or hide a log column, open the View menu and activate or 
deactivate the desired items.

Changing the column 
order

You can change the order of the log columns through simple 
Drag&Drop operations. Please refer to the following example:

View before moving the columns

View after moving the columns
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Sorting by log columns You can sort the data by various log columns. Simply click on the 
header of the column by which you would like to sort the data. In the 
following example, the data have been sorted by the Date column 
which is also indicated by the small triangle shown next to the column 
header.

Sorting by the Date column

Show/hide entries If you move the mouse over the area to the right of a log header and 
make a left-click, a drop-down menu will open.

Example: drop-down menu of the Event column

If you activate one of the five log entries, only the lines containing that 
entry will be shown. It is also possible to activate more than one entry 
at the same time. To return to the display of all data, select (All).
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Customised filters If you press (Custom ...) in the drop-down menu shown above, the 
Custom Filter window will open. Here you can set two filter conditions 
and connect them using AND or OR.

For instance, to determine the events WTG 2 and WTG 4 have caused 
in the place of immission 1, set the Custom Filter window of the 
columns WTG and PI as shown in the two following figures:

Customised Filter window of the WTG column.

Customised Filter window of the PI column

After you have performed these settings, the log table shows only the 
data of the following relations PI 1 to WTG 2 und PI 1 to WTG 4.

Expanded filter In addition to the log customising options described above, there is the 
Expanded Filter feature in the Options menu. For a description of this 
feature, please refer to chapter 5 "Troubleshooting" on page 24.
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3.3 Shadow Impact Events

In the Event column, the shadow impact module can display the events 
described in the following:

Event Explanation

Theoretical
shadow impact

The corresponding WTG causes theoretical shadow impact in the 
corresponding PI. However, the direct sun radiation is not strong 
enough to cause real shadow impact.

Shadow impact The corresponding WTG causes real shadow impact in the 
corresponding PI. The direct sun radiation is strong enough to cause 
real shadow impact.

Stop WTG The corresponding WTG was stopped.

Shadow impact end The shadow impact in the corresponding PI caused by the 
corresponding WTG has ended as the sun has changed its position.

Start WTG The corresponding WTG has been released by the SIM.
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4 Menus and Functions in Shadow Memory

This chapter describes how to customise the data read out according to 
your requirements. Furthermore, you it will outline the functions 
available in Shadow Memory.

4.1 File menu

File > Exit Exits the program.

4.2 View menu

View In the View menu, you can show or hide the available items. For a list 
of available log items with descriptions, please refer to "3.1 Log
Columns" on page 13.

4.3 Protocol menu

Protocol > Open Opens an existing log.

Protocol > Save Saves a log that has been read out.

Protocol > Print Use this option to print a saved log. You can set the following 
parameters:

Printer Select the printer to be used. 

Copies Set the number of copies to be printed.

Export If you want to output the log to a file instead of print 
it, select one of the following formats by clicking: 
CSV, PDF or HTML.

Cancel Click this button to cancel the settings and the print 
process.

Protocol > Operating 
Protocol

The operating protocol is read out separately. Here, you can show, e.g. 
the date and time of a light sensor failure.
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4.4 Statistics menu

Statistics > Shadow 
impact

Selecting Statistics > Shadow impact will open the following window:

Statistics > Shadow impact window

In this window you can display the following statistics by clicking the 
corresponding button:

Actual Shadow 
Impact 

Displays statistics of the actual shadow impact 
caused in the corresponding PI by the corresponding 
WTG.

Shadow 
impact without 
WTG stop

Displays the shadow impact that would have 
occurred in the corresponding PI caused by the 
corresponding WTG had there not been a Shadow 
Impact Module. 

Max. possible 
shadow impact

Displays statistics of the maximum shadow impact 
that can be caused theoretically by the 
corresponding WTG in the corresponding PI.

The information in the window above shows e.g. the following: 

•WTG 2 has caused shadow impact in PI 1 for 4 minutes.

•WTG 1 has caused shadow impact in PI 2 for 10 minutes.

To close the shadow impact statistics, click Close.
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Statistics > Holding 
time 

Selecting Statistics > Holding time will open the following window:

Statistics > Holding time window

This window shows the period over which each WTG was shut down. 
The period is displayed as follows: day/hour/minute.

To close the shadow impact statistics, click Close.

4.5 Options menu 

Select Options > 
Communication

Under Options > Communication, you can set the connection to the 
SIM. For a description of this procedure, please refer to “2.4 Reading
out the log" on page 10 .

Options > Languages Here you can select one of the following languages: Deutsch, English 
and Dansk. 

Options > Marking Here you can activate or deactivate the coloured background of the 
events Start WTG, Stop WTG, Shadow Impact, End of Shadow 
Impact and Theoretical Shadow Impact by selecting or deselecting 
the corresponding check box. 

Example: If you select End of Shadow Impact the log will show all 
events of this type with a blue background.
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Options > 
Expanded filter

After selecting this option, you will see a dark-grey field above the 
column headers displaying the following:

Drag a column header here to group by that column.

For example, if you drag and drop the column header WTG to the grey 
field, your log will be displayed in way similar to the following:

Group by column header WTG

If you now click on the “+” next to WTG : 2, all data corresponding to 
WTG 2 will be displayed as shown in the following.

Displaying the data corresponding to WTG 2

To return to the original log display, simply drag the WTG column header 
back to the column header bar. 

Of course, using the  Expanded filter  option, you can also group the 
data by all other headers as desired.
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Info > Info about 
Shadow Memory 4

4.6 Info menu

Here you will find the following information

•Information on the software version

•Our contact information

•System information on your operating system

Info about Shadow Memory 4 window
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5 Troubleshooting

If you should encounter any problems with reading out the shadow 
impact module data, please read the information in this chapter. You 
may be able to quickly find the cause & solution for your problem.

In case the information provided does not solve your problem, you can 
reach us at +49 46 39 78 33 0.

Problem Possible cause and solution

The log table is empty.

Despite the fact that 
the log has been read 
out, the program does 
not display any data. 

You have selected a period during which the SIM did not record any 
data. 

•Check the period and change it as necessary. See step 4 under 2.4 
"Reading out the log" on page 10.

... more problem descriptions on the next page ...
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Problem Possible cause and solution

It is not possible to 
read out the log using a 
serial connection.

When trying to read out 
the log using a serial 
connection, Shadow 
Memory displays the 
following message: 
„The connection to the 
module was 
interrupted“.

The cable you are using is not suitable. Check if the cable used to 
connect the PC to the SIM complies with the following requirements:

•The cable used for transmission of data is a serial cable.

•The cable is a straight cable (Rx and Tx not crossed over).

•The cable has a 9 pin plug.

•The cable is in a good condition (not kinked or porous).

•The cable is connected firmly.

The SIM has not been set to read-out mode. 

•Set the SIM to read-out mode, see 2.3 "Before reading out the log" 
on page 8.

The data cannot be 
read out via network 
connection.

When trying to read out 
the log using a network 
connection (cable or 
WLAN), Shadow 
Memory displays the 
following message: 
„The connection to the 
module was 
interrupted.“

The cable used for a physical connection is not suitable. Check if the 
cable used to connect the PC to the SIM complies with the following 
requirements:

•The cable used is a crossed Ethernet cable.

•The cable is in a good condition (not kinked or porous).

•The cable is connected firmly.

The IP addresses used are wrong:

•When reading out the data using a physical connection (cable), the 
first three number sets of the IP addresses of Notebook and SIM 
must match.

•In this case, the fourth number set must not be identical.
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