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1 About the manual

This manual documents the range of functions of Shadow Manager 4 (SM4), the operating software
for the Shadow Master Unit V4 for our system for shadow impact monitoring and species conserva-
tion. As the software we describe here offers even more options than its predecessor, the user
handbook has become significantly bigger. But don’t worry, we have designed the SM4 user inter-
face to be user friendly and intuitive to operate so that experienced users will be able to perform
many tasks even without the manual. 

If you are not yet familiar with SM4, please carefully read through the relevant information in this
manual to ensure that the system for shadow impact monitoring and species conservation operates
correctly at all times. This will ensure that your wind turbine generators are only shut down when it
is necessary to satisfy residents and the authorities – as often as necessary, as infrequently as
possible.

Structure of the manual – what is relevant for whom1.1

This documentation serves as a guideline for the beginner, but at the same time as a reference do-
cument for experienced users.

How to use this manual:

· Information on a specific topic can be found in the Contents.

· Step-by-step instructions on standard tasks can be found using the Practical section
(chapter 3).

· An explanation of all menus, parameters etc. can be found in the Reference section
(chapter 4).

· Information on a specific term can be found using the Index (Appendix).

· Special SM4 terms are explained in the glossary .

· If SM4 does not operate as expected at any time, you can find helpful information in the
Troubleshooting chapter. 

472
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Conventions1.2

The following conventions apply in this manual:

Designation Meaning

Bold

The names of menus, windows, buttons etc. in the body text are writ-
ten in bold.

Example: Open the Places of Immission window. 

Bold type is also used to highlight important parts within a text block.

Italics, blue
Path names are printed in blue and italics.

Example: Project > Project Settings > Ethernet settings

This sign indicates that a parameter/setting/function needs to be defi-
ned particularly carefully, as an error could result in serious conse-
quences.

This symbol refers to a practical example or a practical tip that exists
for the respective topic.

This symbol indicates helpful information.

8  This symbol identifies step-by-step instructions.

Blue, underlined Cross-references are highlighted in blue font color and underlined. Click
on the cross-reference to jump to its target. 

Green background
In the explanation for the parameters, you will find information on the
default, input format, input range, etc. highlighted green, where appli-
cable and appropriate.
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Abbreviations1.3

The following abbreviations are used in this manual:

Abbr. Term Information

CMDR Cyclic Multi Data
Recording

A data set defined in SM4 for automatic regular recor-
ding of measured values including specifications for pro-
viding the results in .csv format.

LS Light sensor
· measures the sunlight’s direct intensity of illumination

to enable the SMU to determine whether shadow
impact effects are possible at all at a given point in
time

· provides information on time and location to the SMU
(via a GPS receiver) 

POI Place of immission Building with walls and areas to be protected from
shadow impact.

OSS On-Demand Shadow
Shutdowns 

OSS can be used to allow residents of places of
immission to  switch off WTGs that cause shadow
impact using an app on their smartphone.

SM4 Shadow Manager 4 The operating software for the system for shadow
impact monitoring and species conservation described in
this manual. 

SMU Shadow Master Unit The central unit of the system for shadow impact
monitoring and species conservation.

SIIU Shadow Impact Interface
Unit

Hardware component that receives analog measurement
signals (e.g., wind speed) in a WTG and transmits them
to the SMU via a TCP network.

SNU Sensor Node Unit Standalone optional hardware used to connect sensors
in such a way that commands and answers can be com-
municated in a cyber-secure manner.

SS Special shutdown Shutdown conditions not involving shadow impact (e.g.
for bat or bird protection).

TP Third Party –

WCU Windfarm Communication
Unit

Stand-alone optional hardware for connecting remote
wind farms or wind farm segments, which offers its own
shutdown calendar for use in the event of communication
failures.

WTG Wind Turbine Generator –
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Digital navigation aids1.4

If you read this manual in digital form on a screen, in many places you can click on a cross refe-
rence to jump directly to a section with further information. Cross-references are highlighted in blue
fonts and underlined. In PDF Reader, you can also display the content at the left-hand side of the
window and use it to navigate.
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2 Introduction

The purpose of the Shadow Manager 4 (SM4) software is to configure and monitor the Shadow
Master Unit (SMU), the central component of the system for shadow impact monitoring and species
conservation. Users include predominantly commissioning engineers, service personnel and technical
system management employees. 

User identification and a password are required to log in to an SMU. The user is set to admin and
the password to admin upon delivery. A dongle is always required to make changes to the SMU
settings.

Our system for shadow impact monitoring and species conservation enables you to comply with a
large number of permit conditions that apply to wind turbine generators (WTG), primarily with refe-
rence to shadow impact and species conservation. The following diagram and brief information will
help you to get an initial overview of the main components of the system, and in particular to identify
the function/role of each component.

1 Shadow Master Unit (SMU)  - is located in the WTG or in the hand-over station.The SMU re-
ceives the project data via Shadow Manager 4, calculates shadow impact periods, shuts down
the WTGs when required, records measurement data and alarms, sends the corresponding
email notifications and records log data.

2 Places of Immission (POI) - Buildings with walls and areas requiring protection

3 Light sensor - mounted on the nacelle of a WTG, primarily measures the intensity of illuminati-
on of the sunlight.

4 Shadow Manager 4 (SM4) - operating software

The project data (coordinates of the WTGs and POIs, permitted shadow impact periods, shut-
down conditions for species conservation and other shutdown specifications) is defined in
SM4. It also reads out measurement data and logs.
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5 Ethernet connection with encrypted data transmission - is used to transfer project data from
SM4 to the SMU and measurement data as well as for retrieving the SMU logs.

The configuration of the Shadow Master Unit (SMU) can only be performed via SM4. Unlike earlier
versions, operation and thus configuration can no longer be carried out directly on the SMU. 

After you have gained an initial overview of the basic elements of the system for shadow impact
monitoring and species conservation, you will find more detailed information on the overall system
including its optional components in the next section.
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The hardware components of the system2.1

The system consists of the Shadow Master Unit (SMU) and, depending on the application, different
sensors. The required meteorological readings can be obtained via the communication interface to
the wind turbine generators (WTG), on the one hand. On the other, there is also the option to
connect other measurement units to the SMU, e.g., a climate sensor, laser precipitation sensor or
hygro-thermo sensor. At least one light sensor must be installed when using the system for shadow
monitoring.

The following table lists the functions and tasks of all core and optional hardware components of the
system for shadow impact monitoring and species conservation.

Component Function

Shadow Manager Unit
(SMU for short, central com-
ponent of the system for
shadow impact monitoring and
species conservation)

· contains all configuration data of Shadow Manager 4 (SM4) (e.g.,
coordinates of the WTGs and places of immission, permitted
shadow impact periods, shutdown conditions for species conserva-
tion) 

· calculates the shadow impact periods

· communicates with the connected sensors

· requests the current operating data from the WTG

· sends stop and start commands to the WTG 

· logs all the relevant events

· records measurement data

· calculates the potential shadow impact one day in advance 
Purpose: If a place of immission (POI) is already “preloaded” due
to the shadow impact of another WTG that you are unable to
switch yourself, you should then surmise a worst-case scenario
and assume that the WTG runs continuously, and the rotor is al-
ways in a 90 °position with respect to the sun.)

Light Sensor

(mounted on the nacelle of at
least one WTG)

· measures the sunlight’s direct intensity of illumination to enable the
SMU to determine whether shadow impact effects are possible at
all at a given point in time

· provides information on time and location to the SMU (via a GPS
receiver) 

Laser precipitation sensor
· measures the precipitation amount and optionally the outside tem-

perature

Hygro-thermo sensor
· measures humidity and outside temperature

Climate sensor
· measures, e.g., temperature, precipitation amount, relative humidi-

ty and atmospheric pressure

iSpin sensor
· enables for example the monitoring and optimization of the perfor-

mance of WTGs
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Component Function

Sensor Node Unit (SNU)
· standalone optional hardware used to connect sensors in such a

way that commands and answers can be communicated in a cyber-
secure manner

Signal converter unit
· enables communication between the SMU and the sensors via a

network

Windfarm Communication
Unit (WCU)

· stand-alone optional hardware for cost-effective AND cyber-secure
connection of remote wind farms or wind farm segments

· offers a backup shutdown calendar for use in the event of a com-
munication failure and writes its own protocols

The following section provides information on the options offered by SM4 and how this software is
used to configure the SMU.
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Overview of Shadow Manager 4 functions2.2

The configuration and monitoring of the Shadow Master Unit (SMU) is performed in SM4. Unlike ear-
lier, operation and thus configuration can no longer be carried out directly on the SMU.

Because SM4 not only enables you to set the project-specific data, but also offers other helpful op-
tions, a corresponding overview of its functions is provided in this section.

2.2.1 Functions relevant to a project

To ensure the system can fulfill its most important task, namely shutting down wind turbine
generators because of shadow impact or for bat protection, data specific to the project must first
be created in SM4 and then stored in the SMU. 

Moreover, further settings you can make project-specific settings – the most important functions are
listed below. 

Several functions can only be used together with the dongle, which you can purchase from us.

The logged-in users must be authorized for specific right groups in order to transfer a configuration
to the SMU, download logs and use the online communication with the SMU (see Shadow Manager
Interface User Management window ).

Set main elements of a shadow impact scenario

· Project data (see Project Data window )

· Wind Turbine Generators (see Wind Turbine Generators window )

· Places of Immission (see Places of Immission window )

· Walls and Areas of the POI to be protected (see Edit Walls and Areas sub window )

Amongst other things, data on the length of time permitted to be impacted by shadow (per day and
year) according to the authorities is specified when defining places of immission (POI). The project
is complete once the elements listed above have been correctly defined. Project data can then be
transferred to configure the SMU, making it possible to adhere to requirements by carrying out the
corresponding shutdown operations.

Create optional elements of a shutdown scenario

The scenario can also be extended by the following shutdown processes and shutdown elements:

· Calendar periods for WTG shutdown (see section Shutdown Calendar window )

· Time periods with/without monitoring (see Shadow Impact Monitoring Periods sub window )

· Complex special shutdowns for species conservation (see Special Shutdowns window )
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· Power thresholds for the purpose of yield optimization (see “Combinations” under WTG
Combinations sub window )

· Exclude individual combinations of WTGs and POIs, e.g., due to obstructions (see WTG
Combinations sub window

Define measurement data recordings

You can configure the SMU in such a way that it logs user-defined measurement data automatically.
The following options are available:

· Single Data Recordings: record individually selectable measurement data and connect/compare
them. The corresponding data is output as a separate log.

· Cyclic Multi Data Recording (CMDR): have a set of readings recorded periodically and define
settings for outputting the results in .csv format. 

See also:

Single Data Recordings window

Cyclic Multi Data Recordings window

Perform alarm settings

You can specify when the SMU triggers an alarm for which system/unit and whether an email notifi-
cation is sent at the same time.

See also Alarm Settings window .

Perform hardware settings

Here you can change the defaults of the SMU and the sensors connected to it.

See also Hardware .

Visually check the locations of WTG and POI

You can open an overview map to visually check the locations of the WTGs and the POIs. It is also
possible to export the data to Google Earth, see Overview Map window .

2.2.2 Online communication with the Shadow Master Unit (SMU)

In addition to the configuration of the SMU, SM4 also offers the option of calling up the live data of
the sensors and WTGs connected to the SMU and performing switching tests and test alarms. For
further information on this topic, please refer to the SMU menu  section in the reference part.
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2.2.3 Log functions

The SMU generates various logs, which you can download and display in SM4 as well as filter, ex-
port, and print. 

For further information, please refer to Logs menu .

2.2.4 Practical tools

Simulate shadow impact scenario

You can calculate the defined shadow impact scenario according to the most unfavorable conditions
(worst-case) for different periods of time. This calculation is performed in SM4. See also Simulation
window .

Check project integrity

SM4 has an integrity module installed, which can be used to test for plausibility in a project (incom-
plete references, missing parameters and other “errors”) prior to uploading to the SMU. See also
Project Integrity window

Check the availability of the SMU

SM4 provides a window in which you can identify at a glance whether the SMU is ready for a
connection. This prevents you from making unsuccessful attempts to connect to the SMU. See also
SMU Connectivity window .

WTG Types

You can call up a window that lists what types of WTGs can be selected when creating wind turbine
generators in the project. See also WTG Types window .
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Notes on the working environment2.3

The menu structure, the assignment of the mouse keys and the design of the software are based on
the standard Windows interface and the corresponding operating elements. 

If you are not familiar with using Windows, please get up to date with basic Windows operations
(using a mouse, menu technique, changing sizes of windows etc.).

Shortcuts

To make working with SM4 easier, you can use the following standard shortcuts

Shortcut Function

CTRL-C Copy

CTRL-V Paste

SHIFT-CTRL-O Open (a project)

SHIFT-CTRL-S Save (a project)

The following SM4-specific shortcuts can also be used

Shortcut Function

SHIFT-CTRL-C Connect

SHIFT-CTRL-E Single data recordings

SHIFT-CTRL-Z Cyclic multi data recordings

SHIFT-CTRL-L Local log files

SHIFT-CTRL-I Integrity check

SHIFT-CTRL-P Visualization

Furthermore, you may use the following function keys...

Shortcut Function

F1 Online Help
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Shortcut Function

F11 Night Slice Shutdowns

F12 Special Shutdowns

... as well as the following cursor keys

Shortcut Function

Arrow up/down Scroll through a list

Arrow right Expand a sublevel

Arrow left Collapse a sublevel

Enter Expand/collapse all sublevels
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Shadow Manager 4 – Requirements and Installation2.4

There are 2 versions of SM4: 

· desktop version that is installed on a PC like a conventional program

· mobile version that is started from a USB stick. 

The latest version of the Shadow Manager software can be downloaded from our website
(www.northtec.de).

The following technical requirements must be fulfilled before using Shadow Manager 4 (SM4):

Prerequisites Description

SMU Shadow Master Unit 4.0 or higher

PC
· a minimum of 4 GB RAM 

· at least 100 MB free hard disk space

· USB port for software dongle

· network port/internet connection

Operating system
· SM4 runs on computers with Windows 7 or a higher Microsoft operating

system 

· Limited functionality is also available for Windows XP, which is no longer
supported. 

Rights Running the desktop version: administrator rights required

Running the mobile version: no administrator rights required

Dongle To enable the SM4 to be used to its full extent, purchase a USB hardware
dongle from us, which we will then send to you.

After you have downloaded the desired version, double-click on the .exe file and follow the instructi-
ons on the screen.
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General properties of the software2.5

SM4 is implemented as an MDI (multiple document interface) application, i.e., there is a main
window in which other sub windows can be opened.

The size of the sub windows can be changed, and they can be freely placed in the main window. If
a sub window is closed and then opened at a later point in time, it will be displayed in the same po-
sition.

The user is thus able to create a specific arrangement of windows, which will remain in place even
after restarting. Each sub window only has one visible instance at a time. If you attempt to reopen a
window that is already open, it will simply display at the uppermost display level.

If an opened sub window takes up more space than is available, a scroll bar will appear. You can
use it to scroll to windows that are not displayed or not fully displayed.

The following windows deviate from the MDI structure:

· information or error windows (must be acknowledged)

· windows that require input to be entered before it makes sense to work in other windows (e.g.
Walls and Areas window)

If you enter an invalid value into an input field (incorrect value or incorrect input format), it will appear
highlighted in red:  

Press the Enter key or the Tab key to complete the current entry and jump to the next input field.

In certain windows, some buttons, e.g., Apply and Add, will not be activated until the mandatory
fields of the window have been filled out correctly.

If an input window for the menu item that you selected is not displayed, one reason
could be that the size of the SM4 main window has been reduced and the input window
has opened outside the visible area. 

Check whether a scroll bar has appeared at the right-hand side or bottom edge of the
SM4 main window, which you can use to move to the visible area.
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Operating the windows in SM42.6

You can press the Enter key or the Tab key to complete the current entry and jump to the next input
field in most input windows in SM4.

Many windows and sub windows in SM4 can be differentiated based on the type of operation as
follows:

· horizontally divided windows (e.g. Wind Turbine Generators and Places of Immission)

· vertically divided windows (e.g. Special Shutdowns, Night Slice Shutdowns, Hardware
Assignments, Interface Cards)

· menu tree windows (e.g. Application Settings) 

The following section provides basic details on working with the different types of windows.

2.6.1 List windows

Examples of list windows in SM4:

Wind Turbine Generators, Places of Immission , Logs from Local LogPool 

List window, example: Places of Immission

Operating notes for list windows

· The list area is a pure display area, no editing is possible.

· To edit a record, select it in the list by clicking on it (record will be highlighted in blue) and then
click Edit on the bottom right.
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· If you click on one of the buttons to sub-windows, a window opens, which refers in each case to
the dataset selected in the list (highlighted in blue).

· To add a record, click Add on the right.

· The numbers in the middle box below refer to the record selected in the list.

· Move columns: columns can be moved by drag and drop.

· Sort by columns: You can sort by a column title by clicking on it; if you click on the same column
title again, the sort order will change from ascending to descending or vice versa.
You can also sort by multiple column titles (criteria). To do this, first press and hold the Shift
key and then click on the desired column titles. The sorting is then carried out in the order in
which you click on the titles.

For some lists, you can copy the data from existing records so that you do not have to redefine all
the data for each new object. 
For more information, see the practical tip in the Wind turbines window .

2.6.2 Vertically divided windows

Vertically split windows in SM4 include: Special Shutdowns, Night Slice Shutdowns, Single Data
Recordings, Interface Cards, Interface Connectors, Hardware Assignments

Vertically divided window, example Night Slice Shutdowns

98
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Operating instructions for vertically divided windows 

· Display area: Here, already created data records can be shown/hidden. To show/hide re-
cords individually, click on the small arrows displayed directly in front of a record. 

· To show/hide all records at once, corresponding buttons are available at the bottom left.

· To show/hide a single sub-level, right-click on the respective level and select Collapse All or
ExpandAll.

· Settings area: Here you make the settings for the data set that you have previously selected
in the left area.

· If no data set is displayed on the left, you must first add a data set on the right by selecting a
WEA at the top and then clicking on  Add at the bottom.

· If no record appears in the right pane, you probably did not select a record or an editable re-
cord on the left. Select a dataset on the left - you may need to click on the small arrow in
front of the dataset to get to an editable dataset. Make sure that the record you want to edit
is highlighted in blue on the left side of the window. 

· Logical links can be created in windows such as Special Shutdowns, Bat Shutdowns, and
Individual Records. If there are several conditions within a condition block, then these are
linked by AND, i.e. only if all conditions are fulfilled, the shutdown takes place. If there are se-
veral condition blocks, then these blocks are linked by OR, i.e. even if the conditions of one
block are fulfilled, the shutdown takes place.

2.6.3 Menu tree windows

Menu tree windows in SM4:

Application Settings, Project Settings
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Menu tree windows, example Application Settings

Operating instructions for menu tree windows

· A menu tree is located at the left-hand side. Click on + and - to expand or collapse it.

· The settings area selected on the left can be edited in the right half of the window. 

· The Application Settings window must be closed by clicking on OK or Cancel before another
process can be carried out.
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Sequence of a configuration session in SM42.7

It is important to understand in general how SM4 is used to configure the Shadow Master Unit
(SMU). For this reason, this chapter is intended for you to familiarize yourself with a configuration
session and to explain what takes place in the background. 

To ensure the system for shadow impact monitoring and species conservation is able to fulfill its
most important task, namely shutting down wind turbine generators because of shadow impact or
bat protection etc., it is necessary that data specific to the project is first created in SM4.

To do so, a project is created or an existing one is opened in SM4. This project contains all data
and settings relevant to a specific wind park or its SMU and the connected sensors. If a project is
complete and inherently consistent, SM4 can derive the configuration data for the SMU. The project
and the configuration data are then encrypted and transferred to the SMU. Once it is there, the
SMU stores the project as a file and is then configured according to the configuration data. Only
then is it possible for it to fulfill its main task: shutting down and (restarting) WTGs according to the
specifications of the authorities and other factors (e.g., yield optimization). This sequence is exem-
plified in the following overview.

The sequence of a configuration session in SM4 can be divided into three steps:

Step 1: Create/open a project 29
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Step 2: Edit project

Step 3: Configure the SMU

2.7.1 Configuration step 1: Create/open project

In most cases, you will use Shadow Manager 4 (SM4) to perform changes to an existing configurati-
on of a Shadow Master Unit (SMU). To do so, you should open the project stored in the SMU and
not, if applicable, the project saved locally on the computer. This will prevent possible conflicts bet-
ween different project versions. Only if you are absolutely certain that an up-to-date project file is
stored on your computer, and that it corresponds to the configuration of the SMU, can you forgo
opening the SMU project.

You therefore have 3 options for Step 1.

§ Create a new project: Open the File menu, select New Project and follow the instructions on
the screen.

OR

§ Open a locally saved project: Open the File menu, select Open Project (Local) and select
the project that you want to edit.

OR

§ Open a project from the SMU: Click on File, select Open Project (SMU) and follow the in-
structions on the screen. 
NOTE: This option is only available if you are connected to the SMU!

2.7.2 Configuration step 2: Edit project

In this step, you define or edit all data and settings that are relevant to the respective wind park or
its SMU and the connected sensors based on the information in the Practical section  and Refe-
rence part  od these instructions.

NOTE

You should document every change you perform to a configuration in the Project Data window (Pro-
ject > Project Data) under Log book, to ensure you and other people are able to track changes at
all times (see  Project Data window ). 
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2.7.3 Configuration step 3: Configure SMU

After you have completely created the project or performed all changes, select the Configuration
menu item from the Project menu.   The Check Configuration window will now open, where you
can first test whether the configurations derived from the project fulfill all the requirements. Only
when this is the case can you initiate the actual transfer of the configuration to the SMU (see section
Check Configuration window ).

NOTE

Step 3 can only be performed if there is a connection to the respective SMU, the user has been
authorized to configure the SMU and a dongle is present.

Please be very careful when entering values in Shadow Manager. Incorrect parameter
values may result in avoidable wear and tear, loss of earnings, problems with authorities
or residents and in the worst-case force operators to decommission wind turbine
generators.  

· Where possible, download an already existing project from the SMU prior to editing it.
This will ensure that you work with the version that corresponds to the current configu-
ration of the SMU.

· Document every change that you perform on a project in the Log book in the Project
Data window.

165
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3 Practical part

This chapter contains basic step-by-step instructions, which even SM4 beginners can use to operate
the software.

Based on examples, we describe typical operating sequences that you can use as a basis for your
own projects. If more complex setting steps are required or are optional, we will make reference to
the corresponding section in this manual where you can find more detailed information.

If SM4 does not operate as expected, consider whether the reason for this could be the
application settings (File > Application Settings) or the project settings (Project > Pro-
ject Settings).

Example: You enter the value “3.0” for the “Hub distance” in the Add/Edit WTG window
but SM4 does not accept the value (the field remains highlighted in red). You may have
set a “,” (comma instead of a point) in the Application Settings as the Decimal separa-
tor in the Country-Specific Settings.

If an input window for the menu item that you selected is not displayed, one reason
could be that the size of the SM4 main window has been reduced and the input window
has opened outside the visible area. 

Check whether a scroll bar has appeared at the right-hand side or bottom edge of the
SM4 main window, which you can use to move to the visible area.

We will now describe the steps that you need to perform before and after changing a project in
SM4.

Preparation: Load current configuration 

If you do not want to create a new project but would like to make changes to the current configurati-
on of the SMU, first open the current project from the SMU as follows:

8 Click on  or select File > Connect.

8 Enter Parameters, User and Password and click on Connect. For more information, see
Connect .

8 Select File > Open Project (SMU) and open the current project. 

OR (only if you are absolutely certain that an up-to-date project file is stored on your computer, and
that it is 100 % identical to the current configuration of the SMU)

8 Click on  or select File > Open Project.

8 Select the current configuration file (.smp4).

58
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Post-processing: Send Configuration

So that the SMU can work with the new configuration, the data must be transferred as follows.

8 Select Project > Configuration. The Check Configuration window will open.

8 Now click on Test Config. in the Configuration window.

8 If a green checkmark is now displayed in front of all 6 test points, you can click on Send Con-
fig. (Otherwise, you will need to conclude any pending tasks, see Check Configuration
window ).

8 The configuration you changed will now be sent to the SMU. Wait until the procedure is conclu-
ded.

165
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Example 1: Set up new WTG with new POI3.1

An existing project (sample project) that already contains five wind turbine generators (numbers 1-5)
and seven places of immission (numbers 1-7) is expanded by a WTG. Within the range of that
WTG, there is a POI which has not yet been defined. 

You will find corresponding step-by-step instructions below (remember to load the current project
file before you begin; please also read sections “Preparation“ and “Post-processing“ at the
beginning of chapter 3 .

3.1.1 Define new wind turbine (WTG)

8 Click on  or select Project > Wind Turbine Generators.

8 In the Wind Turbine Generators window a) click on Add WTG at the bottom right OR b)
select the dataset of an already defined WTG as a template from the list at the top of the
window and select Edit WTG OR c) double-click on a WTG to be used as a template.

8 If you used option b) or c) in the previous step, the WTG number field will now be highlighted
in orange. Enter the next free number here (in this example, this would be the No. 6) and then
enter an identifier that does not yet exist into the WTG identifier field. All fields should then
again be highlighted in green.

8 Enter or change the parameters for the new WTG in the Add/Edit WTG window. See
Add/Edit WTG window  for an explanation of the individual parameters.

8 Click on Add to save the dataset of the new WTG.

If entries in the window should NOT be applied, close the window with  and confirm
the question as to whether you want to discard the changes.

3.1.2 Define new immission point (POI)

8 Click on  or select Project > Places of Immission.

8 In the Places of Immission window, a) click on Add at the bottom right OR b) select the da-
taset of an already defined POI as a template from the list at the top of the window and select
Edit OR c) double-click on a POI to be used as a template. 

8 If you used option b) or c) in the previous step, the No. of place of immission field will now
be highlighted in orange. Enter the next free number here (in this example, this would be the

31

99



34Practical part > Example 1: Set up new WTG with new POI

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

No. 8) and then enter a name that does not yet exist in this configuration in the Name of place
of immission field. All fields should then again be highlighted in green.

8 Enter the parameters of the new POI in the Add/Edit Place of Immission window. For an ex-
planation of the individual parameters see Add/Edit Place of Immission sub window .

8 Click on Add to save the dataset of the new POI.

3.1.3 Define patio

8 Ensure that the newly added POI is selected in the Places of Immission window. Click on
Walls and Areas at the bottom left to open the like-named window. Click on + in the input area
at the bottom left and enter the coordinates of the corner points of the area to be protected.
The value under Length will be automatically determined and serve as a control. See also Edit
Walls and Areas sub window .

8 Click on Apply to save the new area.

Please be very careful when entering values in Shadow Manager. Incorrect pa-
rameter values may result in avoidable wear and tear, loss of earnings, pro-
blems with authorities or residents and in the worst-case force operators to
decommission wind turbine generators. 

If the field Length to a wall or area in meters (last field of the line) is highlighted in
yellow (instead of green), the entered values are not plausible or the maximum length
of a wall or side of an area according to the warning limit (File > Application
Settings > Warning limits) has been exceeded. Check that you have entered the
coordinates correctly. For further information, please refer to section Application
Settings window, Warning limits .
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Example 2: Check the position of POIs and WTGs
visually

3.2

Visually check whether the locations of the POIs and WTGs are correctly defined for an existing
project. You will find corresponding step-by-step instructions below (remember to load the current
project file before you begin; please also read sections “Preparation“ and “Post-processing“ at the
beginning of Chapter 3 ).

3.2.1 Open overview map

8 Click on  or select Project > Overview Map.

8 If applicable, select the option OSM (Open Street Map) at the top right under Maps.

8 All hidden maps of all WTGs (red), all POIs (green) and the geographical central point of the
WTGs, i.e., the project center (orange) will now be displayed in the map.

8 You can show/hide all individual elements by setting/removing checkmarks at the top right un-
der Elements.

8 In the map display area, you can zoom in (turn the mouse wheel or move two fingers outwards
on a touchpad) and shift the displayed section (hold down the left mouse button and move
mouse).

8 To move the “project center” back into the center of the display, click on Center Project on
the bottom right.

3.2.2 Display coordinates of WTGs and POIs in Google Earth

8 In the Overview Map window, click on Export Google Earth and save the export file (.kml).

8 Open the exported .kml file with Google Earth.

8 The WTGs and the POIs are also represented here by red squares or green dots. 

8 If you click on a WTG in Google Earth, a window with data relating to the respective WTG (ty-
pe, meters above sea level, hub height, etc.) will be displayed. 

8 If you click on a POI in Google Earth, a window with data relating to the respective POI
(address, building type, max. load, etc.) will be displayed. 

8 Using the Google Earth functions, you can also zoom in so far that you can identify, e.g., walls
and areas defined for a POI. 
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Example 3: Changed load times & utilization times
of a POI

3.3

The authorities have changed the permitted load times for a POI. In the future, moreover, new wor-
king hours and annual closures will apply to this POI that is used as a commercial property:

Old working hours New working hours

Mon–Fri, 09:00 AM to 05:00 PM, 
Sat 09:00 AM–02:00 PM

Annual closures: none

Mon–THU, 09:00 AM to 06:00 PM, 
Fri 09:00 AM–04:00 PM, Sat closed

Annual closures: every year from 15 to 31 July 

You will find corresponding step-by-step instructions below (remember to load the current project
file before you begin; please also read sections “Preparation“ and “Post-processing“ at the
beginning of chapter 3 .

3.3.1 Change maximum load times

8 Click on  or select Project > Places of Immission.

8 Select the POI whose load times must be changed from the list of POIs in the Places of
Immission window.

8 Click on Edit at the bottom right.

8 Enter the new value in minutes under Maximum permissible daily load.

8 Enter the new value in minutes under Maximum permissible annual load.

8 Click on Apply.

3.3.2 Change weekly recurring utilization times of the POI

8 Ensure that the POI to be changed is selected (highlighted in blue) in the Places of Immission
window.

8 Click on Shadow Impact Monitoring Periods on the bottom left.

8 All the periods of time in which the building is monitored are displayed with a red square in the
calendar in the Shadow Impact Monitoring Periods window at the right-hand side. Select
the currently defined time for Monday to Friday by clicking on the corresponding square or
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select the corresponding line below right in the window. A black arrow will be displayed in
front of the selected time:

8 Replace “Mon–Fri” with, e.g., “Mon–Thu” in the Comment field at the top left under Periods,
remove the checkmark set for Friday, replace 05:00 PM with 06:00 PM at End time and click
on Apply under Weekly.

8 Enter, e.g., “Fri” under Comment in the same input area, change the End time from 06:00
PM to 04:00 PM, remove all the checkmarks at the weekdays, set a checkmark for Friday
and click on the Add button under Weekly.

8 Select the “old time” for Saturday, 09:00 AM–02:00 PM at the right in the calendar or in the
list at the bottom right and click on the Delete button under Weekly.

3.3.3 Change periods without shadow monitoring (annual closures)

8 In the Periods area at the top left, select the option without shadow impact monitoring.

8 Also in the Periods area, enter, e.g., "Annual closure" at Comment. 

8 In the Time range area, enter 15.07.2017 as the Start date and 31.07.2017 as the End
date. 

8 Check the box Repeat annually and then click on the Add button below. 
If you have defined everything correctly, the following will now be displayed at the bottom right
of the Shadow Impact Monitoring Periods window:

8 Click on  at the top right to close the window.

Please be very careful when entering values in SM4. Incorrect parameter values may
result in avoidable wear and tear, loss of earnings, problems with authorities or resi-
dents, and, in the worst-case, force operators to decommission WTGs.
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Example 4: Editing the combination of POI and WTG3.4

Up to now, WTG 2 has caused shadow impact on POI 4 within an existing project. In the meantime,
a high building has been erected between POI 4 and WTG 2 meaning that, with immediate effect,
WTG 2 can no longer cause shadow impact on POI 4. Moreover, you have found out that POI 2, a
house, will not be lived in for an indeterminate period. 

To accommodate these changes, you must disable the combination of WTG 2 andPOI 4 and all
combinations with POI 2 in SM4. You will find corresponding step-by-step instructions below (re-
member to load the current project file before you begin; please also read sections “Preparation“
and “Post-processing“ at the beginning of chapter 3 ).

3.4.1 Deactivate combination of WTG 2 and POI 4

8 Click on  or select Project > Wind Turbine Generators.

8 Select WTG 2 in the list in the Wind Turbine Generators window and click on Combinations
at the bottom left. 

8 Remove the checkmark at POI 4 in the WTG Combinations window.

8 Click on Apply and then click on Close.

3.4.2 Deactivate all POI 2 combinations

8 Click on  or select Project > Places of Immission.

8 Select POI 2 in the list in the Places of Immission window and click on Combinations (bot-
tom). 

8 Click on Wizard at the bottom left in the POI Combinations window.

8 Ensure that the option Apply to selected POI is selected in the Combinations Matrix Wizard
window.

8 Click on the Deactivate Combinations button in the Combinations area and then click on
Close below.

8 All checkmarks will now be removed under Combination Active in the POI Combinations
window. Click on Close.

Please be very careful when entering values in SM4. Incorrect parameter values may
result in avoidable wear and tear, loss of earnings, problems with authorities or resi-
dents, and, in the worst-case, force operators to decommission WTGs.
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Example 5: Requirements for bat protection w/ night
windows

3.5

The authorities have prescribed a time slices shutdown for a WTG:

· The night is to be divided into 10 time slices for the wind speed condition.

· A further Time slice before sunset should make up 15 % of the night.

· The temperature conditions are the same for the individual months of the monitoring period.

· To prevent the system from being switched on and off repeatedly during gusty winds (high we-
ar) due to the WTG operating around the wind speed threshold value, it is permitted, according
to the requirements, that the WTG be switched off only when the wind speed condition has
been fulfilled constantly for a period of 30 minutes. The system may only be switched on again,
however, when the corresponding conditions have remained continuously absent for the same
period. Response delay and Release delay have been added to SM4 to ensure that these re-
quirements can be met.

· Moreover, it is known that the temperature measured by the WTG is always 1 °C below the ac-
tual temperature. This can be corrected by configuring the Offset parameter. 

The precise shutdown conditions for the individual slices are listed in the following table.

June July August September October

Temperature [°C]

16.0 15.0 14.5 15.5 9.0

Night time Wind speed [m/s]

-0.15–0.0 3.2 3.8 3.7 2.9 2.7

0.0–0.1 5.0 5.3 5.3 4.7 4.6

0.1–0.2 5.5 5.7 5.7 5.2 5.1

0.2–0.3 5.2 5.4 5.5 5.0 4.8

0.3–0.4 5.2 5.3 5.4 5.0 4.6

0.4–0.5 5.1 5.2 5.3 4.9 4.5

0.5–0.6 4.8 5.0 5.0 4.6 4.2

0.6–0.7 4.8 5.0 5.0 4.6 4.2

0.7–0.8 4.4 4.7 4.6 4.1 3.8

0.8–0.9 4.2 4.6 4.6 4.1 3.8

0.9–1.0 2.5 3.2 3.1 2.5 2.1

You will find corresponding step-by-step instructions below (remember to load the current project
file before you begin; please also read sections “Preparation“ and “Post-processing“ at the
beginning of Chapter 3 ).31
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3.5.1 Set up time slices

8 Open the Night Slice Shutdowns window (Switching & Measurement).

8 Select the respective WTG from the menu at the top right and click on +  Add below.

8 Click on the small arrow in front of the selected WTG at the top left in the window.

8 Click on the red highlighted Date range and enter 06/01 and 06/30 at the right. (If you do not
define a year, the conditions will also apply to subsequent years.) Click on Apply at the bot-
tom right in the window.

8 Click on the small arrow in front of the date range at the top left in the window. Now click on
the new Time slice 1 that appears (it will be highlighted in blue).

8 Select Time slice before sunset in the drop-down list at the right in the window, enter the va-
lue 15 % for Time slice length and click on Add at the bottom in the window.

8 Set up 10 Night time slices in the same way.

3.5.2 Rename condition blocks (optional)

8 Click on the arrow in front of Time slice before sunset and then on Condition block 1. Now
enter a block name on the right and click on Apply. 

8 Repeat this procedure for Night time slice 1 to Night time slice 10. 
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3.5.3 Define conditions for time slice before sunset

8 Click on the arrow in front of Condition block 1 and then on <empty>. The Condition input
area will now appear on the right. Now define the first condition for Condition block 1 in the
Conditions input area as follows:

8 Click on Add at the bottom right in the window and then define the second condition for Con-
dition block 1 in the Conditions input area as follows:

8 Subsequently set up all other Time slices and Condition blocks according to the requirements
of the authorities. For further information on the Shutdown condition input area, please refer
to Shutdown condition input area .213
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Please be very careful when entering values in SM4. Incorrect parameter values may
result in avoidable wear and tear, loss of earnings, problems with authorities or resi-
dents, and, in the worst-case, force operators to decommission WTGs.
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Example 6: Special shutdowns3.6

WTG 4 “1234” has been approved with the following requirements:

Bat protection 

Shutdown is prescribed in the months of May to September inclusive during the period of one
hour before sunset to one hour after sunrise if

· the wind speed is less than 6 m/s for at least 15 minutes and

· the outside temperature is +10 °C or more for at least 20 minutes

The same minimum time periods shall apply for starting up again, i.e., if, for example, the wind
speed is more than 6 m/s again, then this state must last for at least 15 minutes before the WTG is
started up again.

Bird protection

The same WTG should be shut down in the months of February to June inclusive every day from
7 minutes after sunrise to 257 minutes after sunrise.

Noise protection

The authorities prescribe that WTG 1 with the identification “1234” is to be shut down during the
period from 10:00 PM to 07:00 AM, if the nacelle is at an angle of between 90° and 180° and wind
speed is less than 7 m/s.

You will find corresponding step-by-step instructions below (remember to load the current project
file before you begin; please also read sections “Preparation“ and “Post-processing“ at the
beginning of Chapter 3 ).

3.6.1 Define bat protection condition block

8 Click on  or select Switching & Measurement > Special Shutdowns to open the Special
Shutdowns window.

8 At the right-hand side of the screen, select the WTG for which a special shutdown needs to be
defined for from the WTG drop-down list.

8 Click on + Add at the bottom right of the screen. The selected WTG will now appear on the
left-hand side of the screen.

8 Click on the small arrow in front of the blue highlighted WTG on the left-hand side of the
screen. Condition block 1, special shutdown will now be displayed underneath.

31



44Practical part > Example 6: Special shutdowns

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

8 Click on the small arrow in front of Condition block 1, special shutdown on the left-hand si-
de. <empty> will now be displayed below, which will later be replaced by the first condition.

8 Assign a name for the condition block at the right-hand side of the screen under Block name
(e.g., bat protection May–September) and select, for example, Bat protection in the Switch
reason drop-down list. 

The switch reason is important on three accounts:

· When entering a condition block for bat or bird protection, the correct switch reason
must be defined so that SM4 can run the applicable plausibility check .

· The Switch reason also tells the SMU in which particular log a shutdown is to be re-
corded.

· For the WTG type "via relay", additional DOs can be assigned a switch reason, see
Communication Parameters input area .

8 Click on Apply at the right-hand side of the screen.

8 Click on <empty> on the left-hand side of the screen. This line will then be highlighted in blue,
and the right-hand side of the screen will display the Condition input area.

8 Now define the first condition (from May to September) in the Condition area as follows:

8

8 Click on Add at the bottom right in the window.

8 Define the remaining three conditions of the first condition block in the same way:

214

117
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Condition 2 Condition 3 Condition 4

For more information, for example, on the Additional input area, which is refelcted in conditions 3
and 4, see the section on special shutdowns under Shutdown condition with Source = WTG .

Once all conditions have been correctly defined, Condition block 1 will be displayed on the left-hand
side of the window as follows:

3.6.2 Define bird protection condition block

The WTG should be shut down in the months of February to June inclusive every day from 7
minutes after sunrise to 257 minutes after sunrise.

8 Now define condition block 2 with 2 conditions as follows:

223
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Condition 1 Condition 2

Once all conditions have been correctly defined, Condition block 2 will be displayed on the left-hand
side of the window as follows:

3.6.3 Define noise protection condition block

The authorities prescribe that WTG 4 with the identification 1234 should be shut down from
10:00 PM to 07:00 AM if the nacelle’s angle is between 90° and 180° and the current wind speed is
less than 7 m/s.

8 Now define Condition block 3 with 4 conditions as follows:

Condition 1 Condition 2 Condition 3 Condition 4

10:00 PM.–07:00 AM Nacelle. 90° Nacelle. 180° Wind speed
< 7 m/s

Operand 1 Operand 1 Operand 1 Operand 1 Operand 1

Source Time WTG WTG WTG

Number - 1 “1234” 1 “1234” 1 “1234”

Reading Time range Nacelle angle Nacelle angle Wind speed

From 10:00:00 PM - - -

To 07:00:00 - - -

Offset - - - -

Hysteresis - - - -

Operation Operation Operation Operation Operation

Operation - greater than or equal to less than or equal to less than

Operand 2 Operand 2 Operand 2 Operand 2 Operand 2

Source - Fixed value Fixed value Fixed value

Fixed value - 90 ° 180 ° 7 m/s
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Once all conditions have been correctly defined, Condition block 3 will be displayed on the left-hand
side of the window as follows:

Please be very careful when entering values in SM4. Incorrect parameter values may
result in avoidable wear and tear, loss of earnings, problems with authorities or resi-
dents, and, in the worst-case, force operators to decommission WTGs.
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Example 7: Supplement a bat shutdown with
condition flags

3.7

A project contains a bat shutdown with night slices for May through September. It includes shut-
down conditions for wind speed and outdoor temperature. It has now been decided that the emitting
WTGs need not be shut down for the rest of the night once precipitation of 0.01 mm/h intensity has
been measured, even if it stops raining again in the course of the same night. 

In order to take precipitation into account, you could simply add the shutdown condition "Intensity of
climate sensor X less than + 0.1 mm/h" to the condition blocks in the Night Slice Shutdowns
window. However, to ensure that once precipitation has been measured, the system will not be
switched off again for the rest of the night, regardless of precipitation, the "Precipitation present"
status must be stored until the next morning. This requires the definition of a condition flag, which
will then be included in the night slice shutdown.

Prerequisite for the carrying out this practical example

Since we do not list each operating step individually in this practical example, the user is assumed to
have basic knowledge of SM4. 

The structure and operation of the vertically divided Condition Flags window essentially
corresponds to the Special Shutdowns window. If you are not familiar with the latter, please start
by reading the sections Vertically divided windows  and Special Shutdowns window . 

In addition, before executing this practical example, you should have executed Example 6  and
read the information in the Condition Flags window  section.

You will find corresponding step-by-step instructions below (remember to load the current project
file before you begin; please also read sections “Preparation“ and “Post-processing“ at the
beginning of chapter 3 ).

3.7.1 Define condition flags

8 Select Switching & Measurement> Condition Flags and in the Condition Flags window, defi-
ne the Set and Reset conditions to match the following screenshot:

Notes on the above screenshot

25 205

43

266

31
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· Under Set, you define the conditions that must apply for the flag to be set, i.e. for the result "1"
to be returned. 

· The Response delay field is designed to prevent the WTG from being switched too often.

· Since all of the defined conditions must apply, they are defined in one and the same condition
block (logical AND link).

· Reset defines the condition that must apply for the flag to be reset, i.e. for the result "0" to be
returned (during the day).

3.7.2 Include condition flags in night slice shutdown

8 Select Switching & Measurement > Night Slice Shutdowns and include the previously defined
condition flags in the Night Slice Shutdowns window as shown in the following screenshot:

Notes on the above screenshot

· The condition block with the shutdown conditions for wind speed and external temperature was
supplemented here by the condition flag defined in the previous section.

· As soon as this third shutdown condition is no longer fulfilled because climate sensor 1 measu-
res more than 0.1 mm/h of precipitation during the night in the period from 1 May to 30 Septem-
ber and therefore no longer returns the result "0" but "1” instead, the emitting WTG is started up
again. If it stops raining the same night, the WTG will not be shut down again, because the flag
is not reset until sunrise.

Now, of course, the condition blocks for all other time slices and months must be adjusted as well.
To do this, use the drag and drop functions, see section Easily duplicate special shutdowns using
drag & drop .

For more information on condition flags, see section Condition Flags window .

Please be very careful when entering values in SM4. Incorrect parameter values may
result in avoidable wear and tear, loss of earnings, problems with authorities or resi-
dents, and, in the worst-case, force operators to decommission WTGs.

235
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Example 8: Regular recording of several measured
values

3.8

For different WTGs of a project X, different measured values are to be recorded at certain time in-
tervals.

1) Data from WTG 17 every 12 minutes:

· Rotor speed (RotSpd) in 1/min

· WTG Status

· Wind speed (WSpd) in m/s

· Outdoor temperature (Temp.) in °C

· Power mean 10 min. (Pwr.)

· Nacelle position (NPos)

2) Wind every 10 minutes, only during the night

· WTG 1

· … 

· WTG 10

3) Temperatures every 10 minutes, between 10:00 a.m. and 10:00 p.m.

· Temperature of ISpin sensor 1

· External temperature of WTG 1

· Communication OK from WTG 10

In the output file, each measured value should appear in a separate column; the abbreviation and, if
applicable, the unit should be indicated in the title row.

The above task could also be accomplished with the help of single data recordings; however, due to
the scale, it is much more convenient and less time-consuming to make use of cyclic multi data re-
cordings (CMDR).

You will find corresponding step-by-step instructions below (remember to load the current project
file before you begin; please also read sections “Preparation“ and “Post-processing“ at the
beginning of Chapter 3 ).31
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3.8.1 Define interval timers (10 and 12 minutes)

8 Open the Interval Timer window (Switching & Measurement > Interval Timer).

8 Enter, e.g., the following for Name: 10min.

8 Enter or select 10 for interval.

8 Click on .

8 Enter, e.g., the following for Name: 12min

8 Enter 12 for interval.

8 Click on  and close the window.

3.8.2 Define multiple recordings

8 Open the Cyclic Multi Log Recordings (Switching & Measurement > Cyclic Multi Data
Recordings).

8 For Name, in the upper right corner, enter, e.g., the following: Data WTG 17.

8 Select the “12 minutes" interval from the Timer dropdown list.

8 In the File name field, enter, e.g.: WTG 17_123417.

NOTE: Observe the Windows file naming conventions and define unique names, since all .csv files
are output to the same folder.

8 Click on .

8 For Name, in the upper right corner, enter, e.g., the following: Wind 1-10.

8 Select the "10 minutes" interval from the Timer dropdown list.

8 In the File name field, enter, e.g.: Wind 1-10 and click on .

8 For Name, in the upper right corner, enter, e.g., the following: Temperatures.

8 Select the “10 minutes" interval from the Timer dropdown list.

8 In the File name field, enter, e.g.: Temperatures and click on .

The file names can still be changed later, please refer to (Export Cyclic Multi Log
window).

The next section explains how to add the reading points (what to record?) and conditions (when to
record?).
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3.8.3 Add reading points and conditions

8 Click on  at the bottom left of the window.

8 For the first recording (WTG 17), click on <empty> under User-defined reading points.

8 In the input area Measurement, select “WTG” for Source, 17 “123417” for No. and for

Reading point select the Rotor speed option. Click on .

8 Now define the reading points WTG status, Wind speed, External temperature, Average
power and Nacelle position in the same way, see figure below.

8 For the second recording (wind), click on <empty> under User-defined reading points.

8 In the input area Measurement, select “WTG” for source, 1 “12341” for No. and for Reading

select the Wind speed option. Click on . 

8 Repeat this procedure for WTGs 2 through 10.

8 Also for the second recording (wind), click on <empty> under Condition block 1.

8 In the Log Condition input area on the right, select Sun for Source and then Sunset to Sun-

rise for Reading point. Click on .

8 For the third recording (temperatures), click on <empty> under User-defined reading points.

8 In the Measurement input area, select ISpin sensor as the Source and Temperature as

Reading point. Click on . 

8 Now select the option WTG for Source, option 1 "12341" for No. and the Outdoor tempera-

ture option for Reading point. Click on . 

8 Now select the option WTG for Source, 10 “123410” for No, and the Communication OK

option for Reading point. Click on . 

8 Still in the third record (temperatures), click on <empty> under Condition block 1.

8 In the Log Condition input area on the right, select the Time option for Source and then the
Time Range option for Reading Point. Enter the value 10:00:00 AM for From and the value

22:00:00 PM for To. Click on .

If you have made all entries as described, the left half of the window should correspond to the
following screenshot. 
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3.8.4 Retrieve recorded data

After the project containing the CMDRs has been sent to the SMU and a certain time has elapsed,
in which the SMU was allowed to record values, these can be retrieved as follows: 

8 Click on  or select File > Connect.

8 Enter Parameters, User and Password and click on Connect. For further information see
Connect .

8 Once the Login LED at the bottom of the screen lights up green, select Logs > SMU Log Fi-
les.

8 In the Logs from the SMU window, click on .

8 Under Log, select the desired log of project X and click on .

8 Select Logs > Local Log Files to open the Logs from Local LogPool window.

8 Select Project X in the list at the top left.

8 Select the desired date range on the right and click on Export. The Export Cyclic Multi Log
window opens.

58
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3.8.5 Check the data display and export the data

8 In the Export Cyclic Multi Log, click on the recording named Data WTG 17 at the left edge
of the window to display it in the right half of the window, see the following screenshot
(section):

8 Under Settings, Column Header now enter the desired abbreviations for the reading points
and activate the boxes under Unit, see the following screenshot:

8 Click on Export, select a destination folder, and click on OK.

The data is now exported to a CSV file, which you can open with, e.g., Microsoft Excel.

The entry of the column headers and the selection and deselection of the unit can also
be done when creating the recordings in the Cyclic Multi Log window.

· While entering/changing the file name, the respective recording itself must be selected
in the directory tree in the left half of the window. Otherwise, the  button is not
available.

· If you do not enter anything under Settings, Column Header, the corresponding mea-
sured value will still be exported, but there will be no header.

· If you don’t want to export a certain measured value, you can now deselect it under
Export, Use.

For more information on exporting CMDRs, see section Cyclic Multi Data Recordings .261
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4 Reference part

The Shadow Manager 4 (SM4) setting windows and sub windows are arranged in menus and can
be called up through them. Some windows can be directly opened by clicking on the corresponding
button in the toolbar of the main window; see following figure. The function of individual symbols will
be displayed if you hover the mouse cursor over them for a moment. 

Symbols in the SM4 main window (with tool tip)

The following table provide you with an overview of the content of the individual menus.

Menu name   What you can do there

File
· Establish a connection to the SMU

· Open, create, download, save project files

· Print configuration log

· Application settings (e.g., language, country-specific settings,
warning limits, colors etc.)

Project  
· Define project data, wind turbine generators (WTG), places of

immission (POI), walls and areas, special shutdowns etc.

· Visually check the location-defined WTG and the POI (Overview
Map)

· Perform project settings

· Send project file to the SMU (Configuration)

Hardware
· Define and assign sensors and hardware

Switching & Measure-
ment

· Define WTG shutdowns

· Define measurement data recordings

· Define various accessories, e.g., condition flags, calculations, etc.

SMU
· Display and acknowledge alarms

· Manage users and assign right groups

· Set the Phone option

· Manually set the time

· Update SMU software

57
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Menu name   What you can do there

Realtime data
· Display live data (sensor data, counters, etc.) from the SMU

Logs
· Readout, display, filter, print and export logs,

Tools
· Simulate a shadow impact scenario

· Check project integrity

· Check the availability of the SMU

· Display WTG types that can be selected

· Reset window arrangement and screen detection

Help
· Display version information and check for new software version

Click on a menu item to jump directly to more information.
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File Menu4.1

The following table provides you with an overview of the File menu. 

Symbol Menu item Purpose 

Connect Establish an online connection to the SMU

New Project Create a new project

 

Open Project (Local) Open an existing project

 

Open Project (SMU) Open a project from the SMU (only possible if there is an
online connection to the SMU)

Save Project Save Project

Print Print configuration log – you can print the configuration log
to PDF or as a hard copy (in German or English)

Import swk file Import a project file that was created using Shadow
Manager 1

Application Settings   Define basic settings for SM4

Close Shadow Manager Exit

Click on a menu item to jump directly to more information.

58

64

66

66

67

67

69

73

92



58Reference part > File Menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

4.1.1 Connect

Purpose Establish online connection to SMU

Button

Path File > Connect 

Shortcut SHIFT-CTRL-C

Usage type Interactive

Reference Project

In this window you can establish an online connection to the SMU. To do this, you must know the IP
address and port of the SMU and be registered as a user.

 Connect window

The information, options or buttons are described in the following table 
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Input field/area Explanation/Function

IP address IP address of the SMU to be communicated with

Please note that SM4 IP addresses are always interpreted
decimally, even if there are leading zeros, which would sug-
gest an octal notation.

Example: 192.168.000.001 will be interpreted as
192.168.0.1 in network direction.

4 numbers, separated by a period, example:  192.0.2.42

Port Port number of the SMU you want to communicate with

Number from 1 to 65535

 Phonebook
Opens the Phonebook window. Here you can store the communication
parameters for various projects so that they can be conveniently selec-
ted from the Connect window.

· In the upper half of the input area the already created entries are lis-
ted. 

· In the lower half of the input area you can remove entries (mark the
corresponding entry at the top of the list), edit ( Replace button) or
add (Add button; enter information under IP Address, Port etc. be-
forehand).

· IP address, Port and Name are mandatory fields.

· Comment is an optional input field.

Name The name defined in the Phonebook window is displayed here.

Comment The comment that was defined in the Phonebook window is displayed
here, if applicable.

User Enter your user name here. Default setting on delivery: admin

NOTE

Entries are case-sensitive: "Admin" is a different user than "admin".

Password Enter your password here. Default setting on delivery: admin

Click on the eye  to show/hide the password.

NOTE

For security reasons, please change the user and the corresponding
password (admin and admin) preset at delivery as soon as you put
SM4 into operation (the change is made in the Shadow Manager
Interface User Administration window  and is only possible with don-
gle).

300
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Input field/area Explanation/Function

 Connect
Starts the connection process. This button changes depending on the
connection status and user data input:

1. not connected and no user data entered = deactivated

2. not connected and user data entered = activated

3. connected = changes to Disconnect button

User No. The number of the dongle used is displayed here.

Description The name of the owner of the dongle used is displayed here.
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4.1.1.1 Automatic check of the SMU time

When you connect to the SMU, the system automatically checks in the background whether the time
of the SMU (UTC) is different from the time of the computer (UTC). The deviation tolerance can be de-
fined in the Application Settings (File > Settings > Warning limits > Allowed deviation). You can set values
from one minute to one year (all values in minutes). 

If the deviation determined during automatic check exceeds the permitted value, the following window opens:

Warning: A time deviation was recognized 

Information about the Warning: A time deviation was recognized window

· This window displays the current time zone of the SMU, the time of the SMU (UTC) and the time
of the computer (UTC). The permitted deviation is also displayed.

· If you click on the gear symbol, you are taken directly to the Allowed deviation setting.

· The button Set time manually only appears if a dongle is connected. Clicking this button takes
you directly to the Set time manually window .

· Checking the time can also be triggered manually (SMU > Check Time Deviation), see Check
Time Deviation menu item .

305
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4.1.1.2 Information at the bottom of the main window

In the status bar at the bottom of the SM4 main window, you will find information about the state of
the connection between SM4 and the SMU (left-hand) and dongle information (right-hand).

Status LED and Dongle information

The status LEDs indicate the connection status of the data traffic between SM4 and the SMU, simi-
lar to a telephone modem.

Element Explanation/function

Login

 connected

 not connected

This LED is lit green if a connection to the SMU via user name/password
has been established successfully. The LED turns off as soon as the
logout command is sent to the module (File > Connect > Disconnect but-
ton) or the corresponding Connect timeout (File > Settings > Communi-
cation parameters) has expired while waiting for a reaction from the
SMU. 

TX:

 transmission

 no transmission

This LED is lit, while SM4 transmits a command or data to the SMU.
Since this usually takes only a short time, the LED usually just flashes.

This LED is also switched on at the beginning of a connection setup and
remains lit until either the connection has been established or the
Connect timeout has been exceeded. 

RX:

 reception

no reception

If this LED is lit, this means that a readout process has been started in
SM4. It remains lit until a response can be read by the module (which ta-
kes different lengths of time depending on the request).

ST

(session time)

Once a connection to an SMU has been established, the remaining
connection time until the connection is automatically terminated due to in-
activity is displayed here. Every time you press the left mouse button or
use the keyboard in SM4, the session time is reset to the value defined in
the Application Settings for Session time (File > Application Settings >
General > Communication parameters).

If ST: 03:36 is displayed, for example, this means that the connection will
be automatically terminated in 3 hours and 36 minutes if inactivity per-
sists. If Session time is set to 4 hours, clicking the left mouse button
would reset the value to 4 hours, and the status bar would display
ST: 04:00.  
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Element Explanation/function

Three different states can be displayed for ST:

Display only Explanation

--:-- SM4 is not connected to an SMU.

03:36 SM4 is connected and the Session time is active.

**:** SM4 is connected and the Session time was paused.
Reason: For some file operations (transferring a configurati-
on/update or requesting/reading out log files), the connection
must not be disconnected. If such a file operation takes longer
than the remaining session time, an inactive user is automati-
cally logged off once the file operation is complete.

Connection From left to right, the IP address, port, and SMU location name for the
current connection are displayed here.

If there is currently no connection to an SMU, the information of the last
established connection is displayed here.

The user and number of the dongle used (if connected) are displayed at
the bottom right.

NOTE

The TX and RX LEDs may also light up for the following reason:

The only way for SM4 and the SMU to reliably determine whether the connection between them still
exists is based on "life signs" from their connection partner. A possible “life sign” may be traffic bet-
ween the two, such as when a Live Data window regularly retrieves data from the SMU. However,
if nothing was transmitted over a certain period, SM4 will start a mechanism that sends a ping
command to the SMU at regular intervals and receives the corresponding ping response. 
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4.1.2 New Project

Purpose Select the SMU type in order to automatically define a range of basic settings 

Buttons

Path File > New Project 

Type of use Interactive

Reference Project

This window allows you to start to create a new project by selecting the SMU type.

New Project window

Information on the New Project window

· The SMU types offered by NorthTec are displayed on the left-hand side of the window and can
be selected by clicking. Selecting the wrong SMU type can cause serious malfunctions.



65Reference part > File Menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

· The hardware components belonging to the selected type are displayed in the right half of the
window.

· By clicking Next you will be taken, one after the other, to the following windows in which you
can make further settings: 

o Project Settings window, SMU, Time settings

o Project Settings window, SMU, Ethernet settings

o Project Settings window, SMU, Additional hardware

o Project Settings window, SMU, Shadow impact calculation

· The selected SMU type, Summer/winter time handling, the specified Ethernet address and Po-
werLink address as well as the Phone option, if applicable will then be displayed in the New
Project / Summary window (see screenshot). 

· If the information is correct, click on Create to generate the project. 

New Project / Summary window

153

158

164

162
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4.1.3 Open Project (Local)

Purpose Select already existing project files to open them to edit or display them

Symbol

Path File > Open Project 

Shortcut SHIFT-CTRL-O

Type of use Interactive

Reference Project

Follow the instructions on the screen for this menu item.

4.1.4 Open Project (SMU)

Purpose Readout the current project file of the respective SMU to open it for editing
or display purposes.

Symbol

Path File > Open Project (SMU) 

Prerequisites
· Online connection to the SMU (this menu item is not active otherwise) 

· A project file has been loaded to the SMU 

Type of use Interactive

Reference Project

Follow the instructions on the screen for this menu item.
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4.1.5 Save Project

Purpose Save a newly created or a changed project file.

Symbol

Path File > Save Project 

Shortcut SHIFT-CTRL-S

Type of use Interactive

Reference Project

Follow the instructions on the screen for this menu item.

4.1.6 Print

Purpose Print configuration log 

Symbol

Path File > Print

Type of use Interactive

Reference Project

You can print out the configuration log in this window and specify beforehand what information the
print version should contain. 
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Print window

The information, options or buttons are described in the following table

Element Explanation/function

Report language In this drop-down list, you can specify in which language the log should
be output. In all cases, the Program language option (report language
= language of the SM4user interface) can be selected. The other lan-
guages available depend on the supported languages.

Page selection Here you can specify what information should be contained in the report.

Preview
Opens a preview window corresponding to the page selection defined
above.

Print Opens the print window with normal setting options.

PDF Opens the Save as window in Windows where you can specify the
desired file name and storage location. 
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4.1.7 Import swk file

Purpose Import a project file that was created using Shadow Manager 1

Path File > Import .swk file 

Type of use Interactive

To import a project created with Shadow Manager 1, select the path specified above, select the
desired sky file, and then follow the on-screen instructions. 

The import process automatically creates a new project in which the data to be imported are saved.
Once created, the window for the settings of a new project opens automatically (see section New
Project ).

It is recommended to check the SWK project file for formal and content errors in Shadow Manager
1 before importing it to SM4.

The following data areas are included in the import:

· Project Data  

· Wind Turbine Generators  (WTGs)

· Places of Immission  (POI)

· Combination Matrix  (from several WTGs and POIs)

· Shutdown Calendar

The following data areas are not included in the import:

· Sensors

· Special Shutdowns

· Night Slice Shutdowns

These data areas may have to be edited/completed manually after the import has been carried out.

In SM4 there are some changes to the imported data areas, which are described in the following
tables:

64
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Project Data

Name in SM1 Name in SM4 Notes

Time zone Must be set after import in order to display the local
time correctly.

Coordinate format Coordinate format The implementation of the coordinate systems in SM4
differs from that in SM1.

To display a map, an existing coordinate system must
be selected by EPSG-No. – it must correspond to the
one from the forecast or surveying.

Wind turbine generators

Name in SM1 Name in SM4 Notes

Follow-up time Release delay

Generator type WTG type Is specified by selecting a WTG type in the WTG Types
window.

Since WTG types did not exist in this form in SM1, a for-
mal placeholder type for imported WTGs is assumed
(WTG ID 4210000000, Miscellaneous), which enables
buffering. This placeholder type must be newly selected
and replaced by a valid WTG type.

IMPORTANT NOTE!

Before selecting a new WTG type, select Don’t use
presets under Action following WTG type selection
(File > Application Settings > Wind Turbine Generators
> WTG editor) to make sure the imported data will not
be overwritten.

Generator type ID This parameter does not exist in SM4 in this form; the
contained information is determined by selecting the
WTG type.

Switch output Digital output for
stop

There is no automatic transfer.

If a WTG type was selected whose communication type
is via relay, the WTG must be assigned a digital output
under Hardware > Hardware Assignments (see section
Hardware Assignments window ).

Ref. sensor Reference sensor In SM1, the lowest number (number of the first sensor)
is “0”, however, in SM4 the lowest number is “1”. There-
fore, the number of the reference (light) sensor is auto-
matically increased by one when importing the new
data.

201
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Name in SM1 Name in SM4 Notes

If “all” has been selected as the reference sensor in
SM1, the setting must be made manually, since the se-
lection "all" is not available in SM4.

In principle, the light sensor data are not imported auto-
matically and must be entered manually.

Switchable The parameter Switchable with the options yes and no
is no longer available. This information is defined in SM4
by the WTG type.

Places of Immission

Name in SM1 Name in SM4 Notes

No. of place of
immission

No. of place of
immission

In SM1, the numbering of the POIs starts with "0", in
SM4 with "1". When a 0 is imported, it is converted to
the number 300 and a pop-up window will display the re-
spective information.

Name of place of
immission

This unique identification is generated automatically. The
identification consists of the imported No.of plc. of
immission and the preceding letters “POI".

Weekday selection Periods with
shadow impact
monitoring

You will find the equivalent of the Weekday selection
parameter in SM4 in the Shadow Impact Monitoring
Periods window. 

There you can, e.g., exclude individual weekdays from
monitoring. The weekdays are imported and automati-
cally created with a period from 12:00 AM to 11:59 PM.

For more information on setting parameters in SM4,
please refer to the Shadow Impact Monitoring Periods
sub window  section.135
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Combinations

Name in SM1 Name in SM4 Notes

Combinations WTG Combinations

POI Combinations

The data from the Combinations window will be adop-
ted in SM4, however, they are displayed somewhat dif-
ferently:

Whether a combination is active or not is indicated in
SM4 by a checkmark in the Combination Active
column. 

Since it is not possible to activate or deactivate a power
threshold (Max.Power in SM1) in SM1, it is pre-set to
the high value of 99999 kW, which never applies in prac-
tice. In SM4 on the other hand, the power threshold is
set to 0 kW by default, as it can be activated and deac-
tivated here. Therefore, a power threshold value of
99999 kW from previous versions is displayed in SM4 in
the Power Threshold [kW] column with a value of 0.

Shutdown Calendar

Name in SM1 Name in SM4 Notes

Shutdown
calendars

Shutdown calendar The State column from previous versions was replaced
in SM4 by the Light Sensor column: 

· Entries whose state = inactive in the previous
version will not be transferred to SM4. 

· Entries whose state = active are assigned the value
Ignore all light sensors in SM4. 

· Entries whose state = active (light sensor = 1) are
assigned the value Evaluate WTG’s light sensors
in SM4.
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4.1.8 Applications Settings window

Purpose Specify basic SM4 settings

Symbol

Path File > Application Settings 

Window type Menu tree window

Type of use Interactive

Reference SM4 software

You can specify basic SM4 settings in this window; for example, input formats, warning limits, dis-
play filters for logs etc.

In each of the input areas explained above, you can reset the settings to their Factory
Defaults at any time by clicking on the button with the same name.  

Application Settings window, Warning limits (example)

Notes on the Application Settings window 
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· The setting ranges available in the Application Settings window can be selected in the left-
hand half of the window via a menu tree and can be shown/hidden (+ or -).

· Press the Enter key or the Tab key to complete the current entry and jump to the next input
field.

· It can be changed there at any time.Fields in which an invalid value was entered (value is outsi-
de the permitted range, wrong input format) are highlighted in red: 

You will find an explanation of the individual parameters and setting options in the following tables.

In the explanation for the parameters, you will find information on the default highlighted in green,
where applicable and appropriate.

4.1.8.1 Application Settings, General, Language

Input area Explanation/function

Language Select between German and English user interface.

4.1.8.2 Application Settings, General, Country-specific settings

Input area Explanation/function

Country-specific
settings

The standard settings for the decimal separator, thousands separator etc.
correspond to the selected language and are not changed as a rule.

In the following figure you can see the standard settings to which the
parameters can be reset by clicking on the Factory Defaults button below:

For the date format, you can select between dd/MM/yyyy (day first) and
MM/dd/yyyy. This setting also affects the entry of a date without defining a
year, such as that in the Shutdown Calendar window, for example. 
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4.1.8.3 Application Settings, General, Update

Input area Explanation/function

Update Check for updates at application start-up

When this option is activated, a search for an update for SM4 is automati-
cally carried out through your internet connection when starting the applica-
tion. If the search is successful, you will be asked in a dialog window whe-
ther you want to install the new version. 

4.1.8.4 Application Settings, General, Communication parameters

The parameters in this input area relate to the connection that is established between SM4 and the
SMU. 

In the explanation for the parameters, you will find information on the factory defaults, input format,
range, etc. in a green field, if applicable and appropriate.

Parameter Explanation

Connect timeout This timeout is used to monitor the initial setup of a connection to a SMU.

If you click on Connect in the Connect window, SM4 will try to connect to
the defined SMU via the network, however, it will continue do so only as
long as specified under Connect timeout. If a connection cannot be esta-
blished during this time and the number of connect retries has been “used
up”, the attempt will be aborted.

Factory default: 4000 ms

Changing this value will have the following effects: 

INCREASE VALUE

· SM4 will try to connect to the SMU over a longer period.

DECREASE VALUE

· SM4 will abort the attempt to establish a connection earlier.

Connect retries If you click on Connect in the Connect window, the number of connect re-
tries specified here will be carried out until a connection has been establis-
hed. 

After a command to configure the SMU has been sent in SM4, the SMU will
be unavailable for some time. To cause SM4 to try to connect to a (non-re-
sponsive) SMU several times, you can increase the number of connection
attempts here. 
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Parameter Explanation

However, you can also check in the Connectivity window (Tools > SMU
Connectivity) whether the SMU is available and ready for a connection be-
fore you try to establish a connection. 

Factory default: 1

Changing this value will have the following effects:

INCREASE VALUE

· If a connection attempt fails, SM4 automatically carries out the number
of further attempts specified here.

Time between 2
attempts

After an attempt to connect has failed, SM4 will wait as long as specified
here, before a new attempt is made (provided that more than 1 attempt has
been specified under Connect retries).

Factory default: 4000 ms

Changing this value will have the following effects: 

INCREASE VALUE

· SM4, after an attempt to connect to the SMU has failed, will wait longer
before a new attempt is started; this may reduce the number of unsuc-
cessful attempts, however, it may take longer to re-establish a connecti-
on.

DECREASE VALUE

· After a connection attempt has failed, SM4 will start a new attempt soo-
ner; thus, the number of unsuccessful attempts may increase, but the
connection may be restored faster.

Read command
timeout

This parameter is identical to the Connect timeout parameter in terms of
its functionality, however, it applies to all other commands (all commands
except for "Establish Connection", which is triggered by clicking on Connect
in the window with the same name). 

This timeout monitors the time between sending a command to the SMU
and receiving a response. The value must mainly depend on the commands
with the longest processing times and on the transmission time of TCP
packets from SM4 to the SMU and back.

If SM4, after sending a command, does not receive a response for the
period specified here, SM4 will assume that the connection to the SMU has
been lost.

Factory default: 16000 ms

Changing this value will have the following effects: 

INCREASE VALUE

· SM4 will wait longer, after sending a command, until it assumes that the
connection to the SMU has been lost due to the absence of a
response. 

DECREASE VALUE

· If SM4, after sending a command, does not receive a response, it will
be quicker to assume that the connection to the SMU has been lost.
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Parameter Explanation

Delay between 2
commands

This parameter determines how long SM4 waits after an answered
command until a new (different) command is sent. This prevents the SMU
from getting overloaded.

Factory default: 100 ms

Changing this value will have the following effects: 

INCREASE VALUE

· After sending a command, you will have to wait longer before the next
command can be executed. This way, you can avoid overloading the
SMU.

DECREASE VALUE

· After sending a command, you can execute the next command sooner.
However, this may overload the SMU.

Login refresh interval The only way for SM4 and the SMU to reliably determine whether the
connection between them still exists is based on "life signs" from their
connection partner. 

A possible “life sign” may be traffic between the two, such as when a Live
Data window regularly retrieves data from the SMU.

However, if nothing was transmitted over a certain period of time, SM4 will
start a mechanism that sends a ping command to the SMU at regular inter-
vals and receives the corresponding ping response. 

This parameter is used to control as to when and how often this mechanism
is activated. As long as no data commands are sent from SM4 to the SMU,
the sending of ping commands is repeated regularly at the interval specified
here. This is also indicated by the regular flashing of the TX and TX LEDs at
the bottom left of the SM4 main screen. 

This prevents the SMU from assuming that it is still involved in an already in-
terrupted connection (e.g. termination due to a malfunction in the VPN tun-
nel) and therefore not available for a new connection (only one connection
can exist at a time).

This parameter must match the parameter Session timeout (Project > Pro-
ject Settings > Server settings), which controls how long the SMU will wait
for a ping command: To ensure that SM4 will start sending before the SMU
assumes that the connection was interrupted, the value on the SMU side
(Session timeout) must be higher than the value on the SM4 side (Login
refresh interval). 

Factory default: 3000 ms

Changing this value will have the following effects: 

INCREASE VALUE

· The monitoring mechanism starts later, and the ping commands are sent
at longer intervals. If a connection has been lost, the SMU will take lon-
ger to get ready for new connections. 

DECREASE VALUE
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Parameter Explanation

· The monitoring mechanism starts earlier, and the ping commands are
sent at shorter intervals. 

Command repetitions This parameter determines how often the command is repeated. 

Session time This parameter defines the maximum connection duration in case of inactivi-
ty. It is activated as soon as a connection is established between SM4  and
a SMU. 

Every time you press the left mouse button or use the keyboard in SM4, the
Session time is reset to the value defined here.

The status of the Session time is displayed in the status bar at the bottom
left of the SM4 main screen at ST. Click here for further Information .

Value range: 1–12 h, Factory default: 4 h 

INCREASE VALUE

· If the user does not make an entry in SM4 (inactivity), it will take longer
for the connection to the SMU to terminate automatically.

DECREASE VALUE

· If the user does not make an entry in SM4 (inactivity), the connection to
the SMU is automatically terminated sooner.

Read file operation
timeout

Commands that affect the SMU file system (e.g. delete file, request directo-
ry) trigger actions on the SMU that take some time to complete, which also
means that it may take some time until a response is sent back to the SM4.
Therefore, with actions like these, SM4 has to wait a relatively long time for
a response.

The Read file operation timeout parameter is used to make sure SM4
waits for a response as long as file operations usually need to be comple-
ted.

The value should be based on the maximum time the SMU needs for a file
operation. The transmission time of the channel is so short that it can be ne-
glected.

Factory default: 360000 ms

Changing this value will have the following effects: 

INCREASE VALUE

· SM4, after having sent file command, if there is no response from the
SMU, will wait longer before it assumes that the connection to the SMU
has been lost. 

DECREASE VALUE

· If SM4, after sending a file command, if it does not receive a response,
it will be quicker to assume that the connection to the SMU has been
lost.

FSP timeout File Stream Protocol; upload/download of files) there is a separate timeout
as these tasks usually take longer to be completed than others. 

62
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Parameter Explanation

Here, too, the value should depend on how long the SMU needs to carry out
the respective action. Delays due to the connection channel are very short –
they can be neglected.

Factory default: 120000 ms

Changing this value will have the following effects: 

INCREASE VALUE

· SM4, after having sent an upload/download command, when there is no
answer from the SMU, will wait longer before it assumes that the
connection to the SMU has been lost. 

DECREASE VALUE

· SM4, after having sent an upload/download command, when there is no
answer from the SMU, will be quicker to assume that the connection to
the SMU has been lost.

4.1.8.5 Application Settings, General, Dialogs

Option box Explanation/Function

Show integrity check
confirmation

If the integrity check detects dependencies when deleting, e.g., a POI,
these are displayed in a dialog. There you can have the dependencies
cleaned up in order to finally carry out the operation, or cancel the action
at the last minute without further consequences. 

If a check mark is set here, a dialog is displayed even if SM4 does not
detect any dependencies. This will present you with the action again and
give you the option to cancel it after all. 

NOTE

Keep in mind that after deactivating the dialog, for example, when
deleting an otherwise unused sensor, it will be removed immediately,
and you will have no way to cancel the operation.

Factory default: check mark set
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4.1.8.6 Application Settings, Warning limits

Input area Explanation/function

Warning limits Warning limits are an aid to prevent inadvertent entry of incorrect values.

EXAMPLE

If the value “20.00 meters” is set under “Max” for “Wall length”, and a wall
length of e.g., 50 meters is defined (in the Edit Walls and Areas window) due
to having entered an incorrect coordinate, the corresponding entry will be
highlighted in yellow to indicate to the user that the value needs to be re-
checked. This can prevent a WTG being shut down too often or for too long
due to a much too large wall area.

Click on the Factory Defaults button to restore the standard settings.

Parameter Min/Max* Factory
defaults

Reference to window/ function

Wall length 2.00/20.00 m 2.00 Places of Immission > Walls and Areas

Wall height 1.50/10.00 m 1.50 Places of Immission > Walls and Areas

Sun azimuth 0.00/360° 0.00 Special and Night Slice Shutdowns

Sun elevation -180.00/180.00° -180.00 see above

360 degrees 0.00/360.00° 0.00 see above

Wind speed 0.00/50.00 m/s 0.00 see above

Outside temp. -100.00/100.00°C -100.00 see above

Humidity 0.00/100.00 % 0.00 see above

Rotor tolerance 0.00/90.00 % 0.00 Project > Project Settings 
> Shadow impact calculation

Allowed deviation 1 min/1 year 
(in min)

5 Automatic check of the SMU time when esta-
blishing a connection to the SMU

*The entry format (decimal comma or decimal point) is based on the pre-settings (defaults) in the in-
put area Country-specific settings (File > Application Settings > Shadow Manager > General)
and can be changed there at any time.
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4.1.8.7 Application Settings,Csv-Export, Cycl. Multi Log

Here you can specify general settings for the .csv files to which CMDRs are exported.

Explanation/function

CSV delimiter Separates the columns/data of a row in the csv file.

Decimal delimiter: Decimal separator for floating point values.

Times in Specifies whether data with time specifications are written to the ex-
port file in local time or UCT time.

Section from Cyclic Multi Log sub window .

Include column captions Switch header on/off

Add unit to column caption* Displays the unit of the reading point (if applicable) and determines
whether it is included in the title row of the export file.

Decimal places* Number of decimal places for decimal values

Text for Boolean true/false Individual texts for Boolean values

*These defaults for the fields of the same name in the Cyclic Multi Log window only affect those reading points that are
newly added; reading points that have already been defined retain their csv settings.

In the following figure you can see the settings to which the parameters can be reset by clicking
on the Factory Defaults button below:

360
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4.1.8.8 Application Settings, Plausibility Limits

The parameters in this input area refer to the plausibility check SM4 carries out for certain inputs in
order to detect errors users may make when defining shutdown conditions in the Special
Shutdowns and Night Slice Shutdowns windows. For more information on this functionality, see
Plausibility check .

The following figure shows a section of the input area for the plausibility limits.

Input area for plausibility limits (detail)

Notes

· In addition to the plausibility limits for bat protection and bird protection, you can also set limits for
night slices and for meteorological conditions. 

· To the right of each input field, in pale gray, you will find the allowed input range, followed by the
default value in square brackets (you can reset all values of this input range to their value preset
by NorthTec using the Factory Defaults button).

· If you don't change anything in this window, the plausibility check will be performed according to
the default values. 

214
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4.1.8.9 Application Settings, Phone Book

Here you have the following options:

· Define entries with communication parameters for different projects in order to be able to select
them easily in the Connect window

· Display, add, edit, remove, import or export existing entries

Top:

Existing entries are displayed here in list form, see the following example:

Bottom:

The following input fields and buttons (elements) are available here:

Element Explanation

IP address mandatory field: 4 numbers, separated by a period

Port mandatory field: number from 1 to 65535

Name mandatory field: Name must be unique.

Comment optional input box

To remove an entry, select it in the list and click Remove.

To edit an entry, select it in the list, then fill in the three or respectively four input
fields and click Replace.

To add an entry, fill in the three or respectively four input fields and click Add.

When you press Import, a standard dialog box opens where you can select the
phone book file to be imported. Then a window opens in which all entries of the
imported file are displayed. You can select individual or all entries for import. You
can also specify whether existing entries should be overwritten. If you do not
select the Overwrite existing names radio button, imported entries whose name
is identical to the name of an existing entry will be ignored.

If you click Export, a new window opens in which all current entries in the phone
book are displayed. You can select individual or all entries to export them in CSV
format. The data of an entry are separated by semicolons in the CSV file. 
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4.1.8.10 Application Settings, Colors

Input area Explanation/function

Colors Here you can change the default colors of specific elements in the Special
Shutdowns window and Special Shutdown Log. If you click on the colo-
red bar, a corresponding color palette will open, where you can choose a
different color.

In the following figure you can see the default colors, to which the colors
can be reset by clicking on the Factory Defaults button below:
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4.1.8.11 Application Settings, Places of immission

Here you can influence the behavior of the software when working in the Places of Immission and
Add/Edit Place of Immission window.

NOTE:

You can also access this settings area directly from the Add/Edit Place of Immission window
(Settings button top right).

Input area Explanation/function

Places of Immission Here you can specify how you would like the Add/Edit Place of
Immission editing window to behave; the available options have self-ex-
planatory names. It opens when you click on Add in the Places of
Immission window. Select one of the three options, which have self-ex-
planatory names. 

In the following figure you can see the standard settings to which this pa-
rameter can be reset by clicking on the Defaults button below:

NOTE

The Use preferences option relates to the POI preferences values set in
the following input area.

POI preferences Here you can enter the preferences for the Add/Edit Place of Immission
window in the fields with self-explanatory names.

In the following figure you can see the defaults, to which the parameters
can be reset by clicking on the Factory Defaults button below, and the in-
put format:

NOTE

The entered value for the Permissible daily load is not permitted to be
higher than the Permissible annual load.

POI editor Here you can specify what happens when you click on Add in the
Add/Edit Place of Immission window; the available options have self-ex-
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Input area Explanation/function

planatory names.

In the following figure you can see the standard settings to which the
parameters can be reset by clicking on the Factory Defaults button be-
low:

NOTE

“preferences” relate to the settings area 
POI preferences.

POI walls and areas

Here you can specify whether the Edit Walls and Areas window should
remain open or be closed after clicking on Apply.
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4.1.8.12 Application Settings, Wind turbine generators

Here you can influence the behavior of the software when working in the Wind Turbine Generators
and Add/Edit WTG windows.

Input area Explanation/function

Wind turbine
generators 

Here you can specify how you would like the Add/Edit WTG editing window
to behave when you click on Add WTG in the Wind Turbine Generators
window. Select one of the three options, which have self-explanatory na-
mes. 

In the following figure you can see the standard settings to which this para-
meter can be reset by clicking on the Factory Defaults button below:

WTG editor Here you can specify what should happen when you carry out various actions
in the Add/Edit WTG editor window; the available options have self-explana-
tory names. In the following figure you can see the standard settings to
which the parameters can be reset by clicking on the Factory Defaults but-
ton below:

WTG Types Here you can specify how the WTG Types window behaves, using options,
which have self-explanatory names. In the following figure you can see the
standard settings to which the parameters can be reset by clicking on the
Factory Defaults button below:
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4.1.8.13 Application Settings, Display filters

The SMU generates 4 different logs (operating log, shadow impact log, shutdown log (special
shutdown) and single data recordings). A very large volume of data can be generated depending
on the selection. In order not to overload the PC when processing this data, the entries can be pre-
filtered using the Display Filter.

Alongside this function, entries from various different types of logs can also be combined. Log
entries from an operating log can, e.g., be presented with entries from the shadow impact log in one
view. 

The measurement data logging logs are the exception. In this case the values set by the user are
recorded. No display filters can be used for this log and its entries cannot be combined with entries
from other logs.

Input area Explanation

LogPool path The file path to the folder where you stored the .exe file for running
SM4 is displayed here. As soon as you run this .exe file, the Sha-
dowManager4Data\LogPool folder structure will be created in the
same directory, and, once you download logs from the SMU, these
will be automatically stored in the LogPool folder.

You can use this button to select a different path than the one auto-
matically created by SM4.

You can use this button to restore the default path automatically crea-
ted by SM4.

Maximum number of entries
to be shown

Here you can specify the maximum number of entries that should be
displayed in the log. Default value: 100000

NOTE

If the number of entries to be displayed is too high, the system could
become instable – the program could crash.

or
This button is located twice at the right-hand side window edge. It
serves to show or hide the Export filter and Import filter fields.

Export filter

If you show the Export filter area by clicking on , the individual log
filters will be displayed with checkboxes. Set a checkmark next to the
logs you would like to export and click on Export.

Import filter

If you show the Import filter area by clicking on , the Open button
will be displayed. Now, if you click on it, you can select a filter file sa-
ved on your computer. The already existing filters and the “new” filter
will then be displayed. Now click on Import to conclude the import
process.
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Input area Explanation

Operation log

Shadow Impact

 Bat protection 

Bird protection

Sector shutdown

Noise protection

Special shutdown

WCU Operation log*

WCU Shadow impact log*

Not all events that the system for shadow impact monitoring and spe-
cies conservation records and sends are important or interesting for
every log or every user. Display filters are therefore predefined here
(see column to the left).

To edit the predefined display filters, select one on the left in the tree
menu. The following will then be displayed.

Possible log entries

The entries shown here are the ones that are not yet contained in the
filter selected on the left-hand side of the Application Settings
window (click on the respective arrow to expand a list). To select an
entry to display in a log, mark it here and then click on Add.

Selected log entries

The entries shown here are the ones that are already contained in the
filter selected on the left-hand side of the Application Settings
window (click on the respective arrow to expand a list). To remove a
display filter, mark it here and then click on Remove. 

Assign colors

You can assign colors to the entries under Selected log entries to
make the log easier to read. To do this, expand one of the logs (click
on the white arrow to the left of it) and then click on the first white
field to the right of the desired entry to select the desired color from a
color palette, see the following figure:
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Input area Explanation

NOTES

· The second white field is only relevant to entries with the differen-
tiation [occurs/leaves]: 
first field = color for occurs, second field = color for leaves. 

· When you click on Factory Defaults, pre-settings will only be re-
stored for the filters marked on the left-hand side.

User-defined filter If you click on User-defined filter at the top left, an additional input
area will appear at the top right:

Here you can specify a user-defined filter. To do so, enter the desired
name under Filter name and then click on Add.

Then select the desired entries further below in the window as descri-
bed above.

NOTE 

In order to use a display filter created here in the Logs from Local
LogPool window (Logs > Local log files), select them in the Choose
a filter drop-down list (at the bottom of the Logs from Local
LogPool window).

* If there is no communication between the SMU and a WCU, the WCU will write its own operation
and shadow impact logs. While there is a connection, the SMU will periodically download the
WCU's log files and save them on the SMU's USB sticks. When downloading the "normal" SMU
logs to SM4, the WCU logs that the SMU has previously (down)loaded from the WCU can also be
downloaded, or in other words: the SMU copies the WCU logs and makes them available for dow-
nload in SM4. When editing the filters and assigning colors, proceed in the same way as with the
SMU logs.

4.1.8.14 Application Settings, Live data

Explanation/function

You specify here the intervals at which the data should be retrieved for display in the Realtime
Data menu.

In the following figure you can see the settings to which the parameters can be reset by clicking
on the Factory Defaults button below:
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Explanation/function

4.1.8.15 Application Settings, Select coordinate system

Explanation/function

Here you make defaults for the display of the Select coordinate system window (Project > Pro-

ject Data > ). In the following figure you can see the settings to which the parameters can be
reset by clicking on the Factory Defaults button below:
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4.1.9 Close

Purpose Close SM4

Symbol

Path File > Close 

Type of use Interactive

Reference Project

If you select File > Exit or  and have changed project data beforehand without saving it, a dia-
log box will appear in which you will be asked whether the changes should be saved. You can ans-
wer the question with Yes or No or cancel the process with Exit. 

NOTES

· If windows in which you have made changes that are not yet saved are still open, you will be gi-
ven a confirmation prompt (dialog box) for each window that contains changes that have not
been saved. Only afterwards will you be asked whether the entire project should be saved.

· If, however, none of the existing changes have been saved yet and you answer Yes to all indivi-

dual confirmation prompts (Discard changes?) after Exit , the application will close after the
last of these prompts. You will not be asked whether the project should be saved as this questi-
on has already been answered individually for each of these windows. 

Example: You change data for a WTG and a POI, and DO NOT save either of them, leave both
windows open and then select Exit. You now receive a confirmation prompt for either window,
and you answer Yes (discard) to each. The program will then end without any other query.

· If SM4 is connected to the SMU when you exit, the connection will be terminated.
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Project menu4.2

From the settings and information that you make or enter in the Project menu, SM4 later derives
the configuration data that are transmitted to the SMU together with the project file itself. While the
project file will only be stored in the SMU, the configuration data will be used to configure the SMU
functions.

The following table provides an overview of the Project menu. 

A detailed explanation of the individual settings windows can be found after the overview table.

Symbol Menu item Purpose

Project Data  Edit and view project-specific information on location, date of
commissioning, customer etc.

Wind turbine
generators

Edit and view the data of a WTG whose shadow impact is to
be calculated.

Places of Immission Edit and view the areas/walls that could possibly be affected
by shadow impact..

Overview Map Visually check the position of WTGs and POIs.

Alarm Settings Define which alarms are to be triggered for which WTGs/de-
vices.

Settings Basic settings which apply for the entire project can be defi-
ned here.

Configuration  Send a new or reviewed configuration to the SMU.

Click on a menu item to jump directly to more information.

94

97

126

146

149

152

165
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4.2.1 Prjoject Data window

Purpose Display and edit project-related information with regard to location, date of
commissioning, customer etc.

Symbol

Path Project > Project Data

Type of use Display + interactive

Reference Project

Project Data window
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Notes regarding the Project Data window 

· Press the Enter key or the Tab key to complete the current entry and jump to the next input
field.

· The Apply button will not be activated until the mandatory fields of the window have been filled
out correctly.

The information, options or buttons are described in the following table 

Element Explanation/function

Project name Enter any characters

Location Enter any characters

PC Postal Code, enter any characters

State, country Enter any characters

SMU location This entry is for information only.

Longitude Using the entered coordinates (Add/Edit WTG window > WTG positi-
on X/Y) SM4 determines longitude and latitude, uses these values to
calculate the project center (geographic center of the WTGs, see Over-
view Map window  window and displays the respective latitude/longi-
tude here.

NOTE:

If no valid coordinate system was selected, you can also enter the lon-
gitude and latitude manually.

Latitude see above

Date of commissioning Date of commissioning of the SMU (MM/DD/YYYY)

Time zone Drop-down list for selecting the time zone in which the wind park is lo-
cated.

Coordinate format If you click on , the Select Coordinate System window will be
opened. Here you can select the system to be used in the project from
the list and then click on OK. Usually, the expert has decided on a coor-
dinates system in the shadow impact forecast, which will be maintained
in most cases.

NOTES

· In the search field in the upper part of the window you can find a
specific system by entering free text.

· By clicking on the Info button in the lower part of the window, you
will open a website providing information on the coordinate system
you have selected at the top of the window (internet connection
required).

146
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Element Explanation/function

· In the application settings (File > Application Settings > Select
coordinate system) you can define defaults for the display of the
Select Coordinate System window.

Data source Information for internal purposes/ authorities (optional, unlimited number
of characters). 

To edit the entry, click on Edit Entry.

Customer name Enter any characters

Customer address Enter any characters

Log book Please carry out the following steps whenever you change a project
file: 

§ Click on Add New Entry and enter your name under User.

§ Describe in the input field below as precisely as possible which
changes you have made to the project file, so that you and others
can easily understand them later.

§ Click on Add.

NOTES

· If you enter a log book entry as described above, the time and aut-
hor of the entry are automatically recorded under Timestamp and
User. These manual entries in the log book cannot be changed af-
terward.

· In addition to the manual log entry, the system logs changes auto-
matically. However, this automatic log is difficult to understand - so
it serves only for additional security purposes. 

Opens the Log book area in a separate window in order to display
more information.

If you click on Close without having clicked on Apply beforehand, a
new dialog window will be opened in which you can see the parameters
that have been changed. You will also be asked whether or not the
changes should be discarded. If you are sure that the changes should
not be applied, click on Yes. Otherwise click on No in order to apply
the changes.

This button is used to confirm the entered data. 

Please be very careful when entering values in SM4. Incorrect parameter values may
result in avoidable wear and tear, loss of earnings, problems with authorities or resi-
dents, and, in the worst-case, force operators to decommission WTGs.
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4.2.2 Wind Turbine Generators window

Purpose Display/remove/edit/add wind turbine generators (WTGs)

Symbol

Path Project > Wind turbine generators

Window type List window

Type of use Display + buttons for sub windows

Reference Project

This window shows a list of the WTGs already created in the project that is currently opened.
The individual parameters for a WTG are defined in the Add/Edit WTG window, please refer to
the next section.

Notes regarding the Wind Turbine Generators window

· Move columns: Columns can be moved by drag & drop.

· Sort by column: You can sort a column according to its heading by clicking on it. If you then click
again on the same column heading, the sort sequence will change from ascending to descen-
ding or vice versa.
You can also sort by more than one column heading (criteria). To do this, first press and hold
the shift key and then click on the desired column headings. The sorting will be carried out
according to the order in which you click on the column headings.

· Column filters: You can also apply filters to columns: Move the mouse cursor to the top right-
hand corner of a column heading until a small filter symbol  appears. Click on the filter sym-
bol. A list of possible entries will then be shown. Now set a checkmark next to the desired entry.
Only the selected entries will be displayed afterwards.

The information, options or buttons are described in the following table

Element Explanation/function

Number of WTGs 
(top right)

Indicates how many WTGs have already been created (maximum num-
ber: 100).

Wind turbine generators List of WTGs already created. The column titles (parameters) are des-
cribed in the Add/Edit WTG window .

Opens a like-named window, where you can select a predefined WTG
type. This avoids you having to make several entries manually.

Opens a like-named window, see WTG Combinations sub window .

Deletes the WTGs selected above. 

99

106
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Element Explanation/function

Attention: The WTGs will be deleted immediately, no confirmation
prompt.

Opens the Add/Edit WTG window, where you can edit the WTG selec-
ted above, see next section.

Opens the Add/Edit WTG window, where you can add a new WTG,
see next section.

Please pay attention to the Information in the following boxes.

Use the data of existing WTGs as a template

· If you want to copy the data of a WTG that has already been created, click on this
WTG in the Wind Turbine Generators window to select it (dataset will be highlighted in
blue). 

· Then click on  Edit WTG (or double-click the desired WTG dataset in the list).

· The Add/Edit WTG window will open and the 
WTG number input field will be highlighted in orange. 

· Now enter the next free number here.

· The field will now be highlighted in green and the Add WTG button at the bottom of
the window is now activated.

See also Practical example 1: Set up a new WTG with a new POI

Note that if you change the WTG type of an already defined WTG, many of its values
will be set to zero.

33
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4.2.2.1 Add/Edit WTG window

Purpose Create a wind turbine generator (WTG) in the project

Symbol

Path Project > Wind Turbine Generators > Add WTG/Edit WTG

Type of use Interactive 

Reference WTG

You can define the individual parameters for a WTG in this window.

Wind Turbine Generators window
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Notes regarding the Add/Edit WTG window

· Press the Enter key or the Tab key to complete the current entry and jump to the next input field.

· Input format: For input boxes where decimals are allowed the decimal separator to be used de-
pends on the default in the input area Country-Specific Settings (File > Application Settings >
Shadow Manager > General.)

· Fields in which an invalid value was entered (value is outside the permitted range, wrong input for-
mat) are highlighted in red: 

· The buttons Apply and Add will not be activated until the mandatory fields of the window have
been filled out correctly.

You will find a detailed description of this window in the following table.

Element Explanation/function

Selected WTG The WTG selected in the Wind Turbine Generators window (reference
only)

WTG Number Up to 100 WTGs can be defined.

If you have clicked on Add WTG in the Wind Turbine Generators
window, then the next free number will automatically be provided here. 

If you have clicked on Edit WTG in the Wind Turbine Generators
window, in order to use the data of another WTG, enter the next free
WTG number here, see Wind Turbine Generators window .

NOTE: You can also enter/use the number of an existing WTG. The da-
taset of this existing WTG will then be overwritten with the “new data”.
Before that, however, the Dependencies window  will open.

WTG Identifier Internationally unique ID number of the WTG as indicated on the outside
of the tower (mandatory field). This number appears in the shadow
impact log as WTG name.

Name shadow forecast Name of the WTG as used in a shadow impact forecast which may have
been created (reference only).

WTG position X Coordinates of the WTG position.

NOTE: The coordinates of all WTGs and POIs must be defined using
the same metric coordinate system.

2 decimals 

WTG position Y see above

Height above sea level WTG’s height above sea level

Input in m, value can also be negative, 2 decimals

98
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Element Explanation/function

Rotor diameter Input in meters, 2 decimals

Hub height NOTE: If the hub height is less than half the rotor diameter, you will see
a warning symbol and the dataset cannot be added.

Input in meters, 2 decimals

Hub distance Distance between the hub and the center of the tower

Input in meter

Avg. blade depth Average blade depth = ½ (max. blade depth + min. blade depth at
0.9*rotor radius) see Glossary .

Input in meter

Nacelle angle offset Difference between the nacelle angle reported by the WTG and the ac-
tual position (orientation).

Input in degrees

Standstill If the actual rotor speed drops below the value specified here, the SMU
will be considered as stopped.

Input in rpm, 2 decimals

Release delay Delay before startup of the WTG after having been shut down due to
shadow impact. Serves to reduce wear by avoiding frequent start-up
and shutdown processes during rapidly changing weather conditions.

Input in seconds, standard setting 300 s

EXAMPLE

A WTG has been stopped due to shadow impact (the light intensity is so
high that shadow impact is possible). Later, the light sensor reports that
the light intensity is not sufficient to cause shadow impact. Now the
WTG will be started up only after the time period specified under Relea-
se delay has elapsed. However, if the sun has now reached a position
in which no POI will be affected by WTG shadow, the release delay will
be ignored, i.e., the WTG is started up immediately.

Start-up time Period between sending the start command to the WTG and the point in
time when the rotor actually starts rotating.

Input in seconds

EXAMPLE

Start-up time has been set to 120 s. If, according to the system’s
forecast, theoretical shadow impact will not be possible anymore from a
specific point in time (because the sun will have reached a position at
which no POI can be affected by WTG shadow), the start command will
be sent x seconds (Start-up time) earlier (yield optimization). 

Shutdown delay Period between sending the stop command to the WTG and the point in
time when the rotor stops rotating (standstill).

472
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Element Explanation/function

EXAMPLE

According to the system’s forecast, theoretical shadow impact will be
possible at a POI from a specific point in time (because the sun will have
reached a position at which the POI can be affected by WTG shadow).

The shadow impact budget for this POI has already been exploited OR 
28 of 30 minutes of the budget have already been used.

In this case, the stop command will already be sent x seconds (Shut-
down delay) before shadow impact actually occurs to ensure that the
WTG definitely stands still at this point in time and the regulatory requi-
rements are complied with.

Input in seconds

Stop command timeout Defines the time period after which the SMU reports an alarm to the
park server because a WTG fails to respond to a stop command (rotor
speed does not drop below the value specified under Standstill). 

Input in seconds, default 180 s

Com. delay timeout Used to set a break between sending two consecutive queries to two
WTGs. Reason: If the break between sending queries is too short, this
may cause technical problems with devices. 

Input in seconds, default depends on the WTG type

Reference sensor 1/2 Here you can set the light sensor to be used to evaluate the light
conditions. We recommend selecting the nearest light sensor.

With some nacelles it is not possible to install the light sensor in such a
way that it can measure the intensity of the sunlight all day (due to sha-
de). In this case, it may be necessary to install a second light sensor.

0 = no sensor is used, 1 to 40 = sensor x is used

Alternative light sensor Specifies whether an alternative light sensor is available that should be
used if reference sensor 1 and/or 2 have failed.

0 = no sensor is used, 1 to 40 = sensor x is used

Reference temperature
sensor

Specifies which hygro-thermo sensor should be used to measure the hu-
midity and outside temperature.

0 = no sensor is used, 1 to 5 = sensor x is used

Reference precipitation
sensor

 Specifies which precipitation sensor should be used to measure the
precipitation amount.

0 = no sensor is used, 1 to 5 = sensor x is used

If you want to add a new WTG, start by clicking on WTG Types. A
window of the same name will then open in which you can select the re-
spective WTG type in order to use standard values that are identical for
every WTG of the same type as default values. When selecting the ty-
pe, please pay special attention to the information under Communi-
cation and Rotor diameter. 
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Element Explanation/function

For further information on the individual WTG types, please refer to
Communication Parameters input area .

NOTE: Note that if you change the WTG type of an already defined
WTG, many of its values are set to zero.

Manufacturer Will be filled in automatically depending on the WTG type.

WTG type Will be filled in automatically depending on the WTG type.

Communication Will be filled in automatically depending on the WTG type.

Connection to Use this drop-down list to specify whether the WTG is connected direct-
ly to the SMU or to a WCU.

Communication
parameters

This input area contains different parameters depending on the selected
WTG type, see Communication Parameters input area section.

Offline Values

Use offline values Here you can define how the SMU will react if it does not receive data
from the WTG anymore due to a communication error. Depending on the
type of interface used to communicate with the WTG it is possible that
some or all data are missing. However, with most interface types, an er-
ror means that all data are missing and that it is no longer possible to
send stop and start commands or alarm messages to the WTG.

If no checkmark is set here, the SMU continues to operate with the last
data received until new data can be received.

If a checkmark is set, the SMU will use the pre-sets for the WTG, which
can be defined here, after the period set under Timeout for pre-sets.
In this case, these values will also be reflected in the log.

Consider WTG as not
running

If a checkmark is set here, the SMU considers the WTG to be "not run-
ning" in the event of a communication failure. This is useful for WTGs
that stop automatically in the event of a communication failure in order to
prevent them from consuming the shadow impact budget (see glossa-
ry ) for no reason.

Rotor speed If the value defined here is greater than or equal to the value defined un-
der Standstill and a WTG communication error occurs, the SMU will as-
sume that the WTGs is always operating. This ensures that any shadow
impact that may occur while communication is interrupted is duly reflec-
ted in the shadow impact log.

Input in rpm, 2 decimals, default: 2 

Wind speed A wind speed pre-set may be relevant if this parameter is part of a spe-
cial shutdown condition and the interface to the WTG enables sending
stop or start commands even during a temporary communication break-
down.

Input in m/s, 2 decimals

117
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Element Explanation/function

Outside temp.  An outside temperature pre-set may be relevant if the outside tempera-
ture parameter is part of a special shutdown condition and the interface
to the WTG enables sending stop or start commands even during a tem-
porary communication breakdown.

input in °C, 2 decimals

Precipitation A precipitation amount pre-set may be relevant if the precipitation para-
meter is part of a special shutdown condition and the interface to the
WTG enables sending stop or start commands even during a temporary
communication breakdown.

Input in mm/h, 2 decimals

Relative humidity A humidity pre-set may be relevant if the humidity parameter is part of a
special shutdown condition and the interface to the WTG enables sen-
ding stop or start commands even during a temporary communication
breakdown.

Input in %, 2 decimals

Current power If a power threshold was defined for a WTG (see WTG Combinations
sub window ) this value must be greater than or equal the power
threshold.Otherwise, the SMU would send a stop command to the WTG
as soon as shadow impact occurs. 

NOTE

A current power pre-set may be relevant if this parameter is part of a
special shutdown condition and the interface to the WTG enables sen-
ding stop or start commands during a temporary communication break-
down.

Input in kW, 2 decimals

10 min Average power Some WTG types report a 10 minutes average value. In this case, the
average value is used instead of the current power value. 

Otherwise, please refer to the explanation under Current power above.

Input in kW, 2 decimals

Timeout for offline values Specifies how long the SMU will wait until it uses the pre-sets after a
communication failure has occurred. 

Input in seconds., 2 decimals, default: 300 s 

Switches to the Wind Turbine Generator window (or opens it). 

Opens the Input options for wind turbine generator editor where you
can define what happens when you click on Add or Apply in the
Add/Edit WTG window; the available options are self-explanatory.

Deletes the data from the input fields of the selected WTG.
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Element Explanation/function

Confirms the entered data. 

Adds a new WTG No. Adds a new WTG No. Up to 100 WTGs can be
defined.

The coordinates used to define WTGs and POIs must be based on the same metric
coordinate system.

Please be very careful when entering values in SM4. Incorrect parameter values may
result in avoidable wear and tear, loss of earnings, problems with authorities or resi-
dents, and, in the worst-case, force operators to decommission WTGs.
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4.2.2.2 WTG Combinations sub window

Purpose
· Activate/deactivate combination(s) of WTG and POI manually (e.g. be-

cause a line-of-sight obstacle between WTG and POI precludes shadow
impact) 

· Automatically activate/deactivate combination(s) of WTG and POI depen-
ding on shadow range (see Glossary ) and distance to POI

· Change/define direct relations between the WTG selected in the Wind
Turbine Generators window and each POI for yield optimization

Path Project > Wind Turbine Generators >  Combinations 

Type of use Interactive + Wizard

Reference
The WTG selected in the Wind Turbine Generators window (reference
only). 

The tabular arrangement of all combinations of all WTGs and POIs of a project is called combinati-
on matrix. If you click on the Combinations button at the bottom of the Wind Turbine Generators
window, the WTG Combinations window opens. Only the column of the combination matrix belon-
ging to the currently selected WTG is shown here; however, the view includes sub-elements such as
Combination Active, Power Threshold [kW], etc. These can be edited directly in this window or in
the Combination Matrix Wizard sub window (button  ). The entire combination matrix can
be seen, for example, when configuring the simulation (Tools > Combination).

WTG Combinations sub window

Not all setting options are always available for every combination (fields highlighted in gray), e.g., if
the daily counter limit and/or annual counter limit of a POI are not being used.

For each relationship between the WTG and a POI, conditions can be defined with regard to the
following aspects.

· Combination Active column: 
Shadow impact possible or not (deactivate the combination if there is an obstacle between a
WTG and a POI) 

472
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· Threshold Power Active and Threshold Power [kW] columns: 
Power threshold for saving shadow impact budget for more profitable times

· Columns Max. Daily Load [min]/ Max. Annual Load [min]:
maximum daily/annual load used to save shadow impact budget for more powerful WTGs 

· No. of Grace Days – Daily Load
Number of days (per year) on which the Max. Daily Load (see above) may be exceeded.

· Columns Distance [m] and Used Range [m]
Deactivation of combinations according to fixed or determined shadow range and distance

The information, options or buttons are described in the following table

Element Explanation/function

POI Number Number of the place of emission

Combination
Active

After the WTGs and POIs of a project have been defined, all combinations are set
to Active by default. This means that the SMU will assume that each WTG is able
to cause shadow impact at each POI. However, if there is an obstruction between
a WTG and a POI, the real shadow impact is not possible at this place of
immission. Consequently, no calculation has to take place and the corresponding
combination can be deactivated (remove checkmark).

Default: þ

Power Thres-
hold Active

Here you can activate or deactivate a power threshold defined in the subsequent
column. If the respective WTG is running below this power threshold while at the
same time causing shadow impact at the respective POI, the WTG is stopped
even if the limit value specified by the authorities has not yet been reached. While
a WTG is running above the power threshold, the permitted periods of shadow
impact will be exploited. With this method, the available shadow budget is saved
for "better" (windier) times when the WTG can generate higher power.

For more information, please refer to the Glossar  as well as Define a power
threshold .

NOTES

· This column is not displayed if the WTG does not transmit current power
values to the shadow impact system (e.g. a preload).

· This parameter is automatically disabled under certain conditions, see section
Automatic deactivation of the power threshold.

Default:  

Power Thres-
hold [kW]

Here you define the power threshold in kW. This value will only be applied if
Threshold Power Active has been activated in the previous column.

NOTES

· This column is not displayed if the WTG does not transmit current power
values to the shadow impact system (e.g. a preload).

· This parameter is automatically disabled under certain conditions, see section
Automatic deactivation of the power threshold.
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Element Explanation/function

Default: 0

Max. Daily/
Annual Load
[min]

Here you can reduce the value set in the Add/Edit Place of Immission window at
Maximum permissible daily/annual load to, e.g. to assign a smaller portion of
the shadow budget to a low rated WTG than to a high rated WTG. 

These parameters are also used to save shadow budget, not for "windier" times,
however, but for more powerful WTGs instead.

For further information see Max. daily/annual load .

NOTE
These columns are not displayed for WTGs that cannot be switched by the
shadow impact system (WTG is only a preload).

Default = value in the Add/Edit Place of Immission sub window at Max. dai-
ly/annual load

No. of Grace
Days – Daily
Load

In SM4 = number of days (per year) on which the Maximum permissible daily
load (see above) may be exceeded.

Distance[m] Displays the shortest distance (on the map) from the WTG tower center to the
nearest wall or area coordinate of the POI.

Used 
Range [m]

Indicates whether a shadow range is used, and if so, which one. The following op-
tions are available:

--- There is no „used range“.

fixed x A fixed range x was set in the wizard.

calc. x After the Set combi according to blade depth button has been acti-
vated in the wizard, this number is indicated at x.

manually Is displayed if inactive single combinations were set and accepted
(Apply button) or active single combos were deactivated and accepted
in the WTG Combinations window.

Default: ---

Opens the Combinations Matrix Wizard window.

If you click on Close without having clicked on Apply beforehand, the system will
ask you whether you want to apply the changes. 

Confirms the entered data.

See also: Combinations Matrix Wizard sub window .
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4.2.2.3 Combinations Matrix Wizard sub window

Purpose
· You can easily apply the settings of the WTG Combinations window to

all combinations and then exclude individual ones as necessary.

· Have combinations automatically set to active/inactive depending on di-
stance to POI and shadow range (see Glossary )

Symbol

Path Project > Wind Turbine Generators >  Combinations >  Wizard

Type of use Interactive

Reference Selected WTG/entire matrix

Using the wizard, you can easily apply the setting options of the WTG Combinations window to all
combinations and then exclude only individual ones as necessary. This procedure is particularly sui-
table for large wind parks to avoid having to edit each combination individually (save time). You can
also use this window to configure the SMU in such a way that combinations will be activated/deacti-
vated automatically depending on shadow range and distance.

Combinations Matrix Wizard sub window

472
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Note regarding the Combinations Matrix Wizard window:

Press the Enter key or the Tab key to complete the current entry and jump to the next input field.

The information, options or buttons are described in the following table

Element Explanation/function

Apply to selected WTG Applies the change(s) made in this window only to the WTG selec-
ted in the Wind Turbine Generators window. 

Apply to entire combinations ma-
trix

Applies the change(s) made in this window to all combinations (the
SMU assumes that each WTG can cause shadow impact at each
POI because there are no obstructions between them).

Activate/ Deactivate
Combinations

Sets the combinations of the selected POIs or respectively of the
entire combinations matrix to active/inactive.

Set combi according to fixed
range

To use this option, first enter the desired Fixed range and then click
on the button. Normally, the value determined in the shadow impact
report is used; in the UK, it is common to select 10 times the rotor
diameter. 

Now the distance of the POI is automatically compared with this
range, and the respective combination is set to active if the distance
to the POI is smaller or equal to the range.

Meter, decimals allowed

Set combi according to blade
depth

If you select this option, the distance is compared with the calcula-
ted shadow range according to the German 20% criterion (face of
the sun is covered to 20% by a rotor blade). 

The respective combination is set active if the distance is smaller or
equal to the range.

NOTE

If the calculated range with 20% sun coverage is to be used, the
average blade depth specified in the manufacturer data must be
checked very carefully.

Activate/ Deactivate Power
Threshold 

Here you can activate or deactivate one or more combinations by
clicking the respective button.

Furthermore, you can set a new power threshold (in kW). 

If the power of the respective WTG drops below this value, it will be
shut down (provided that the power threshold was activated).
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Element Explanation/function

Set power threshold Here you can enter the desired power threshold. If a WTG is opera-
ted below this power threshold while causing shadow impact in a
place of immission, the respective WTG is shut down immediately.

kW, no decimals

In order to apply the values to one WTG or to the entire combinati-
ons matrix, click on Apply.

Max. daily/ annual load You can enter the maximum permissible load per day/year.

minutes, no decimals

 see above

If you click on Default, the settings defined in the Add/Edit Place of
Immission window under Maximum permissible daily/annual load
will be applied.

No. of grace days – daily load Here you enter the number of days (per year) on which the Max.
daily load may be exceeded.

 see above

If you click on Default, the settings defined in the window Add/Edit
Place of Immission under No. of grace days – daily load will be
applied.

If you enter a value that is higher than the value set when defining
the place of immission, then the value set there will be applied here.

If you click this button, the values of the entire combination matrix
(combinations of all WTGs with all POIs) will be reset (Max. dai-
ly/annual load and No. of grace days – daily load) to the respec-
tive values set in the Add/Edit Place of Immission window, all
others to 0).

See also Practical example 4: Editing a POI and WTG combination

NOTES 

· You can use the Combination Matrix Wizard to change one selected combination or apply a
change to all combinations. Please make sure that the combinations whose Threshold Power
Active parameters were automatically set to inactive are not changed by the assistant. For fur-
ther information, please refer to section Automatic deactivation of the power threshold .

38
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· If you plan to use the activation according to a fixed or calculated range, we recommend you
open the combination wizard from the WTG menu, because the shadow range is WTG-related.
For the Set All Combinations function, it does not matter whether you open the combinations
window from the POI list or the WTG list.

In the following subsections you will find further information, examples and step-by-step instructions
on the possibilities offered by the WTG Combinations window – they will allow you not only to
meet the requirements of the authorities but also to optimize the yield of a wind park.

4.2.2.3.1 Activate/deactivate a combination

Is shadow impact possible between the WTG and the POI?

After the WTGs and POIs of a project have been defined, all combinations are set to Active by
default. This means that the SMU will assume that each WTG is able to cause shadow impact at
each POI. However, if there is an obstruction between a WTG and a POI (e.g., a stable or forest),
real shadow impact is not possible at this place of immission. Consequently, no calculation must ta-
ke place and the corresponding combination can be deactivated.

A combination can be activated/deactivated in two ways:

1. Combinations window (activate/deactivate the desired combination with the selected WTG/POI
by setting/removing a checkmark)

2. Combinations Matrix Wizard sub window109
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4.2.2.3.2 Define a power threshold

Would it make sense to define a power threshold for the WTG/POI combination?

According to the requirements of the authorities, a specific maximum number of minutes with
shadow impact per day/year are acceptable for each POI. This means that the wind park has a so-
called shadow impact budget for each POI. Since the wind and consequently the possible yield is
different depending on the time of the day or year, it can be interesting to define a power threshold
– please refer to the following example.

Shadow impact is caused at a POI; however, the budget has not been exploited; the WTG opera-
tes at a power output of 490 kW.

Consequences without power threshold

· WTG will not be shut down since the budget
has not been fully exploited

· although operating at a low power output,
the WTG consumes budget

· later, when the wind may be stronger, the
WTG may have to be shut down
immediately

· high loss in yield 

Consequences with 500 kW power threshold

· WTG is shut down

· budget saving

· later, when the wind may be stronger, the
WTG may not have to be shut down 

· yield optimization

L J

There are two ways to define and activate/deactivate the power threshold:

1. Combinations window

8 Set the checkmark for the desired combination in the Power Threshold Active column.

8 Enter the desired value in the Power Threshold [kW] column and click on Apply (no de-
cimals possible).

2. Combinations Matrix Wizard sub window 109
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4.2.2.3.3 Define a maximum daily/ annual load

Does it make sense to define a maximum daily/annual load for the combination of WTG and
POI?

According to the requirements of the authorities, each POI may be exposed to shadow flicker for a
certain maximum number of minutes per day/year, so the wind farm has a so-called shadow impact
budget available for each POI. However, since shadow impact at an POI can often be caused by
more than one WTG, but not every WTG is running at the same power in the process, it may make
sense to allocate less budget to lower-power WTGs than to higher-power WTGs. For this purpose,
the value set in the Add/Edit Place of Immission window at Maximum permissible daily/ annual
load can be reduced for certain combinations, see the following example.

Example

WTG 1 and WTG 2 can theoretically cause shadow impact at an POI. WTG 1 achieves a rated
power of 1,500 kW, while WTG 2 provides a rated power of 3,000 kW.

By reducing the maximum load per day/year on WTG 1, you allocate a larger portion of the budget
to the much more powerful WTG 2, optimizing your yield.

There are 2 ways to define and activate/deactivate a maximum daily/annual load:

1.  Combinations window

8 Specify the maximum number of minutes for the desired combination (no decimals possi-
ble) in the Max. Daily/Annual Load [min] column. 

8 Click on Apply.

Since, as described above, you want to reduce the amount permitted by the authorities,
the value you enter here must be lower than the value you defined under Maximum per-
missible daily/annual load in the Add/Edit Place of Immission window.

2. Combinations Matrix Wizard sub window  106
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4.2.2.3.4 Automatic deactivation of the power threshold

In the windows Add/Edit Place of Immission and Add/Edit WTG, conditions can be defined (see
table below) which, as soon as they are applied, defeat the purpose of the power threshold functi-
on. Therefore, the power threshold is automatically deactivated in certain cases in the respective

combination matrix. For further explanation, refer to the 2 tables below.

This table shows as to how the definition of such conditions in the Add/Edit Place of Immission
window affects the associated combination matrix:

Setting in the 
Add/Edit Place of Immission
window

Effect on the
POI Combinations window

Explanation

Limit active Limit [kW
[kW]

Only log WTG stop (day) =  

Use daily limit =  

Only log WTG stop (year) =  

Use annual limit =  

Checkmark is
automatically
removed, field
is deactivated

Value is
automatically
removed, field
is deactivated

Daily and annual counters
are not used, the WTG
does not stop, and there-
fore the power threshold
does not need to be con-
sidered.

Only log WTG stop (day) = þ

Use daily limit = þ

Only log WTG stop (year) = þ

Use annual limit = þ

Checkmark is
automatically
removed, field
is deactivated

Value is
automatically
removed, field
will be deacti-
vated

Only logging is desired,
the WTG must not stop,
not even when the power
falls below the power
threshold.

Only log WTG stop (day) = þ

Use daily limit = þ

Only log WTG stop (year) =  

Use annual limit =  

Checkmark is
automatically
removed, field
is deactivated

Value is
automatically
removed, field
is deactivated

The annual limit is not
used, and if the daily limit
is exceeded, this should
only be logged. The WTG
must not stop when the
power falls below the
threshold.

Only log WTG stop (day) =  

Use daily limit =  

Only log WTG stop (year) = þ

Use annual limit = þ

Checkmark is
automatically
removed, field
is deactivated

Value is
automatically
removed, field
is deactivated

The daily limit is not used,
and if the annual limit is
exceeded, this should
only be logged. The WTG
must not stop when the
power falls below the
threshold
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This table shows as to how the definition of such conditions in the Add/Edit WTG window affects
the associated combination matrix:

Setting in the 
Add/edit WEA
window

Effect on the window 
WEA Combinations

Explanation

Limit active
Limit [kW
[kW]

Communication = Preload

Switch WTG by foreign system  

column is
not displayed

column is
not displayed

Communication = Preload

Switch WTG by foreign system þ

column is
not displayed

column is
not displayed

Communication = via relay

AI -  current WTG power =  

column is
not displayed

column is
not displayed

AI -  current WTG power = þ is not automa-
tically set to
inactive

remains acti-
ve

In this case, it is possi-
ble to have the WTG
shut down according to
the power threshold.

NOTE

Note that combinations whose Power Threshold Active parameter was automatically set to Inacti-
ve cannot be changed by the Combination Matrix Wizard.
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4.2.2.4 Communication Parameters input area

Purpose Define settings for the communication between the SMU and the wind turbine
generators to be monitored

Path Project > Wind Turbine Generators > Edit/Add WTG

Window type Input area

Type of use Interactive

Reference Selected WTG

This area contains different parameters depending on the selected WTG type and the correspon-
ding communication type.

For each type of WTG, you will find the respective parameters and their explanation in the following
tables. 

Communication = Preload

This is not an actual communication type, but rather of setting of preload caused by a WTG of,
e.g., a different wind park.

Switch WTG by foreign
system

If a checkmark is set, it is assumed that in the case of shadow impact
the WTG will be switched by an external system. 

Use nacelle position from
WTG

Allows the value for the nacelle angle of a different WTG to be used for
the shadow impact calculation.

Communication “via relay”

Stop command via Here you can select whether the stop command should be received by
way of a digital output of the master unit or via the digital output of a
light sensor. In the latter case, you must define the number of the light
sensor.

DO - WTG stop signal Digital output for sending the stop command to the WTG. This option
cannot be deactivated. If the wind turbine generator to be switched
stops at LOW, set a checkmark at Output LOW active (Hardware >
Interface Cards ).

DO - WTG error alarm
contact

Digital output for reporting errors from the SMU to the WTG. If the wind
turbine generator to be switched detects LOW as an error, set a check-
mark at Output LOW active (Hardware > Interface Cards). 

DI - WTG status Digital input for retrieving the WTG Status. If the wind turbine generator
to be switched reports operation at LOW, set a checkmark at Input
LOW active (Hardware > Interface Cards). If this option is activated,
the background of the input field for Standstill on the left side of the
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Communication “via relay”

window changes to red (no input possible) since this parameter cannot
be considered anymore.

AI - WTG nacelle angle Analog input for retrieving the nacelle angle of the WTG to be switched.

AI - current WTG power Analog input for retrieving the current power of the WTG to be switched.

AI - WTG rotor speed Analog input for retrieving the rotor speed of the WTG to be switched –
if this option is activated, the background of the input field Standstill on
the left side of the window changes to green and you can define the
desired value.

AI - WTG wind speed Analog input for retrieving the wind speed measured by the WTG to be
switched.

Additional DO 1

Additional DO 2

Some WTGs have several stop inputs, often, e.g., a separate input for
stops due to bat protection. These separate inputs should be operated
depending on the reason for shutdown. By setting the checkmarks in
these two input areas, you specify the switch reason for which the addi-
tional digital outputs (DO1 and DO2) shall be used. Please note the
following:

· A switch reason selected here will subsequently no longer be sent
via the DO - WTG stop signal (above).

· With these two additional DOs, a maximum number of 3 DOs are
available having a WTG shut down for various reasons.

· The two additional DOs are only available once for each SMU, not
for each of the maximum 100 WTGs.

· If an additional DO is assigned one or more switch reasons, then it
must be assigned to an interface card with digital outputs (Hardware
> Hardware Assignments).

Communication “SWSE Type 01”

With this type of communication, all 4 analog signals (nacelle angle, current power, rotor speed
and wind speed) are not retrieved individually but by way of a Shadow Interface Unit (SIU), which
is installed in each WTG and provides signals. These signals are retrieved by the SMU.

IP address Enter the IP address of the SIU.

Port Enter the port of the SIU.

Gear ratio Some WTGs report the gear speed instead of the rotor speed. In this
case, the factor for converting the rotor speed must be entered here.  
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Communication “Senvion IEC 61400 Type 01”

So far, data can only be read out via this IEC interface. It is not possible to send stop commands,
for example. Therefore, the stop commands are sent via an SIU for now.

Stop command via Here you can choose whether the WTG will be switched via a relay of
the SMU or via a relay of the Shadow Interface Unit (SIU unit with basic
functions).

IP address Enter the IP address of the WTG to be switched.

Port Enter the port of the WTG to be switched.

Domain ID Access data for access to the IEC interface which will be communicated
by the manufacturer for each project.

Password Access data for access to the IEC interface which will be communicated
by the manufacturer for each project.

IP address of SWSE unit Enter the IP address of the SIU.

SWSE unit port Enter the port of the SIU.

Communication “Senvion IEC 61400 Type 02”

Via this IEC interface, an IEC61400 server is available both on the WTG side and on the SMU si-
de. The switch signals are provided by the SMU and picked up by the client of the WTG. 

IP address Enter the IP address of the WTG to be switched.

Port Enter the port of the WTG to be switched.

WTG identifier Displays the name of the WTG as it is stored in the SMU-side server. 

WTG password Access data for access to the IEC interface which will be communicated
by the manufacturer for each project.

Server port Port of the SMU-side IEC server.

Server password A password for the SMU-side IEC server can be entered here. If the
string is empty, no password authentication is active.

Domain ID Access data for access to the IEC interface which will be communicated
by the manufacturer for each project.

Communication “Nordex Modbus/TCP Type 01”

Communication takes place via a network connection: the SMU acts as the client, while the WTG
act as the slave. 
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Communication “Nordex Modbus/TCP Type 01”

IP address Enter the IP address of the WTG to be switched.

Port Enter the port of the WTG to be switched. All WTGs use the same port.

Modbus slave address Enter the slave address 

Send collective stop
command if another stop
command is pending

If a checkmark is set, a collective stop command is sent in addition to
the actual stop command due to e.g. shadow impact, bird protection, or
bat protection, and the reason for this collective command remains
open.

Several stop commands are possible – however, for now, it is necessa-
ry to send a collective command.

Communication “Nordex Profinet Type 01"

Communication takes place via an additionally plugged in Profinet interface card. The SMU is a
Profinet device and the wind park server acts as a Profinet controller. 

Send collective stop
command if another stop
command is pending

If a checkmark is set, a collective stop command is sent in addition to
the actual stop command due to e.g. shadow impact, bird protection, or
bat protection, and the reason for this collective command remains
open.

Several stop commands are possible – however, for now, it is necessa-
ry to send a collective command.

Communication ”Vestas OPC-Server Type 01”

Communication takes place via a network connection to the park server of the WTGs to be swit-
ched.

IP address Enter the IP address of the park server.

Port Enter the port of the park server.

WTG Communication
Number

This is the number of the respective WTG in the wind park. This number
may be different from the “WTG number” in the shadow impact forecast.



121Reference part > Project menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

Communication “Vestas Modbus/TCP 01”

Communication takes place via a network connection: the WTG to be switched acts as the client
while the SMU acts as the slave. Therefore, since the SMU, instead of establishing the communi-
cation, will only respond, entering an IP address is not necessary here.

Port Enter the port of the park server.

WTG Communication
Number

This is the number of the respective WTG in the wind park. This number
may be different from the “WTG number” in the shadow impact forecast.

Communication “Siemens WPS Type 01”

Communication takes place via a network connection to the park server of the WTGs to be swit-
ched.

IP address Enter the IP address of the park server.

Port Enter the port of the park server.

WTG name Name of the WTG as used in the data telegram sent from a Siemens
WTG.

Extended WPS communi-
cation

Activates shutdowns for bat protection in the communication.

Communication “Siemens OPC Type 01”

Communication takes place via a network connection to the park server of the WTG to be swit-
ched. OPC UA is used for the communication. The SMU is the client in this case.

WTG identifier Displays the name of the WTG as it is stored in the server – serves the
exact assignment of the data. 

Log server identifier Here you can enter the name of the log server as it is stored in the ser-
ver – serves to exchange shadow impact log data.

Alarm server identifier Here you can enter the name of the alarm server as it is stored in the
server – serves for averaging faults.

Port Enter the port of the WTG to be switched.

User authentication User name for logging on to the server.

Password authentication Password used to log on to the server.
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Communication ”Enercon OPC-Server Type 01”

Communication takes place via a network connection to the park server of the WTGs to be swit-
ched.

IP address Enter the IP address of the park server.

Port Enter the port of the park server.

User ID for control access Access data needed to write data to the Enercon server so that an addi-
tional identification ensures increased security, e.g. when sending stop
commands.

WTG name Name of the WGT specified by Enercon, which is transferred during the
communication.

Name of OPC server tem-
perature knot

Name of the WTG control – used to determine the correct temperatu-
res.

Use extended stop list This can be used to define that instead of the standard stop signals (60°
and 90°) an extended list defined by Enercon is used, which, e.g., provi-
des an individual stop number for shadow impact. 

Stop shadow impact Stop at 60° or 90° in the case of shadow impact. However, if Use ex-
tended stop list is active, the shadow impact module will stop the
WTG.   

Stop calendar Stop at 60° or 90° according to calendar. However, if Use extended
stop list is active, the shadow impact module will stop the WTG.   

Stop bat protection Stop at 60° or 90° for bat protection. If Use extended stop list is acti-
ve, stop due to species conservation 60° or species conversation 90°
will be carried out.   

Stop sector Stop at 60° or 90° in the case of shadow impact. However, if Use ex-
tended stop list is active, stop due to shadow impact will be carried
out.

Stop noise protection Stop at 60° or 90° in the case of shadow impact. However, if Use ex-
tended stop list is active, the shadow impact module will stop the
WTG.   

Stop external Stop at 60° or 90° in the case of shadow impact. However, if Use ex-
tended stop list is active, the shadow impact module will stop the
WTG.   

Stop bird protection Stop at 60° or 90° in the case of shadow impact. If Use extended stop
list is active, stop due to species conservation 60° or species con-
versation 90° will be carried out.     

Measured ambient tempe-
rature

Place where the ambient temperature is to be measured: Ground level,
nacelle level or use the mean value of the two.
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Communication "Enercon OPC Vleemo Type 01"

Communication takes place via a network connection to the park server of the WTGs to be swit-
ched.

IP address Enter the IP address of the park server.

Port Enter the port of the park server.

WTG name Name of the WGT specified by Enercon, which is transferred during the
communication.

Use extended stop list This can be used to define that instead of the standard stop signals (60°
and 90°) an extended list defined by Enercon is used, which, e.g., provi-
des an individual stop number for shadow impact. If the checkmark is
set, the extended stop list is used.

Stop shadow impact Stop at 60° or 90° in the case of shadow impact. However, if Use ex-
tended stop list is active, the shadow impact module will stop the
WTG.   

Stop calendar Stop at 60° or 90° according to calendar. However, if Use extended
stop list is active, the shadow impact module will stop the WTG.   

Stop bat protection Stop at 60° or 90° for bat protection. If Use extended stop list is acti-
ve, stop due to species conservation 60° or species conversation 90°
will be carried out.   

Stop sector Stop at 60° or 90° in the case of shadow impact. However, if Use ex-
tended stop list is active, stop due to shadow impact will be carried
out.

Stop noise protection Stop at 60° or 90° in the case of shadow impact. However, if Use ex-
tended stop list is active, the shadow impact module will stop the
WTG.   

Stop external Stop at 60° or 90° in the case of shadow impact. However, if Use ex-
tended stop list is active, the shadow impact module will stop the
WTG.   

Stop bird protection Stop at 60° or 90° in the case of shadow impact. If Use extended stop
list is active, stop due to species conservation 60° or species conversa-
tion 90° will be carried out.   

Communication “Eno Energy Modbus/TCP Type 01”

Communication takes place via a network connection: the SMU acts as the client, while the WTG
act as the slave. 

IP address Enter the IP address of the WTG to be switched.
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Communication “Eno Energy Modbus/TCP Type 01”

Port Enter the port of the WTG to be switched. All WTGs use the same port.

Modbus slave address Enter the slave address

Communication “Acciona Modbus/TCP Type 01”

Communication takes place via a network connection: the SMU acts as the client, while the WTG
act as the slave. 

IP address Enter the IP address of the WTG to be switched.

Port Enter the port of the WTG to be switched. All WTGs use the same port.

Modbus slave address Enter the slave address

Communication “GE Modbus/TCP Type 01”

Communication takes place via a network connection: the SMU acts as the client, while the WTG
act as the slave. 

IP address Enter the IP address of the WTG to be switched.

Port Enter the port of the WTG to be switched. All WTGs use the same port.

Modbus slave address Enter the slave address

Wind speed as 10 min.
average value

By selecting this option, you specify that the SMU determines a mean
value over 10 minutes and uses it instead of the actual value reported by
the WTG. 

Communication “Vensys Modbus /TCP 01”

Communication takes place via a network connection: the WTG to be switched acts as the client
while the SMU acts as the slave. Therefore, since the SMU, instead of establishing the communi-
cation, will merely be addressed, entering an IP address is not necessary here.

Port Enter the port of the park server.

WTG communication
number

This is the number of the respective WTG in the wind park. This can de-
viate from the "WTG number" from the shadow impact forecast.
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Communication “Lagerwey GE Modbus/TCP Type 01”

Communication takes place via a network connection: the SMU acts as the client, while the WTG
act as the slave. 

IP address Enter the IP address of the WTG to be switched.

Port Enter the port of the WTG to be switched. All WTGs use the same port.

Modbus slave address Enter the slave address

Communication „Amperax Modbus Type 01” 

Communication takes place via a network connection: the SMU acts as the client, while the WTG
act as the slave. 

IP address Enter the IP address of the WTG to be switched.

Port Enter the port of the WTG to be switched. All WTGs use the same port.

Modbus slave address Enter the slave address

Communication "General TCP Type 01"

IP address Enter the IP address of the server.

Port Enter the port of the server.

Select names of
certificates

Select whether certificate designations different from the standard are to
be used. 

Name of your own
certificate:

Enter the name of the SMUs own certificate.

Name of your own key Enter the name of the SMU's own key.

Name of your own confi-
guration file

Enter the name of the SMUs own configuration file.

Name of trusted third-par-
ty certificate

Enter the name of the trusted third-party certificate.
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4.2.3 Places of Immission window

Purpose Display and edit places of immission (POIs), areas/walls, shadow impact pe-
riods, combinations, etc.

Symbol

Path Project > Places of Immission 

Window type List window

Type of use Display + buttons to sub windows

Reference Project

This window shows a list of the POIs already created in the project that is currently opened. The in-
dividual parameters for a POI are defined in the Add/Edit Place of Immission window, see next
paragraph.

Places of immission window

General notes regarding the Places of Immission window 

· The top part of the window shows a list of the already created POIs, the actual settings are
made in the Add/Edit Place of Immission sub window. The information “9/2000” in the upper-
right corner of the screen means that 9 of 2000 possible POIs have already been created. An
explanation of the individual columns (parameters) can be found in the Add/Edit Place of
Immission sub window  section.

· The currently selected POI is highlighted in blue.

130



127Reference part > Project menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

· POI 6 is highlighted in red because no walls/areas have yet been defined for this POI.

· If you double-click on a POI in the list, the Add/Edit Place of Immission window will be ope-
ned.

· The parameters defined in the Add/Edit Place of Immission window under Maximum permis-
sible annual load/Maximum permissible annual load are displayed in the Daily Limit/Annual
Limit columns. For more information on these two columns, see the end of this chapter.

Operating instructions regarding the Places of Immission window 

· Move columns: Columns can be moved by drag & drop.

· Sort by column: You can sort a column according to its heading by clicking on it. If you then click
again on the same column heading, the sort sequence will change from ascending to descen-
ding or vice versa.
You can also sort by more than one column heading (criteria). To do this, first press and hold
the shift key and then click on the desired column headings. The sorting will be carried out
according to the order in which you click on the column headings.

Information and setting options in the bottom part of the window 

Element Explanation/function

According to the default settings, a defined POI will be monitored
24/7 all year round. If you click on this button, you can exclude
specific periods of time from monitoring, please see Shadow Im-
pact Monitoring Periods sub window .

In the Edit Walls and Areas window, you can edit or create walls
and areas for an existing POI, see Edit Walls and Areas sub
window .

Used to define phone numbers from which residents can shut
down WTGs that currently cause shadow impact by dialing a spe-
cial phone number, see Phone Option sub window .

Opens the POI Combinations window. This window corresponds
to the WTG Combinations sub window  (for more information,
see the respective section), however, instead of the possible com-
binations of one WTG with all POIs, the possible combinations of
ONE specific POI with all WTGs defined in the project are concer-
ned here.

NOTE:

To reduce the production periods of a small WTG during shadow
impact in favor of a larger WTG that has a higher power output,
for example, you can reduce the load periods for each combination
even further here. In other words: The times during which a WTG
with low rated power output is allowed to cause shadow impact
should be reduced so that a WTG with a higher output can yield
more revenue.

135
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Element Explanation/function

SI periods with monitoring Displays the number of shadow impact periods with monitoring
that have been defined for the POI selected in the list — no input
possible. For further information, see Shadow Impact Monitoring
Periods sub window .

SI periods without monitoring Displays the number of shadow impact periods without monitoring
that have been defined for the POI currently selected in the list —
no input possible. For further information, see Shadow Impact Mo-
nitoring Periods sub window .

Phone numbers Shows how many telephone numbers for the phone option have
been defined for the POI currently selected in the list. For further
information, see Phone Option sub window .

No. of walls Displays the number of walls that have been defined for the POI
currently selected in the list — no input possible. For further infor-
mation, see Edit Walls and Areas sub window .

No. of areas Displays the number of areas that have been defined for the POI
currently selected in the list — no input possible. For further infor-
mation,see Edit Walls and Areas sub window .

If you click on this button after you have deleted one or more
POIs, a consecutive numbering will be restored (the purpose of
this function is simply to provide a better overview). 

Deletes the POI selected in the list. Attention: If you click this but-
ton, the POI will be deleted immediately, (no confirmation dialog).

Is used to edit the POI selected in the list. 

Adds a new POI. Up to 2000 POIs are possible.

135
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Notes regarding the "Daily Limit" / "Annual Limit" columns

The following table shows how the parameters defined in the Add/Edit Place of Immission window
affect the display in the Daily Limit/Annual Limit columns in the Places of Immission window.

 
Add/Edit Place of Immission window

 
Places of Immission window

Maximum permissible
daily/annual load pa-

rameter

Parameter 
Only log

WTG stop

Parameter 
Use annual

limit/ Use daily
limit

Day Limit
column

Annual Limit
column

1 --   -- --

2 30 / 356  þ 30 356

3 30 / 356 þ þ (30) (356)

NOTE: Please note that defined limit values (Maximum permissible daily/annual load), for which
the corresponding parameter Only log WTG stop has been activated, are displayed in brackets in
the Places of Immission window.

The following table shows the representation of the parameters from the above example in the con-
figuration log and Google Earth export:

POI
Indication in the configuration log / Google Earth export 
Max. permissible daily/annual load

1 not used

2 30 min / 356 min

3 (30) min / (356) min

Use the data of an existing place of immission

§ If you want to copy the data of a POI that has already been created, click on this POI in
the Places of Immission window in order to selected (dataset highlighted in blue). 

§ Then click on  Edit (or double-click the desired POI dataset in the list).

§ The Add/Edit Place of Immission window will open and No. of place of immission will
be highlighted in orange. 

§ Now enter the next tree number here (in the case of the above window this would be
number 4). The box will now be highlighted in green and  Add at the bottom of the
window will be activated.

See also Practical example 1: Set up a new WTG with a new POI 33
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4.2.3.1 Add/Edit Place of Immission sub window

Purpose Add or edit places of immission (POI) including information, such as address,
height above sea level, maximum permissible load and building type.

Symbol

Path Project > Places of Immission > Edit or Add

Type of use Interactive + buttons to sub windows

Reference POI

Add/Edit Place of Immission sub window

 

Notes regarding the Add/Edit Place of Immission window

· Press the Enter key or the Tab key to complete the current entry and jump to the next input
field.

· Fields in which an invalid value was entered (value is outside the permitted range, wrong input
format) are highlighted in red:

· The buttons Apply and Add will not be activated until the input fields have been filled out cor-
rectly.
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The information, options or buttons are described in the following table 

Element Explanation/function

Selected place of immission Displays the POI that was selected in the Places of Immission
window and whose data will be used for the new POI. 

No. of place of immission Up to 2000 POIs can be defined.

If you have clicked on Add in the Places of Immission window, the
next free number will automatically be provided here. 

If you have clicked on Edit in the Places of Immission window, you
can enter the next free POI number here in order to use the data of
another POI, see the productivity tip in the Places of Immission
window  section. 

NOTE

You can also enter/use the number of an existing POI. The dataset of
this existing WTG will then be overwritten with the “new data”. Before
that, however, the Fenster Abhängigkeiten  will open.

Name from shadow impact
forecast

Name of the POI as used in a shadow impact forecast which may have
been drawn up.

Name of place of immission This piece of information is useful when there is more than one POI
with the same address. Each name can be used only once. This uni-
que identification of a POI will also be shown in the log and can thus
be allocated in the shadow impact forecast.

Address of place of
immission

Exact address of the POI (street name, city, area code)

Height above sea level Height above sea level of the POI

Meter

Building type Drop-down list that offers the following: House, Commercial, Stable,
Church, Open area, Unknown

You can also enter free text.

Maximum permissible 
daily load

Maximum permissible shadow impact load at the POI per day; after
reaching this limit, the responsible WTG is switched off. This parame-
ter can be activated or deactivated in the Use daily limit checkbox –
this makes it possible, e.g., to only observe the shadow impact for a
while without actually switching off. 

NOTES

· In the Place of Immission window, this parameter is displayed in
the Daily Limit column.
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Element Explanation/function

· If you increase this value, click Apply and confirm with OK in the De-

pendencies window, you will see the following message:

It indicates that the change made here has no effect on the values in

the corresponding columns in the Combinations window. In other

words, this parameter only defines the "maximum value" that cannot

be exceeded in the Combinations window (otherwise an error mes-

sage will appear there). The redistribution of the shadow impact

budget from low rated to higher rated WTGs can be defined/adjus-

ted in the Combination windows, see WTG Combinations sub

window .

Minutes (integers only), the value must not exceed the corresponding
value for the year

Only log WTG stop This checkbox is only available (active) if the subsequent box has been
checked. In this case, if a checkmark is also set here, exceeding the
daily limit only causes an entry in the log, but no shutdown of the re-
sponsible WTG.

Use daily limit This checkbox is marked by default. 

If the checkmark is removed, this has the following effects:

· no WTG will be shut down due to a daily limit having been excee-
ded 

· the previously displayed limit value is replaced by a double line,
and the input field is highlighted in gray

· the Only log WTG stop checkbox belonging to the counter is de-
activated.

No. of grace days – daily
load

In SM4 = number of days (per year) on which the Maximum permissi-
ble daily load (see above) may be exceeded.

NOTE

If you increase this value, then click Apply and confirm with OK in the

Dependencies window, you will see the following message:

106
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Element Explanation/function

It indicates that the change made here has no effect on the parameter

values in the corresponding columns in the Combinations window. In

other words, this parameter only defines the "maximum value" that

cannot be exceeded in the Combinations window (otherwise an error

message will appear there).

0 Tage

Reset date for applied grace
days (MM/dd)

The grace days counter will be reset on the date set here.

01/01

Maximum permissible
annual load

Maximum permissible shadow impact load at the POI per year; after
reaching this limit, the responsible WTG is switched off. This parame-
ter can be activated or deactivated in the Use annual limit checkbox –
this makes it possible, e.g., to only observe the shadow impact for a
while without actually switching off. 

NOTE 1

In the Place of Immission window, this parameter is displayed in the
Annual Limit column.

NOTE 2

If you increase this value, a system message informs you that a
change you make here will have no effect on the value in the Max.
Annual Load [min] in the Combinations window. In other words, this
parameter only defines the "maximum value”, which cannot be excee-
ded in the Combinations window (error message). The redistribution
of the shadow impact budget from low rated to higher rated WTGs
can be defined/adjusted in the Combination windows, see WTG
Combinations sub window .

Minutes (only integers)

Only log WTG stop This checkbox is only available (active) if the subsequent box has been
checked. In this case, if a checkmark is also set here, exceeding the
annual limit only causes an entry in the log, but no shutdown of the re-
sponsible WTG.

Use daily limit This checkbox is marked by default. 

If the checkmark is removed, this has the following effects:

· no WTG will be shut down due to an annual limit having been ex-
ceeded 

· the previously displayed limit value is replaced by a double line,
and the input field is highlighted in gray

· the Only log WTG stop checkbox belonging to the counter is de-
activated.
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Element Explanation/function

Reset date for annual coun-
ter (MM:dd)

Since the “shadow impact year” does not necessarily correspond to
the calendar year, you can set another date here.

Always presume shadow
impact/sunlight for the POI
(light sensor will be ignored)

If you set a checkmark here, shadow impact will be logged as soon as
the conditions for theoretical shadow impact are met, and the WTG re-
sponsible for the theoretical shadow impact will be shut down, no mat-
ter if the sky is cloudy or not. Otherwise, when weather conditions
changes from cloudy to sunny, a WTG will not come to a stop until 1 to
2 minutes after the shutdown command is sent.  

Switches to the Places of Immission window (if this window is not
open already, it will be opened now). Here you can specify what hap-
pens if you click on Add in the Add/Edit Place of Immission window.

Opens the Action following ‘Add’ input area in the Application
Settings window where you can define what happens when you click
on Add in the Add/Edit Place of Immission window; the available op-
tions are self-explanatory.

Opens a window of the POI Combinations sub window.

Clears the freely definable input fields of the current POI.

Accepts the entered data.     

Add a new POI number. Up to 2.000 POIs are possible.

See also Practical example 1: Set up a new WTG with a new POI

See also Practical example 3: Changed load times & utilization times of a POI
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4.2.3.2 Shadow Impact Monitoring Periods sub window

Purpose Here you can define time periods in which the shadow impact at a POI is to
be monitored or not monitored. 

Icon

Path Project > Places of Immission > Shadow Impact Monitoring Periods

Usage type Display + Dialog

Reference POI

According to the default settings, all places of immission defined in SM4 will be monitored 24/7 all
year round. In the Shadow Impact Monitoring Periods sub window, you can define up to 40 peri-
ods in which shadow impact at a place of immission will be monitored and another 40 during which
shadow impact will not be monitored, for example, in order to reduce monitoring of commercially
used POIs to the working hours or to deactivate monitoring during annual closures.

Shadow Impact Monitoring Periods window

Overview of the individual areas of the Shadow Impact Monitoring Periods window

A Area for defining a new dataset or edit or delete an existing dataset.

B Display only; information displayed depends on what has been set under Project Settings
window, SMU, Time settings , you will find further information there.

C Area for changing the time resolution of display area D

D Calendar view of existing data records (display only)

E List of existing records (display only)

153



136Reference part > Project menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

Notes on the example window Shadow cast monitoring times

· In the above example window, as can be seen on the bottom right, 2 weekly recurring
monitoring periods are defined to ensure that the building is exposed to limited shadow impact
during office hours, marked red.

· Below this you can see the company vacations in July, which are excluded from shadow
impact monitoring, marked green. Whenever "green" periods (without monitoring) overlap with
"red" periods (with monitoring), green periods are given priority.

· If you do not make any changes in the Shadow Impact Monitoring Periods  times window, then
only the following default dataset is created here, which ensures that monitoring takes place
24/7 all year round:

An explanation of the information, options or buttons can be found in the following table 

Input field/area Explanation/ function

Place of immission Displays the number of the place of immission point selected in
the Places of Immission window.

[x/40] Shows how many of 40+40 possible periods have already been
defined.

In this area you can add, edit or delete a dataset. 

Add a dataset - procedure

1. First you decide on one of two options:
- with shadow impact monitoring
- without shadow impact monitoring

2. Then you can enter a descriptive free text at Comment (e.g.
commercial property, usage MO-FR). 

3. If a day segment (start time to end time) is to be defined
and repeated on certain or all weekdays, then make the fur-
ther entries in the Weekly area and click on Add there.

However, if you want to define a yearly period (start date to
end date), then make the further entries in the Time range
area and click Add there. A period defined here will be ex-
cluded from monitoring in the following years as well only if
you activate Repeat annually.

NOTE RE 3.
Please note that it makes a difference whether you use the but-
tons in the Weekly area or in the Time range area.

Delete a record
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Input field/area Explanation/ function

· Select the record to be deleted in the calendar view (click on
a red box of the respective period) or select it in the list at the
bottom right, then click on Delete in the Weekly area or in the
Time range area, depending on the dataset type concerned.

Modify a record

· Select the record to be changed in the calendar view (click
on a red box of the respective period) or select it in the list
at the bottom right. 

· Make the desired change and then click on Apply (again,
under Weekly OR under Time range, depending on the da-
taset type). 

GENERAL NOTES

· Entry formats for time and date depend on the settings un-
der File > Application Settings > Shadow Manager 4 > Ge-
neral > Country-specific settings.

· According to the default setting, monitoring takes place 24/7
all year round ("Default" data set: every Sunday, Monday,
Tuesday, Wednesday, Thursday, Friday, Saturday from
00:00 to 23:59*).

· If time ranges without and with shadow impact monitoring
overlap, then the time range without monitoring has priority.

Defined periods are displayed in a calendar view in the top right
of the window. You can change the temporal resolution (Year,
Month, Week, Timeline) using the buttons at the bottom left of
the window under Calendar view), description see below.

Periods with shadow monitoring

Periods without shadow monitoring

Calendar view Here you define the view in which periods with/without shadow
impact monitoring are to be displayed in the top right of the
window. In the Date drop-down list, you can switch directly to a
specific day. Use the Year, Month and Week buttons to call up
the corresponding time frames and then scroll back and forth as
you wish. If you click on Timeline, the current day is displayed
and you can scroll one day forward and one day back at the
bottom scroll bar.

List at bottom right All currently defined datasets are listed here. In the Color
column, periods with shadow impact monitoring are marked red,
while times without shadow impact monitoring are marked
green. If you wish to edit or delete a dataset, you can select it
here.
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*The entry format (date and time format) is based on the pre-settings (defaults) in the input area
Country-specific settings (File > Application Settings > Shadow Manager 4 > General) and can
be changed there at any time.

Defining periods with/without shadow impact monitoring can be useful in the following cases:

· It is not necessary to monitor a POI on Saturdays and Sundays because it is not used on these
days. 
Measure: Remove the checkmarks for Saturday and Sunday of the “default” dataset under
Periods with shadow impact monitoring.

· It is not necessary to monitor or a POI doing a specific period of the year due to annual clos-
ures.
Measure: Add a dataset that specifies the corresponding period under Periods without
shadow impact monitoring.

See also Practical example 3: Changed load times & utilization times of a POI

Practical tip for zero shadow impact

Requirement

At POI X, shadow impact should be = 0 (zero) on weekends and holidays, regardless of
how much of the shadow impact budget has been used at the time.

Solution

Set up POI X twice as follows: 

POI X.1

Add/Edit Place of Immission window > Maximum permissible daily/annual load:

daily = 30 min, annual = 480 min

Shadow Impact Monitoring Periods subwindow: 

Periods with shadow impact monitoring, Monday to Sunday, 00:00–23:59 (00:00 AM–
12:00 PM)

POI X.2 (copy POI X1, i.e., use X1 as template)

Add/Edit Place of Immission window > Maximum permissible daily/annual load:

daily = 0 min, annual = 0 min

Shadow Impact Monitoring Periods subwindow: 

Periods with shadow impact monitoring > Saturday and Sunday, 00:00–23:59 (00:00
AM–12:00 PM)

Periods without shadow impact monitoring > public holidays  

36
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4.2.3.3 Edit Walls and Areas sub window

Purpose Specify the coordinates of the walls and areas to be monitored

Symbol

Path Project > Places of Immission > Edit Walls and Areas

Type of use Display + interactive

Reference POI

In order to enable the SMU to monitor a defined place of immission (POI), you have to define the
actual walls and/or areas of the POI that need to be protected from shadow impact. No monitoring
will take place until you have defined the corresponding coordinates in the Edit Walls and Areas
sub window.

Edit Walls and Areas window
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Notes regarding the Edit Walls and Areas window

· To add a wall or area, click on the + character (bottom left) in the corresponding screen area;
to remove a wall or area, select the wall/area to be removed and then click on the - character
(also bottom left).

· Press the enter key to confirm your input and jump to the next field.

· Input format: For input fields in which decimals are allowed, the decimal separator to be used
depends on the default selected in the input area Country-specific settings (File > Application
Settings > Shadow Manager 4 > General.). It can be changed there at any time.

· Upon confirming the last input field of a line by pressing the Enter key, you automatically add a
new empty dataset.

· In the top view on the right you can visualls check your entries

You will find a detailed description of this window in the following table.

Element Explanation/function

Place of immission Number of the POI selected in the Places of Immission window (refe-
rence only).

Walls and areas of all
places of immission

Indicates how many walls and areas have already been defined for all
POIs and how many can be defined in total. In the exemplary window
above, you can see that 86 of 10.000 possible walls and areas have been
defined so far.

Walls/No. Consecutive number of the respective wall

Walls/X1, Y1, X2, Y2 A wall is defined here by specifying 4 metric values based on the coordi-
nate system selected in the Project data window (Project > Project
Data).

2 decimals
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Element Explanation/function

Walls/ Offset NN Enter the distance between Meters above sea level specified when defi-
ning the POI and the first window of the building.

EXAMPLE

The bottom edge of the lowest window in a wall is located 5 m above the
ground, and from a height of 8 m above the ground, there are no more
windows in this wall. In the above example you would have two enter
“5 m” as Offset.

 

You can also enter a negative value, e.g. for buildings situated on a slope
whose windows may be located below sea level.

meter, 2 decimals

Wall/ Height Actual place of immission: Enter the height of the wall area to be consi-
dered as POI. In the above example you would have two enter “3 m”

meter, 2 decimals

Walls/ Orientation Defines the orientation of the respective wall.

Wall/ Length This field will be filled out automatically – here you can verify the entered
coordinates are correct.

Area/No. Consecutive number of the area

Areas/ Offset NN Enter the distance between Meters above sea level as specified when
defining the POI and the elevation of the respective area. Example: roof-
top garden. 

meter, 2 decimals

Areas/X, Y (1, 2, 3 …) The sides of an area are defined here by specifying 2 metric values based
on the coordinate system selected in the Project data window (Project >
Project Data).

2 decimals
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Element Explanation/function

Areas/ Length This field will be filled out automatically – here you can verify the entered
coordinates are correct.

Important notes for defining walls and areas

· The points defining area must be entered clockwise or counterclockwise; it is import-
ant not to enter them in a criss-cross manner. 

· Walls and areas, you have already edited or created will only be saved and applied if
you click the Apply button.

· The coordinates of all WTGs and POIs must be defined using the same metric coor-
dinate system.

· You can define an unlimited number of walls and areas for each POI. However, the
number of walls and areas is limited to 10,000 for each project. 

· Once you have entered or edited a parameter of a wall/area, you can press Enter to
jump to the next parameter (to reduce mouse operation). 

· An area must have at least 3 sides (defined by points) and can have a max. number
of 9 sides (i.e., 10 points); the last point connects to the first point.

Please also pay attention to the following note.

Please be very careful when entering values in Shadow Manager. Incorrect parameter
values may result in avoidable wear and tear, loss of earnings, problems with authori-
ties or residents and in the worst-case force operators to decommission wind turbine
generators. 

If the field Length to a wall or area in meters (last field of the line) is highlighted in yel-
low (instead of green), the entered values are not plausible or the maximum length of a
wall or side of an area according to the warning limit (File> Application Settings > War-
ning Limits) has been exceeded. Check that you have entered the coordinates correct-
ly. For further information, please refer to section Application Settings window, War-
ning limits .

See also Practical example 1: Set up a new WTG with a new POI

80

33
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4.2.3.4 Phone Option sub window

Purpose Define phone numbers from which residents can shut down WTGs that
currently cause shadow impact by dialing a special phone number.

Symbol

Path Project > Places of Immission > Phone Option 

Window type Divided horizontally

Type of use Display + interactive

Reference Project

For each place of immission, you can define up to 10 phone numbers from which residents can call
to stop shadow impact at their place of immission. A connected modem will then forward the identi-
fied caller number to the SMU without answering the call.

A will immediately stop a WTG that causes shadows at this POI, even if no limit has yet been ex-
ceeded. On the following day this function is switched off again and must be reactivated by a new
call if necessary. Several WTGs in the vicinity of the place of mission may be shut down
immediately after a call has been made.

Phone Option window

You will find a detailed description of this window in the following table.
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Element Explanation/function

Place of immission Displays the number of the place of immission selected in the Places
of Immission window.

Address Displays the number of the address selected in the Places of
Immission window.

The number of telephone numbers already added (up to 10 are possi-
ble) is displayed in square brackets on the right-hand side.

+ – To add a phone number, click on the + character (bottom left); to re-
move a phone number, select the phone number to be removed and
then click on the - character (also bottom left).

Index Sequential number

Number Enter the phone number.

NOTE: Enter international area codes with a “+” (00 is not allowed).

Comment Free text field in which you may enter the name of the subscriber, for
example.

Phone option mode The following 5 options are provided here: 

Off

The Phone option is switched off for this POI, none of the subscribers
can prevent shadow impact via telephone.

Phone call, consider light sensor, ignore counter

A WTG that causes shadow impact will only be stopped if a subscri-
ber has called. The entered limit values do not apply in this mode.

Phone call, consider light sensor, consider counter

A WTG causing shadow impact is stopped if (a) one of the defined
limit values is exceeded and/or (b) a subscriber has called.

Phone call, ignore light sensor, ignore counter

If a subscriber calls, the WTG is switched off, provided that shadow
impact is mathematically possible. Whether or not the sun actually shi-
nes is not taken into account if you select this option.

Phone call, ignore light sensor, consider counter

A WTG causing shadow impact is stopped if (a) one of the defined
limit values is exceeded and/or (b) a subscriber has called. Whether
or not the sun actually shines is not taken into account if you select
this option.
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4.2.3.5 POI Combinations sub window

Purpose Define/change direct relationships between the POI selected in the Places of
Immission window and each WTG for the purpose of yield optimization

Symbol

Path Project > Places of immission >  Combinations 

Type of use Interactive + Wizard

Reference POI

Just like the Wind Turbine Generators window, the Places of Immission window also provides a
Combinations button. When you click on this button, the POI Combinations window opens; the
operation of this window basically corresponds to the WTG Combinations window except that here
you are dealing with relationships from the ‘viewpoint’ of a place of immission instead of a WTG.
Therefore, you can find more information on this window under WTG Combinations sub
window . 106
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4.2.4 Overview Map window

Purpose Visually check whether WTGs, POIs as well as walls and areas have been
defined correctly

Symbol

Path Project > Overview Map

Type of use Display + interactive

Reference Entire project

You can open an overview map to visually check the defined locations of WTGs, POIs as well as
the defined walls and areas. It is also possible to export the data to Google Earth.

Overview map window several POIs (green dots) and WTGs (red squares) 

Notes regarding the Overview Map window 

· Click on the map and use the mouse wheel/touchpad or press the plus (+) or minus (-) key to
zoom in or out. 

· To move the map, hold down the left mouse button and drag the map in the desired direction or
use the arrow keys on the keyboard.
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· If you zoom in strongly on the map and have selected the POI (detail) option, you can also see
the defined walls and areas. The small rectangular line on walls indicates their orientation.

The information, options or buttons are described in the following table 

Element Explanation

Selected Coordinate
System

Displays the coordinate system selected in the Project Data window for
Coordinate format.

Cards

White Background is white.

OSM Open Street Map will appear in the background.

NOTE

The computer must be connected to the internet to use the OSM. 

POI focus

Zoom If the Zoom option field has been activated, you can use the dropdown list
underneath to select a POI number which will then become the center of the
map. 

Elements

POI (dot) Used to show/hide defined places of immission. Defined POIs are displayed
as green dots.

POIs (detail) Used to show/hide defined walls and areas. Defined walls and areas are dis-
played as black lines. The view needs to be greatly enlarged to be able to
detect them. The small rectangular line on walls indicates their orientation.

WTG Used to show/hide defined wind turbine generators. Defined WTGs are dis-
played as red squares.

Frame Used to show/hide a black frame.

Center If you click on this button, the map section is moved so that the project center
is displayed in the middle of the map. The project center, i.e. the center of the
WTGs according to the longitude and latitude specified in the Project data
window, is displayed as an orange circle. It is calculated automatically. 

Exports the data as a kml file that can be opened in Google Earth. 

When you open the kml file with Google Earth, the WTGs and the POIs are
also represented there by red squares or green dots. 
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Element Explanation

If you click on a WTG in Google Earth, a window with data relating to the re-
spective WTG (type, meters above sea level, hub height, etc.) will be dis-
played. 

If you click on a POI in Google Earth, a window with data relating to the re-
spective POI (address, building type, max. load, etc.) will be displayed. 

Using the Google Earth functions, you can also zoom in so far that you can
identify e.g. the walls and areas defined for a POI.

Moves the map view so that the center of the WTGs is displayed in the cen-
ter of the window.

See also Practical example 2: Visually check the position of POIs and WTGs 35
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4.2.5 Alarm Settings window

Purpose Specify when alarms are initiated for what components

Symbol

Path Project > Alarm Settings 

Type of use Display + interactive

Reference Entire project

In this window you specify the way in which alarms are initiated for which components. All possible
alarms have been pre-defined: you may edit these, but you cannot add alarms. 

Perform edits directly in the list of alarms (there is no editor here). After changing an alarm, click on
Apply to apply the changes.

Alarm Settings window (section)

The information, options or buttons are described in the following table
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Element Explanation

Identification

No. Consecutive number for the alarm

Alarm options

Active All alarms are active by default. It is possible to deactivate each alarm indivi-
dually by removing the checkmark in this column.

EXAMPLE

If it is known in advance that a WTG does not react to a stop command, it
may be helpful to deactivate this alarm until the respective error has been re-
medied.

NOTE

If this option is not checked, the alarm will continue to be displayed and log-
ged as soon as it occurs. However, no notification will be sent via email and
it will not be transferred to the WTG. 

EMail If this option is checked, a corresponding message will be sent to the person
specified in Project Settings (Project > Project Settings > Email recipient
settings) for each alarm.

Auto acknowledge If this option is checked, the respective alarm will be automatically reset after
the error has been remedied.

Warning By activating this box, you can classify a specific event that requires no im-
mediate action as a warning (the watchdog will continue to be controlled, ho-
wever, there will be no transmission to the WTG). Whether and to whom an
email warning notification will be sent can be specified in the Project
Settings (Project > Project Settings > Email recipient settings).

Suppress If this option is checked, the alarm will be ignored. This means that it will not
be displayed or logged, and no message will be sent to an external destinati-
on – it will be completely ignored. 

Delay The values of the two subsequent columns (Reset Autom.[s], Delay[s]) are
activated/deactivated in this column, provided values have been entered the-
re.

Delays

Auto Acknowledge
[s]

If a check mark has been placed in the Auto Acknowledge column, you can
specify a period in seconds by which the automatic reset is delayed.

Delay[s] If an alarm should not be triggered as soon as it occurs but only after a cer-
tain period has elapsed, you can enter the desired delay (in seconds) here.
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Element Explanation

Alarm number and text

Alarm No Automatically generated number that is also displayed in the log.

Alarm Text Automatically generated text that is also displayed in the log. 

The default settings of the Alarm Settings window can be found in Appendix
I.

Use this button to open the Alarm routing to WTG settings window for the
alarm marked in the Alarm Settings Window. This is not relevant for all
WTG types. This is only relevant for WTG types the SMU communicates with
directly. In this case, you can set which alarms are to be forwarded to which
WTGs. This is particularly useful if an alarm is received by the SMU that trig-
gers an action of the WTG (e.g., stop during night time because the bat shut-
down feature is active then). During this time, non-relevant alarms, such as
the fault of a sensor not assigned to this WTG or errors in the communication
with another WTG, should not be forwarded.

Relevant WTG types: 

200xx, 300xx, 400xx, 2200xx, 6200xx, 19100xx

To route the selected alarm (displayed above the list of WTGs in the Alarm
routing to WTG setting window) to all WTGs, click on ... to all WTGs (un-
less all WTGs are already selected in the Alarm routing column).

To route the selected alarm only to specific WTGs, click on ... to no WTG
and select only certain WTGs individually in the Alarm routing column.

If you click on Close without having clicked on Apply beforehand, the system
will ask you whether you want to apply the changes.

Confirms the entered/selected values.
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4.2.6 Project Settings window

Purpose Perform basic settings that apply to the entire project

Symbol

Path Project > Settings 

Window type Menu tree window

Type of use Interactive

Reference Project

You can perform basic settings that apply to the entire project in this window. 

From the settings and information, SM4 later derives the data used to configure the SMU. It is the-
refore imperative that you observe the following warning notice:

Pay particular attention when entering the following information in the Project Settings
window:

§ Port number(Server settings )

§ Ethernet IP address, Ethernet net mask, Gateway, DNS server (Ethernet
settings )

If incorrect information is entered here and transmitted to the SMU, the SMU will no
longer be available, and a service technician will have to determine the IP address of
the SMU on site.

You will find an explanation of the individual parameters and setting options in the following tables.

In the explanation for the parameters, you will find information on the default highlighted in green,
where applicable and appropriate. 

157

158
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4.2.6.1 Project Settings window, SMU, Time settings

Two forms are relevant for the time settings in SM4. They will be explained here in two separate
tables. In a third table, we explain the interaction between the first form (Summer winter time ap-
plication) and the setting Use summer/ winter time in the second form (Time synchronization
settings). In addition, you will find notes and recommendations for practical use.

Form 1: Summer winter time application

NOTE

If you change the setting in this form, times already defined in the project will not be automatically
adjusted according to this change.

Parameter Erläuterung

One time source If you select this option, you must note the following when making entries
in SM4:

NOTES

If you select this option, you must decide in the Time synch settings
form (see next section) at Use summer/winter time whether or not the
"only time source" should take the ST/WT changeover into account or
not.

Two time sources If you select this option, you must note the following when making entries
in SM4:
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Form 2: Time sync settings

NTP Settings (NTP = Network Time Protocol)

In this input area, you specify whether and how the internal system time of the SMU is synchronized.
If synchronization is not performed, this will result in the internal system being imprecise and quickly
lead to inaccurate shutdown times. In the previous version, synchronization was only possible via a
request to the light sensor (with GPS). In the current version, synchronization can also take place
via a request to an NTP server.

If an NTP server is used, the SMU must be available via an internet connection and the server data
must be entered. If the system is only used for species conservation, using an NTP server means
that it is not necessary to install a light sensor.

Parameter Explanation

Synchronize system
time

You specify here whether the system time should be synchronized.

Use NTP You specify here whether synchronization should take place via
NTP.

If NTP is used, the SMU must be available via an internet connecti-
on.

If a system is only used for bat shutdowns, for example, this makes
the light sensor superfluous; whereas in the previous versions,
synchronization was only possible via a request to the light sensor
(with GPS).

NTP server 1–10 If NTP is used, you need to enter at least one NTP server address
here.

Repetitions NTP request The SMU sends a request to the registered NTP servers, one after
the other. If all requests are unsuccessful, it starts, after the Delay
until next NTP request, again with the first NTP server, etc. After
X (here set number) unsuccessful “request rounds”, the request
process will be aborted, and a new attempt will only take place the
next day.

Default: 3

Delay until next NTP
request

see above

Default: 300 s

Error after X day(s)
without synchronization

Specifies after how many days without synchronization an alarm is
generated.

Default: 7 days

Use time of
synchronization

If a checkmark is set here, synchronization always takes place at
00:00 hours (midnight, local time)
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Time of synchronization If a checkmark is set here, synchronization only takes place at the
time set here (local time).

Default: 00:00:00

Use light sensor If a checkmark is set here, synchronization always takes place via
the GPS module of the light sensor.

Use climate sensor If a checkmark is set here, synchronization always takes place via
the GPS module of a climate sensor.

Use summer/ winter
time

This should be deactivated for countries that do not have daylight
savings time.

NOTE

This setting is only relevant if you have selected the One time sour-
ce option in the Summer/winter time application form (see table
above). Otherwise, this setting is grayed out.

Interaction between form 1 and form 2

The following table explains the interaction between the first form (Summer winter time applicati-

on) and the Use summer/winter time setting in the second form (Time synch settings). Here you
can see the effects on relevant windows (Shutdown Calendar, Shadow Impact Monitoring
Periods, conditions in the Special Shutdowns window, Night Slice Shutdowns window, etc.) and

underneath you will find notes and recommendations for practical use.
 

 Settings Effects

 Project Settings window Shutdown
calendar
window

Shadow impact
Monitoring times

window

Time conditions, e.g.
for special

shutdowns or night
slice shutdowns

 Summer winter
time application

Time synch
settings

A One time source

Use ST*/WT** Date and time in
summer/winter

time

Date and time in
summer/winter

time
Summer/winter time

B One time source

Use ST/WT Date and time in
winter time

Date and time in
winter time

Winter time

C
Two time
sources

No selection
possible

Date and time in
winter time

Date and time in
summer/winter

time

Winter time

Summer/winter time

 ST = summer time, WT = winter time

 

Table: Interaction of forms 1 and 2
 



156Reference part > Project menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

Notes and recommendations for practice

·

Data for shutdown calendars are usually provided by external sources, e.g. in the form of expert
reports, and these are often based on winter time throughout.
 

·

Times in shadow impact monitoring periods as well as special shutdowns, night slice shutdowns
etc. of POIs should refer to the "usual" time of day. Example: A school is to be protected every
day during school hours from 08:00 A.M. to 2:00 #P.M., regardless of whether it is SZ or WZ.
 

·

Solutions A and B in the table above only allow for an "either-or" because there is only one time
setting for both, i.e. either all windows work according to WT, or the ST/WT changeover is taken
into account in all windows. Solutions A and B are always suitable if both, externally supplied
shutdown calendar data as well as times in monitoring periods and e.g. special shutdowns are
based on the same specification, i.e. both with or both without ST/WT changeover.

  Solution A and B are generally used if there is no shutdown calendar; Use ST/WT is activa-
ted or deactivated as required (usually activated).
 

·

Solution C (two time settings: one permanently with ST/WT changeover, one without) allows for
mixed operation: shutdown calendar in WT, but shadow impact monitoring times as well as
special shutdowns, night slice shutdowns etc. in ST/WT. For the latter, you can also choose
between the two time settings in the respective window.

  If a shutdown calendar is available, you should use solution C; this must then be provided in
WT, which is usually the case;
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4.2.6.2 Project Settings window, SMU, Server settings

Settings for the connection between SM4 and the SMU are defined here.

Pay particular attention when entering the Port No.: If incorrect information is entered he-
re and transmitted to the SMU, the SMU will no longer be available, and a service techni-
cian will have to find out the port number of the SMU on site.

Parameter Explanation

Server settings

Timeout The only way for SM4 and the SMU to reliably determine whether the
connection between them still exists is based on "life signs" from their
connection partner. 

A possible “life sign” may be traffic between the two, such as when a Live
Data window regularly retrieves data from the SMU.

If the SMU receives neither a data command nor a ping command from
SM4 for the period specified here, the SMU will recognize that its connec-
tion to SM4 has been lost. Now it will change its connectivity from Busy
to Ready for connection. 

Default: 30000 ms

NOTE: This parameter must match the Login refresh interval (File>
Settings> General > Communication parameters) that controls the
interval at which SM4 sends a ping command. The value on the SMU side
(Session timeout) must be higher than the value on the SM4 side (Login
refresh interval) to ensure that SM4 sends before the SMU assumes
that the connection has been interrupted.

Port No You specify the port number of the SMU server here.

Default: 60200

NOTE: The port number and the IP address need to be entered into the
Connect window to establish a connection to the SMU.

Special Shutdown Interface

Timeout The special shutdown interface is used, among other things, to set the ex-
ternal triggers (see Glossary ) on the SMU. If the interface receives
neither a data command nor a ping command from SM4, the connection
will be closed.

Default: 30000 ms

Port No Here you define the port number of the SMU behind which the functionali-
ties of the special shutdown interface are located.

Default: 60300

Interface active Place a check mark here to activate the interface.

472
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4.2.6.3 Project Settings window, SMU, Server settings

Settings for the connection between SM4 and the SMU are defined here. The control unit has 2
physical network connections, with only one being used as a rule. 

To be able to establish an online connection to the SMU, the following settings must match that of
the SMU: Ethernet IP address, Ethernet net mask, Gateway, DNS server and Port number
(see above).

Please be very careful when entering values in SM4. Incorrect parameter values may
result in avoidable wear and tear, loss of earnings, problems with authorities or resi-
dents, and, in the worst-case, force operators to decommission WTGs.

Input for all addresses: 4 integers from 0 to 255 separated by periods

Example: 192168044201

Parameter Explanation

Ethernet IP address You specify the IP address of the SMU server here.

NOTE 

The port number and the IP address need to be entered into the
Connect window to establish a connection to the SMU.

Ethernet net mask You specify the network mask of the SMU server here.

PowerLink IP address

PowerLink net mask

The PowerLink IP address and PowerLink net mask fields relate to
the second physical network connection of the SMU. There are two
options:

1. Use it to retrieve data from POI modules (analog/digital inputs and
outputs)

EXAMPLE

The cabinet is located at the base of the tower, some POI modules
are not installed on a DIN rail in the cabinet but, instead, installed in the
nacelle. These are fitted with a network module, which can be queried
via the Powerlink port.

2. Use it as a second network port

In this case, the PowerLink interface in Ethernet mode checkmark
must be checked below.

This makes it possible to set up a second network with its own IP
address. It is important that both networks are separate from one ano-
ther physically.

Gateway The term gateway (GW) refers to hardware and software used to
connect non-compliant networks, that work with different network pro-
tocols, to each other. 

As a rule, the address corresponds to the IP address of the router. 
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Parameter Explanation

DNS server The Domain Name System (DNS) primarily responds to name resoluti-
on requests.

As a rule, the address is identical with that of the gateway.

Host name Freely selectable host name (of the SMU) for the own computer com-
ponent that will be displayed instead of the IP address.

PowerLink interface in
Ethernet mode

Set a checkmark here if the Powerlink port should be used as a se-
cond network port, see above.
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4.2.6.4 Project Settings window, SMU, Email settings

The access data of an email provider must be entered here and stored in the SMU to automatically
send emails (e.g., in the case of alarms and/or other warnings) through the SMU.

NOTES

· The transmission of emails only works if a provider is entered here that still supports unencryp-
ted transmission.

· E-mails are only sent if this has been activated in the Alarm Settings window .

Parameter Explanation

Server name Provider’s outgoing email server

Email user User name as stored with the provider

Email password Password as stored with the provider

Sender nameFreely selecta-
ble (example:

SMU_serial_number_project_name)

Domain name e.g. gmx.de

Timeout The SMU attempts to make contact to the email server for x seconds.

Default: 30 s

Port No Port number of the outgoing email server (as made available by the
provider)

Delay after sending The SMU summarizes several alarms and/or notifications that belong
to a fault in one email. After sending such an email, the SMU waits for
the number of seconds specified here before it sends the next one.
What notifications should be sent is specified under Email recipient
settings; see the next table.

Default: 60 s

Use SMTPS Specifies whether the SMTPS (Simple Mail Transfer Protocol Secure)
is used to secure e-mail communication via SMTP using SSL/TLS.
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4.2.6.5 Project Settings window, SMU, Email recipient settings

Error messages (alarms), Warnings, and Other emails can be automatically sent by the SMU as an
email. You can define 10 recipient email addresses for this and specify whether they should be sent
either Alarms and/or Warnings and/or Other Emails.

Parameter Explanation

Receiver Enter a valid email address here.

Alarms Set a checkmark here if Alarms should be sent to the recipient address.

NOTE

E-mails are only sent if this has been activated in the Alarm Settings
window .

Warnings Set a checkmark here if Warnings should be sent to the recipient address.
Warnings are a kind of alarms (seeAlarm Settings window) .

Other If you set a check mark at Other for a recipient, this recipient will receive all
e-mail messages defined in the Other Emails window (Switching & Measu-
rement > Email) (provided that the respective conditions are met).

Subject for alarm/
warn/ other mails

If you enter $PN or $SN here, these strings will be replaced by the respec-
tive project name or serial number in the subject line of a sent e-mail. 

After x minutes send
email again

If you set a checkmark here, emails that were not sent successfully will be
sent again after the number of minutes specified.

149
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4.2.6.6 Project Settings window, SMU, Shadow impact calculation

You can specify the various basic settings for the shadow impact calculation here.

Parameter Explanation

Rotor radius tolerance If you are not sure whether the POIs of the project have been measu-
red accurately, you can decrease/increase the WTG rotor to be on the
safe side.

EXAMPLE

If this parameter is set to 5 % for an actual rotor diameter of 100 m,
this will result in a calculated diameter of 105 m.

Default: 0 %

Min. sun elevation As soon as the sun sinks to the elevation set here, all shadow impact
calculations will be stopped.

Default: 3°

Min box to rotor angle If the angle between the rotor and POI is zero degrees, disruptive
flickering could still be perceived at the POI. This value ensures that
the ellipse always has a minimum width to ensure that shutdown oc-
curs in the case where the SMU assumes that shadow impact is not
possible.

Default: 5°

Add missed shadow impact
periods to POIs after SMU
start (assumption: worst-
case scenario)

Checking this box has the following effects: If a system including the
SMU has the power switched off for a specific period of time (e.g.,
due to a fault, deliberate shutdown etc.) and it is then started up again,
the shadow impact that may have been caused by other WTGs moni-
tored by this SMU will be recalculated and added to the budget. The
calculation is carried out based on a worst-case scenario (sun shines,
rotor is in a 90 °position with respect to the sun)
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4.2.6.7 Project Settings window, SMU, Monitoring

You perform settings for the SMU hardware here.

Parameter Explanation

Standard inputs and outputs

Use "DC present" You set a checkmark here if the SMU does not have a puffer module
installed for the power supply. 

The CPU of the SMU monitors its own power supply. 

If there is a power cut, the system is shut down in safe mode, without
saving the last events. Log entries may be lost, meaning that, for ex-
ample, there is no longer a log entry regarding the power cut.

Use "DC OK" You set a checkmark here if the SMU is provided with a puffer module
(normal case). 

The CPU of the SMU monitors its own power supply. 

In the case of a power cut, the CPU can draw power from a puffer
module for 2 to 3 seconds in order to complete saving processes and
shut down in safe mode to ensure that no data or data structures are
destroyed. Moreover, all log entries can be carried out.

Use "Watchdog output" This option is activated if the WTG type has a watchdog (see Glossa-
ry ). 

Use "Watchdog input" This option is activated if the watchdog function should be monitored
by the SMU.

Use "Modem reset" If you check this box, you enable the use of an additional digital output
signal, see Phone Option window . 

Prerequisites for using the signal: 

· assignment to an output of a DO card

· wiring of the DO to the reset input of the modem

Watchdog

Monitor watchdog It only makes sense to activate this option if the Use “Watchdog in-
put” above is also activated. If this is the case, a test is performed to
ensure the watchdog relay is operating for additional security.

On duration

Off duration

Set here how often the watchdog is controlled. At a value of 10000 ms
(pre-setting), the output of the control switches to high for a corre-
sponding period and then to low for exactly the same length of time. If
the change between high/low is not carried out, the voltage to the wat-
chdog relay drops and it is apparent that the control is faulty. 

Default: 10000 ms

472
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4.2.6.8 Project Settings window, SMU, Additional hardware

Select here which component should be used by the Phone option.

NOTE

The Phone option is supported from SMU version 4.2.15 and higher.

Parameter Explanation

Use GSM modem (RS232) Only the GSM modem can be selected at this time.

Use Profinet card The Profinet card is only used in connection with the WTG type
“Nordex Profinet Type01”. 

4.2.6.9 Project Settings window SMU, Customer Interface

The SMU customer interface is a read-only interface that is used to read out the status of the SMU,
the cause of shutdowns, and measured values. The interface is designed as a switchable ModBus
TCP interface. The port can be set here. 

If you are interested in the customer interface, please contact NorthTec.

Parameter Explanation

Use interface Default: not activated

Port Here you set the port number of the SMU server.
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4.2.7 Configuration / Partial configuration

Purpose
· Check the configuration of pending tasks

· Send the configuration to the SMU

· Verify the configuration of the SMU

Symbol

Path Project > Configuration / Partial Configuration

Right group Project configuration

Prerequisites Online connection to the SMU; 
Partial configuration requires SMU 4.2.50 or later

Type of use Display + interactive

Reference Project

1. Configuration
All data of the project is sent to the SMU; then the SMU is restarted. This process can take a
long time, and especially the restart of the SMU can cause some wind parks to switch to emer-
gency mode and stop all WTGs.

2. Partial configuration
Only the differences between the configuration running on the SMU and the project currently
opened in SM4 will be transferred to the SMU if you choose this option. This method is faster
and also often doesn't require a SMU restart; SM4 remains connected to the SMU, and you can
continue to edit the project in the current session. See also the info boxes on Storing the project
file on the SMU  and Live data windows  at the end of this chapter.

Once you select Project > Configuration / Partial configuration, one of the windows shown below
will open – a preliminary stage of the actual configuration. This window lists a number of conditions
that must be met before the configuration can be started. See the following example windows:

171 171
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Pretests Full / Partial Configuration windows

Procedure

To check the current project, click on Test Config. in the respective pre-test window. The system
will now check whether the conditions listed in each case are met for the project. If not all conditions
are met, the window may then look like one of the following screenshots:
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Pretests windows (after clicking on Test Config.)

Explanation of the symbols in the examples above

A green check mark always means that the respective conditions are already met – no
need for action.

An exclamation mark means that an essential condition is not met: you must make a
change in the project, or, in some cases, you must carry out a full configuration instead
of a partial configuration. 

The screenshot on the left above shows that a partial configuration is not allowed; one
or more of the following reasons may be the cause:

· SMU version is older than 4.2.50.

· Hardware changes have been made, e.g., IO boards have been added to
the SMU or you have defined digital inputs or outputs.

· The IP address of the Shadow Manager Interface has changed.

 In all 3 cases, you must perform a full configuration instead of a partial configura-
tion.

An info icon means that a detected difference has already been confirmed. In the
screenshot on the right above, you can see that different network settings have been
detected and the user has already answered Yes to the corresponding query.

An explanation of all elements in the pre-test window (full / partial configuration) can be found in the
following table
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Element Explanation

SMU version is supported Checks whether the SMU version to which a connection has been
made is higher than the lowest supported version. 

Requirements of the SMU
version are met

There are SMU versions that do not yet support specific functions and
features in the project. The Phone option, for example, or specific
WTG types are not supported in older SMU versions. 

If these functions or features are not used in the current project, the
configuration can be transferred to SMU. Otherwise the transfer will be
rejected.

Configuration required This is a check to determine whether or not there are differences bet-
ween the configuration running on the SMU and the project loaded in
SM4.

Changes for partial configu-
ration permitted

This is a check that a partial configuration is allowed. The following
conditions must be met

· No hardware changes have been made (e.g. equipping the SMU
with IO cards or defining digital inputs or outputs).

· The IP address of the Shadow Manager Interface has not changed.

· In addition, a SMU 4.2.50 or a later version must be used.

If one of these conditions is not met, you must carry out a full configu-
ration.

Network settings OK The network settings required to establish a connection to the SMU
are part of the project. Before starting a configuration, the system en-
sures that the relevant network settings (Port No, Ethernet IP
address, Ethernet net mask, PowerLink IP address, PowerLink-IP
netmask, Gateway) match the settings of the SMU to which a connec-
tion has been established. If differences are found, you will be asked if
you want to apply the changes to the network settings. If you answer
No to this dialog, you can click on the small arrow to the left of the
condition to expand a record that shows the set data one below the
other, as shown in the following Ethernet address example:

You now have two options:

1. You can click on Test config. again, only this time you accept the
settings. During the configuration process, the Ethernet address
entered in the project is now transferred to the SMU and stored
there. After the configuration, the SMU will no longer be accessible
under the current Ethernet address of the current connection
(172.027.002.021), but will receive the new address
(172.027.002.150). Select this option if you want to change the
Ethernet address of the SMU. 

2. You open the area in the Application Settings window where you
can change the Ethernet settings of the project. The reason why
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Element Explanation

the Ethernet address in the project is different from that used on
the SMU can be, for example, that you copied a project from ano-
ther user and you only changed the shadow impact scenario (you
forgot to change the Ethernet address). This option allows you to
correct (at the last minute) the Ethernet address of the SMU stored
in the project while you are already connected to it for configuration
purposes. Choose this option if you want to change the Ethernet
address of the project.

If the info icon   is displayed here, then different IP addresses have
been identified, and the new IP address has already been confirmed
with Yes in the dialog.

Project integrity OK In Shadow Manager 4 (SM4), you can create a project or a project
component (e.g. light sensor) even if not all the required parameters
are known in order to prepare the project as far as possible. The
following situations are conceivable:

· creating a new project without an IP address being assigned for
the SMU

· adding a light sensor that is not yet connected to the hardware

· defining a WTG that refers to sensors that do not yet exist

However, an incomplete project may not be transferred to the SMU
(configured). In order to check the project for integrity, go to Project >
Configuration / Partial Configuration and then click on Test Config. All
incomplete references will be detected and clearly displayed to the
user. Starting the configuration is only possible if there are no longer
any unresolved items.

Project saved If the project from which the SMU configuration is derived was
changed but has not yet been saved, this must be remedied here at
the latest.

Counters assigned For a description of this condition, please refer to the Assign Counter
sub window  section.

Click on this button to test or retest the configuration. The results of
the individual items will then be displayed on the left-hand edge of the
window. 

When all items are OK, click on this button to open the Configuration
window.

Send the configuration

As soon as a green checkmark is displayed for all points in the Pretest window, the Send Config
button is active, and you can send the configuration to the SMU as follows and then verify the
process.

172



170Reference part > Project menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

8 Click on Send Config. in the Pretests Full / Partial Configuration window to open the Con-
figuration window.

8 Set a checkmark, if applicable, at Open connectivity window after configuration in the
Configuration window.

8 Click on Start Configuration. 

The bar at the top of the Configuration window will display the progress of the readout of the
current counter readings (if the assignment of the counter readings takes a long time, further
shadow impact may have increased the counter readings). The second bar displays the progress of
the configuration transfer, see following figure.

Configuration window

Verify the configuration

To make sure all data have been accepted by the SMU, you can compare the data on the SMU with
the data in SM4:

8 Click on Verify in the Configuration window.

If the configuration was sent successfully, this is indicated in the Configuration window as shown in
the figure on the next page (or similar).
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Configuration window (following verification)

Saving the project file on the SMU

At the end of a configuration, the project file must be stored on the SMU. In a full confi-
guration, this is one of the last steps before logging out and restarting the SMU. In the
case of a partial configuration, this time-consuming step may postponed, among other
things because further partial configurations may follow. However, before logging off,
the project file must be stored on the SMU; therefore this step will be carried out auto-
matically at that point. Since the process is rather time-consuming, there is a progress
indicator.

The fact that the transfer of the project file is still pending is indicated by an icon in the
bar at the top of the SM4 main window:

  . . .   

The icon changes from inactive-gray to colored after a partial configuration. You can
click on it at any time to start the transfer manually and thus avoid the waiting time later
when logging out. However, after another partial configuration you would have to upload
the project again.

Live data windows (Realtime Data menu)

For the duration of a configuration process, the values displayed in the real-time data
windows will not be updated.
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4.2.7.1 Assign Counter sub window

Purpose Manually assign counters that cannot be automatically assigned

Path Project > Configuration / Partial Configuration > Test Config.

Right group Project configuration

Prerequisites Dongle, online connection to the SMU

Type of use Display + interactive

In correspondence with the maximum number of configurable POIs, there are an identical number of
counter registers on the SMU, which take on the role of daily and annual counters. These registers
only exist on the SMU and are not a part of a dataset that belongs to a POI in the project because
the content changes according to the shadow impact that occurs at the POI. The POI and the coun-
ter register are linked via the POI number – for example, the load times from POI 20 are registered
in counter register 20. 

If the number of a POI is changed in a project, this would mean a correspondingly different counter
would be addressed. This would also mean that the previous counter readings of the POI would be
lost or, respectively, would be recorded to a different counter register. Due to the renumbering of
the POIs, it is important to ensure that the counter readings are correspondingly ‘moved’ so that
counting continues correctly and without any loss after the configuration. 

It is only possible to determine if one or several POIs have been renumbered by comparing the pro-
ject to be configured with the configuration currently running on the SMU. In the process, the SMU
will attempt to “recognize” the corresponding POI on the SMU based on all the parameters of a POI
in the project (name, designation, and also all walls and areas). If this is successful, the content of
the associated counter can be automatically copied to the new counter position. 

If an area, for example, is also changed in a project in addition to the number of a POI, the POI can
no longer be identified on the SMU in this way, or at least not a 100 % correctly. In this case, the
user must manually determine which (changed) POI in the project corresponds to the (previous) POI
on the SMU. This manual assignment thus allows counter readings to be correctly transferred. The
operation of this window will be described on the following, based on examples.

Example

You have clicked on Test config. in the Pre-tests Full Configuration or Pre-tests Partial Confi-

guration window. A green checkmark   is displayed in front of all conditions, only the last

condition named Counters assigned is preceded by the info icon  and the following window
opens:
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Assign Counters window (example)

While a green bar indicates the progress of the readout you can move the POIs, but the window
cannot be closed.

Legend for the Assign Counters window

1 Depending on the option selected (All, Assigned automatically, etc.), the corresponding POIs
of the opened project will be displayed here. 

2 The POIs that could not be automatically assigned to the SMU will be displayed here. If nothing
is displayed here, you can be sure that all POIs and/or counters have been correctly assigned.
If you want to confirm the changes to the POI displayed here, move this POI to the POI with the
same number in area 1 per drag & drop. Note: The drag & drop function only works here if you
have selected the Assigned manually option above. 

3 If a wall or an area has been changed for the POI selected under 1, the changes will be repre-
sented graphically here. An area has been changed in the example above. 
The green-black shape represents the “old” area, a square. The green-blue shape represents
the “new” area, an irregular four-sided rectangle.

4 Comparison: The most important data of the POI selected under 1 is displayed in this table. The
second column shows the data of the project currently opened in SM4, the third column the data
of the project in the SMU.

5 If a wall of a POI selected under 1 is changed, the old and new offset values and coordinates
are displayed here (as specified in the Edit Walls and Areas window). Changed coordinates
are highlighted in yellow.

6 If an area of a POI selected under 1 is changed, the old and new offset values and coordinates
are displayed here (as specified in the Edit Walls and Areas window). Changed values are
highlighted in yellow.
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7 If there are no coordinates displayed in 5 or 6 despite changed walls/areas, click on the small
arrow to display them.
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Hardware4.3

The following table provides you with an overview of the Hardware menu.

Symbol Menu item Purpose

Sensors and IO Signals Define light sensors, hygro-thermo sensors, laser precipi-
tation sensors and digital inputs and outputs (if deployed)

Interface Cards Define digital input properties

Sensor Node Units Define Sensor Node Units (SNU) - enhance the cyber secu-
rity of wind farms

Windfarm Communication
Unit 

Define Windfarm Communication Units (WCU), which offer
e.g. the following advantages:

· WCUs encrypt data from sensors and transmit them to a
central SMU via a low-cost Internet connection, even
over long distances.

· In the event of a communication failure between the
SMU and the WTGs, a WCU will meet species conser-
vation requirements using its own backup shutdown
calendar whereas otherwise all WTGs would have to be
shut down completely.

Interface Connectors Assign the individual sensors to the interface connectors

Hardware Assignments Assign required hardware to the various components

Click on a menu item to jump directly to more information.
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4.3.1 Sensors and IO Signals window

Purpose Define light sensors, hygro-thermo sensors, laser precipitation sensors
and digital inputs and outputs (if deployed)

Symbol

Path Hardware > Sensors and IO Signals 

Window type List window (with tabs)

Prerequisites Can only be edited with a dongle

Type of use Display + interactive

Reference Project

The various sensors that can be integrated into the system for shadow impact monitoring and spe-
cies conservation serve the following functions:

Sensor Function

Light Sensor Light Sensor This sensor measures whether or not shadow impact is
possible and provides the SMU with a time signal (GPS).

Hygro-thermo sensor This sensor measures the relative humidity and outside temperature. It is
only used for species protection.

Laser precipitation
sensor

This sensor measures the precipitation amount and optionally the outside
temperature. It is also only used for species protection.

Climate sensor This sensor can measure both humidity and precipitation amount, provi-
ding more flexibility when requirements change. In addition, the sensor
collects climate data and provides the SMU with a time signal (GPS). 

iSpin sensor This sensor enables, for example, the monitoring and optimization of the
performance of WTGs.

Visibility sensor The main task of this sensor is to determine the visibility in the atmosphe-
re. 

The reading points of sensors can be used to formulate special and night slice shutdowns as well as
for Single Data Recordings. They can also be entered as elements to be logged as events in the ex-
tended Special Shutdown Log. They report the alarms “Sensor error” and “Communication error”. If
you have established an online connection to an SMU (File > Connect), you can display live data for
each connected sensor. 
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Sensors and IO Signals window, displaying the Light Sensors tab (section)

NOTE

All fields of all tabs except for the Comment field are mandatory fields.

In the following sections, you will find a description of the tabs of the different sensors. In some
cases, you will find helpful examples.
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4.3.1.1 Light Sensors tab

The information, options or buttons are described in the following table

Parameter Explanation

Settings

No. No. of the light sensor, 40 are possible 

Elevation for
spectral
correction start

The percentage of red light in the color spectrum of sunlight increases when the
sun is low. This thus also shifts the threshold level for direct intensity of illuminati-
on from when shadow impact effects can occur. Enter here from which sun ele-
vation the spectral correction begins.

Degrees (default: 17.2)

Spectral
correction factor

Spectral correction can be reduced here (value less than 1) or, respectively, in-
creased (value greater than 1) here.

Value range: 0.8 to 2, default: 1

Sensitivity The higher the set value here, the more sensitive the light sensor reacts.

Value range: 0.8 to 2, default: 1

Relay out
· Shadow possible means that the relay output will switch as soon as the

threshold limit of the light intensity (direct percentage of sunlight > 12,000
lux) is exceeded. 

· Universal means that the output can be switched to the light sensor by
command (targeted control through the master unit).

Default: Shadow Possible

Clouds delay A time period is defined here that has to elapse before a change in condition
from “shadow impact” to “no shadow impact” is taken into account. Hysteresis
should not be set too low to ensure that the WTG does not restart too early if
the weather is changeable (or in the case of small clouds). 

NOTE: 

When switching in the opposite direction (no shadow impact 
-> shadow impact) switching takes place immediately to fulfill the requirements
of the authorities/residents. 

Input in seconds, default: 60 s

Communication

Bus address Address of the sensors on the RS485 bus

a = master unit, remaining sensors = b, c, etc.
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Parameter Explanation

Timeout Specifies the length of time that the master unit waits for a response from the
sensor before it sends a request to the next sensor. This prevents a situation
where if one sensor fails none of the other sensors are sent a request as only
one sensor request can be executed at a time. 

Input in milliseconds, default 2000 ms

Delay Set here how often the master should send requests.

Input in milliseconds, default 250 ms

Offline Values

The parameters of the Offline values area are used to define the values to be assumed by the
SMU in cases when a sensor does not respond. 

Light Set here the base values that the SMU should assume if the sensors do not re-
spond. Select available here to prevent shadow impact periods being exceeded.
If more than one light sensor is used in a wind park, it may make sense to select
not available for one of the light sensors as it can “stand in for” the second in
the case of a fault.

available, not available

Comment Enter any characters

Location For the sake of clarity, enter the location of the light sensor (the WTG on which
it is installed).

Enter any characters
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4.3.1.2 Hygro Thermo Sensors tab

The information, options or buttons are described in the following table

Parameter Explanation

Settings

No. Hygro-thermo sensor No., 5 are possible

Offline Values

The parameters of the Offline values area are used to define the values to be assumed by the
SMU in cases when a sensor does not respond. 

Temperature Set here the base values that the SMU should assume if the sensors do not
respond. 

Input in °C, default 20 °C

Humidity Set here the base values that the SMU should assume if the sensors do not
respond.

Input area 0 to 100 %, default 0 %

Communication

Bus address Address of the sensors on the RS485 bus

0, 1, 2 etc.

Timeout Specifies the length of time that the master unit waits for a response from
the sensor before it sends a request to the next sensor. This prevents a si-
tuation where if one sensor fails none of the other sensors are sent a
request as only one sensor request can be executed at a time. 

Input in milliseconds, default 2000 ms

Delay Set here how often the master should send requests.

Input in milliseconds, default 250 ms

Comment Enter any characters

Location For the sake of clarity, enter here the location of the hygro-thermo sensor
(the WTG on which it is installed).

Enter any characters
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4.3.1.3 Laser Precipitation Sensors tab

The information, options or buttons are described in the following table

Parameter Explanation

Settings

No. Sequential No. of the laser precipitation sensor, 5 are possible

Threshold value This is a general setting that can be used later when setting up special
shutdowns for the “Precipitation yes/no” condition. 

EXAMPLE

If the precipitation value entered here has been reached, the precipitation
condition is considered to be fulfilled. 

Input in mm/h, default 0 mm/h

Offline Values

The parameters of the Offline values area are used to define the values to be assumed by the
SMU in cases when a sensor does not respond. 

Precipitation Set here the base values that the SMU should assume if the sensors do not
respond. 

available, not available

Temperature Set here the base values that the SMU should assume if the sensors do not
respond.

Input in °C, default 20 °C

Communication

Bus address Address of the sensors on the RS485 bus

0, 1, 2 etc.

Timeout Specifies the length of time that the master unit waits for a response from the
sensor before it sends a request to the next sensor. This prevents a situation
where if one sensor fails none of the other sensors are sent a request as only
one sensor request can be executed at a time. 

Input in milliseconds, pre-setting 5000 ms

Delay Set here how often the master should send requests.

Input in milliseconds, pre-setting 900 ms

Comment Enter any characters

Location For the sake of clarity, enter the location of the laser precipitation sensor (the
system in which it is installed).

Enter any characters
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4.3.1.4 Climate Sensors tab

The information, options or buttons are described in the following table

Parameter Explanation

Settings

No. No. of the climate sensor, 5 are possible

Communication

Bus address Address of the sensors on the RS485 bus

0, 1, 2 etc.

Timeout Specifies the length of time that the master unit waits for a response
from the sensor before it sends a request to the next sensor. This pre-
vents a situation where if one sensor fails none of the other sensors are
sent a request as only one sensor request can be executed at a time. 

Default: 5000 ms

Delay Set here how often the master should send requests.

Default: 900 ms

Offline Values

The parameters of the Offline values area are used to define the values to be assumed by the
SMU in cases when a sensor does not respond. 

Temperature Default: 20 °C

Rel. Humidity Default: 0 %

Air pressure Default: 1013.25 hPa

Dew point Default: -10 °C

Synop 4680 Identifier for precipitation type (synoptically encoded); light drizzle, for
example, has the Synop key 51.

Default: 0

Precipitation Default: Checkmark not set

Intensity Default: 0 mm/h

Wind speed Default: 0 m/s

Wind Direction Default: 0 °
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Parameter Explanation

Comment Enter any characters

Location For the sake of clarity, enter the location of the climate sensor here (the
WTG on which it is installed).

Enter any characters

Opens the Multisensor parameters window. There you can adjust the
parameters of the sensor. A description of this window can be found in
the following table.

Multisensor parameters sub window

In this sub window you can adjust the parameters of the climate sensor.

Do not change the pre-set parameters of the climate sensor unless you have fully un-
derstood the functioning of the climate sensor. In case of doubt, be sure to consult the
climate sensor’s manual beforehand.

Parameter Explanation

Averaging method The averaging procedure for wind direction and wind speed can be selec-
ted here. With the scalar averaging method (default setting), the wind di-
rection and wind speed are averaged independently of each other. Howe-
ver, in the vectorial averaging method, wind direction and wind speed de-
pend on each other. This procedure should only be selected for specific
applications.

Default: Scalar

Averaging time The averaging period for all measured values is set here. The averaging
period is calculated from the set value multiplied by 100 ms. Moving avera-
ges are formed.

Value range: 0 to 6000, default: 600

Brightness option The total brightness can be determined by two methods. The Brightest
sensor option used the highest measured value of an individual sensor.
The Vectorial sum option determines the total brightness from the measu-
red values of the adjacent brightness sensors with the highest brightness.

Default: Brightest sensor

Bus termination Here, a 120-ohm termination resistor can be switched on or off on the
RS485 bus.

Default: No (without termination resistor)

Timeout error Here you can set the period of time after which a measured value is mar-
ked as invalid if there is an error in the reading.

Value range: 10 to 60 s, default: 30 s
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Response delay After the climate sensor receives a request, the response is delayed by
the time set here. An increased delay of the response is useful e.g. when
using interface converters.

Value range: 5 … 1000 ms, default: 5 ms

Time sync Here, you can set whether and how time and date are to be synchronized
using GPS information. Instead of the complete daily synchronization of
time and date, it is possible to only have the second value or the second
and minute values synchronized.

Default: Complete

Min. heater voltage If the supply voltage falls below the set value, the heating no longer swit-
ches on. Only when the voltage exceeds the set value by 2 volts does the
heating become active again.

Value range: 5 to 48, default: 10 V

Min. heater pwr. Here the power with which the heating starts its operation is set in %. The
heat output will then be controlled automatically depending on the current
wind speed and temperature.

Value range: 0 to 100 %, default: 10 %

Heater This is where the operating mode of the heating is set. Switching off the
heating is not recommended. 

Default: On at below 5 °C 

Height measurement The station height can be determined from the GPS information. This func-
tion can be activated and set here. The station height can be extracted
from the GPS information as an instantaneous value or as a 14-day avera-
ge value. A determined 14-day average value can be stored permanently
or determined anew after each restart of the climate sensor.

Default: 14 days GPS-Ø, sets default 

Station height If the determination of the station height by the GPS information is not acti-
ve, the station height can be specified here.

Value range: 0 to 9000 m, default: 0 m

Measurement delay This parameter sets the delay between two readings of the ultrasonic wind
measurement. The value is calculated from the set value multiplied by
10 ms.

Value range: 2 to 25, default: 2  10ms

Wind dir. correction This parameter can be used to compensate for a misalignment of the cli-
mate sensor. If, for example, the climate sensor has not been aligned to
the north (0°) but to the north-east (45°), the value 45 must be entered for
correction. The input of a correction value is only necessary if the wind di-
rection or the direction of the brightness is to be measured. If the value
1000° is set, the north correction is carried out via the compass correction.

Value range: 0 to 359° /1000°, default: 1000 °
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Wind speed units Here you can set the desired unit of wind speed.

Default: m/s

No of drops for rain This is where the minimum number of drops is determined, which is used
to detect the beginning of precipitation.

Value range: 2 to 30, default: 16

Volume threshold per
part

This parameter sets the threshold for the volume of a single precipitation
particle. Precipitation particles with a smaller volume will be ignored.

Value range: 100 to 600 µm, default: 260 µm

No of parts precip. Here the minimum number of precipitation particles to detect precipitation
is determined; only those particles are counted which are above the thres-
hold value defined above (see Volume threshold per partl. above) AND
which were detected within the last set period (see Precip. time window
below).

Value range: 1 to 15, default: 2

Precip. threshold Here the threshold of the precipitation intensity for reporting precipitation is
defined. If this threshold is exceeded, precipitation is reported.

Value range: 1 to 200 µm/h, default: 10 µm/h

Precip. time window Here you define the time window in which the set number of precipitation
particles must be recorded before precipitation is reported.

Value range: 10 to 60 s, default: 60 s

Compass correction The magnetic compass correction adds a constant angle to the measured
direction of the magnetic compass. Thus, a magnetic declination can be
compensated.

Value range: 0 to 359°, default: 0 °

Synop threshold The lower precipitation intensity threshold from which a Synop key is
output is defined here. 

Value range: 0 to 1000 µm/h, default:  0 µm/h

Resets all parameters in this window to their default values, see above
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4.3.1.5 iSpin Sensors tab

The information, options or buttons are described in the following table

Parameter Explanation

Settings

No. No. of the iSpin sensor, 100 are possible

Offline Values

The parameters of the Offline values area are used to define the values to be assumed by the
SMU in cases when a sensor does not respond. 

Temperature Input in °C, default 20 °C

Wind speed Input in m/s, default 0 m/s

Rotor speed Input in 1/min, default 3 1/min

Yaw angle Angle between rotor axis and wind direction

Input in °, default 0°

Communication

IP address In contrast to the other sensors, which are equipped with RS485 interfa-
ces, the iSpin sensors only have an Ethernet interface. Instead of the
connection via interface connectors, the IP address and port are specified
directly at the iSpin sensor.

4 numbers, separated by a period, example: 192.0.2.42

Port see above

number from 1 to 65535

Bus address Address of the sensors on the RS485 bus

0, 1, 2 etc.

Timeout Specifies the length of time that the master unit waits for a response from
the sensor before it sends a request to the next sensor. This prevents a si-
tuation where if one sensor fails none of the other sensors are sent a
request as only one sensor request can be executed at a time. 

Input in milliseconds, default 1000 ms

Delay Set here how often the master should send requests.

Input in milliseconds, default 1000 ms

Connection to Use this drop-down list to specify whether the sensor is connected directly
to the SMU or to a WCU.

SMU
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Parameter Explanation

Comment Enter any characters

Location For the sake of clarity, enter here the location of the hygro-thermo sensor
(the WTG on which it is installed).

Enter any characters

4.3.1.6 Visibility Sensors tab

The information, options or buttons are described in the following table

Parameter Explanation

Settings

No. No. of the visibility sensor, 5 are possible

Offline Values

The parameters of the Offline values area are used to define the values to be assumed by the
SMU in cases when a sensor does not respond. 

Visibility Set here the base values that the SMU should assume if the sensors do not
respond. 

Input in meter

Communication

Bus address Address of the sensors on the RS485 bus

0, 1, 2 etc.

Timeout Specifies the length of time that the master unit waits for a response from the
sensor before it sends a request to the next sensor. This prevents a situation
where if one sensor fails none of the other sensors are sent a request as only
one sensor request can be executed at a time. 

Input in milliseconds, pre-setting 5000 ms

Delay Set here how often the master should send requests.

Input in milliseconds, pre-setting 900 ms

Comment Enter any characters
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Parameter Explanation

Location For the sake of clarity, enter the location of the laser precipitation sensor (the
system in which it is installed).

Enter any characters
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4.3.1.7 External Trigger tab

External triggers are, in simple terms, software versions of digital inputs. They were introduced in
SM4 as a way of allowing users to control shutdowns or other processes externally in a convenient
yet IT-safe manner (see Glossary ).

Parameter Explanation

No. No. of the external trigger, max. 2500 are possible

Name Enter any characters

Comment Enter any characters

4.3.1.8 Tabs for Digital/Analog Inputs/Outputs

These tabs are not currently in use.

472
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4.3.2 Interface Cards window

Purpose Define digital input properties

Path Hardware > Interface Cards 

Window type Divided vertically, see Vertically divided windows

Prerequisites Can only be edited with a dongle

Type of use Display + interactive

Reference Project

Only the manufacturer is authorized to set up more interface cards and therefore this is not descri-
bed here in more detail.

25
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4.3.3 Sensor Node Unit window

Purpose Define Sensor Node Units (SNU) – enhance the cyber security of wind
farms

Path Hardware > Sensor Node Units

Window type Vertically split, see Vertically split windows

Requirements Editing requires a dongle

Usage type Display + dialog

Reference Project

Sensor Node Units (SNU) are optional hardware for connecting sensors. They can transmit data
from up to five RS485 buses via an IP network; several sensors can be connected to each bus. 

Communication between SNUs and a SMU is encrypted. Commands and responses from sensors,
which are transmitted as "plain text", will be encrypted by a SNU to make them tamper-proof and
unreadable for unauthorized third parties or hacker attacks from outside. 

When using existing connections (Internet), sensor data can be transmitted over long distances in a
cost-effective AND cyber-secure manner.

The SNU is set up in the following window:

Sensor Node Units window

25
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Notes on the Sensor Node Units window

· For general instructions on working in vertically split windows, please refer to Vertically Split
Windows .

· Each Sensor Node Unit can transmit data from up to five RS585 buses over an IP network.

· In the example window above, two of 60 possible Sensor Node Units have been set up.

An explanation of the input fields (right half of the window) can be found in the following table

Field Explanation/Function

Number The number of the connection can be freely assigned in the range from 1 to 60
(only once) and is used later as a reference.

Comment Free text input

IP address Here you enter the value of the Sensor Node Unit that is addressed.

Port no. Here you enter the value of the sensor node unit that is addressed.

SMU Port No Enter the port number for responses to the SMU here.

Number of cards Here you enter how many RS-485 cards are inserted in the respective Sensor
Node Unit.

Connection to Use this drop-down list to specify whether the SNU is connected directly to the
SMU or to a WCU.

To work with SNUs, perform the following tasks:

1. Set up a SNU in the Sensor Node Units window: define the connection and the number of
RS485 cards, see table above.

2. In the Interface Connector window, create a connector of the "via SNU" type for the desired
sensor type (parameters: SNU and RS485 card No.), see the following screenshot:

25
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3. Add the appropriate sensors to the previously created interface connector; please refer to
Interface Connector  window and the following screenshot:199
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4.3.4 Windfarm Communication Unit window

Purpose Define Windfarm Communication Units (WCU), which offer, e.g. the
following advantages:

· WCUs encrypt data from sensors and transmit them to a central SMU via
a low-cost Internet connection, even over long distances.

· In the event of a communication failure between the SMU and the WTGs,
a WCU will meet species conservation requirements using its own backup
shutdown calendar whereas otherwise all WTGs would have to be shut
down completely.

Path Hardware > Windfarm Communication Units

Window type Vertically split, see Vertically split windows

Requirements Editing requires a dongle

Usage type Display + dialog

Reference Project

In simple terms, a WCU is a mixture of a Shadow Master Unit (SMU) and a Sensor Node Unit
(SNU), see also glossary . A WCU summarizes and encrypts the communication between indivi-
dual segments (often individual wind farms) so that the data can be forwarded to a SMU via existing
connections (Internet) without any security concerns. In this way, remote segments of extensive
wind farms can be connected to a central SMU in a cost-effective AND cyber-secure manner.

Basic features of a WCU:

· A WCU can transmit data from up to five RS485 buses to the SMU via an IP network, and multi-
ple sensors can be connected to each bus (same as with an SNU).

· In addition, sensors can be connected to a WCU via the Ethernet interface (same as with a SNU);

· WEA and/or SNUs can also be connected to a WCU;

· By writing its own logs, the WCU documents all events that occur while communication to the
SMU is down;

· A WCU can monitor WTGs according to its own shutdown calendar if necessary.

 An example of a network with WCUs can be found in the following diagram.

25
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Fig.: Example of a network with WCUs

WCU's own shutdown calendar for "emergencies"

Another important advantage of WCUs is their ability to take their own shutdown calendars into ac-
count. If communication in a wind farm fails, the SMU can no longer perform its most important
tasks as it lacks the necessary measured values (wind strength, precipitation, etc.). In such cases,
a WCU can provisionally take over monitoring of the WTGs connected to it in order to at least ensu-
re compliance with the shutdown conditions for species conservation, wheres otherwise all WTGs
would have to be shut down for the entire duration of the communication breakdown.

While communication is down, the WCU turns into a makeshift SMU that autonomously takes its own
shutdown calendar into account. Provided that such a backup shutdown calender has been created,
the WCU can carry out actions that come surprisingly close to the complex shutdown scenario of a
"real" SMU, especially as the measured values of local light sensors can also be taken into account
(as with the conventional shutdown calendar).

There are three options for setting up a WCU shutdown calendar:

· Define shutdown periods manually – same way as in the conventional Shutdown Calendar
window

· Import an already defined shutdown calendar

· Import already defined special shutdowns
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You can of course combine these three options and/or use an import as a data basis and then dele-
te individual entries from the import or add new ones. You will find more information in the WCU
Shutdown Calendar window  section .

The WCU itself is set up in the following window.

Fig.: Windfarm Communication Units window

Notes on the Windfarm Communication Units (WCU) window 

· General instructions for working in vertically split windows can be found in the Vertically split
windows  section.

· Each WCU can transmit data from up to five RS585 buses via an IP network.

· In the example window above, two of a possible ten WCUs have been set up so far.

An explanation of the input fields (right half of the window) can be found in the following table

Box Explanation/function

Number A maximum number of ten WCUs can be defined; each is assi-
gned a number from this numerical range.

Location The location must be specified, e.g. to prevent misunderstan-
dings when visualizing a wind farm network (Tools > Windfarm
layout).

Comment Free text input

248
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Box Explanation/function

Given by WCU

IP address ETH The SMU requires these four details in order to connect to the
WCU. NorthTec defines these values when preparing a WCU for
use – they cannot be changed later during operation.Port no.

User name

Password

 Adjustable by SMU

IP address Powerlink These parameters relate to the second network interface of a
WCU – they can be set. While the first network interface is inten-
ded for communication with the SMU, this second interface crea-
tes its own network: WTGs, sensors and SNUs that are to be
assigned to this WCU must be in this address range.

Further information on these parameters can be found under Pro-
ject Settings, SMU, Ethernet settings .

Netmask Powerlink

Gateway

No. of RS485 cards Sensors are connected to these cards via an RS485 bus. The
number of cards specified here must correspond to the number
of cards with which a WCU has been equipped by NorthTec.

Use watchdog The correct operation of a WCU can be monitored by a watch-
dog relay (see glossary ). A running WCU must trigger this re-
lay regularly – otherwise it drops out and triggers a restart. Pre-
requisite: The WCU control cabinet has been equipped with a
watchdog relay by NorthTec.

To work with WCUs, perform the following tasks SM4:

1. Set up the WCU (Hardware > Windfarm Communication Units).

2. Create a connector of the "via WCU" type for the desired sensor type (Hardware > Interface
Connectors).

3. Add the corresponding sensors to the previously created interface connector (Hardware >
Interface Connectors).

4. If using an iSpin sensor, assign it to the WCU (Hardware > Sensors and IO Signals > iSpin
Sensors tab at Connection to).

5. If necessary, connect the WTG to the WCU (Project > Wind Turbine Generators > Add/edit
WTG at Connection to).

6. If necessary, set up a WCU shutdown calendar for communication failure events (Switching &
Measurement > WCU Shutdown Calendar).

158
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Connecting a SNU to a WCU

It is also possible to connect a SNU to a WCU. In this way, a remote segment of a wind farm can
be connected to the SMU using the Internet (via SNU and WCU). Furthermore, it is conceivable that
some of the sensors in this segment connected by a SNU are so far away that they also need to be
connected to the WCU via the Internet using a SNU – this can also be achieved using WCUs and
SNUs. 

For this purpose, there is a drop-down list in the Sensor Node Units  window in which you can
specify whether the SNU is connected directly to the SMU or to a WCU.

Overview of SMU, SNU, WCU, WEA and sensors

To get an overview of the many different connection options, you can visualize the installation under
Tools > Windfarm Layout. The window displays the loaded project in SM4 as currently defined. You
can therefore also use this function to visually review any changes you have made before you ac-
tually configure the SMU. For more information, see section Visualization window .

191
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4.3.5 Interface Connectors window

Purpose Assign the individual sensors to the interface connectors

Path Hardware > Interface Connectors 

Window type Divided vertically, see Vertically divided windows

Prerequisites Can only be edited with a dongle

Type of use Display + interactive

Reference Project

Here you can assign the sensors defined in the Sensors and IO Signals window (light sensors, hy-
gro-thermo sensors, precipitation sensors) to the interface connectors to ensure that the SMU
knows which sensors are connected.

Interface Connectors window

Notes on the Interface Connector window 

· General instructions on vertically divided windows can be found in the  Vertically divided
windows  section.

· In the example window above, 3 out of 40 possible light sensor connectors are assigned.

25
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· Corresponding to the 5 "normal" sensor types, there are also 5 connector types (connectors for
light sensors, precipitation sensors, hygro-thermo sensors, climate sensors and visibility
sensors). The sixth sensor type, the iSpin sensor, is a mere network device with point-to-point
communication and does not require an interface connector.

· Connectors for precipitation sensors can only be assigned precipitation sensors; connectors for
hygro-thermo sensors can only be assigned hygro-thermo sensors, etc.

· Each sensor can only be assigned once.

· Light sensor connectors can also be assigned hygro-thermo or precipitation sensors, provided
that a light sensor has already been assigned.

· If you select a sensor on the left, a list of all sensors defined in the Sensors and IO Signals
window will appear on the right. It is possible to identify here whether a sensor is assigned
(sensor No. highlighted in green) or not assigned (sensor No. highlighted in red), see the
following figure: 

Interface Connectors window, Sensors
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4.3.6 Hardware Assignments window

Purpose Assign required hardware to the various components

Path Hardware > Hardware Assignments

Window type Divided vertically, see Vertically divided windows

Prerequisites Can only be edited with a dongle

Type of use Display + interactive

Reference Project

Here you can assign, for example, connectors for sensors (defined in the Interface Connector
window) that are queried via a RS485 bus to the respective RS485 card. Furthermore, the following
can be assigned:

· connectors for sensors queried via a RS485 bus to the respective RS485 card 

· watchdog inputs/outputs 

· inputs/outputs for operating voltage 

· inputs/outputs (digital and analog) of relay-controlled WTGs

· digital/analog inputs/outputs created by the user (Sensors and IO Signals window)

· GSM modem for the Phone option

See the following window for illustration.

25
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Hardware Assignments example window

Notes on the Hardware Assignments window

· General instructions on working in vertically divided windows can be found in the Vertically
divided windows  section.

· Hardware highlighted in green on the left is already assigned to an input/output.

· Hardware highlighted in red on the left has not yet been assigned to an input/output.

· If you click on Unassigned at the left in the window, only the hardware that is not yet assi-
gned will be displayed.

· If you click on Matching at the right in the window, only the cards that are suited to be assi-
gned will be expanded. If an analog input is selected on the left, for example, all analog in-
put cards will be expanded on the right.

· More information on watchdogs can be found in the Glossary .

25
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Switching & Measurement menu4.4

The following table provides you with an overview of the Switching & Measurement menu.

Symbol Menu item Purpose

Special Shutdowns

Special Shutdowns  Define shutdown conditions – used for example to fulfill offi-
cial requirements regarding bat protection.

WTG Speed Reducti-
on

Automatically reduce the speed of wind turbines depending
on certain conditions, e.g. for bird protection, bat protection,
etc.

Night Slice Shutdowns Complex shutdown conditions for bat protection (divide the
night into slices with different conditions).

Shutdown Calendar  Calendar for scheduling fixed shutdown periods

WCU Shutdown
Calendar 

Set fixed periods for monitoring WTGs by means of a WCU

On-Demand Shadow
Shutdowns window

OSS can be used to allow residents of places of immission
to switch off WTGs that cause shadow impact using an app
on their smartphone.

Digital Out Switching Set conditions for switching digital outputs

Data Recording

Single Data Recording  To record individually selectable measurement data and
link/compare them to one another.

Cyclic Multi Data
Recording  

Automatically record one or more readings for one or more
WTGs at regular intervals and define the output of the re-
sults as a file

Interval Timer  Define intervals, e.g., for the Cyclical Multi Data window.

Accessories

Condition Flags  Define condition flags for special or night slice shutdowns
that can be activated (set) by one set of conditions and clea-
red (reset) by another

Reading Point
Switches  

Set up automatic switching between two reading points (e.g.
to increase the reliability of sensors)

Calculations  Define automatic calculation of certain values to use them in
shutdown conditions of Special Shutdowns and Night Slice
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Symbol Menu item Purpose

Shutdowns, Single Data Recordings or as user-defined rea-
ding points in the Special Shutdown Log, etc.

Events Read out which reading points (measured values) are auto-
matically logged for a special shutdown event und Add your
own (user-defined) reading points

Email  Define emails to be triggered by conditions

Click on a menu item to jump directly to more information.

280
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4.4.1 Special Shutdowns window

Purpose Define shutdown conditions other than shadow impact and link them using
logical operators (e.g., for the protection of bats or birds) while taking into ac-
count criteria, such as sunset/sunrise, temperature, wind speed, precipitation,
and humidity

Symbol

Path Switching & Measurement > Special Shutdowns 

Shortcut F12

Window type divided vertically, see Vertically divided windows

Type of use Read-only (left-hand side)/ selection/ drag & drop, dialog (right-hand inside)

Reference Project

The Specials Shutdowns window provides (almost) unlimited possibilities for creating shutdown
conditions other than those related to shadow impact, e.g. protection of bats protection of birds etc.
Once shutdown conditions have been defined, the SMU will continuously check whether or not these
are met by comparing actual values with the corresponding thresholds defined here. As soon and as
long as the conditions are met, the corresponding WTG will be shut down. While it is true that the
possibilities in the Special Shutdowns window are enormous, its operation is not as complex as it
may seem at first glance – the structure, operation as well as all options available will be explained
in an easily understandable manner in this chapter.

25
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Special Shutdowns window 

Since the Special Shutdowns window may look very differently depending on the operations car-
ried out thus far, you will find a schematic representation of the basic window structure in the
following.
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 Special shutdowns

display area (levels)

Special shutdowns that have already been de-
fined are displayed here (in different colors

according to the level) and can be easily selec-
ted or copied using drag & drop.

WTG block 1 

Condition block 1 

Shutdown condition 

Shutdown condition

…

Condition block 2

Shutdown condition

Shutdown condition

…
WTG block 2 

Condition block 1

Shutdown condition

Shutdown condition

…
WTG block …

settings area 

Drop-down lists with options and input fields for
the following operating procedures:

· select/add/remove a WTG

· specify/change block name

· select switch reason for block

· add/change/delete condition blocks

· define/add/change/delete a dataset with
shutdown conditions

Condition

The result of the current settings in the settings
area is displayed in words 

display area buttons settings area buttons

Schematic representation of the Special Shutdowns window

The most important elements of the Special Shutdowns window are explained in the following
table:

Element Explanation

WTG block The WTG blocks shown in the display area are highlighted in green:

A WTG block (e.g. WTG 1) refers to one WTG and contains at least one
condition block (e.g. for protection of bats or protection of birds). And
each condition block contains several shutdown conditions (e.g. referring
to date, time of day, wind speed etc.). 

Condition block The condition blocks shown in the display area are highlighted in yellow: 

Each condition block consists of several shutdown conditions that are
combined to form a shutdown scenario used to ensure, e.g. that a WTG
will be shut down during a specific calendar period during a specific time
of the day provided, at the same time, specific meteorological conditions
are met. 
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Element Explanation

Condition blocks are linked by a logical OR, i.e. the corresponding WTG is
shut down as soon as the conditions of ONE block are met.

Shutdown condition Shutdown conditions are highlighted in light gray in the display area: 

A shutdown condition is a dataset that is created by selecting options from
drop-down lists and entering values into input fields in the Shutdown
condition area (right-hand side of the window).  

Date range from 05/01 to 09/30.

Several shutdown conditions are combined to form a condition block, e.g.:

Date range from 05/01 to 09/30.

From 1 hour before sunset until 1 hour after sunrise

External temperature of WTG 6 “V1234” less than + 6 m/s 
External temperature of WTG 1 “1234" greater than + 10 °C

The shutdown conditions within a single condition block are linked by
a logical AND, i.e., the corresponding WTG will be shut down only if ALL
conditions are met.

The following figure shows the Special Shutdowns window with a typical shutdown scenario. You
will find helpful explanations underneath.
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Special Shutdowns window with an example

The window above shows the following:

· 6 WTG blocks have already been defined; only the fourth (WTG 4 "1237") is expanded.

· Condition block 1 of the fourth WTG block serves for the protection of bats and it consists of
5 shutdown conditions.

· The fifth of the 5 shutdown conditions has been selected by mouse click and is therefore
highlighted in blue. Its accordingly defined parameters are displayed in the Shutdown
condition settings area (right-hand side of the window); the result of the settings is displayed in
words at the bottom right in the window in the Conditions field. 

If a shutdown condition is displayed in red or black bold letters in the display area of
the Special Shutdowns or Night shutdowns window (left half of the window), then
SM4 has detected that an input is "not plausible". Please refer to the information in the 
Plausibilty check  section.

Below you will find a list of the most important general notes regarding the Special Shutdowns
window.

214
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General notes regarding the Special Shutdowns window

· In order to create special shutdowns, one or more condition blocks, each consisting of one or
more shutdown conditions, are created for each WTG.

· Condition blocks that have already been created as well as their individual shutdown conditions
are displayed on the left-hand side of the window.

· These conditions are specified on the right-hand side of the window under Shutdown Conditi-
on, see also Shutdown condition input area .

· The result of the settings of a single shutdown condition is displayed at the bottom right under
Condition.

· The conditions within a single block are linked by a logical AND, i.e., the corresponding WTG
will be shut down only if ALL conditions are met.

· Several condition blocks are linked to each other by a logical OR, i.e. the corresponding WTG is
shut down as soon as the conditions of ONE block are met.

· The SMU continually checks whether or not the defined conditions are met. As soon and as long
as all conditions of one condition block are met, the corresponding WTG will be shut down.

If there is more than one condition within a condition block, these conditions are linked
by a logical AND, i.e., the corresponding WTG will be shut down only if ALL conditions
within a condition block are met. 

If several condition blocks exist, these blocks are linked by OR, meaning that shutdown
will occur already if the conditions of ONE block are fulfilled.

Now that you are familiar with the structure and the basic function of the Special Shutdowns
window, let’s get to the details.

The buttons in the Special Shutdowns window are described in the following table

Element Explanation

Left-hand side
of the window

The left-hand side of the window shows the condition blocks that have already
been defined for a WTG (in this example this would be WTG 1 with ID 1234). If
you click on the small arrow on the left-hand side of the WTG or condition block,
the condition blocks will be collapsed or respectively expanded. No settings can
be made in this area of the screen. 

Expands all condition blocks and conditions that have already been defined (dis-
played on the left-hand side of screen).

You can also use the small arrows displayed to the left of the condition block or
condition to expand the respective screen element.

213
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Collapses all condition blocks and conditions that have already been defined (dis-
played on the left-hand side of screen).

You can also use the small arrows displayed to the left of the condition block or
condition to collapse the respective screen element.

Adds the object type that is selected on the left-hand side. 

NOTE

This button is active only in the following situations:

· when adding a WTG, a WTG was selected from the WTG drop-down list (top
right) for which no special shutdown has been defined thus far

· when adding a condition block, a name was entered under Block name (top
right) that does not yet exist within the corresponding WTG

· a shutdown condition that does not yet exist in the corresponding block has
been defined in the settings area. If a shutdown condition has been selected,
it can be added as often as required.

Is used to change an object; the following changes are possible:

· change the name of a condition block

· change the parameters of a shutdown condition

NOTES

· This button will not be activated until the corresponding name/parameter has
been changed. 

· Changes will only be applied if you confirm them by clicking on Apply. Other-
wise, the changes will be discarded as soon as you select a different object
or close the window.

Deletes the object that is marked on the left-hand side of the screen. 

NOTE

The condition blocks within a WTG are always numbered consecutively, even af-
ter a block has been removed. 

EXAMPLE

If you remove the second of 3 condition blocks in total, the former “condition block
3” will become “condition block 2”.

See also Practical example 6: Special shutdowns due to bat and bird protection without
night slices plus noise protection 43
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4.4.1.1 Create a special shutdown – basic steps

This section describes how to set up a special shutdown if none have been defined befo-
rehand.

8 Click on  (or select Switching & Measurement> Special Shutdowns) to open the Special
Shutdowns window.

8 Select the WTG for which a special shutdown needs to be defined from the WTG drop-down
list on the right-hand side of the screen (top).

8 Click on + Add at the bottom right of the screen. The selected WTG will now appear on the
left-hand side of the screen.

8 Click on the small arrow in front of the blue highlighted WTG on the left-hand side of the
screen. Condition block 1, special shutdown will now be displayed underneath.

8 Click on the small arrow in front of Condition block 1, special shutdown on the left-hand si-
de. <empty> will now be displayed below, which will later be replaced by the first condition.

8 Assign a name for the condition block on the right-hand side of the screen under Block name
(e.g., bat protection May) and select, e.g. Bat protection from the switch reason drop-down
list.

The switch reason is important on three accounts:

· When entering a condition block for bat or bird protection, the correct switch reason
must be defined so that SM4 can run the applicable plausibility check .

· The Switch reason also tells the SMU in which particular log a shutdown is to be re-
corded.

· For the WTG type "via relay", additional DOs can be assigned a switch reason, see
Communication Parameters input area .

8 Click on Apply at the bottom right of the screen.

8 Click on <empty> on the left-hand side of the screen. This line will then be highlighted in blue,
and the right-hand side of the screen will display the Shutdown condition input area.

8 Now select e.g., Time from the Source drop-down list under Operand 1 in order to get star-
ted with the actual shutdown condition settings. The operands, operations and input fields are
explained under Shutdown condition input area .

Drag & Drop: If you wish to define shutdown conditions for more than one WTG, you can
save time and effort by copying the condition blocks of the first WTG and reuse them for
the second WTG with the help of drag & drop. For more information on the drag & drop
function for special shutdowns, please refer to the following section:

See also: Easily duplicate special shutdowns using drag & drop .
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If a shutdown condition is displayed in red or black bold letters in the display area of
the Special Shutdowns or Night shutdowns window (left half of the window), then
SM4 has detected that an input is "not plausible". Please refer to the information in the 
Plausibilty check  section.

4.4.1.2 Shutdown condition input area

This section describes how to define the actual shutdown conditions. The basic structure is as
follows:

Operand 1

Source (e.g., WTG) drop-down list

Number drop-down list 

Reading drop-down list (e.g., Outside temperature)

Offset input field(s) (optional)

Hysteresis input field (optional)

will be compared using an

Operation

Operation drop-down list

(greater than, less than, greater than or equal to, less
than or equal to, equal to or not equal to)

to

Operand 2

(Fixed value)

and with many reading points, a

Delay

Response delay input box

Release delay input field

can be added to the condition.

214
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Condition

Displays the result of the parameters defined above in
words.

The basic structure of each shutdown condition is as shown in the above schematic representation
with the exception of conditions for which Time, Sun or External Trigger is selected under Source
(see Glossary ). Sometimes only ONE operand is available, and in some cases neither the Num-
ber drop-down list nor the optional parameters Hysteresis, Response delay or Release delay are
offered. In the case of the Date range and Time range reading point, you need to fill out the input
fields From and To.

The content of the Reading drop-down list also depends on the option selected under Source. 

The options available in the drop-down lists have self-explanatory names. You will find typical ex-
amples of shutdown conditions that you can use as a basis for your own projects on the following
pages. 

For standard condition blocks with detailed parameter settings, please refer to Typical condition
blocks .

4.4.1.3 Plausibility check

Errors can occur when entering shutdown conditions. If these remain undetected, there is a risk of
serious fines due to violations of operating requirements on the one hand, and yield losses due to
unnecessary shutdowns on the other. Therefore, SM4 performs plausibility checks for certain
entries you make in the Special Shutdowns or Night Slice Shutdowns windows.

How is the plausibility check triggered?

The check is triggered automatically in the following cases:

· You click the Apply or Add button in the Special Shutdowns or Night Slice Shutdowns window
when adding or editing certain shutdown conditions. Whether or not a check is run and what is
checked in each case depends on the type of input, see table "What is checked for an input?" be-
low.

· You change the switching reason of a condition block to "Bat protection" or "Bird protection" in
the Special Shutdowns window. 

· You move objects in the Special Shutdowns or Night Slice Shutdowns window using the
Drag&Drop function, see also Duplicating special shutdowns conveniently using Drag&Drop .

· You load an existing SM4 project from a file or SMU.

· You start an integrity check(Tools > Integrity check), see also Project Integrity window .

· You select Project > Configuration / Partial Configuration to configure the SMU, which automati-
cally triggers an integrity check, see also Check Configuration window .
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What is checked for an input?

Some plausibility checks are only performed if bat or bird protection is selected as the switch rea-
son for a condition block, or they only apply to the Night Slice Shutdowns window. Other checks
are run for every switch reason and in both the Special Shutdowns and the Night Slice
Shutdowns window. You will find comprehensive information in the following table.

Element SM4 detects "not plausible" in the following cases

Bat protection (condition block with switch reason = bat protection)

Date range
· First date is greater than second date

· Start date is before 03/01

· End date is after 11/30

Time range 
(source of shutdown condition = sun)

· Reading point = sunrise to sunset

· Offset at sunrise is greater than 120 minutes

· Offset at sunset is greater than 120 minutes and time range is not
sunset to sunset

Bird protection (condition block with switching reason = bird protection)

Date range
· First date is greater than second date

· Start date is before 03/01

· End date is after 11/30

Time range 
(source of shutdown condition = sun)

· Reading point = sunrise to sunset

· Offset at sunrise is greater than 120 minutes

· Offset at sunset is greater than 120 minutes

Night slice shutdowns

Date range
· First date is greater than second date

· Start date is before 03/01

· End date is after 11/30

Time slices
· Time slice before sunset is longer than 15% of the night

· Time slice after sunrise is longer than 15% of the night

Meteorological conditions (check is done for every switch reason)

Wind speed
· Operation is greater than, equal to, equal to or unequal to
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Element SM4 detects "not plausible" in the following cases

· Offset is not equal to zero

· Hysteresis is greater than 1 m/s

· Value is greater than 7.5 m/s

· Response delay or release delay is greater than 1,800 seconds 

Outdoor temperature
· Operation is less than, equal to, equal to or unequal to

· Offset is not equal to zero

· Hysteresis is greater than 1 °C

· Value is less than 8 °C

· Response delay or release delay is greater than 1,800 seconds

Precipitation amount
· Operation is greater than, greater than or equal to, equal to, or un-

equal to

· Offset is not equal to zero

· Hysteresis is greater than 1 mm

· Value is greater than 10 mm/h

· Response delay or release delay is greater than 1,800 seconds

Humidity
· Operation is greater than, equal to, equal to or unequal to

· Offset is not equal to zero

· Hysteresis is greater than 5

· Value is less than 80

· Response delay or release delay is greater than 1,800 seconds

Visibility
· Operation is less than, greater than or equal to, equal to, or not

equal to

· Offset is not equal to zero

· Hysteresis is greater than 100 m

· Value is less than 800 m

· Response delay or release delay is greater than 1,800 seconds

NOTE

The values for the meteorological conditions (see above) can also use a calculation as a source.
In order for the correct check to be run in this case, you must select the appropriate option in the
In Shutdown Conditions treat as drop-down list in the Calculations window, see Calculations
window .

External trigger check

274



217Reference part > Switching & Measurement menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

Element SM4 detects "not plausible" in the following cases

Source = External trigger External trigger is equal to 0

(The purpose of this check is to prevent an External Trigger from being
accidentally checked for its LOW state, see also Shutdown condition
with Source = External Trigger ).

How can I recognize a negative plausibility check?

Elements identified as "not plausible" are marked in red or black bold letters in the left half (display
area) of the Special Shutdowns and Night Slice Shutdowns windows, see the following example:

Special Shutdowns window (section)

Notes on the above example

· Because the date range defined for Condition block 2 is not plausible (start date is before
03/01), this shutdown condition is shown in red boldface. 

· The date range defined for condition block 3, which SM4 has also identified as "not plausible",
has already been manually declared as plausible by the user (see next section) and is therefore
displayed in black boldface.

What does a shutdown condition detected as "not plausible" mean?

Red entries prevent a configuration process, i.e. the project fails the integrity check SM4 automati-
cally runs when the configuration is started, and it cannot be transferred to the SMU. If a shutdown
condition is to be used despite being "not plausible", the user can manually "declare it as plausible"
so that it no longer prevents configuration. 

229
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How do I declare a "non-compliant" shutdown condition as plausible?

If you are sure that you want to use a shutdown condition that has been identified as non-plausible,

first right-click on the condition shown in red bold, click  Plausibility, and check Declared as
plausible. The confirmation of non-plausible shutdown conditions is saved when a project is saved,
so it does not have to be repeated when the project is reopened.

4.4.1.4 Typical shutdown conditions

The options available in the drop-down lists in the Shutdown condition settings area have been na-
med as self-explanatory as possible. However, input fields, such as Offset, Hysteresis, Response
delay, Release delay, will be explained using helful examples in the following sections:

Shutdown condition with Source = Time

Shutdown condition with Source = Sun

Shutdown condition with Source = WTG

Shutdown condition with Source = POI

Shutdown condition with Source = GSM modem

Shutdown condition with Source = Calculations

Shutdown condition with Source = External trigger
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4.4.1.4.1 Shutdown condition with Source = Time

Parameter Explanation of “Date range” reading

Source In the above example, the Time option was selected so that the SMU will
compare the current time with a time period defined below. 

Reading point In the above example, by selecting the Date range option, it was specified
that the period to be compared is defined by a date range (From/To). 

MM/DD*

Additional Here you can see whether winter time is used or a time with summer/winter
time changeover. Whether or not a selection can be made here depends on the
setting under Project > Project Settings > Time settings > Summer winter time
handling.

Condition Displays the result of the parameters defined above. This condition is conside-
red to be met whenever the current date is within 01/01 and 01/31. A shutdown
condition like this one will not make sense unless it is combined with other shut-
down conditions defined within the same block (linked by a logical AND), for
example, “Wind speed less than + 6 m/s”. 

*The format stated here corresponds to the default settings in the input area Country-Specific Settings (File> Application
Settings > Shadow Manager 4 > General) and can be changed there at any time.
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4.4.1.4.2 Shutdown condition with Source = Sun

Parameter Explanation of „Sunset to sunset“ reading

Source Sun was selected in the above example in order to define a
condition that depends on the current time of sunset or sunrise. 

Reading point Sunset to sunset was selected in the above example in order to
define a condition that depends on the current time of sunset.

Offset In the above example, -60 was entered in the first Offset field,
while nothing was entered in the second Offset field, because the
condition is to be considered to be met only until sunset. 

Condition Displays the result of the parameters defined above. This condition is
considered to be met as soon as the time left until sunset is 60
minutes or less. 

To achieve that the above condition is considered to be met not only until sunset but until 2 hours af-
ter sunrise on the next day, the shutdown condition would have to be configured as follows:
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Overview of typical shutdown conditions for Source = Sun

Condition Settings

From 15 minutes before sunset
to 45 minutes after sunset.

From sunrise to sunset.

From 15 minutes after sunrise
to 30 minutes after sunset.

From sunset until 02:00:00.

From sunset until 2 hours after
sunset.

From sunset until 6 hours after
sunset.
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From 30 minutes before sunri-
se to 1 hour after sunset.

From sunrise to 10:00:00.

From 03:00:00 until sunrise.

From 1 hour before sunrise to
3 hours after sunrise.
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4.4.1.4.3 Shutdown condition with Source = WTG

Parameter Explanation of “Wind speed” reading

Source The WTG option was selected in the above example so that the SMU will
compare the wind speed measured by the WTG to a fixed value. 

Number Since it is possible to define more than one WTG in a project, you can select
a specific WTG here. 

WTG 1 “12341” was selected in the above example in order to have the
SMU compare the wind speed measured by this specific WTG to a fixed va-
lue.

Reading point The Wind speed option was selected in the above example in order to have
the SMU compare the wind speed measured by the WTG to a fixed value.

Offset* Here you can specify a value that corrects the value provided by the WTG.

In the above example, it is a known fact that the wind speed reading provi-
ded by the WTG is always 1 m/s above the actual wind speed. Therefore, a
value of -1 m/s was entered here.

Decimals possible, decimal point*
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Hysteresis* The hysteresis defines the desired permissible difference between the swit-
ching points for start-up or respectively shutdown.

To ensure that the WTG will not be switched to frequently during times when
the readings are unstable (e.g., gusty winds), you can delay the response by
specifying a hysteresis.

Only positive values can be entered. The direction in which the hysteresis
works depends on the operation (greater than/less than) the value refers to.

A hysteresis of 1 m/s was entered in the above example to specify that the
WTG will be shut down if the wind speed drops below 6 m/s and will be star-
ted up when the measured wind speed exceeds 7 m/s.

Example of a shutdown condition with the reading “External tempera-
ture"

External temperature greater than + 14 °C with 2 °C hysteresis: 
The WTG is shut down when the external temperature exceeds 14 °C, and it
will be started up again as soon as the external temperature drops below 12 °
C.

Example of a shutdown condition with the reading "Precipitation"

Precipitation less than + 0.5 mm with 0.1 mm hysteresis:  
The WTG is shut down when the precipitation drops below 0.5 mm and will
be started up again as soon as a precipitation of more than 0.6 mm is measu-
red.

NOTE 

The hysteresis is applied only if all conditions within one condition block are
met (logical AND link).

Operation The less than option was selected in the above example to ensure that the
WTG is shut down if the wind speed drops BELOW a specific fixed value.

Fixed value* 6 m/h was selected in the above example to ensure that the WTG is shut
down if the wind speed drops BELOW this value.

Decimals possible, decimal point*

Response delay* To ensure that the WTGs are not switched too frequently (high wear and te-
ar) when conditions relating to wind speed, precipitation or temperature are
involved, you can specify here that the shutdown conditions need to be met
continuously over a specific period of time before a WTG will actually be shut
down.

A Response delay of 1800 seconds was selected in the above example to
ensure that the WTG will be shut down only after a wind speed of less than
6 m/s has been measured continuously over a period of 30 minutes.

Decimals possible, decimal point*

Release delay* To ensure that the WTGs are not switched too frequently (high wear and te-
ar) when conditions relating to wind speed, precipitation or temperature are
involved, you can specify here that the shutdown conditions must NOT be pre-
sent for a specific period of time before a WTG is actually started up on
again after having been shut down due to a special shutdown.
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A Release delay of 1800 seconds was selected in the above example to
ensure the WTG will not be started up again after a special shutdown until a
wind speed of 6 m/s or above has been measured continuously over a period
of 30 minutes.

Decimals possible, decimal point*

Activate delays if in
time range

OR

Delays start
immediately

If a condition block contains a Time condition (e.g., sunset to sunrise), it may
be useful to select the upper option (Activate delays if in time range). If se-
lected, the parameters Response delay and Release delay will not take ef-
fect right away but only when the time range defined in each case also takes
effect. The selection made here has the following effect:

Activate delays in time range

If the wind speed has already fallen below 7 m/s (fixed value of 6 m/s
plus offset) long before sunset, the respective WTG is shut down
30 minutes after sunset at the earliest since the response delay does
not take effect until sunset.

Delays start immediately

If the wind speed has already fallen below 7 m/s long before sunset and
the response delay time has also already expired, then the WTG is shut
down immediately at sunset and the set response delay no longer takes
effect. 

NOTE

You can choose between the two options, but it is not possible to activate
both of them or to deactivate both of them. The selection is only relevant if the
respective condition block also contains a Time condition, otherwise any set
delays (response delay, response delay) always take effect immediately.

Condition Displays the result of the parameters defined above. This condition is consi-
dered to be met if WTG 1 measures a wind speed of less than 7 m/s (fixed
value plus offset).

*The input format corresponds to the default settings in the input area Country-specific settings (File> Application Settings >
Shadow Manager > General) and can be changed there at any time.
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4.4.1.4.4 Shutdown condition with Source = POI

Parameter Explanation of “Daily counter” reading

Source Place of immission was selected in the above example to achieve that the
SMU will compare its current counter reading with a number of minutes as defi-
ned below. 

Number Since each POI in the project has a daily counter as well as an annual counter,
the number of the desired POI needs to be selected here. POI 7 “7” was selec-
ted in the above example in order to have the SMU compare the shadow
impact minutes counted for this specific POI to a fixed value.

Reading point The Daily counter was selected in the above example in order to compare the
shadow impact minutes counted on the respective day to a fixed value. The only
alternative to the Daily counter option in this case is the Annual counter option
which is selected in order to have the SMU compare the shadow impact minutes
counted in the current year to a fixed value.

Operation The greater than option was selected in the above example to ensure that the
condition is considered to be met if the counted shadow impact minutes have ex-
ceeded the fixed value defined below. 

Fixed value 20 minutes was specified in the above example to ensure that the condition is
considered to be met as soon as the currently counted shadow impact minutes
have exceeded this specific value.

minutes, decimals are possible, decimal point*
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Condition Displays the result of the parameters defined above. This condition is conside-
red to be met as soon as the shadow impact minutes counted for POI 7 have
exceeded the value of 20.

*The format stated here corresponds to the default settings in the input area Country-Specific Settings (File> Application
Settings > Shadow Manager 4 > General) and can be changed there at any time.

4.4.1.4.5 Shutdown condition with Source = GSM modem

Parameter Explanation of “Incoming call” reading

Source In the example above, the GSM modem option was selected so that the SMU
will compare the phone number of the caller with a phone number defined below
when an incoming call is received. 

NOTE

The GSM Modem option is only available if the option Use GSM modem
(RS232) was selected under Project > Project Settings > Additional hardware.

Reading point The only reading available here is Incoming Call.

Operation The only operation available here is equal to.
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Value Phone number of the caller who should be able to switch off by call.

Input without spaces

Additional In the above example it was determined that a possible shutdown call should
be valid until the time 18:00:00 is reached twice and that another call will have
no effect. 

There are 2 additional options in the Further call drop-down list:

· re-starts call
The triggered call is started again from the beginning – the counter is reset
to the start value.

· ends call
The call is terminated immediately.

Condition Displays the result of the parameters defined above. If the caller calls from the
defined phone number at 16:00, for example, the deactivation remains in effect
for exactly 26 hours.   

Special shutdowns by telephone call can be combined with other shutdown
conditions in the usual way. For example, you could add "From sunrise to sun-
set" as a further condition, so that shutting down a WTG by phone is only possi-
ble if the sun can actually shine at all.

4.4.1.4.6 Shutdown condition with Source = Calculations

Shutdown conditions like this one may be used, e.g., in
the following situation: in a wind park project that inclu-
des bat protection shutdown conditions, some WTGs
are often sheltered from wind due to one or more other
WTGs being located nearby. Therefore, the shutdown
condition on wind speed is to be applied, for all WTGs
of the park, based on the reading of the WTG that is
picking up the strongest wind. This will prevent WTGs
(that are located on the lee side of other WTGs and
therefore measure lower wind speeds than actually
exist) from being shut down even though the bat re-
mains in safe harbor due to hard wind. 
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Parameter Explanation of “Calculation” reading

Source In the above example, the Calculations option was selected in order to have
the SMU compare a number determined using a certain “Calculation” to a value
defined further below.

NOTE: The option is only available if at least one calculation has been defined
under Switching & Measurement > Calculations.

Reading point The automatic calculation set up in the Calculations window to determine the
highest wind speed has been selected here.

Operation “less than” was selected here, since the shutdown concerned was defined the
for the purpose of bat protection, and bats only fly at low wind speeds.

Value Value as required by the authorities. 

Additional Optional settings – for more information on condition on the settings available
here, see section Shutdown condition with Source = WTG .

Condition Result of the parameters defined above: Shutdown occurs when none of the
WTGs in the wind park measures a wind speed of 5 m/s or more.

4.4.1.4.7 Shutdown condition with Source = External trigger

223
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Parameter Explanation of “External Trigger” reading

Source In the above example, the External Trigger option (see Glossary ) has
been selected in order to have the SMU check whether the external trigger “mo-
wing shutdown” is set or not.

NOTES

· The option is only available if an external trigger has been set up under
Hardware > Sensors and IO Signals > External Triggers and the external
special shutdown interface has been activated in the project settings (Pro-
ject > Project Settings).

· External triggers are set via the special shutdown interface (SMU > Special
Shutdown-Interface > Server settings).

Reading point Here the external trigger defined in the Sensors and IO Signals window was
selected.

Operation This parameter was set to “equal” and Value was set to “1” so that the shut-
down condition be fulfilled when the external trigger is set.

Value see above

Condition Result of the parameters defined above: The respective WTG will be shut down
as soon as the condition “mowing shutdown” equals 1.

Please also note the following information box on “External Triggers”.

There are two basic types for the use of external triggers in SM4:

Type 1
· a trigger named “mowing shutdown” is define in SM4 

· this trigger is included in the special shutdowns of all WTGs that would be affected once
a certain meadow is mowed .

If this trigger is subsequently set by an external user, all these WTGs are stopped. 

Advantage: comfortable shutdown of several WTGs “at one click”

Type 2
· a separate trigger is defined for each WTG in SM4; its name contains the respective

WTG number 

· for each WTG, the trigger defined for it is included in the shutdown of that WTG

In order to implement mowing shutdowns for certain WTGs, the external user must set a
corresponding number of triggers. 

Advantage: more flexible solution, changed affiliations of a WTG to a meadow can be im-
plemented “externally” (no need to reconfigure the SMU).

Furthermore, conditions that cause a mowing shutdown via triggers can be limited to certain
periods by including additional conditions (e.g..: sunrise and sunset, date range spring/
summer). 

472
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Please be very careful when entering values in SM4. Incorrect parameter values may
result in avoidable wear and tear, loss of earnings, problems with authorities or resi-
dents, and, in the worst-case, force operators to decommission WTGs.

4.4.1.5 Typical condition blocks

In this section, you will find typically used condition blocks with detailed parameter settings, which
you can use as a basis for your own projects.

A) Bat protection

Requirement: Shut down WTG 99 “12341” from 1 May to 30 September from 60 minutes before
sunset until 60 minutes after sunrise on the following day provided that “this same WTG” (not one of
the other WTGs) measures a wind speed of less than +6 m/s and an external temperature of more
than +10 °C while precipitation sensor 1 measures a precipitation total of less than + 0.5 mm. The
following shutdown conditions must be defined for this condition block:

Condition 1 Condition 2 Condition 3
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Condition 4 Condition 5

See also Practical example 6: Special shutdowns due to bat and bird protection without
night slices plus noise protection 43
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B) Bird protection

Requirement: Shut down WTG 1 “12341” from 1 June to 30 June from sunrise to sunset provided
that this same WTG has measured a wind speed of less than +5 m/s for at least 30 minutes; after a
shutdown due to wind speed, this condition must have been fulfilled over a period of at least
15 minutes before the WTG is started up again.

The following 3 shutdown conditions must be defined for this condition block:

Condition 1 Condition 2 Condition 3

NOTE 

For condition 3, the option Activate delays if in time range is selected in the Additional input area,
so that a shutdown will be carried out 30 minutes after sunset at the earliest. If Delays start
immediately is selected and the wind speed has already fallen below 5 m/s, e.g., one hour before
sunset, the respective WTG would be shut down right at sunset. 

For more information, for example, on the Additional input area that see the section on special
shutdowns underShutdown condition with Source = WTG .223
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C) Bird protection

Requirement: Shut down WTG 1 “12341” from 1 June to 30 June from 15 minutes after sunrise to
30 minutes after sunset, if wind speed is less than + 5 m/s at “this same WTG”. 

The following 3 shutdown conditions must be defined for this condition block:

Condition 1 Condition 2 Condition 3

If a shutdown condition is displayed in red or black bold letters in the display area of
the Special Shutdowns or Night shutdowns window (left half of the window), then
SM4 has detected that an input is "not plausible". Please refer to the information in the 
Plausibilty check  section.214
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4.4.1.6 Easily duplicate special shutdowns using drag & drop

Defining special shutdowns for each WTG of a big wind park can be a very time-consuming
process. Often, the conditions required for several if not all WTGs of a wind park are identical or at
least very similar to each other. Therefore, they can be easily copied per drag & drop in order to
save time. During this process, references to the source WTG (e.g., “Wind speed of WTG 2 less
than +6 m/s”) can be replaced by corresponding references to the target WTG. 

In the explanations of this subsection, it is assumed that you are familiar with the basic operation of
the Special Shutdowns window. If this is not true, please read the following section on Special
shutdowns:

Special Shutdowns window

Create a special shutdown – basic steps

Shutdown condition input area

Typical example: Transfer all conditions of one WTG to a new WTG

In many cases, it is useful to transfer the special shutdowns defined for one WTG to a 2nd WTG for
which no special shutdowns have been defined thus far. Only 2 steps need to be carried out:

§ create a new WTG block (target object)

§ drag the WTG block (source object) that has already been defined to the target object

The new WTG block will now have the same condition blocks including (and shutdown conditions) as
those source WTG block. If the latter contains shutdown conditions referring to the source WTG
(the "own" WTG), these can be replaced in the target WTG block with references to the target
WTG (the user must confirm this in a corresponding dialog window).

Not only WTG blocks but also individual condition blocks or shutdown conditions can be duplicated. 

Please pay attention to the following notes when using drag & drop

· An object can only be dragged to an object of the same type (example: a WTG block can only
be dragged to another WTG but not to a condition block).

· It is also possible to copy a condition block within the same WTG block. In this case, you have
to decide in a dialog window whether the block should either be moved or added as a new
block, see dialog window A below.

· If a shutdown condition object is dragged within the same condition block, it can only be
moved (in order to change its position in the list of shutdown conditions) – duplicating per
drag & drop is not possible in this case.

· In order to duplicate a shutdown condition within the same condition block, select it by clicking
on it (will be highlighted in blue) and click on Add at the bottom right in the window.

· If you try to drag an object to a "forbidden" target (e.g. you are trying to drag a condition block
to a shutdown condition) a prohibition symbol (x) will be displayed instead of the mouse poin-
ter.

205
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· If you drop a WTG block onto another WTG block, all condition blocks including all shutdown
conditions of the source WTG will be added to the target WTG block, no matter if the target
block is empty or already contains condition blocks (i.e. nothing will be overwritten).

· If you drag an object that contains one or more shutdown conditions with a reference to the
source WTG (e.g. wind speed of the source WTG less than + 6 m/s“), you have to decide in a
dialog window whether the reference should be replaced by a reference to the target WTG (this
is typically used) or the reference to the source WTG should remain unchanged, see dialog
windows B, C, D below.

All dialog windows you may encounter when using drag & drop are explained in the following.

Dialog windows you may encounter when copying or moving an object

A

You are moving a condition block within its own WTG block. If you select Copy
condition block, the condition block will be duplicated (the number of condition blocks in-
creases by 1). If you select Move condition block, nothing will change except for the
position of the block.

B

You are copying a WTG block that contains one or more shutdown conditions with refe-
rence to the source WTG (the same WTG). If a checkmark is set, the reference will be
replaced with a reference to the target WTG (this is typically used), otherwise the refe-
rence to the source WTG will remain unchanged.
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C

You are copying a condition block that contains one or more shutdown conditions with re-
ference to the source WTG (the same WTG). If a checkmark is set, the reference will be
replaced with a reference to the target WTG (this is typically used), otherwise the refe-
rence to the source WTG will remain unchanged.

D

You are copying a shutdown condition with reference to the source WTG (the same
WTG). If a checkmark is set, the reference will be replaced with a reference to the target
WTG (this is typically used), otherwise the reference to the source WTG will remain un-
changed.

E

You are dragging a WTG object that contains NO shutdown condition with reference to
the source WTG (the same WTG). To complete the process, click on OK. If the target
object is empty, it will be overwritten; if it is not empty, the source object will be added
as a new object.
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F

You are dragging a condition block that contains NO shutdown condition with reference to
the source WTG (the same WTG). To complete the process, click on OK. If the target
object is empty, it will be overwritten; if it is not empty, the source object will be added
as a new object.

G

You are dragging a shutdown condition without reference to the "same" WTG. To com-
plete the process, click on OK. If the target object is empty, it will be overwritten; if it is
not empty, the source object will be added as a new object. 

If a shutdown condition is displayed in red or black bold letters in the display area of
the Special Shutdowns or Night shutdowns window (left half of the window), then
SM4 has detected that an input is "not plausible". Please refer to the information in the 
Plausibilty check  section.214



239Reference part > Switching & Measurement menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

4.4.2 WTG Speed Reduction window

Purpose Automatically reduce the speed of wind turbines depending on certain
conditions, e.g. for bird protection, bat protection, etc.

Symbol

Path Switching & Measurement > Speed reduction

Window type divided vertically, see vertically divided windows

Type of use on the left: only display/selection/drag & drop

on the right: interactive

Reference Project

If, in accordance with requirements for bird protection, bat protection, etc., it is sufficient for the
rotors not to exceed a specified number of revolutions per minute at a certain wind speed and humi-
dity, the WTG speed reduction function is used instead of a complete shutdown.

The structure and operation of the vertically divided WTG Speed Reduction window essentially
corresponds to the Special Shutdowns window. If you are not familiar with the latter, please start by
reading the sections Vertically divided windows  and Special Shutdowns window .

The following is an example of the WTG Speed Reduction window to illustrate the differences from
the Special Shutdowns window.

Speed Reduction window

25

25 205



240Reference part > Switching & Measurement menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

Special features of the WTG speed reduction window

· At the top level (green, blue in the figure above because selected), you specify the WTG at which
speed reduction is to take effect, and in addition, you can define a Rotation speed tolerance
and an Alarm delay:

Rotation speed tolerance: As long as the WTG speed remains below the target speed plus this
tolerance, no alarm is triggered.

Alarm delay: This is used to bridge brief speed exceedances. The alarm is only triggered ("WTG
does not respond to stop command" alarm) if the speed exceedance is still present after the
alarm delay has expired.

· On the second level (red), you define one or more speed values the SMU will command to the re-
spective WTG as soon as the conditions (gray) of the underlying condition blocks (yellow) apply .

 

Blocks are linked to each other by a logical OR, i.e. the reduction will be commanded
even if the conditions of only ONE block are met.

Conditions within a single condition block are linked by a logical AND, i.e. the reduction
will be commanded only  if ALL conditions are met.

Notes on the way speed reduction commands are processed

· If more than one speed reduction is defined for a WTG and the conditions for more than one of
these reductions apply at the same time, the SMU will command the lowest of the defined speed
values.

· The speed commanded to a WTG by the SMU is not always accomplished 100%, because the
WTG control system decides as to how this lower speed is achieved. As it could also be achie-
ved, for example, by setting a higher power level, the resulting speed may be significantly lower
than commanded by the SMU.

· If a speed reduction command is sent to a WTG type that is not designed for this function, the
SMU writes a corresponding log entry and the WTG is stopped.

· The defined reduced speed serves as an upper limit, i.e. if the speed of a WTG is lower, no
alarm is triggered.

· A speed reduction triggers 2 events (speed reduction and monitoring phase), and standard mea-
suring points as well as one or more condition measuring points are recorded in the Events
window:
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User-defined measuring points can also be added.

· A further event indicates that the respective WTG is running at reduced speed:
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4.4.3 Night Slice Shutdowns window

Purpose Define complex shutdown conditions for bat protection (division of the night in-
to slices with different conditions) 

Symbol

Path Switching & Measurement > Night Switching Shutdowns 

Shortcut F11

Window type Divided vertically, see Vertically divided windows
(basic operation like the Special Shutdowns window)

Type of use Interactive

Reference Opened project

Some bat protection requirements are so complex that different conditions apply in different Time
slices during the night. To fulfill such requirements, SM4 provides Night Slice Shutdowns options. If
the bat protection requirements are less complex (shutdown conditions are the same for the entire
night), you do not have to use the Night Slice Shutdowns settings and can simply use Special
Shutdowns.

The basic structure and operation of the Night Slice Shutdowns window are based on the Special
Shutdowns window.  However, date ranges and night slices also exist in addition to WTG blocks,
Condition blocks and shutdown conditions in the Night Slice Shutdowns window; see the following
figure (differences to the Special Shutdowns window marked in red):

25
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 Night Slice Shutdowns

display area (levels)

Night Slice Shutdowns that have already been
defined are displayed here (in different colors

according to the level) and can be easily selec-
ted or copied per drag & drop.

WTG block 1 

Date range...

Time slice 1

Condition block 1

Shutdown condition

Shutdown condition

…

Date range...

Time slice…

Condition block 1

Shutdown condition

Shutdown condition

…
WTG block 2 

Date range...

Time slice

Condition block 1

Shutdown condition

Shutdown condition
…

WTG

settings area 

Drop-down lists with options and input fields for
the following operating procedures:

· select/add/remove a WTG

· specify/change/delete date ranges

· define/add/change/delete Time slices

· specify/change block name

· select switch reason for block

· add/change/delete condition blocks

· define/add/change/delete a dataset with
shutdown conditions

Condition

The result of the current settings in the settings
area is displayed in words

display area buttons settings area buttons

Schematic representation of the Night Slice Shutdowns window

Because the operation of the Night Slice Shutdowns window is almost no different to that of the
Special Shutdowns window, only the basic procedures for creating night slice shutdowns are des-
cribed below. Information on defining the individual shutdown conditions can be found under Shut-
down condition input area .

Basic procedures for creating a Night Slice Shutdown

This section describes how you can set up a Night Slice Shutdown if none have been defi-
ned beforehand.

§ Open the Night Slice Shutdowns window (Switching & Measurement > Night Slice
Shutdowns).

§ Select the respective WTG from the WTG drop-down menu at the top right and click on Add
below.

§ Click on the small arrow in front of the selected WTG at the top left in the window.

213
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§ Click on the red highlighted Date range and enter Begin and End at the right. Click on Apply
at the bottom right in the window.

Date ranges that are defined with data on the year are only valid for the year entered. If
no data on the year has been entered, the date range also applies to the following years.
Years must be entered with four digits.

§ Click on the small arrow in front of the date range at the top left in the window. The first Time
slice will now be displayed. Click on it to select.

§ Select the Time slice before sunset option in the drop-down list at the right in the window,
enter the desired value for Time slice length % of the night (e.g. 15 %) and click on + Add
at the bottom of the window. The percentage refers to the time between sunset and sunrise. If
no time slice before sunset is required, select Night time slice from the dropdown list.

§ Click on the arrow in front of Time slice before sunset or respectively Time slice 1, then
click on Condition block 1. Now enter the desired name in the Block name field on the right
and click on Apply. 

§ Click on the arrow in front of Condition block 1 and then on <empty>. The Condition input
area will now appear on the right.

§ Now define the conditions in the Condition input area. The operation is identical to that of the
Shutdown condition area in the Special Shutdowns window (see Shutdown condition input
area ).

§ Subsequently set up and define all other Time slices and Condition blocks according to the re-
quirements of the authorities (a Night slice for the time after sunrise can also be defined).

If a shutdown condition is displayed in red or black bold letters in the display area of
the Special Shutdowns or Night shutdowns window (left half of the window), then
SM4 has detected that an input is "not plausible". Please refer to the information in the 
Plausibilty check  section.

See also Practical example 5: Requirements for bat protection w/ night slices

213
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4.4.4 Shutdown Calendar window

Purpose Define fixed shutdown periods (unconditional)

Symbol

Path Switching & Measurement > Shutdown Calendar 

Type of use Interactive

Reference Project

The Shutdown Calendar window is used to define fixed shutdown periods to be applied regardless
of other conditions, such as position of the rotor with respect to the sun. The only condition that can
be defined in addition to time is Sun is shining, which is determined by the light sensor. 

Shutdown Calendar window

General notes on the Shutdown Calendar window 

· Shutdown periods that have been defined are displayed in list form. The number "398" at the
top right of the screen corresponds to the number of shutdown times already defined:

- 31 periods (2 h every day from 1 July to 31 July) plus 
- 366 periods (1 h every day from 1 January to 31 December) plus 
- 1 period (from 14 June to 17 June without interruption)

· The shutdown periods can be created or edited directly in the columns of the list. To add a new
shutdown period, click on the + at the bottom left or press ENTER when the cursor is in the last
column. To remove, use – or DEL accordingly.

· Mandatory fields are highlighted in red (only visible in empty lines).

· Correctly defined input fields are highlighted in green.
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· If the values defined result in an exceptionally long period under Duration, the value will be
highlighted in yellow.

Operating instructions for the Shutdown Calendar window 

· Move columns: Columns can be moved by drag & drop.

· Sort by column: To sort the table by a certain column, click its heading. If you then click again
on the same column heading, the sort sequence will change from ascending to descending or vi-
ce versa.
You can also sort by more than one column heading (criteria). To do this, first press and hold
the shift key and then click on the desired column headings. The sorting will be carried out
according to the order in which you click on the column headings.

The information, options or buttons are described in the following table

Element Explanation/Function

WTG

Number Number of the WTG that is to be shut down at fixed periods.

Shutdown Start / Shutdown End

Date Here you specify the first/last day of the period during which the respective
WTG is to be shut down at fixed times.

MM/DD*

Time Here you specify the time at which the shutdown time should begin/end. The
Summer/winter time handling settings must also be taken into account here
(Project > Project settings > SMU > Time settings).

12 h

Time Period For a shutdown from … to, select Continuously, for a daily recurring shut-
down, select Daily.

Continuous

Duration This field is filled in automatically and is for checking purposes only. If you have
defined a time range that covers more than 29 minutes, the field is highlighted in
yellow to indicate that the system will be shut down over a relatively long
period.
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Element Explanation/Function

Light Sensor Select one of the 3 options from the drop-down list: 

Option Effect

Ignore all
light sensors 

The defined shutdown period is always applied.

Evaluate
WTG's light
sensor

The defined shutdown period is only applied if the WTG's  light
sensor reports that shadow impact is possible.

Light sensor:
1... 40

The defined shutdown time is only applied if the selected light
sensor reports that shadow impact is possible.

Date and time
in winter time

This is displayed in the following cases

In the Summer/winter time application input area (Project > Project Settings
> SMU > Time settings > Summer/winter time handling), the One time sour-
ce option is selected and the Use summer/winter time checkbox in the Time
synchronization settings input area (Project > Project Settings > SMU > Time
settings > Synchronization) is NOT checked.

OR

The Two time sources option is selected in the Summer/winter time applica-
tion input area (Project > Project settings > SMU > Time settings > Sum-
mer/winter time handling).

Date and time
in summer/winter
time

This is displayed if the One time source option is selected in the Summer/win-
ter time application input area (Project > Project Settings > SMU >Time
settings > Summer/winter time handling) AND a checkmark is placed at  Use
summer/winter time in the Time synchronization settings input area (Project
> Project settings > SMU > Time settings > Synchronization).

Used to confirm the entered/selected values. 

*The format stated here corresponds to the default settings in the input area Country-specific settings (File > Application
Settings > Shadow Manager 4 > General) and can be changed there at any time.

Please be very careful when entering values in SM4. Incorrect parameter values may
result in avoidable wear and tear, loss of earnings, problems with authorities or resi-
dents, and, in the worst-case, force operators to decommission WTGs.
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4.4.5 WCU Shutdown Calendar window

Purpose Set fixed periods for monitoring WTGs by means of a WCU

Symbol

Path Switching & Measurement > WCU Shutdown Calendar 

Prerequisites WTGs to be monitored must be connected to a WCU

Type of use Interactive

Reference Project

In the WCU Shutdown Ccalendar window, you can define fixed periods during which, if communi-
cation to the SMU is down, a WCU takes over the role of the SMU and monitors all WTGs connec-
ted to this WCU. Conditions such as "position of the rotor in relation to the sun" are not taken into
account. As with the "normal" shutdown calendar, only the "sun is shining" condition determined via
the light sensor can be additionally taken into account.

If a communication failure occurs, the WCU practically becomes a "slimmed-down" SMU that auto-
nomously processes its own shutdown calendar. Provided that this backup calender has been crea-
ted in SM4, the WCU can carry out actions that come surprisingly close to the complex shutdown
scenario of a "real" SMU.

Fig.: WCU shutdown calendar window

There are three options for filling a WCU shutdown calendar:
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· Manually define shutdown times in the window itself – same as in the conventional Shutdown

Calendar window

· Import existing entries from the Shutdown Calendar window: Shutdown calendar button 

· Generate and import entries from the Special Shutdowns window: Special Shutdown button

 
You can of course combine these three options and/or use an import as a basis and then delete/edit
individual entries from the import or add new ones. 

The operation of the WCU Shutdown Calendar window is almost identical to that of the Shutdown
Calendar window  – further details can be found there. The three additional buttons Shutdown
Calendar, Special Shutdown and Delete, which are only available in the WCU Shutdown
Calendar window, are described in the following sections.

245
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4.4.5.1 Shutdown Calendar button

Use this button to import all entries from the Shutdown Calendar window.

This usually results in scenarios that are not plausible, as light sensors (LS) defined in the Shut-
down Calendar window may not be accessible to the WCU when the WCU shutdown calendar is
used in the event of a communication failure. Examples:

· If the value "Light sensor 3" is defined in the Light Sensor column of the WCU Shutdown
Calendar window, then this LS must be connected either directly to the WCU (via RS485 card or
Flcom server in the WCU network), or to a SNU that is connected to the WCU.

· If the value "Evaluate WTG's light sensor" is set in the Light Sensor column of the WCU Shut-
down Calendar window, then the WCU must be able to connect to the LSs set in the Add/Edit
WTG window for Reference light sensor 1, Reference light sensor 2 and Alternative light
sensor.

It is recommended to start an integrity check (Tools > Project integrity) after using the Shutdown
Calendar import function (please also refer to the Project Integrity window  section).

Here is an example of a network with WCUs to illustrate the above:

Fig.: Example of a network with WCUs

418
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Notes on the above example

· As WCU shutdown calendar entries can only be defined for WTGs that are connected to a WCU,

only the WTGs of wind farms 2 and 3 would qualify in the above example.

· In a WCU calendar entry for WTGs of wind farm 2, only LS 2a may be defined as the light

sensor to be taken into account.

· If the value Evaluate WTG' light sensor is defined in the WCU shutdown calendar entry for a

WTG of wind farm 2, then light sensor LS 2a must also be defined for the respective WTG in the

Add/Edit WTG window at Reference light sensor 1, Reference light sensor 2 or Alternative

light sensor.

· It is of course possible to define Ignore all light sensors in each entry instead. 

· Any conflicting settings will be rejected by the integrity check.
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4.4.5.2 Special Shutdown button

If you click on this button, SM4 generates monitoring periods for the WCU shutdown calendar from
existing special shutdowns (Switching & Measurement > Special Shutdowns) and imports them.
Please note the following:

· Only those condition blocks from the Special Shutdowns window whose Switch reason is "Bat
protection" or "Bird protection" are taken into account; and of these condition blocks only those
shutdown conditions whose source is "Time" or "Sun" will be used.

· Exception for shutdown conditions with source = "Sun": If the measuring point of such a shut-
down condition is "Sun azimuth" or "Sun elevation angle", then it is not taken into account.

· Shutdown conditions with measuring point = "Sunrise" and/or "Sunset" are taken into account –
sunrise/sunset is converted into the current time of day.

An example:

Fig.:  Special Shutdowns window +  WCU Shutdown Calendar window
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Notes on the above example

The above sections of the two relevant windows show you how SM4 processes an imported special
shutdown for the WCU Shutdown Calendar window: 

· The date range is adopted from condition block 1 as defined in the Special shutdowns window.

· From condition block 2, the shutdown condition "sunset until sunrise" is converted into the corre-
sponding times of sunset and sunrise in the defined date range.

· Condition block 3 is ignored for two reasons: Switch reason "Bird or bat protection" and
Reading point = "Sun azimuth".

4.4.5.3 Delete button

If you click this button SM4 will delete all entries at once without prompting you for confirmation.
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4.4.6 On-Demand Shadow Shutdowns window

Purpose OSS can be used to allow residents of places of immission to 
switch off WTGs that cause shadow impact using an app on
their smartphone.

Icon

Path Switching & Measurement > On-Demand Shadow Shutdowns 

Prerequisite SMU version 4.2.52 or higher

Usage type Interactive

Reference Project

On-demand shadow shutdowns (OSS) allow residents of places of immission (POI) to switch off the
WTG(s) causing shadow impact at their POI using an app on their smartphone.

The structure and operation of the vertically divided Reading Point Switches window essentially
corresponds to the Special Shutdowns window. (If you are not familiar with the latter, please start
by reading the sections Vertically divided windows  and Special Shutdowns window .) Howe-
ver, at the top level of this window, you do not select the WTG to be shut down, but a POI whose
residents can shut down WTG(s) causing shadow impact on demand.

What is the difference between OSSs and  "standard" shadow impact shutdowns?

In the case of "standard" shadow impact shutdowns, a WTG causing shadow impact is shut down
only when the annual or daily counters of the affected POIs exceed the upper limit. With OSSs, on
the other hand, taking the counters into account can be deselected (see Consider counter of the
POI in the screenshot below). 

In addition, with "standard" shadow impact shutdowns, WTGs are shut down only if the light sensor
reports conditions that allow for actual shadow impact. This can also be deselected with OSSs (see
Consider WTG light sensor in the screenshot below).You will find further information on the next
page.

25 205
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On-Demand Shadow Shutdowns window (OSS)

Explanation of the above example window:

· The two options explained above (Consider counter of the POI and Consider WTG light
sensor) are deselected. Therefore, only the conditions defined on the left will determine the shut-
down of WTGs that cause or could cause shadow impact at the POI.

· To allow residents of POIs to shut down a WTG via smartphone app, define a shutdown condition
with an external trigger, as already done in the example above for POIs 213, 212 and 215.  Ex-
ternal triggers can be defined as software versions of digital inputs, see glossary . In order to
be able to define a trigger as a source in a shutdown condition, you must have created it befo-
rehand under Hardware > Sensors & IO Signals > External Triggers tab.

· The residents of the POI can then use a smartphone app to turn off the WTG(s) that cause or
could cause shadow impact at their POI.

· Just like several other shutdown windows, the OSS window allows for defining a time range (not
visible in the screenshot above) in addition to triggers. However, other options are not available in
this window.

472
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NOTE

· External triggers can only be used for OSSs and can only be set remotely if  (a) an external trig-
ger has been set up beforehand at Hardware > Sensors and IO Signals > External Triggers tab
and (b) the external Special Shutdown Interface has been activated in the project settings (Project
> Project Settings > Server settings).

· OSSs trigger an event when they become active. The POI number is recorded for this type of
event as the Default reading point while the conditions defined at OSSs are recorded as the
Condition reading points. In addition, you can define User-defined reading points (for more
information, refer to the Events window  section ). 280
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4.4.7 Switching of Digital Outputs window

Purpose Set conditions for switching digital outputs 

Path Switching & Measurement > Digital out switching 

Type of use Display + interactive

Reference Entire project

In this window you can define conditions that set a digital output as soon as they are fulfilled and re-
set the output as soon as they not fulfilled anymore. The Set and Reset operations trigger events
that can be referenced in the Events window .

The structure and operation of the vertically divided Switching Digital Outputs window essentially
corresponds to the Special Shutdowns window. If you are not familiar with the latter, please start
by reading the sections Vertically divided windows  and Special Shutdowns window . 

Switching of Digital Outputs window

Explanation of the above example window Switching of digital outputs:

· The digital output selected in the DO drop-down list (right half of the window) has previously
been defined in the Digital Outputs tab (Hardware > Sensors and IO Signals).

· In the above example, the digital output is set when the measured light value of light sensor 1 is
greater than 12000 lux, and reset again as soon as the light value has fallen below 11900 lux
because of the hysteresis of 100 lux.

· An event is triggered by setting or resetting a digital output. In the Events window, the number
of the DO and the values of the reading points from the conditions for switching the DO are log-
ged as standard. Further reading points can be added by the user as desired.

· For switching of digital outputs to work, they must be assigned in the Hardware Assignments
window (Hardware > Hardware Assignments), see section Hardware Assignments window
for more information.

280
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4.4.8 Single Data Recordings window

Purpose To record individually selectable measurement data and link/compare them to
one another. The corresponding data is output as a separate log.

Symbol

Path Switching & Measurement > Single Data Recording 

Shortcut SHIFT-CTRL-E

Window type Divided vertically, see Vertically divided windows

(basic operation like the Special Shutdowns window)

Type of use Interactive

Reference Project

In addition to the 3 standard logs (Operation/Shadow impact/Shutdown log) you can also define a
user-defined log in SM4 with data that can be individually selected. 

Logging can take place cyclically at selected intervals and/or depending on specific log conditions
(Attention: the actual conditions, which are called “Shutdown conditions” for Special shutdowns, are
designated as “Log conditions” here).

The linking logic is the same as for Special shutdowns (condition blocks are linked by OR and
conditions by AND). 

The basic structure and operation of the Single Data Recordings window are based on the Speci-
al Shutdowns window. However, at the top level, you do not select the WTG to be shut down but a
measurement object instead (source and reading) whose values should be logged.  See the
following figure (differences to the Special Shutdowns window are marked in red):

25
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 Single Data Recordings

display area (levels)

Single data recordings that have already been
defined are displayed here (in different colors

according to the level) and can be easily selec-
ted or copied by drag & drop.

Measurement object 1

Condition block 1 

Log condition 

Log condition

…

Condition block 2

Log condition

Log condition

…
Measurement object 2

Condition block 1

Log condition

Log condition

…
Measurement object...

settings area

Drop-down lists with options and input fields for
the following operating procedures:

· select /add /change / delete measurement
object

· specify/change block name

· add/change/delete condition blocks

· define / add / change / delete datasets with
log conditions

Condition

The result of the current settings in the settings
area is displayed in words

display area buttons settings area buttons

Schematic representation of the Single Data Recordings window

Because operating the Single Data Recordings window is almost no different to operating the
Special Shutdowns window, only the basic procedures for creating measurement data logging are
described. Defining individual log conditions corresponds to how shutdown conditions are defined,
see Shutdown condition input area .

Basic procedures for setting up Single Data Recordings window 

This section describes how you can set up a Single Data Recording set if none has been
defined beforehand.

8 Open the Single Data Recordings window (Switching & Measurement > Single Data
Recording).

8 Select the desired source in Source at the top right. 

8 If applicable, enter a different number in No.

8 Select the desired option at Reading point.

8 If readings should be performed cyclically, set a checkmark at Cyclic log and define the Log
interval underneath.

8 Click on  Add at the bottom of the window.

213
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The following steps are optional

8 Click on the small arrow in front of the created measurement object at the top left in the
window.

8 Now click on the small arrow in front of Condition block 1.

8 Click on <empty>.

8 Now define the actual condition in the Log Condition input area and then click on  Add. The
operation is identical to that of the Shutdown condition area in the Special Shutdowns
window (see Shutdown condition input area ).

8 You can then set up and define all other measurement objects, condition blocks and log
conditions as you wish.

213
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4.4.9 Cyclic Multi Log window

Purpose
· Regular recording of a series of measured values 

· Define specifications exporting the results in .csv format

Abbreviation Cyclic Multi Data Recording = CMDR

Path Switching & Measurement > Cyclic Multi Data Recording

Shortcut SHIFT-CTRL-Z

Window type divided vertically, see Vertically divided windows

(basic operation similar to the Special Shutdowns window)

Type of use left part: display only; right part: interactive

Reference Project

Using Cyclic Multiple Data Recordings, the regular recording of an entire series of measured
values can be conveniently implemented even for larger wind park projects. The subsequent output
of the results in csv. format requires little more than clicking a button.

Single Data Recordings (previous section) are also used to log data, however, they require a se-
parate recording being defined for each reading point (e.g., wind speed, temperature), and setting
up CMDRs for larger projects, collecting the results and presenting them in a structured csv. file
would be very time-consuming.

In the Cyclic Multi Log window, on the other hand, the focus is on the measuring interval and mea-
suring conditions:

· You first set up a recording (e.g. data from WTG x) with a timer* (e.g., every 10 minutes).

· If required, you can assign measuring conditions, e.g. a time period (e.g., only record from sun-
set to sunrise).

· You can then assign several reading points to each of these WT records.

· In addition, the .csv export file can be predefined (e.g. file name and column headers).

*Interval timers are predefined in a separate window, see section Interval Timer window .

If, for example, in a project of 40 WTGs, four reading points are to be recorded for each of these
WTGs, this requirement could be met by defining just 40 CMDRs instead of 4x40 = 160 single data
recordings. 

CMDRs in the overall process 

Once you transfer a project that contains one or more CMDRs to the SMU, the SMU will the record
defined reading points in the specified time grid. Each measurement is logged as an event in a se-
parate number range of the special shutdown log. These results, like all other events, could be

25
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filtered and presented in tabular form. However, to take advantage of the CMDR functionality, we
recommend using the export function. The overall process is as follows: 

1. Define CMDRs (Switching & Measurement > Cyclic Multi Data Recordings)

2. Save settings and send project to SMU (Project > Configuration)

3. Events are logged by the SMU

4. Download log files from SMU (Logs > Log files SMU)

5. Under Logs > Local Log Files select project and date range and click on Export

6. In the Export Cyclic Multi Log window, make last settings for the export and start the export.

The following is an example of the Cyclic Multi Log window with explanations.

Cyclic Multi Log

In the example window shown above, the task was to record the measured values "wind speed",
"rotor speed", and "temperature" for WTG 1–3 of the project every 10 minutes from sunrise to sun-
set. The following was defined for this purpose:
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· green level: three multiple recordings (one per WTG), the name of the recording is supplemen-
ted by the respective timer. Timers are defined beforehand in a separate window, see section
Interval Timer window .

· red level – User-defined reading points: three user-defined reading points per WTG 

· red level – Conditions: 1 condition block with just 1 condition (record from sunrise until sunset)

· The project on which the above example is based comprises 40 WTGs. The desired four rea-
ding points can be defined with just 40 CMDRs instead of 120 single data recordings.

In the following you will find further explanations on the Cyclic Multi Log window.

The structure and operation of the vertically divided Cyclic Multi Data Recording window
essentially corresponds to the Special Shutdowns window. If you are not familiar with the latter,
please start by reading the sections Vertically divided windows  and Special Shutdowns
window . 

In the following, only those fields or properties are explained that are not self-explanatory or do not
apply to vertically divided windows in general.

When creating a new recording (green level), you need to fill in the Filename field in the
CSV Settings section (see above screenshot). Please note the following:

· conventions for Windows file names must be observed (certain characters and names, e.g. " : ;
'< > as well as LPT0, COM0 etc. are not allowed), otherwise the field is highlighted in red

· all .csv files of all CMDRs will later be output to the same folder – therefore the file names must
be unique so that they won’t each other; file names are not case-insensitive, 
i.e., filename = fileName Filename = fileName Filename = fileName

Also when adding the reading points under User defined reading points (light gray layer), you will
come across the CSV Settings area, which, depending on the type of reading point, will look
like  one of the following examples:

Cyclic Multi Data window (sections thereof)

265
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The information, options or buttons are described in the following table

Box Explanation/function

Column header* In order to recognize later in the .csv file which value was recor-
ded, column headers (captions) can be assigned. When adding a
reading point, the name of the reading point is suggested together
with the name and number of the source (e.g., sensor, WTG,
etc.).

NOTE: If a WTG or a sensor is assigned a new number, then all
shutdowns, shutdown conditions, recordings etc. affected by the
change are automatically adjusted. However, this does NOT apply
to column captions – these must be adjusted manually.

Preset by measuring point names, freely editable

Attach unit*/** Here you determine whether the unit (if applicable) is added to the
column header.

Decimal places** For floating point values, you specify here the number of decimal
places the values will have in .csv file.

Text for Boolean true**

Text for Boolean untrue**

Boolean values default to "0" and "1". You can replace this, e.g.,
with "fail/OK" or "light/shadow".

* Can be edited in the Export Cyclic Multi Log window, see Export Cyclic Multi Log window .

**Can be pre-defined int ehApplication Settings (seeApplication Settings window, Csv-Export, Cycl. Multi Data Recordings. ) but this only affects new reading points,
already defined reading points keep the original settings.

Please be very careful when entering values in SM4. Incorrect parameter values may
result in avoidable wear and tear, loss of earnings, problems with authorities or resi-
dents, and, in the worst-case, force operators to decommission WTGs.

See also Practical example 8: Regular recording of several measured values

360
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4.4.10 Interval timer window

Purpose Define intervals, e.g., for the Cyclical Multi Data window.

Path Switching & Measurement > Interval Timer 

Type of use Display + interactive

Reference Entire project

In this window, you can define intervals that can subsequently be selected as timers in other
windows, e.g., in the Cyclic Multi Log window. 

Interval Timer window

Notes on the Interval Timer window

As with any vertically split window  the datasets already created are displayed on the left, in this
case interval timers, while the actual definition is done on the right. 

· Up to 5 timers can be defined

· Name field: input freely selectable 

· Interval field: The interval you enter here must fit “smoothly” into a period of 24 hours. Ergo, in-
tervals such as “7” or “13” are not permissible and therefore cannot be entered (the input field is
not green, but has a reddish background). The number of times the value you enter or select
with the arrow keys will fit into 24 hours is displayed below the input field. If you select the value
using the arrow keys, only permissible values are offered.

· Longest possible interval: 1 interval a day

25
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4.4.11 Condition Flags window

Purpose Define condition flags for special or night slice shutdowns that can be activa-
ted (set) by one set of conditions and cleared (reset) by another

Path Switching & Measurement > Calculations

Window type Divided vertically, see Vertically divided windows

(basic operation similar to the Special Shutdowns window)

Type of use left part: display only; right part: interactive

Reference can be used in special and night slice shutdowns

In connection with special and night slice shutdowns, it may be necessary or useful to treat a
condition defined as a shutdown criterion (e.g., no precipitation present) as "not fulfilled" for a longer
time than measured by the respective climate sensor. 

A typical situation would be a regulation in the area of bat protection according to which a WTG
doesn’t have to be switched off for the rest of the night as soon as it rains, i.e., not even if it stops
raining in the same night.

In order to reflect a scenario of this type, special or night slice shutdowns must be supplemented
with so-called condition flags, which can be set by one set of conditions and cleared again by ano-
ther, see also Example 7: Supplement a bat shutdown with condition flags .

Condition flags can only influence the shutdown/startup of WTGs if they are referenced
in special or night slice shutdowns. Otherwise, they take no effect.

The structure and operation of the vertically divided Condition Flags window essentially
corresponds to the Special Shutdowns window. If you are not familiar with the latter, please start
by reading the sections Vertically divided windows  and Special Shutdowns window . 

Please be very careful when entering values in SM4. Incorrect parameter values may
result in avoidable wear and tear, loss of earnings, problems with authorities or resi-
dents, and, in the worst-case, force operators to decommission WTGs.

The Condition Flags window is described in detail in the following.

25
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Condition Flags window

Explanation of the above Condition Flags example window

On the left side of the screen a condition flag (Night-time rain in May) is displayed, including its
Set and Reset conditions (red layer). As is usual with vertically split windows, it was defined in the
right half of the window. The following applies to the value of a flag: 

Set condition(s) fulfilled = 1, Reset condition(s) fulfilled = 0

A flag is therefore set (i.e., 1 is returned) if the Set conditions are true. It remains set even if the
Set conditions no longer apply. In the example above, the flag is set as soon as precipitation is
measured. If it stops raining again, the flag will remain set.

A flag is cleared (i.e., 0 is returned) if the Reset conditions apply. Once the Reset conditions no lon-
ger apply, the Set conditions take over. In the example above, the flag can only be effective in the
month of May and even then, only during the night.

On the following, the above example of Night rain in May is also used to describe how condition
flags are used in special or night slice shutdowns.
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Special Shutdowns window with condition flag

Explanation of the above Special Shutdowns example window

The Night rain in May condition flag can be defined as a reading for special shutdowns provided
that the Condition flag option was selected as the Source.

In the above example, the WTG should "normally" be shut down as soon as it is warmer than 10 de-
grees and the wind is blowing at less than 6 m/s. The condition flag is used to ensure that the
system is not shut down if these two conditions are met while at the same time it is raining or has
rained.

The first two shutdown conditions (wind speed and external temperature) are overridden as soon as
the condition flag (the third shutdown condition) is activated because the result is 1. In this case, the
condition "Condition flag Night rain in May equals 0" is no longer fulfilled and a shutdown is therefore
no longer possible, since the shutdown conditions within one condition block are connected to each
other by a logical AND. The block (the shutdown) therefore only takes effect if ALL conditions are
fulfilled. For the above example, this means in other words: As long as it does not rain during May
nights, the other two shutdown conditions can cause the WTG to be shut down. Once it starts rai-
ning so that the condition flag is set, wind and temperature become irrelevant and remain so for the
rest of the night: 

· As a reminder: The following rules apply to conditions flags with regard to Set and Reset:
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· A flag is set (i.e. it returns 1) if the Set conditions apply. 
It remains set, even if the Set conditions no longer apply. 
In the above example, the fact that it is raining sets the flag. It remains set even when it has
stopped raining.

· A flag is cleared (i.e. it returns 0) if the Reset conditions apply. 
Once the Reset conditions no longer apply, the Set conditions take over.

In the example above, the flag is reset when the current date is before or after May or the sun has
risen. Whether it rains or not is not relevant anymore. If the Reset condition is not met anymore, i.e.
a May night begins, then the precipitation condition takes effect. This means here in particular that if
it has already started raining before the night begins, the flag is set immediately as soon as the
night begins.

Condition flags can only influence the shutdown/startup of WTGs if they are referenced
in special or night slice shutdowns. Otherwise, they take no effect.

Concluding general notes on condition flags

· As already mentioned, condition flags can only be used in special and night slice shutdowns, but
not in single data recordings (measurement data logging). 

· Furthermore, they cannot be used as reading points in events of the special shutdown log. They
can therefore neither be added by the user nor can they be automatically taken over as
condition reading points from special and night slice shutdowns.

· Condition flags trigger an event when they are set or reset 
(see Events window ).

Please be very careful when entering values in SM4. Incorrect parameter values may
result in avoidable wear and tear, loss of earnings, problems with authorities or resi-
dents, and, in the worst-case, force operators to decommission WTGs.

280
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4.4.12 Reading Point Switches window

Purpose Set up automatic switching between two reading points (e.g. to increase the
reliability of sensors)

Path Switching & Measurement > Reading Point Switches 

Type of use Display + interactive

Reference Entire project

In this window you can, for example, set up automatic switching between the reading points of two
sensors. If one of the two sensors fails, the second sensor supplies the required measured values in
its place. The reading point switch acts as an "independent" sensor and can be used like one, e.g. in
special shutdowns. This improved fail-safety could also be set up directly in the special shutdowns
window, but only with considerably more work. 

The structure and operation of the vertically divided Reading Point Switches window essentially
corresponds to the Special Shutdowns window. If you are not familiar with the latter, please start
by reading the sections Vertically divided windows  and Special Shutdowns window . 

Reading Point Switches window

Notes on the above example for reading point switches 

· On the right side, a name for the changeover switch has been entered (failproof external tempe-
rature), optionally a unit could be added.

· The function of the changeover switch can be seen on the left: Its (only) condition is to be consi-
dered true if Communication OK has the value 1, i.e. is "OK". If this is the case, the changeo-
ver switch supplies the temperature measured by sensor 1. Only if this condition does not
apply, the value of sensor 2 is passed on.

25 205
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· The same options are available in the Source drop-down list for Conditions, Conditions apply
and Conditions do not apply as in the windows Special Shutdowns, Night Shutdowns, etc.
window, so the possiblities are rather endless.

On the next page you will find an example of setting up a "fail-safe external temperature", once with
measuring point changeover switch, once without.

Special Shutdowns window (WTG 1 with reading point switches, WTG2 without)



272Reference part > Switching & Measurement menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

Notes on the above example 

· Here you can see that the setup effort for WTG 2 without reading point switches was signifi-
cantly higher than that for WTG 1 with reading point switches. The savings in effort also apply
to maintenance, of course.

· Reading point switches are also particularly useful for night slice shutdowns, where the night is
divided into 10 or more slices and separate condition blocks and conditions have to be defined
for each slice. 

Since no separate events are logged for reading point switches, you will find more information on
this topic on the next page.

Output values of reading point switches in the log (events)

Reading point switches don’t trigger any events. Their output value as well as the measured values
in their switchover conditions that have led to an output value are not logged automatically. Since
these values are nevertheless interesting, especially if they have contributed to a special shutdown,
for example, the measured values of reading point switches to be logged are included in the event
record of the corresponding special shutdown, as can be seen in the following example.

Events window (using the example of WTG 1 "Anna")



273Reference part > Switching & Measurement menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

Notes on the above example window Events

· Under the event "WTG special shutdown bat protection" of WTG 1, you can see that the first
entry under Condition reading points” is the output value of the reading point switch; this is the
normal entry for the shutdown condition of the special shutdown itself. 

· In addition, the communication status of thermo sensor 1 is displayed there, and this originates
from the switching condition of the reading point switch. Thus, if a special shutdown occurs, all re-
levant values are logged with the event "WTG special shutdown".
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4.4.13 Calculations window

Purpose Define automatic calculation of certain values to use them in shutdown
conditions of Special Shutdowns and Night Slice Shutdowns, Single Data
Recordings or as user-defined reading points in the Special Shutdown Log,
etc.

Path Switching & Measurement > Calculations 

Type of use Display + interactive

Reference Entire project

Use this window to define the automatic calculation of certain values, such as

· the average of a measured value over a certain period of time or

· the average park wind speed from the wind speeds of all WTGs, 

and then use them as measured values of a sensor for shutdown conditions of Special Shutdowns
and Night Slice Shutdowns, Single Data Recordings, etc. 

Calculations window
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The Calculations window is divided into the following four areas:

A Edit area – here you can enter the syntax for the calculation and additional comments if
desired. 

B Messages (display only) – calculations must comply with a certain syntax. On the one hand,
errors that you may have made in the input area are reported here, and on the other, the
system displays which entry it expects next.

C Calculations (selection only) – any calculations that have already been defined are listed here
and can be selected in order to Delete an existing calculation, Apply changes or Add a new
one.

D Properties

· here, a calculation is given a name and optionally a unit. The calculation can then be refe-
renced under this name, for example in a shutdown condition. 

· In Shutdown Conditions treat as: Here you can define the way the result of a calculation
is to be checked in a shutdown condition. If you select Wind speed here, then, in the
windows Special Shutdowns or Night Slice Shutdowns, every shutdown condition that
uses the current calculation will be checked according to the plausibility rules for wind
speed. The "neutral" option would be Not meteorological – shutdown conditions with a
calculation marked this way are not checked for plausibility. See also Plausibility check .

You will find an overview of the Calculationswindow in the following table

Element Explanation

Input area Here you can enter the actual calculation function; the following are current-
ly possible:

· Minimum/Maximum (e.g., maximum value of wind speeds measured
by 2 or more sensors)

· Mean value (e.g., average value of the intensity of illumination measu-
red by a sensor over a period of 1–60 minutes)

· Rolling mean value (e.g., repeated calculation of the average value of
the intensity of illumination measured by a sensor over a period of 1–60
minutes)

· "Fail-safe" mean value (e.g., average park wind speed from values of
2 or more sensors whose failure can be detected, and definition of a
default value that will be used as a functional result in the event that all
sensors have failed).

The calculations have to comply with a certain syntax, which is explained in
a separate section, seeSyntax for the input area in the Calculations
window

The names of the reading points of sensors must be entered exactly (even
one additional or missing space makes them unrecognizable for SM4), but if
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you click on Readings, you can easily select one or more of the reading
points available in the project in the following window:

You can filter the list of readings by making an entry in the Search text
field. This field defaults to the word at which the cursor was positioned in
the input area of the Calculations window. This word will be replaced there
as soon as you close the Reading point selection window by clicking Ok. 

In the list of reading points, several entries can be marked simultaneously
and applied to the input area of the calculations window. Before applying
them, you can specify a separator to be inserted between the individual
entries in the Multiple selection field and also specify that a line break be
inserted between the entries. 

Calculations Any calculations that have already been defined are listed here and can be
selected in order to Apply changes to an existing calculation or Add a new
one.

Serves to add a new calculation and is only active if a name has been ente-
red for that calculation that does not yet exist in the list in the top right-hand
corner of the window.

Is used to edit an existing calculation and is only active if a calculation has
been selected in the list and something has been changed.

Changes will only be applied if you confirm them by clicking on Apply.
Otherwise, the changes will be discarded as soon as you select a different
calculation or close the window.

Name Unique name of the calculation, no requirements.

Unit Here you can define the unit for the result of a calculation. This text is used,
for example, for shutdown conditions.
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4.4.13.1 Syntax for the input area in the Calculations window

The input of a function must correspond to a certain definition language and syntax. Both will be ex-
plained in this section. 

General notes

· The keyword "return” serves to return the result of the calculation.

· The parameters are entered in round brackets, the reading points in square brackets, the end is
indicated by a semicolon, example:

return max ([reading 1], [reading 2]);

· The keywords of the definition language are in English – even if SM4 is set to German, "return"
remains English. However, names of reading points are language dependent and are switched
accordingly.

· The input area works much the same way as a standard text editor. You can mark, copy, dele-
te, paste, etc. and also undo actions with Ct r l +z .  

· Comments on the calculation can be entered in the input area. They start with two slashes and
apply to the rest of the line, example:

// Maximum wind speed 
return max ([reading 1], [reading 2]);
 
Other than that, line breaks have no effect. You can write everything in one line or insert breaks
as you wish. The text can also be further formatted with spaces. 

On the following pages you will find information on the syntax and further explanations of the indivi-
dual calculation functions.
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4.4.13.1.1 Calculation function “Minimum/Maximum” 

Explanation: This function returns the highest/lowest value from the series of the specified mea-
surements. 

Syntax: min ([reading1], [reading2], ... [reading99]) 

max ([reading1], [reading2], ... [reading99]) 

Reading: any reading of a sensor 

reading1…99

at least 2 reading points 

Example: Maximum value of wind speed values measured by 3 sensors:

4.4.13.1.2 Calculation function “Mean value” 

Explanation: Within the time period, values of the reading point are recorded on a regular basis.
Once the time period has elapsed, the mean value is determined from the recor-
ded values. 

This function returns a new value for each time period.

Syntax: mean ([reading1], time period)

Reading: any reading of a sensor 

Time period: Time period in minutes over which the values of a reading point are averaged. 

Value range: 1–60 minutes

Example: Mean value of the intensity of illumination measured by a sensor over a period of
30 minutes
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4.4.13.1.3 Calculation function “Rolling mean value” 

Explanation Values of the reading point are recorded on a regular basis. After each measured
value recording, a new mean value is calculated from the latest measured values
that were recorded during the specified period of time. 

This function returns a new value for each measured value recording. 

Syntax: fmean ([reading1], time period)

Reading: any reading of a sensor 

Time period: Time period in minutes over which the values of a reading point are averaged. 

Value range: 1–60 minutes

Example: Repeated calculation of the mean value of the intensity of illumination measured by
a sensor over a period of 30 minutes

4.4.13.1.4 Calculation function “Fail-safe mean value” 

Explanation This function calculates the sum of the values of the specified reading points and divi-
des the result by the number of reading points. If a sensor fails, its measured value is
set to 0 and the number of reading points is reduced by 1. If all sensors fail, the
default value is returned. 

Syntax: xmean (default, [reading1], [reading2], [reading3], .. [reading99])

Reading: reading1…99

Reading of a sensor whose failure can be detected 

at least 2 reading points 

Example: An average park wind speed is to be determined from the wind speeds of all three
WTGs. For this purpose, these reading points are entered as parameters for the
xmean function. If the communication to one (or more) WTGs fails, the average park
wind speed is only determined from the remaining WTGs and is thus distorted as little
as possible. If the communication to all sensors fails, the result of the function is 10.
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4.4.14 Events window

Purpose
· Display the reading points (measured values) that are automatically log-

ged for a shutdown event

· Add your own (user-defined) reading points

Symbol

Path Switching & Measurement > Events 

Window type Divided vertically, see Vertically divided windows
(basic operation like the Special Shutdowns window)

Type of use left part: only display

right part: interactive regarding user defined reading points

Reference Project

The SMU writes events such as “WTG stop due to special shutdown", “Start of a night slice" or
“Sunrise" into a log that can be downloaded in SM4. However, the will only be useful if it also re-
cords values that were measured at the time of an event, for example wind speed, humidity, etc.
Some reading points are automatically recorded by the SMU and cannot be deleted or changed in
the window described here. Others can be added by the user as desired, because often different
reading points are relevant for each project.

The following reading points are available:

Default reading points
These reading points are permanently stored in SM4 and cannot be changed or deleted by the user.
This ensures that the most important reading points are always recorded in the log.

Condition reading points
These reading points were used when defining shutdown conditions and can only be edited there.
With the help of condition reading points, the log can show why a WTG was switched off at a cer-
tain time, e.g., because the hygro-thermo sensor exceeded a certain temperature. This makes
much more sense if there are several conditions: the log will then also reveal which of conditions led
to the stop (e.g., temperature or humidity or wind speed). 

User-defined reading points
The user can add these reading points as required. User-defined calculations (Switching & Measu-
rement > Calculations) can serve as a reading here. Reading points that are already included in the
default or condition reading points cannot be added again. 

The structure and operation of the vertically divided Events window essentially corresponds to the
Special Shutdowns window. If you are not familiar with the latter, please start by reading the secti-
ons Vertically divided windows  and Special Shutdowns window .

For more information about the Events window, see the following pages.

25
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Events window (example)

Notes regarding the Events window: 

· At the first level (green level) there are 9 logical groups of areas in which events can occur. 

· The groups of the first level each have a different number of subordinate levels.

· In the example window above, only the Events of shadow impact module level is expanded;
its first sub-level contains 5 possible events (red level). As a second subordinate level, there is
only the User-defined reading points level (gray level).

· In the above example, the reading point Daily counter of POI 1 was added to the events Sun-
rise and Sunset and would therefore be written into the special shutdowns log. Because
nothing was defined for the event Error, a possible error would be logged here without further
measured values.

· As is usual with vertically divided windows, the left part is a read-only area while the user-defi-
ned values are set in the right part of the window. There you can select from the set of reading
points of WTGs, sensors etc. available in the project.

· The currently activated level is highlighted in blue and can be edited in the right part of the
window, provided it is of a type that can be edited.

The following screenshots show examples of all logical groups on the first level, each of them follo-
wed by a short explanation
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Events Special Shutdowns

Screenshot on the left

· In addition to a green, red and gray level, this group also has a purple level, which classifies
events according to the reason for shutdown.

· There are just 2 events for each shutdown (red level).

Screenshot on the right

· Shutdown reasons are defined in the condition blocks of the Special Shutdowns window.

· Shutdown reasons that have been defined several times (WTG3, condition blocks 1 and 6) are
summarized in the Events window. Therefore, the left picture, under WTG 3 “Charlotte”, shows
5 instead of 6 reasons for shutdown.
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Events speed reductions  

Screenshot on the left

· In addition to the green, red and gray levels, this group, too, also has a purple level, which classi-
fies events according to the switch reason.

· There are only 2 events per speed reduction (red level).

Screenshot on the right

· Switch reasons are defined in the WTG Speed Reduction window in the condition blocks.

· Switch reasons that have been assigned more than once (e.g. WTG 6: bird protection x 2) are
summarized in the Events window. Therefore, only 1 bird protection level (purple) can be seen in
the left-hand screen under WTG 6.



284Reference part > Switching & Measurement menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

Events Night Slice Shutdowns

Screenshot on the left

· In the left picture you can see that only WTG 1 has a night slice shutdown (yellow level). If night
slice shutdowns had been defined for other WTGs in the project as well, these would also be
displayed here.

· There are 3 events for each shutdown (red level)

· On the reading points level, there are also the Condition reading points. The reading points that
were used when defining shutdown conditions are automatically listed here. With the help of
Condition reading points, the log can show why a WTG was shut down at a certain time, e.g.
because reading reported by the hygro-thermo sensor exceeded a certain temperature. This
makes much more sense if there are several conditions: the log will then also reveal which of
conditions led to the stop (e.g. temperature or humidity or wind speed).

Screenshot on the right

· Here you can see that for WTG 1 a night slice shutdown with a shutdown condition regarding
the external temperature was defined. This is reflected in the Events window.
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Events On-Demand Shadow Shutdowns

Screenshot on the left

· Each POI, for which an OSS has been defined (Switching & Measurement > On-Demand
Shadow Shutdowns), has only one possible event (red level).

· For each event, the POI number is recorded as the only Default reading point. 

· The conditions defined at the respective OSS are entered as Condition reading points. 

· Additionally, you can define User-defined reading points.

Screenshot on the right

· Here you can see that an external trigger has been referenced in the On-Demand Shadow
Shutdowns window. This is listed in the Events window as a Condition reading point.
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Events Switching of Digital Outputs

Screenshot on the left

· Digital outputs trigger an event when they are set.

· There is only one possible event for each digital output (red level).

· Default reading points (here only the number of the respective digital output) are fixed elements
in SM4 and can neither be changed nor deleted by the user. This ensures that the most import-
ant reading points are always recorded in the log.

· On the reading points level there are Condition reading points in addition to Default and Conditi-
on reading points. Here, the reading points that were used when creating shutdown conditions
are recorded automatically. With the aid of Condition reading points, it is possible to identify in
the log as to why a digital output was set at a certain time, e.g. because the hygro-thermo
sensor exceeded a certain temperature. This makes more sense if there are several conditions,
because the log then also shows which of them led to the DO being set (e.g. temperature or hu-
midity or wind force).

Screenshot on the right

· Here you can see that a condition created for setting such an output has been set in the
Switching of Digital Outputs window. This condition is listed in the Events window as a Con-
dition reading point.
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Events of Wind Turbine Generators

· Each WTG can trigger 9 different events (red level) (only 2 of them are visible in the screens-
hot).

· The number of default reading points (gray level, 6 per event) is also higher than in the case of
the sensors.

· In order to limit the number of reading points logged for an event, only those reading points that
are not yet included in the Default reading points can be added under User-defined reading
points. Example: If you would try to add the reading point Wind speed of WTG 1 in the
settings area on the right side of the window, the Add button would remain inactive. This princi-
ple applies to all events.

Events of Sensors

· There are only 2 possible events for each sensor (red level)

· Default reading points (for sensors only Sensor no) are fixed elements in SM4 and cannot be
changed or deleted by the user. This ensures that the most important reading points are always
recorded in the log.
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Events of Condition Flags

Screenshot on the left

· Condition flags trigger an event when they are set or reset 

· The reading points entered here are the Condition reading points of the set or reset conditions
of the flag.

· The user can also add additional reading points from other sensors. 

· There are no Default reading points here.

Screenshot on the right

· Here you can see that in the Condition Flags window, the "Intensity of climate sensor 1"
condition has been created for setting the condition flag "Night rain in May". This is reflected in
the Events window as a Condition reading point.

Events External Triggers
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· For each trigger there is only 1 possible event (red level).

· There are neither Default reading points nor Condition reading points. 

· Instead, you can "freely" define a wide variety of reading points under User-defined reading
points.

Events Shadow Impact Module

· There are 5 possible events in the Events Shadow Impact Module group (red level).

· There are neither Default reading points, nor Condition readings points. 

· Instead, you can "freely" define a wide variety of reading points under User-defined reading
points.

NOTE

The maximum number of reading points per event is 27. This number consists of 7 default reading
points for night slice shutdowns and 20 additional possibilities for reading points from conditions, as
well as user-defined reading points. 
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4.4.15 Other Emails window

Purpose Define emails to be triggered by conditions

Path Switching & Measurement > Email

Type of use Display + interactive

Reference Entire project

This window allows you to define email messages that are sent automatically depending on certain
conditions, for example, when the power of a WTG falls below a certain value.

The structure and operation of the vertically divided Other Emails window essentially corresponds
to the Special Shutdowns window. If you are not familiar with the latter, please start by reading
the sections Vertically divided windows  and Special Shutdowns window

 

Other Emails window

Explanation of the above example window:

· As you see in the upper right corner, 2 out of 100 possible other emails have been defined so
far.

· green level: On the green level you set up the email yourself. 200 characters are possible.

· yellow level: Here you set up one or more condition blocks (logical OR operation).

· gray level: Here you set up one or more conditions (logical AND operation) that must be fulfilled
in order for the corresponding e-mail to be sent. 

· In the above example, email 1 is sent if the condition Lightning = 1 is fulfilled at digital input 1.

· Email 2 is only sent if less than 500 kW power is generated at WTG 1 while more than 6m/s
wind speed is measured at the same time. In order to cause email 2 to be sent when only one
of these conditions is fulfilled, they would have to be created in different condition blocks.

25 205
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· At the bottom right, you can see that 45 of the possible 200 characters have been used for
email 1.

· Please also pay attention to the following note…

NOTE

The intended recipients of the emails defined in this window must be defined in the Project Settings
window (Project > Project Settings > Email recipient settings) and activated in the Other box, see
the following screenshot:

Project Settings window (section thereof), recipients of other e-mails activated
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SMU menu4.5

The following table provides you with an overview of the SMU menu. 

Menu item Purpose

SMU Information  Check the availability of the SMU

Alarms Display and acknowledge currently active alarms, carry out test
alarms

Phone option Set GSM modems for the use of the telephone option (Places of
Immission window)

User Management

Shadow Manager
Interface

Store individually defined users with corresponding right groups in
the SMU

Special Shutdown-
Interface

Create/edit/remove user for special shutdown interface und Assign
trigger numbers to users

Time

Set time manually Manually set the time and date of the SMU

Check time deviation Check the time of the SMU manually

Tools

SMU Update... Update SMU software from an external location

SMU Ping Check whether the target of the network connection can be rea-
ched (via direct connection to the SMU)

Click on a menu item to jump directly to more information.
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4.5.1 SMU Information window

Purpose SMU Information window 

Path SMU > SMU Information 

Right group Viewer

Prerequisites Online connection to SMU, dongle

Type of use Display+ Dialog

Reference Project

This window shows almost the same information as the connectivity window (Tools -> SMU
Connectivity), but here the information is provided via a different channel, namely via the direct
connection between SM4 and the SMU. The connectivity window, on the other hand, obtains the in-
formation via the SMU website; access to this may be blocked by the park operator for security re-
asons. If the website is not accessible, you can use the window described here to display the
required information. 

SMU Information window

You will find a detailed description of this window in the following table
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Element Explanation

Serial No. Serial number of the SMU

Location Location of the SMU according to the Project Data window

Version Version of the SMU

Alarms If alarms are present, their number is displayed here

Coordinates Coordinates of the location of the SMU according to Project data window

UTC time Current UTC time

Connection One of the following connection states is displayed here:

Connected Connection to SMU has been established

Disconnected Connection to SMU was disconnected

preparing... Connection to SMU is being established

SMU Status One of the following SMU conditions will be displayed here:

--- Status cannot be determined, e.g., because SMU cannot be
reached

Operational The SMU is ready for operation, an existing shadow project
is being processed

preparing… The SMU is started, e.g., after an update 

Stop The SMU shuts down, e.g., before an update

Clicking here opens the Application Settings window, Live data section,
where you can specify the intervals at which live data windows should be up-
dated.

Closes the window. 
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4.5.2 Alarms window

Purpose Display and acknowledge currently active alarms, carry out test alarms

Path SMU > Alarms 

Right group Alarms, Viewer (acknowledge and test alarm not possible as a viewer)

Prerequisites
Online connection to the SMU – acknowledging alarms and initiating test
alarms only with dongle

Type of use Display + interactive

Reference Project

If you have established an online connection to an SMU (File > Connect), you can display currently
active alarms here. Alarms right group users can also acknowledge alarms and initiate test alarms.

It is  essential to check what consequences the respective alarm will have for the SMU
prior to initiating a test (e.g., stop command to the WTG).

Alarms window

The information, options or buttons are described in the following table
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Element Explanation

Last response from the Shadow
Impact module [system time]

SM4 received its last response from the SMU at the date and time
displayed here.

Note Depending on the status of the live data shown in the list below,
the following can be displayed here:

Project loaded The project file of the shadow impact sce-
nario running on the SMU is has been
downloaded.

No project found A shadow impact scenario could not be
found on the SMU.

Loading project… The project file of the shadow impact sce-
nario running on the SMU is being down-
loaded.

Ser. No. Consecutive number of the alarm

Alarm Number Fixed number of the respective type of alarm

Alarm Text A self-explanatory term is displayed for the respective alarm in this
column. 

NOTE

Please get in contact with us every time a fatal alarm occurs. The
alarm text of fatal alarms always contains the request “Please
contact NorthTec”. 

Example:

SWMP01MainStartOpLog internal alarm: Please contact
NorthTec 

A test alarm can only be initiated by a user who is assigned the
Alarms right group. Triggering a test alarm may be necessary,
e.g., to check that the alarm message is being correctly sent by
email. 

NOTE

It is essential to check what consequences the respective alarm
will have for the SMU prior to initiating a test (e.g., stop command
to the WTG).

An alarm can only be committed if the reason no longer exists.
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4.5.3 Phone Option window

Purpose
· Get information about the modem and the signal quality

· Set GSM modems for the use of the telephone option (Places of
Immission window and Special Shutdowns window)

Path SMU > Phone option

Right group Viewer

Prerequisites
· Online connection to the SMU

· SMU version V4.2.34 or later

· Use GSM modem (RS232) must be selected under Project
Settings > SMU > Additional hardware

Type of use Display + interactive

Reference Entire project

In this window you make the settings of the GSM modem, which is required for the Phone Option
functionality – the Phone Option is used to switch off WTGs by calling a specific phone number
(Project > Places of Immission > Phone option, for further information see Phone Option sub
window ). 143
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Phone option window

The information, options or buttons are described in the following table

Element Explanation

Top part of the window

Modem information – This information is read out from the modem (display only).

Signal power Optical interpretation of the signal quality displayed at Signal RSSI

Signal RSSI Display of signal quality in dBm

Manufacturer, Model, Firmware Fixed data of the modem

Registration Indicates whether the modem has dialed into the network of the
mobile network operator or respectively the current status of the di-
al-in.

PIN State Indicates whether the card is ready for use or if a PIN (or PUK)
must be entered for that card.
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Element Explanation

READY: no action required

SIM PIN: PIN must be entered

SIM PUK: PUK must be entered. In addition, the new PIN must be
specified.

Middle part of the window

PIN: Send PIN

PUK: Send PIN and PUK

Here you can enter the PIN and PUK of the phone card inserted in
the modem.

· If you click on an eye , the PIN or PUK will displayed/hidden.

Reset modem To temporarily disconnect the modem from the power supply (via
relay) using this button in order to reset the modem, a check mark
must be set at Use “Modem reset” (Project > Project Settings >
Monitoring). The corresponding digital output (DO) must also be
assigned.

Bottom part of the window

Places of Immission Calls to the POIs are reset daily at 00:00 by the SMU.

Special Shutdowns For special shutdowns, the time of the reset and the reaction to a
further call can be defined. This setting is made when defining the
special shutdown. 
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4.5.4 Shadow Manager Interface Management window

Purpose Store individually defined users with corresponding right groups in the SMU

Path SMU > Shadow Manager Interface

Right group User Management

Prerequisites Online connection to the SMU

Type of use Display + interactive

Reference Entire project

If you have established an online connection to an SMU (File > Connect), you can add individually
defined users and assign them specific right groups in addition to the users admin and northtec,
which are included as default at delivery. 

Shadow Manager Interface User Management Window

The information, options or buttons are described in the following table

Element/area Explanation

User Currently available users are displayed in the left third of the window.
If you select a user, you can see which right groups they are assigned
on the right-hand side. 

The users admin and northtec are default users that are available
upon delivery. You can delete these after you have assigned the User
management group a new user if you do not want anyone else to
have access.
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Element/area Explanation

NOTE

If you delete the two default users before you assign a new user or
the access data for the newly assigned user gets lost, it is no longer
possible to connect to the system!  

Deletes a user selected in the list.

While an online connection to the SMU is being established, the rights
of the logged-in user are checked for changes. If it is determined that
something has changed, the following dialog is displayed:

“Your user rights must be updated in the SMU User Management
window. If you do not have access to the SMU User Management,
please contact the administrator.”

In this case, click Adjust rights to trigger the update. 

NOTE

The button remains active even after clicking and after the update has
been completed. There is no dialog that confirms that the update was
completed successfully.

The button is only deactivated in the following cases:

· the SMU version is older than 4.2.18

· the connection to the SMU is established and the data have not
yet been initialized

· SM4 does not support the communication protocol version of the
SMU

User Data To create a new user, assign them a corresponding name in the midd-
le part of the window, enter the same password twice and then click
on Add. 

To change the password or the assignment of right groups to a user,
select the user on the left, carry out the desired changes and then
click on Apply.

SM4 Right Groups The SM4right groups, with self-explanatory names, are pre-defined
and cannot be changed. They can only be activated/deactivated by
placing or removing the checkmark.

If you have created a new user, deleted an existing one, or changed
the rights of an existing user, these changes do not take effect until
you click Send to SMU.

If you delete the two default users before you assign a new user or the access data for
the newly assigned user gets lost, it is no longer possible to connect to the system!
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4.5.5 Special Shutdown-Interface User Management window

Purpose
· Create/edit/remove user for special shutdown interface

· Assign trigger numbers to users

Path SMU > Special shutdown interface 

Right group Project configuration

Prerequisites Online connection to SMU, SMU version 4.2.44 or higher, external triggers

Type of use Interactive

Reference Project

If you have established an online connection to an SMU (File > Connect), you can use this window
to define users who can access the special shutdown interface.  In addition, you can assign specific
trigger numbers to defined users or revoke them (for more information, see “External triggers” in the
Glossary ).

Special Shutdown-Interface User Management window

The above window is divided into the following sections

A List of already created users (data as downloaded from the SMU or data created/edited via
this window); the current/maximum number of users is displayed on the right above the list.

B Input fields and buttons for user data 

472
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C Button for sending the current user data to SMU 

D Progress bar for receiving/ sending user data from/ to SMU 

You will find a detailed description of this window in the following table.

Element/area Explanation

User

[x/2500] x = Number of already created users of max. 2500

User List of created users (data downloaded from the SMU or created/edited in
this window). If you select a user in the list, the data of this user will be dis-
played on the right.

User Data

Name Here you enter the name of a user to be created.

1–19 ASCII characters, no spaces, must be unique

Password Here you enter or change the password of the user to be created.

1–31 ASCII characters, no spaces 

NOTE

If you leave this field blank when editing an existing user, and then click Apply,
the “old” password is retained.

From In the from and to fields, you specify the trigger numbers to which the re-
spective right shall apply.

1–2500, muss be less than or equal to 

By see above

from–2500, must be greater than or equal to from 

Deletes the user selected in the list completely.

available when 

· a user is selected in the list

· no data is being transferred between SM4 and the SMU

Confirms changed user data.

available when 

· a user is selected in the list

· valid changes have been made to an entry
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Element/area Explanation

· no data is being transferred between SM4 and the SMU

Adds newly created users.

available when 

· all entries are valid

· max. number of users not reached

· no data is being transferred between SM4 and the SMU

If you click here, the existing and changed user data will be sent to or retrie-
ved from the SMU.

A bar at the bottom of the window shows the progress.

only available if user data have been changed

Once the connection to the SMU is disconnected, the Special Shutdown-Interface User Manage-
ment window will be closed automatically.
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4.5.6 Set time manually window

Purpose Manually set the time and date of the SMU

Path SMU > Set time manually 

Prerequisites Dongle, online connection to the SMU

Type of use Interactive

Reference Project

If you have established an online connection to a SMU (File > Connect), you can manually set the
SMU time here. 

Set time manually window

Notes on the window above

· The upper third of the window displays the current time zone of the SMU and the current time of
the SMU in UTC as well as in local time.

· In the middle part there are two input fields where you can enter the date and time to be set for
the SMU. Both input fields refer to the local time of the SMU.

· If you click on PC time to local SMU time to the right of the input fields, the local PC time is re-
trieved, converted according to the local time of the SMU and written into the input fields. The
conversion is based on the time zone set in the SMU.

· If you click Set time at the bottom of the window, the date and time as shown in the input fields
will be sent to the SMU.

· During log operations (directory check and download), the time cannot be set manually. The
corresponding option in the menu is then deactivated (SMU > Set time manually).
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4.5.7 Check Time Deviation menu item

Purpose Check the time of the SMU manually

Path SMU > Check Time Deviation 

Right group Project configuration

Prerequisites Dongle, online connection to the SMU

Type of use Interactive

Reference Project

When you select the Check Time Deviation menu item, the system will check whether the time of
the SMU (UTC) is different from the time of the computer (UTC). The deviation tolerance can be de-
fined in the Application Settings (File > Application Settings > Warning limits > SMU time > Allo-
wed deviation). You can set values from one minute to one year (all values in minutes). 

After you have selected the menu item, it may take a few seconds until the result is displayed, de-
pending on the load of the SMU.

If the deviation determined during automatic check exceeds the permitted value, the following
window opens:

 Warning: A time deviation was recognized window

If the deviation determined during automatic check does not exceed the permitted value, the
following window opens:
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 Warning: A time deviation was recognized window

Notes on the above windows

· The windows display the current time zone of the SMU, the time of the SMU (UTC) and the time
of the computer (UTC). The permitted deviation is also displayed.

· If you click on the gear symbol, you are taken directly to the Allowed deviation setting.

· The button Set time manually only appears if a dongle is connected. Clicking this button takes
you directly to the Set time manually window.

· While logs are being downloaded from the SMU, this function and the Set time manually functi-
on are not available.

· When you establish a connection to the SMU, the system carries out an Automatic check of the
SMU time .61
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4.5.8 SMU Update window

Purpose Update SMU software from an external location

Path SMU > SMU Update 

Right group SMU update

Prerequisites Online connection to the SMU

Type of use Interactive

Reference Project

If you have established an online connection to a SMU (File > Connect), you can update its softwa-
re. 

SMU Update window

Notes on the window above

· To perform an update, click on the folder symbol at the bottom right and select the path for the
update and the update itself.

· If you set a checkmark at Open connectivity window after update, you can identify in the
Connectivity window whether, after carrying out an update, the SMU has reconnected and is
ready for operation. This helps you avoid unsuccessful attempts to connect to the SMU.

· Once you have clicked on Start Update, the bar at the top will display the update progress.

· Please do not remove the dongle while the update is running, as this could cause the software
to not function properly.
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4.5.9 SMU Ping window

Purpose Check whether the target of the network connection can be reached (via di-
rect connection to the SMU)

Path SMU > SMU Ping 

Prerequisites Dongle, online connection to SMU, SMU offers ping possibility

Type of use Interactive

Reference Project

If you have established an online connection to an SMU (File > Connect), you can check in this
window whether the target of the network connection to be set up or already set up can be reached
in principle. This function is usually only used when setting up a network connection or in the event of
problems with the same, but not in normal operation. 

When "pinging", a specific data packet is sent to a network address. If there is a recei-
ving instance, it will a response packet back to the sender. If this works, one can assu-
me that a connection is possible.

SMU Ping window

Notes on the window above

· In the top line, specify the destination to be "pinged”.

· The timeout below determines how long to wait for a response. If the response comes back
within this time, then this ping is reported as "Successful", otherwise as "Timeout error".

· The ping mechanism runs until you click on Stop or close the window.
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Realtime Data menu4.6

The following table provides you with an overview of the Realtime Data menu

Menu item Purpose

WTG Status Display data received by the SMU from the wind turbine generators
(WTG) and execute switching test

Light Sensors Display the sensor data live

Laser Precipitation
Sensors

Display the sensor data live

Hygro Thermo Sensors Display the sensor data live

Climate Sensors Display the sensor data live

iSpin Sensors Display the sensor data live

Visibility Sensors Display the sensor data live

External Trigger Display and test triggers defined in the project

Calculations Display calculations defined in the project with current calculation
result

POI Counter Readings Visualize shadow impact

Click on a menu item to jump directly to more information.

311
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4.6.1 Live Data: WTG Status

Purpose Display data received by the SMU from the wind turbine generators (WTG)
and execute switching test

Path Realtime Data > WTG Status

Right group Switching test or view (no switching test possible as viewer)

Prerequisites Online connection to the SMU, dongle (for switching test) 

Type of use Display + interactive 

Reference Entire project

If you have established an online connection to an SMU (File > Connect), you can display the live
data the SMU receives from the WTGs and perform a shutdown test individually for every switch re-
ason.

Live Data: WTG Status (without footer, see table below)

Notes on the window above

· Information on the individual columns can be found on the next page.

· If you would like to display all available information and not just the standard columns, select the
Details option in the window at the top right. Only the content of the standard columns is explai-
ned in the table on the next page as the detailed view is intended exclusively for technicians for
the purpose of troubleshooting.

The information, options or buttons are described in the following table
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Element Explanation

Last response
(local PC time)

SM4 received its last response from the SMU at the date and time displayed
here.

Status Note: Depending on the status of the live data shown in the list below, the
following can be displayed here:

 Preparing The prerequisites for displaying live data are being crea-
ted (among other things, a connection to the SMU must
exist).

Ready The prerequisites for displaying live data  are met; the
data is retrieved and displayed regularly (interval as spe-
cified in File > Application Settings > Live data ).

Disconnected Connection to the SMU has been disconnected, dis-
played live data are no longer up to date.

Preloading
WTGs  that are
not displayed

This figure indicates the number of WTGs that do not belong to the "own"
wind park and have nevertheless been set up in the project as there are pla-
ces of immission in the project at which these "foreign" WTGs cause shadow
impact (Project > Wind Turbine Generators). Since the SMU cannot commu-
nicate with these foreign WTGs, it does not receive any data from them and
cannot switch them.

This setting area is only active if the connected WTG supports speed reducti-
on.

Use the checkbox to switch the additional data/columns in the table on or off.

The speed that you enter in the number field is transferred as the test target
value when you carry out a test (via the red buttons in the table).

NOTE

You will find further information on the data/columns that you can show/hide in
this settings area in the Data/columns for speed reduction  subsection.

No. Consecutive number of the WTG.

Identifier WTG identifier as defined in the Add/Edit WTG window.

Communi-
cation OK

The status of the communication channel to the WTG is displayed here.

Communication to sensor possible 

Communication to sensor not possible, e.g. due to incorrect IP address
or network problems

Error This is a collective error for the following situations:

315
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Element Explanation

If a communication error has been detected (see above), a red cross is
also displayed here. Even if the WTG does not respond to a stop
command issued by the SMU, an error is signaled here.

If the communication is ok and the WTG responds to stop commands,
the green checkmark is displayed here.

Nacelle Angle
[degree]

Analog or digitally determined value, depending on the WTG type.

Current Power
[kW]

self-explanatory

Rotor Speed
[rpm]

self-explanatory

Wind Speed
[m/s]

self-explanatory

Outside Temp.
[°C]

self-explanatory

Active Stop
Commands:

Shadow/
Calendar/ Bat/
Sector/ Noise/
External/ Bird

If a system has been stopped due to shadow impact, calendar shutdown etc.,
this is indicated here by a green checkmark.

Switching test:

 
You can test here whether the shutdown procedure is working by clicking on
the corresponding red button for every individual switch reason (shadow,
calendar, bat, etc.). This option is frequently used if not all WTGs are swit-
chable at the time of installation of the SMU to test the shutdown procedure
at a later point in time, even externally.

If you would like to display all available information and not just the standard
columns, select the Details option in the window at the top right. Only the
content of the standard columns is explained in the table as the detailed view
is intended exclusively for technicians for the purpose of troubleshooting.

If you click on this button, the Application Settings window, Update inter-
vals for live data windows (File > Application Settings > Live Data) input
area opens. The interval can be changed there.

Footer Park data is displayed in a footer; note the following:

Mean values are indicated with "Ø =" .
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Element Explanation

Power is displayed as the sum of all column values.

Values are only included in the calculation if:

·the communication is ok

·no error is present

·the value is recorded (possibly only visible under details, '-' is then displayed
as value if not recorded)
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4.6.1.1 Data/columns for speed reduction

Purpose Display data the SMU receives from the WTGs and perform a switch test

Path Realtime Data > WTG Status

Right group Switch test or viewer (no switch test possible as viewer)

Prerequisites Online connection to the SMU

Dongle (for switch test)

SMU supports speed reduction

Show data/column option in the Live Data: WTG Status window is acti-
vated

Type of use Display + dialog

Reference Entire project

If you  have activated the Live Data: WTG status window (Realtime Data > WTG Status) at the
top of the window in the Speed reduction settings area, the following information is displayed in the

table:
 

Live Data: WTG Status window (speed reduction section)

Explanation of the information and buttons using the example above

· In the table header, you can see the division into Data Speed Reduction (display of the data re-
trieved from the WTGs) and Test Speed Reduction (buttons for testing the function).

· The second line of the table header shows the possible reasons for speed reductions (Bat, Sec-
tor, etc.); the Speed column displays the lowest reduction value of the current SMU configuration
of a WTG in the Target column (in the fourth line of the above example 3.71 instead of 4.53) or
0.00 if no speed reduction has been defined for a WTG.

· All rows in which numerical values and buttons are displayed represent one WTG each (the WTG
numbers are not visible here, in the full SM4 window they are on the far left of the table).

· The WTGs in the top three rows with numerical values do not support speed reduction (which is
why the buttons in the Reduced columns (right-hand side) are greyed out).

· The WTG in the bottom row does support speed reduction (which is why the buttons in the Re-
duced column (right-hand side) are active), and it has received the command from the SMU to re-
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duce the speed, which is indicated by the green tick . A green tick can also indicate that the
WTG is currently running at reduced speed because the conditions for a reduction have been met.

· You can tell whether a WTG is running at reduced speed by comparing the target and actual
values:

    > Actual value target value = WTG is running at reduced speed

· The symbols on the right under Test Speed Reduction mean the following or respectively take
the following effect:

If you click on this button, you start a speed reduction test with the value you entered at
the top of the Live Data: WTG Status window at Speed.

When this button is displayed, a speed reduction test has been started. Click this button
to end the test.
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4.6.2 Live Data: Light Sensors

Purpose Display live data from the light sensor(s) of the wind park

Path Realtime Data > Light Sensors

Right group Viewer

Prerequisites Online connection to the SMU

Type of use display only

Reference Project

If you have established an online connection to an SMU (File > Connect), you can display live data
of the connected light sensors in this window. 

Live Data: Light Sensors window

Notes on the window above

· The figure above only shows a section of the Live Data:  Light Sensors.

· Information on the individual columns can be found on the next page.

· If you would like to display all available information and not just the standard columns, select the
Details option in the window at the top right (not included in the figure). Only the content of the
standard columns is explained in the table on the next page as the detailed view is intended ex-
clusively for technicians for the purpose of troubleshooting. 

The information, options or buttons are described in the following table
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Element Explanation

Last response (local PC
time)

SM4 received its last response from the SMU at the date and time dis-
played here.

Status Note: Depending on the status of the live data shown in the list below,
the following can be displayed here:

Preparing The prerequisites for displaying live data are
being created (among other things, a connection
to the SMU must exist).

Ready The prerequisites for displaying live data  are
met; the data is retrieved and displayed regular-
ly (interval as specified in File > Application
Settings > Live data ).

Disconnected Connection to the SMU has been disconnected,
displayed live data are no longer up to date.

Sensor

No. Sequential No. of the light sensor.

Comment Name as entered in the Sensors and IO Signals window (Hardware >
Sensors and IO Signals).

Processed Data 

Two types of data can be displayed here in addition to information on e.g., Communication, Error
Status, Last receipt: (a) data SM4 uses or processes in any way, e.g. as off-line values when a
sensor is not accessible; (b) data edited by the SMU, e.g. to generate averaged values of reading
points, such as “Precipitation present” in the case of a laser precipitation sensor.  

Communication OK The status of the communication channel to the WTG is shown here.

Communication to sensor possible 

Communication to sensor not possible, e.g. due to incorrect IP
address or network problems

Shadow Possible
Shadow impact possible 

No shadow impact possible
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Element Explanation

Sensor Data 
Data displayed here as received from the sensor

Direct Light [lx] The value measured by the four photo diodes of the light sensor.

Sun Azimuth [°] Value calculated by the sensor itself.

Sun Elevation Angle [°] Value calculated by the sensor itself.

If you would like to display all available information and not just the
standard columns, select the Details option in the window at the top
right. Only the content of the standard columns is explained in the table
as the detailed view is intended exclusively for technicians for the pur-
pose of troubleshooting. 

If you click on this button, the Application Settings window, Update
intervals for live data windows (File > Application Settings > Live
Data) input area opens. The interval can be changed there.
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4.6.3 Live Data: Laser Precipitation Sensors

Purpose Display live data on the wind park’s laser precipitation sensors

Path Realtime Data > Laser Precipitation Sensors

Right group Viewer

Prerequisites Online connection to the SMU

Type of use display only

Reference Project

If you have established an online connection to an SMU (File > Connect), you can display live data
of the connected laser precipitation sensors in this window. 

Live Data: Laser Precipitation Sensors window (section)

Notes on the window above

· The figure above only shows a section of the Live Data: Laser Precipitation Sensors.

· Information on the individual columns can be found on the next page.

· If you would like to display all available information and not just the standard columns, select the
Details option in the window at the top right (not included in the figure). Only the content of the
standard columns is explained in the table on the next page as the detailed view is intended ex-
clusively for technicians for the purpose of troubleshooting. 

The information, options or buttons are described in the following table
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Element Explanation

Last response (local PC
time)

SM4 received its last response from the SMU at the date and time dis-
played here.

Status Note: Depending on the status of the live data shown in the list below,
the following can be displayed here:

Preparing The prerequisites for displaying live data are
being created (among other things, a connection
to the SMU must exist).

Ready The prerequisites for displaying live data  are
met; the data is retrieved and displayed regular-
ly (interval as specified in File > Application
Settings > Live data ).

Disconnected Connection to the SMU has been disconnected,
displayed live data are no longer up to date.

Sensor

No. Sequential No. of the laser precipitation sensor.

Comment Name as entered in the Sensors and IO Signals window (Hardware >
Sensors and IO Signals).

Processed Data 

Two types of data can be displayed here in addition to information on e.g., Communication, Error
Status, Last receipt: (a) data SM4 uses or processes in any way, e.g. as off-line values when a
sensor is not accessible; (b) data edited by the SMU, e.g. to generate averaged values of reading
points, such as “Precipitation present” in the case of a laser precipitation sensor.  

Communication OK The status of the communication channel to the WTG is displayed here.

Communication to sensor possible 

Communication to sensor not possible, e.g. due to
incorrect IP address or network problems

Precipitation Present see Processed Data above
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Element Explanation

Sensor Data 
Data displayed here as received from the climate sensor

Intensity All, 1 min [mm/h] The precipitation amount measured by the sensor at intervals of one
minute.

If you would like to display all available information and not just the
standard columns, select the Details option in the window at the top
right. Only the content of the standard columns is explained in the table
as the detailed view is intended exclusively for technicians for the pur-
pose of troubleshooting. 

If you click on this button, the Application Settings window, Update
intervals for live data windows (File > Application Settings > Live
Data) input area opens. The interval can be changed there.
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4.6.4 Live Data: Hygro-Thermo Sensors

Purpose Display live data on the wind park’s hygro-thermo sensors

Path Realtime Data > Hygro-Thermo Sensors

Right group Viewer

Prerequisites Online connection to the SMU

Type of use display only

Reference Project

If you have established an online connection to an SMU (File > Connect), you can display live data
of the connected hygro-thermo sensors in this window. 

Live Data: Hygro-Thermo Sensors window (section)

Notes on the window above

· The figure above only shows a section of the Live Data: Hygro-Thermo Sensors..

· Information on the individual columns can be found on the next page.

· If you would like to display all available information and not just the standard columns, select the
Details option in the window at the top right (not included in the figure). Only the content of the
standard columns is explained in the table on the next page as the detailed view is intended ex-
clusively for technicians for the purpose of troubleshooting. 

The information, options or buttons are described in the following table
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Element Explanation

Last response (local PC time) SM4 received its last response from the SMU at the date and time
displayed here.

Note Depending on the status of the live data shown in the list below, the
following can be displayed here:

Preparing The prerequisites for displaying live data are
being created (among other things, a connecti-
on to the SMU must exist).

Ready The prerequisites for displaying live data  are
met; the data is retrieved and displayed regu-
larly (interval as specified in File > Application
Settings > Live data ).

Disconnected Connection to the SMU has been disconnected,
displayed live data are no longer up to date.

Sensor

No. Sequential No. of the hygro-thermo sensor.

Comment Name as entered in the Sensors and IO Signals window (Hardware
> Sensors and IO Signals).

Processed Data 

Two types of data can be displayed here in addition to information on e.g., Communication, Error
Status, Last receipt: (a) data SM4 uses or processes in any way, e.g. as off-line values when a
sensor is not accessible; (b) data edited by the SMU, e.g. to generate averaged values of reading
points, such as “Precipitation present” in the case of a laser precipitation sensor.  

Communication OK The status of the communication channel to the WTG is displayed he-
re.

Communication to sensor possible 

Communication to sensor not possible, e.g. due to
incorrect IP address or network problems

Outside Temperat. [°C] see Processed Data above

Rel. Humidity 
[% r.F.]

see Processed Data above

If you would like to display all available information and not just the
standard columns, select the Details option in the window at the top
right. Only the content of the standard columns is explained in the
table as the detailed view is intended exclusively for technicians for
the purpose of troubleshooting. 
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Element Explanation

If you click on this button, the Application Settings window, Update
intervals for live data windows (File > Application Settings > Live
Data) input area opens. The interval can be changed there.
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4.6.5 Live Data: Climate Sensors

Purpose Display real-time data of the wind park's climate sensors

Path Realtime Data > Climate Sensors

Right group Viewer

Prerequisites Online connection to the SMU

Type of use display only

Reference Project

If you have established an online connection to an SMU (File > Connect), you can display live data
of the connected climate sensors in this window. 

Live Data: Climate Sensors

Notes on the window above

· Information on the individual columns can be found on the next page.

· If you would like to display all available information and not just the standard columns, select the
Details option in the window at the top right. Only the content of the standard columns is explai-
ned in the table on the next page as the detailed view is intended exclusively for technicians for
the purpose of troubleshooting. 

The information, options or buttons are described in the following table
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Element Explanation

Last response (local PC
time)

SM4 received its last response from the SMU at the date and time dis-
played here.

Status Note: Depending on the status of the live data shown in the list below,
the following can be displayed here:

Preparing The prerequisites for displaying live data are
being created (among other things, a connection
to the SMU must exist).

Ready The prerequisites for displaying live data  are
met; the data is retrieved and displayed regular-
ly (interval as specified in File > Application
Settings > Live data ).

Disconnected Connection to the SMU has been disconnected,
displayed live data are no longer up to date.

Sensor

No. Sequential no. of the climate sensor

Comment Name as entered in the Sensors and IO Signals window (Hardware >
Sensors and IO Signals).

Processed Data 

Two types of data can be displayed here in addition to information on e.g., Communication, Error
Status, Last receipt: (a) data SM4 uses or processes in any way, e.g. as off-line values when a
sensor is not accessible; (b) data edited by the SMU, e.g. to generate averaged values of reading
points, such as “Precipitation present” in the case of a laser precipitation sensor.  

Communication OK The status of the communication channel to the WTG is displayed here.

Communication to sensor possible 

Communication to sensor not possible, e.g. due to
incorrect IP address or network problems

Outside Temperature [°C],
Rel. Hum. [%] etc.

see Processed Data above

Sensor Data 
Data displayed here as received from the climate sensor

If you would like to display all available information and not just the
standard columns, select the Details option in the window at the top
right. Only the content of the standard columns is explained in the table
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Element Explanation

as the detailed view is intended exclusively for technicians for the pur-
pose of troubleshooting. 

If you click on this button, the Application Settings window, Update
intervals for live data windows (File > Application Settings > Live
Data) input area opens. The interval can be changed there.
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4.6.6 Live Data: iSpin Sensors window

Purpose Display real-time data of the wind park's iSpin sensors

Path Realtime Data > iSpin Sensors

Right group Viewer

Prerequisites Online connection to the SMU

Type of use display only

Reference Project

If you have established an online connection to an SMU (File > Connect), you can display live data
of the connected iSpin sensors in this window. 

Live Data: iSpin Sensors window (section)

Notes on the window above

If you would like to display all available information and not just the standard columns, select the De-
tails option in the window at the top right. Only the content of the standard columns is explained in
the table on the next page as the detailed view is intended exclusively for technicians for the purpo-
se of troubleshooting. 

The information, options or buttons are described in the following table
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Element Explanation

Last response (local PC
time)

SM4 received its last response from the SMU at the date and time dis-
played here.

Status Note: Depending on the status of the live data shown in the list below,
the following can be displayed here:

Preparing The prerequisites for displaying live data are
being created (among other things, a connection
to the SMU must exist).

Ready The prerequisites for displaying live data  are
met; the data is retrieved and displayed regular-
ly (interval as specified in File > Application
Settings > Live data ).

Disconnected Connection to the SMU has been disconnected,
displayed live data are no longer up to date.

Sensor

No. Sequential number of the iSpin sensor

Comment Name as entered in the Sensors and IO Signals window (Hardware >
Sensors and IO Signals).

Processed Data 

Two types of data can be displayed here in addition to information on e.g. Communication, Error
Status, Last receipt: (a) data SM4 uses or processes in any way, e.g. as off-line values when a
sensor is not accessible; (b) data edited by the SMU, e.g. to generate averaged values of reading
points, such as “Precipitation present” in the case of a laser precipitation sensor.  

Communication OK The status of the communication channel to the WTG is displayed he-
re.

Communication to sensor possible 

Communication to sensor not possible, e.g. due to incorrect
IP address or network problems

Used A green checkmark indicates that basically all is fine with the sensor.

Status Various individual information concerning communication and error sta-
tus of the sensor is displayed here as follows:

Communication exists, no warning at the sensor

There is no communication to the sensor, or the sensor re-
ports an error
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Element Explanation

Communication exists, but the sensor reports a warning

Last Received Date and time of the last time data were received from the sensor.

Error Indicates as follows whether the sensor reports an error:

The sensor reports no errors, everything is fine

The sensor reports a serious error

Warning Here it is indicated as follows whether a warning is pending:

No warning is pending

There is a warning pending

Error Rate [%] The error rate indicates the ratio between (a) the requests sent to a
sensor and (b) the correctly received responses to them.

However, many situations lead to an answer being falsely judged as
incorrect:

· Timeout – no response was received. 

· Incorrect content of the response, e.g. unexpected values or range
overruns

· Checksum error in the response data

Possible reasons for this: network problems, interference, power sup-
ply problems and much more.

It is not possible to say in general terms what error rate is acceptable
in a particular situation. In principle, the error rate should be as low
and constant as possible.

Wind Speed [ms], Yaw
Angle [°] etc.

see Processed Data above

If you would like to display all available information and not just the
standard columns, select the Details option in the window at the top
right. Only the content of the standard columns is explained in the table
as the detailed view is intended exclusively for technicians for the pur-
pose of troubleshooting. 

If you click on this button, the Application Settings window, Update
intervals for live data windows (File > Application Settings > Live
Data) input area opens. The interval can be changed there.
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4.6.7 Live Data: Visibility Sensors

Purpose Display real-time data of the wind park's visibility sensors

Path Realtime Data > Visibility Sensors

Right group Viewer

Prerequisites Online connection to the SMU

Type of use display only

Reference Project

If you have established an online connection to an SMU (File > Connect), you can display live data
of the connected visibility sensors in this window. 

Live Data: Visibility sensors window (section)

Notes on the window above

· The figure above only shows a section of the Live Data: Visibility Sensorswindow.

· If you would like to display all available information and not just the standard columns, check the
Details option in the window at the top right (not included in the figure). Only the content of the
standard columns is explained in the table on the next page as the detailed view is intended ex-
clusively for technicians for the purpose of troubleshooting. 

The information, options or buttons are described in the following table
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Element Explanation

Last response (local
PC time)

SM4 received its last response from the SMU at this time.

Status Note: Depending on the status of the live data shown in the list below, the
following can be displayed here:

Preparing The prerequisites for displaying live data are being
created (among other things, a connection to the SMU
must exist).

Ready The prerequisites for displaying live data  are met; the
data is retrieved and displayed regularly (interval as
specified in File > Application Settings > Live data ).

Disconnected Connection to the SMU has been disconnected, dis-
played live data are no longer up to date.

Sensor

No. Sequential no. of the visibility sensor

Comment Name as entered in the Sensors and IO Signals window (Hardware >
Sensors and IO Signals).

Processed Data : Two types of data can be displayed here in addition to information on e.g.
Communication, Error Status, Last receipt: (a) data SM4 uses or processes in any way, e.g. as
off-line values when a sensor is not accessible; (b) data edited by the SMU, e.g. to generate ave-
raged values of reading points, such as “Precipitation present” in the case of a laser precipitation
sensor.  

Visibility 1 min The visibility in meters measured by the sensor at intervals of one minute.

Communication OK The status of the communication channel to the WTG is displayed here.

Communication to sensor possible 

Communication to sensor not possible, e.g. due to incorrect IP
address or network problems

If you would like to display all available information and not just the standard
columns, select the Details option in the window at the top right. Only the
content of the standard columns is explained in the table as the detailed view
is intended exclusively for technicians for the purpose of troubleshooting. 

If you click on this button, the Application Settings window, Update inter-
vals for live data windows (File > Application Settings > Live Data) input
area opens. The interval can be changed there.
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4.6.8 Live Data: Digital Inputs

Purpose Display digital input data in real time

Path Realtime Data > Digital Inputs

Right group Viewer

Prerequisites Online connection to the SMU

Type of use display + dialog

Reference Project

If you have established an online connection to an SMUF(File > Connect), you can display the digital
inputs defined in the current project and their state in this window. 

Live Data: Digital Inputs

The information, options or buttons are described in the following table



335Reference part > Realtime Data menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

Element Explanation

Last response (local PC
time)

SM4 received its last response from the SMU at the date and time dis-
played here.

Status Note: Depending on the status of the live data shown in the list below,
the following can be displayed here:

Preparing The prerequisites for displaying live data are
being created (among other things, a connection
to the SMU must exist).

Ready The prerequisites for displaying live data  are
met; the data is retrieved and displayed regularly
(interval as specified in File > Application
Settings > Live data ).

Disconnected Connection to the SMU has been disconnected,
displayed live data are no longer up to date.

No. Consecutive number of the signal

Signal Name of the digital input as defined in the Sensors and IO Signals
window (Hardware > Sensors and IO Signals).

State =  1

=  0

Card Number of the card on which the digital input is located.

Card Type -

DI No Number of the digital input as in the Sensors and IO Signals window
(Hardware > Sensors and IO Signals).

If you click on this button, the Application Settings window, Update
intervals for live data windows (File > Application Settings > Live
Data) input area opens. The interval can be changed there.
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4.6.9 Live Data: Digital Outputs

Purpose Display digital output data in real time

Path Realtime Data > Digital Outputs

Right group Viewer

Prerequisites Online connection to the SMU

Type of use display + dialog

Reference Project

If you have established an online connection to an SMUF(File > Connect), you can display the digital
outputs defined in the current project and their state in this window. 

Live Data: Digital Outputs

The information, options or buttons are described in the following table
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Element Explanation

Last response
(local PC time)

SM4 received its last response from the SMU at the date and time displayed
here.

Status Note: Depending on the status of the live data shown in the list below, the
following can be displayed here:

Preparing The prerequisites for displaying live data are being crea-
ted (among other things, a connection to the SMU must
exist).

Ready The prerequisites for displaying live data  are met; the
data is retrieved and displayed regularly (interval as spe-
cified in File > Application Settings > Live data ).

Disconnected Connection to the SMU has been disconnected, dis-
played live data are no longer up to date.

No. Consecutive number of the signal

Signal Name of the digital output as defined in the Sensors and IO Signals window
(Hardware > Sensors and IO Signals).

State =  1

=  0

Card Number of the card on which the digital output is located.

Card Type -

DI No Number of the digital output as in the Sensors and IO Signals window (Hard-
ware > Sensors and IO Signals).

If you click on this button, the Application Settings window, Update intervals
for live data windows (File > Application Settings > Live Data) input area
opens. The interval can be changed there.
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4.6.10 Live Data: External triggers

Purpose
· Display triggers defined in the project

· Change states of triggers for test purposes

Path Realtime Data > External Trigger

Right group Viewer

Prerequisites Online connection to the SMU

Type of use display + dialog

Reference Project

If you have established an online connection to an SMU (File > Connect), you can use this window
to display the external triggers defined in the current project (see Glossary ) and their state (re-
set or set to a specific time). In addition, it is possible here to change the state of a trigger for test
purposes or to correct false triggers. 

Live Data: External triggers

The information, options or buttons are described in the following table
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Element Explanation

Local SMU time Displays the local time of the SMU.

Status Note: Depending on the status of the live data shown in the list below,
the following can be displayed here:

Preparing The prerequisites for displaying live data are
being created (among other things, a connection
to the SMU must exist).

Ready The prerequisites for displaying live data  are
met; the data is retrieved and displayed regularly
(interval as specified in File > Application
Settings > Live data ).

No. Consecutive number of the external trigger

Trigger Name Name of the trigger as entered in the Sensors and IO Signals window
(Hardware > Sensors and IO Signals).

Set/Reset If you click on the box, the Set External Trigger window opens, see
the following example.

Here you can enter the desired runtime or select it via the arrow keys.
Press  to start the trigger, press  to stop it.

After the window is closed, the following is displayed:

Trigger is not active (has been stopped or has expired)

Trigger is set until the time specified under Set to.

Set until see above

If you click on this button, the Application Settings window, Update
intervals for live data windows (File > Application Settings > Live
Data) input area opens. The interval can be changed there..
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4.6.11 Live Data: Calculations

Purpose Display calculations defined in the project with current calculation result

Path Real-time data > Calculations

Right group Viewer

Prerequisites Online connection to the SMU

Type of use display only

Reference Project

If you have established an online connection to a SMU (File > Connect), you can display the calcula-
tions defined in the current project in this window. For more information on calculations, see section
Calculations window .

Live Data: Calculations

The information, options or buttons are described in the following table

274



341Reference part > Realtime Data menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

Element Explanation

Last response (local PC
time)

SM4 received its last response from the SMU at the date and time dis-
played here.

Status Note: Depending on the status of the live data shown in the list below,
the following can be displayed here:

Preparing The prerequisites for displaying live data are
being created (among other things, a connection
to the SMU must exist).

Ready The prerequisites for displaying live data  are
met; the data is retrieved and displayed regular-
ly (interval as specified in File > Application
Settings > Live data ).

No. Consecutive number of the calculation

Calculation name Name of the calculation as defined in the Calculations window
(Switching & Measurement > Calculations).

Calculation result Current results of the calculations.

If you click on this button, the Application Settings window, Update
intervals for live data windows (File > Application Settings > Live
Data) input area opens. The interval can be changed there. The
interval can be changed there.



342Reference part > Realtime Data menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

4.6.12 Live Data: Windfarm Communication Unit

Purpose Display real-time data from the project's windfarm communication units
(WCU)

Path Realtime Data > Windfarm Communication Unit

Rights group Viewer

Prerequisites Online connection to the SMU

Type of use Display only

Reference Project

If you have established an online connection to a SMU (File > Connect), you can display the
following in this window:

· the WCUs defined in the current project and their status,

· the RS485 cards that are functioning correctly and,

· the WTGs connected (configured) to the WCU.

 Real-time data: Windfarm Communication Unit
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An explanation of the information, options and buttons can be found in the following table

Element Explanation

Last Response 
(local PC time)

SM4 received its last response from the SMU at the date and time dis-
played here.

State Depending on the state of the real-time data shown in the list below, the
following can be displayed here:

Preparing The prerequisites for real-time data display are being
created (e.g. a connection to the SMU must be esta-
blished).

Ready The prerequisites for real-time data display are met;
the data is retrieved and displayed periodically (interval
as defined under File > Application Settings > Live
data).

Disconnected The connection to the SMU has been cut; displayed re-
al-time values may no longer be up-to-date.

WCU

No. Number of the WCU

Location Location as entered in the Windfarm Communication Unit window
(Hardware > Windfarm Communication Unit).

Comment Comment as entered in the Windfarm Communication Unit window
(Hardware > Windfarm Communication Unit).

Status data 

Active
WCU is active 

WCU is not active

Communication Ok The status of the communication channel to the WCU is displayed here as
follows:

Communication to WCU possible 

Communication to WCU not possible, e.g. due to incorrect IP
address or network problems

Error
There is no alarm.

There is an alarm pending (an event requires immediate action).
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Element Explanation

Warning
There is no warning.

There is a warning pending (no immediate action required).

RS485 Cards OK

Only the cards that are working properly are displayed here.

WTG Communication Ok

Only the WTGs that are configured are displayed here.

To display not only the standard columns, but all available information,
select the Details option at the top right of the window. Only the content
of the standard columns is explained in this table, as the detailed view is
only intended for troubleshooting by technicians. 

Opens the Application Settings window, Update intervals for live data
windows (File > Application Settings > Live data). The interval for upda-
ting the data can be changed there.
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4.6.13 Live Data: POI Counter Readings

Purpose Quick overview of current daily and annual counters

Path Realtime Data > POI Counter Readings 

Right group Viewer

Prerequisites Online connection to the SMU

Type of use Display + interactive

Reference Project

If you have established an online connection to a SMU (File > Connect), you can use this window to
display an overview of the current daily and annual counter readings for the individual places of
immission. While other live data windows read out the values automatically, you must manually trig-
ger the reading of the data here by clicking on Refresh.

Live Data: POI Counter Readings window (section)

The information, options or buttons are described in the following table
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Element Explanation

Last response (local PC time) SM4 received its last response from the SMU at the date and time
displayed here.

Status Note: Depending on the status of the live data shown in the list below,
the following can be displayed here:

Preparing The prerequisites for displaying live data are
being created (among other things, a connecti-
on to the SMU must exist).

Ready The prerequisites for displaying live data  are
met; the data is retrieved and displayed regu-
larly (interval as specified in File > Application
Settings > Live data ).

Disconnected Connection to the SMU has been dis-
connected, displayed live data are no longer
up to date.

Opens the preview window of the read out counter readings.

This button, as well as the PDF and Print buttons, are only active if
the counter readings have been successfully read out by clicking Re-
fresh.

Used to save counter readings in PDF format.

Used to print the PDF view of the counter readings on paper.

There is no language setting for the document to be printed. The do-
cument will be printed in the language selected under SM4 (File >
Application Settings -> General -> Language).

Reads out the current counter readings from the SMU.
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4.6.14 Live Data: Shadow Impact Visualization

Purpose Visualize the current shadow impact situation

Path Realtime data > Shadow Impact Visualization

Right group Viewer

Prerequisites

Type of use Display + interactive

Reference Project

If you have established an online connection to an SMU(File > Connect), you can visualize the
current shadow impact situation in this window. This window remains open even after the connection
to the SMU has been terminated.

Live Date: Shadow Impact Visualization window

You will find an explanation of the symbols (tower shadow blue/black, rotor shadow light/dark etc.)
that are used to display the current shadow impact situation in the lower half of the window, in the
following section SI visualization symbols . 

An explanation of the information, options or buttons can be found in the following table. 
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Element Explanation

Local SMU time Local time of the currently displayed shadow impact scenario.

SMU time (UTC) UTC time of the currently displayed shadow impact scenario.

Elevation angle limit
[°]

Value as defined und Project > Application Settings > Shadow impact
calculation > Min. sun elevation. This parameter defines the minimum eleva-
tion angle – below this minimum elevation, shadow impact effects are not de-
emed possible and will not be visualized here.

Elevation angle [°] Elevation angle of the sun as calculated by SM4.

Azimuth [°] Azimuth of the sun as calculated by SM4.

Frame extension Outside the project frame, the shadow impact ellipses are cut off.

Input range 0-10000 m, default 200 m

Maps White – Background is white.

OSM – Open Street Map is displayed in the background.

NOTE: To use OSM, the computer must be connected to the Internet.

POI Focus If you check the Zoom box, you can select a POI number in the selection list
below to center the map on this particular POI. 

Opens the Live Data settings area in at File > Application Settings > Live
data, where you can change the interval for updating the display of the
shadow impact scenario.

Data: The tables displayed in the Data area cannot be edited here (display only).

Info WTG Data from the Add/Edit WTG window (Project > Wind Turbine Generators >
Add WTG) is displayed here, please also refer to the screenshot below this
table.

Shadow worst case column 

Since it is not always possible to tell from the shape of the rotor shadow
whether it corresponds to a detected nacelle position or depicts a worst case
scenario, a check mark is displayed here whenever the latter applies.

Live Data Data from the Real-time data: WTG status window is displayed here.

Info LS Data from the Light Sensors tab (Hardware > Sensors and IO Signals) is
displayed here, please also refer to the screenshot below this table.

Live Data (far right) Data from the Live Data: Light Sensors is displayed here.
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 Live Data: Shadow Impact Visualization window, display area Data

The above screenshots show the relationship between what is displayed in the Shadow Impact
Visualization (Realtime) window on the one hand and the settings windows Add/Edit WTG (Pro-
ject > Wind Turbine Generators) and Sensors and IO Signals (Hardware) on the other.
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4.6.14.1 SI visualization symbols

The 4 elements shown in the following figure are used in the Shadow Impact Visualization window
to visualize the current shadow impact situation:

The properties of the elements, which vary depending on the shadow impact situation, are descri-
bed in the following tables 1 to 4:

Table 1: Color of the tower shadow

Color Reason

blue 
WTG is not switchable (WTG type = preload )

black

WTG is switchable (WTG type preload)

NOTE

If the WTG is not switchable (WTG type = preload), then no communication with the WTG is possi-
ble, i.e. no real-time data can be requested from the WTG and the rotor shadow frame cannot be
displayed in red - however, the light sensor data is still taken into account.
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Table 2: Color of the rotor shadow

Color Possible reasons

light 

· Communication with light sensor (LS) ok And there is no error
at LS – but according to real-time data, shadow is not
possible 

· Communication with LS not ok Or there is an error at the LS –
offline value: Light = not present 

· WTG is not running (communication ok)

dark 

· Communication with LS ok And there is no error at LS –
according to real-time data shadow is possible 

· Communication with LS not ok Or there is an error at the LS –
offline value. Light = present 

· WTG is running
· WTG communication not ok

NOTES

· If the WTG is not running, the light sensor data is not taken into account, because even if the light
sensor is ok and shadow is possible, there can be no shadow impact, since the rotor is not tur-
ning.

· Even though the WTG is running, the rotor shadow may be displayed in light gray because no
shadow is possible according to LS readings or because the offline value of the LS has been set
to "not present".

Regarding the visualization of shadow according to the readings reported by light sensors (LS), the
following combinations and states of light sensors should be taken into account

faulty = communication not ok or LS faulty
n.c. = not configured
LS 1 = reference light sensor 1, LS 2 = reference light sensor 2, LS A = alternative light sensor

One light sensor

LS 1 LS 2 LS A Visualization according to...

OK n.c. n.c. LS 1

faulty n.c. n.c. LS 1 (offline value)

n.c. OK n.c. LS 2

n.c. faulty n.c. LS 2 (offline value)

n.c. n.c. OK LS A

n.c. n.c. faulty LS A (offline value)

 
If the LS = OK, the real-time data are evaluated; otherwise, the visualization takes place according
to offline values.
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Two light sensors

LS 1 LS 2 LS A Visualization according to... see

OK OK n.c. LS 1 or LS 2 a)

faulty OK n.c. LS 1 (offline value) or LS 2 a)

OK faulty n.c. LS 1 or LS 2 (offline value) a)

faulty faulty n.c. LS 1 (offline value) or LS 2 (offline value) a)

OK n.c. OK LS 1 b)

faulty n.c. OK LS A b)

OK n.c. faulty LS 1 b)

faulty n.c. faulty LS 1 (offline value) b)

n.c. OK OK LS 2 b)

n.c. faulty OK LS A b)

n.c. OK faulty LS 2 b)

n.c. faulty faulty LS 2 (offline value) b)

a) If two reference LSs are configured, both are evaluated whether faulty or ok – if one of the
Analysiss results in shadow, then shadow applies.

b) If a reference LS and an alternative LS are configured, then the following applies:
§ if both LSs are ok, then the value of the reference LS is evaluated
§ if one LS is ok, then the value of the non-faulty LS is evaluated
§ if both LSs are faulty, then only the offline value of the reference LS is taken into account

Three light sensors

LS 1 LS 2 LS A Visualization according to... see also

OK OK OK LS 1 or LS 2 a)

OK OK faulty LS 1 or LS 2 a)

faulty OK OK LS 2 or LS A b)

OK faulty OK LS 1 or LS A b)

faulty faulty OK LS A -

faulty OK faulty LS 1 (offline value) or LS 2 or LS A (offline value) c)

OK faulty faulty LS 1 or LS 2 (offline value) or LS A (offline value) c)

faulty faulty faulty LS 1 (offline value) or LS 2 (offline value) or LS A (offline
value)

d)

a) If LS 1 and LS 2 or all LSs are ok, then LS 1 and LS 2 are evaluated – if one of the Analysiss
results in shadow, then shadow applies
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b) If LS1 or LS 2 is faulty, then also LS A is evaluated – if one of the Analysiss results in shadow,
then shadow applies

c) If LS 1 or LS 2 is faulty and LS A is faulty, then the offline values of the faulty LS and the real-
time data of the functional LS are evaluated.

d) If all LSs are faulty, then all offline values are evaluated – if an offline value = light is present,
then shadow applies

Table 3: Shape of the rotor shadow

Form Possible reasons

nacelle position WTG is switchable:
· Nacelle position is detected (communication ok)

WTG is not switchable (preload):
· WTG No. for nacelle position is not 0 (exists in the project)

and is recorded

worst case

 

WTG is switchable: 
· Nacelle position of WTG is not detected
· Communication not ok

WTG is not switchable (preload) : 
· WTG no. for nacelle position = 0 (WTG no. for nacelle position

does not exist in the project)
· Nacelle position of the WTG no. is not recorded

NOTE

If WTG type = preload, the values entered in the Add/Edit WTG window under
Communication parameters are checked (since no communication to the WTG and thus
no access to the Live Data is possible).

Table 4: Shape of the rotor shadow frame

Color Possible reasons

black

 

· WTG communication ok
· No error is present

red · WTG communication not ok
· An error is present



354Reference part > Logs menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

Logs menu4.7

The SMU generates the following 4 logs:

· Operation log

· Shadow Impact

· Special Shutdown

· Single Data Recordings

In addition to downloading the desired logs in the Logs menu, you can filter them before displaying,
exporting or printing.

The following table provides you with an overview of the Logs menu. 

Menu item Purpose

Local Opens the Logs from Local LogPool window. Here you can, for example,
filter, display, export and print logs that have already been downloaded.  

Here you can also access the following sub windows:

· Cyclic Multi Log sub window

· Log Statistics Main Menu

SMU Opens the Logs from the SMU window. Here you can download specific
logs or all logs from the SMU, see Logs from the SMU .

Click on a menu item to jump directly to more information.

355
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4.7.1 Logs from Local LogPool window

Purpose Filter, display, export and print logs that have already been downloaded

Path Logs > Local Log Files

Shortcut SHIFT-CTRL-C

Right group Read out logs

Type of use Display + interactive

Reference Cross-project

In this window you can 

· list logs that have already been downloaded from the SMU 

· filter, display, export and print listed logs and

· expand the details of individual logs

· apply pre-defined or user-defined filters before displaying the log in order to reduce the load on
the computer
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Logs from Local LogPool window

The information, options or buttons are described in the following table

Element Explanation

Project area (top window half)

or
This button is located at the right-hand-side window edge. It serves
to show or hide the Project window area.

LogPool path The file path to the folder where you stored the .exe file for running
SM4 is displayed here. As soon as you run this .exe file, the Sha-
dowManager4Data\LogPool folder structure will be created in the
same directory, and, once you download logs from the SMU, these
will be automatically stored in the LogPool folder. It is also possible
to change this path, see the next table row.
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Element Explanation

This button is used for calling up the display filter application
settings, where you can change the path, amongst other things, see
section Display filters .

Search... Here you can search for a specific project by entering free text.

Serial Number Serial number of the respective SMU

Location Location of the wind park

Months Logs are downloaded month by month. Here you can view the num-
ber of downloaded logs.

Project Information Information on the project selected on the left-hand side of the lists
window is displayed here. The input of coordinates (lat./lon.) re-
spectively relate to the automatically determined project center.

For information on this input area, please refer to Cyclic Multi Log
sub window .

After you have selected a project from the top left of the window,
click on this button to list the corresponding logs in the bottom half
of the window.

NOTE: You can also double-click on a list entry to list the logs.

Logs area (bottom window half)

 or This button is located at the right-hand-side window edge. It serves
to show or hide the Logs window area.

Serial Number Serial number of the SMU that generated the displayed logs.

Location Location of the associated wind farm

Drag a column heading here to
group according to the heading.

If you have a large number of logs, it may be helpful to drag & drop
the columns Year or Month to this field in order to sort the tables
and display the logs for a specific year or month more clearly.

Date/ Operation/ Shadow Im-
pact/ Special Shutdown/ Single
Data Recordings (Measurement
Data Logging)

You will find the following information under these column headings:

Date: Information on the year and month of the respective log

Operation: Size of the available operation log

Shadow Impact: Size of the available shadow impact log

Special Shutdown: Size of the available special shutdown logs
(bat, bird, sector, noise, external)

Measurement Data Logging: Size of the available Measurement
data logs.
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Element Explanation

Is used for deleting a line of logs selected in the Logs area. If you
click on Delete, a dialog window will open where you can individual-
ly exclude each of the four logs from being deleted.

It is used to export logs selected in the Logs area. If you click on
Export, a dialog window will open where you can individually exclu-
de each of the four logs from being exported. Moreover, you can
limit the size of the export file by making the corresponding selection
for Size of sub files.

Used to import a log from a local storage location or an external
storage medium to the LogPool. 

NOTE: Always use this import function when importing. If you ins-
tead simply move the corresponding files to the LogPool in
Windows Explorer, the file structure will often be damaged.

This button is only displayed with a dongle and is only active if you
have selected one or more monthly logs in the list of logs. For more
information, see Log Statistics Main Menu .

Show drop-down list Here you can select the log you wish to display.

The SMU generates 4 different logs (operating log, shadow
impact log, shutdown log (special shutdown) and measurement
data logging). A very large volume of data can be generated de-
pending on the selection. In order not to overload the PC when pro-
cessing this data, the entries can be pre-filtered using the Display
Filter.

370
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Element Explanation

Alongside this function, entries from various different types of logs
can also be combined. Log entries from an operating log can, e.g.,
be presented with entries from the shadow impact log in one view. 

The single data recording logs are the exception. In this case the
values set by the user are recorded. No display filters can be used
for this log and its entries cannot be combined with entries from
other logs.

NOTE: Instead of 4 logs, the dropdown list offers 8 logs to choose
from. The reason for this is that the shutdown log is divided into the
following logs here: bat protection, bird protection, sector shut-
down, noise protection and special shutdown. So, when you
select one of these 5 options, you are selecting part of the shut-
down log.

Choose a filter drop-down list If you have set a user-defined filter in the application settings (see
 Application Settings window, Display filters ), you can select this
filter here in order to further filter the log you have selected in the
Show dropdown list.

Click on Show and the log you selected will appear in a separate
window. The entries displayed here correspond to the display filter
you selected. You can find more information on this window in the
next chapter.

NOTE: This button is only active if you selected a log listed in the
Logs area.

While downloading logs in the Logs from the SMU window, the functions of the Logs
from local LogPool window are blocked.
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4.7.1.1 Export Cyclic Multi Log sub window

Purpose Display logged events of defined cyclic multi data recordings (CMDR), edit
their display and export the data to a .csv file

Path Logs > Local Log Files > Export button (after selecting project & date ran-
ge)

Prerequisites The following steps must have been carried out beforehand:

· Define CMDR (see Cyclic Multi Log window )

· Send project to the SMU (see Check Configuration window )

· SMU records data

· Download log files from the SMU (see Logs from the SMU window )

· Export recorded data in the Logs from local LogPool window (see Cy-
clic Multi Log sub window )

Type of use Display + interactive

Reference Project

After the steps listed under Prerequisites (see above) have been carried out and you have finally
clicked on Export in the Logs from local LogPool window, the Export Cyclic Multi Log window
opens. The combined CMDRs are displayed here, see example screenshot below. 

"Merged" in this context means that the reading points of the current project file/configuration AS
WELL as the readings points from legends, i.e. older project files/configurations, are taken into ac-
count. Thus, reading points that have long been deleted may also be displayed here.

Export Cyclic Multi Log window
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The above window is divided into the following sections

A Tree structure of the combined CMDRs with their reading points 

B Data of a CMDR selected on the left with the possibility to change settings

C Opens the relevant settings area in the Application Settings window

D Shows the progress of the data summary and the .csv export.

The information, options or buttons are described in the following table

Element Explanation

Left part of window

Cyclic Multi Log In this display of the merged CMDRs, you can show or hide the rea-
ding points – otherwise no editing is possible.

Once you select a recording, its reading points will be displayed in the
right area of the window. If you select more than one recording on the
left, <no data to display> will appear on the right, as it is not possible
to display the data from more than one recording.

NOTE

It is possible that more reading points are displayed for a CMDR than
are currently defined in the Cyclic Multi Log window, because the
merged setups from several project files (legends) are displayed he-
re, i.e. possibly also those reading points that were created at some
point but later deleted again. When merging, the system checks for up-
per and lower case so that, e.g., the reading points of a recording cal-
led "Data WTG 1" are not merged with those of a recording called
"data WTG 1".

Right side of window

Name Name of the recording as defined in the Cyclic Multi Log window.

Display only

Opens the relevant area in the Application Settings window where
you can specify general settings for the .csv files to which CMDRs are
exported. For more information on this settings area, see Application
Settings window, Csv-Export, Cycl. Multi Data Recordings .

NOTE

The settings you make there in the Measurement point settings area
are defaults for the fields of the same name in the Cyclic Multi Log
window. They only affect those reading points that are newly added;
reading points that have already been defined retain their .csv settings.
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Element Explanation

This button for changing the file name is only active, 

· if a directory name is selected in the tree structure on the left side
of the window (no reading point) AND

· the entry in the File name field corresponds to the conventions for
Windows file names, see next line.

File name File name of the export file. When merging the data, the file name is
taken from the CMDR of the last transferred project file (configurati-
on). Note the following for the file name

· conventions for Windows file names must be observed (certain
characters and names, e.g. " : ; '< > as well as LPT0, COM0 etc.
are not allowed), otherwise the field is highlighted in red

· all .csv files of all CMDRs are output to the same folder – therefore
the file names must be unique so they do not overwrite each other
(case-insensitive): Filename = fileName

Table Displays the reading points and two additional items (timestamps: Da-
te and Time). The rows can be dragged and dropped to change the
column order in the export file. You will find a detailed explanation be-
low this table.

File format Only the .csv format is currently supported.

Starts the .csv export; is disabled during an ongoing export.

Table in the right area of the Export Cyclic Multi Log window



363Reference part > Logs menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

Element Explanation

Name Name of a reading point that will allow you to recognize it in the tree
structure

Display only

Column Header Column title for the export file

If you leave this field blank, the corresponding measured value will still
be exported, but it will appear in the .csv file in a column without a title,
or the title may only contain the respective unit (if activated).

Unit Determines whether the unit is displayed in the column title.

Display only for Date and Time

Column Header What you see here will later appear 1:1 in the column title of the export
file.

Display only

Use Determines whether the record (column) is exported.

Display only for Date and Time

Notes on the above table

· In the table, you can rename the column titles of the export file; a row corresponds to a
"column" in the export file.

· The rows can be dragged and dropped to change the column order in the export file.

· While an export is being executed, data cannot be edited and the drag & drop function is
disabled.

The following is an example of an export file.

Export window Cyclic multiple word recording - Example of an export file

In this section you will find an example of the preview of a CMDR and the corresponding export file.

The following CMDR has been exported:
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If the corresponding export file is opened in Excel, the result will look like this:

As you can see, the columns, as well as the column order, unit yes/no, etc. correspond to the
settings from the screenshot above.

See also Practical example 8: Regular recording of several measured values 50
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4.7.1.2 Operation Log/Shadow Impact Log/Shutdown Log sub windows

Purpose Display, print, etc. logs that have already been downloaded from the SMU.

Path Logs > Local > Display button (after selecting a log)

Type of use Display + interactive

Reference Project

The logs you selected in the Show dropdown list of the Logs from Local LogPool window are dis-
played in this window.

Log display window example: Shadow Impact Log 

The information, options or buttons are described in the following table

Element Explanation

Settings area

In this drop-down list, you can specify in which language the log
should be output. In all cases, the Program language option (report
language = language of the SM4user interface) can be selected. The
other languages available depend on the supported languages.
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Element Explanation

Here you can specify whether the log should be displayed/printed in
Landscape or Portrait format.

Use all legends As e.g. the name of a POI/WTG can change over the course of time,
there may be several legends for a POI/WTG, as applicable. If this
option has been selected, the Legend tab will display older legends
will be displayed. Otherwise, only the latest legend will be displayed.

Auto width If you select this option, all hidden columns will be automatically distri-
buted over the available width.

Show max. width If you a) have not activated the Auto width option and b) have so ma-
ny hidden columns that they cannot easily fit on one page, all the
columns moved to the next page will be highlighted in grey on the
screen. 

Color When this option is activated, all colors assigned to events File > App-
lication Settings > Display filters > Operation log/ Shadow impact log
/...  are shown (it can be seen in the example window on the previous
page that the Sunset event has been assigned the color yellow). 

Information on assigning colors can be found in section Application
Settings window, Display filters .

Export area

Cover sheet When activated, a cover page is generated for the log.

Legend When activated, an explanation of the abbreviations of the places of
immission is provided at the end of the log (address, e.g. 1 ABC
Street, 12345 ABC City). 

Print filter When activated, the filter that was used is listed at the end of the log
(File > Settings > Display filter > Operation log/ Shadow impact log/
...  ) see Application Settings for Display filters, section Display fil-
ters .

Opens the preview window of the log. 

Is used to print the log using a printer connected to SM4.

Is used to save the log as a PDF.

For exporting in .csv format; e.g., for external analyses.
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Element Explanation

Exports the log as an .xlsx file that can be opened with Microsoft Offi-
ce 2007 and later versions (the colors are also exported).

Notes regarding the log display window (Operation Log/ Shadow Impact Log/ Shutdown Log)

· Only the log events that are assigned in the respective filter in the Application Settings (File >
Application Settings> Display filters) are displayed in the Shutdown log. They are displayed in
the log under the same term that is displayed in the Event column.

· What you see is what you get: The log is printed out/saved as a PDF exactly as displayed here.

· Move columns: Columns can be moved by drag & drop.

· Sort by column: You can sort a column according to its heading by clicking on it. If you then click
again on the same column heading, the sort sequence will change from ascending to descen-
ding or vice versa.
You can also sort by more than one column heading (criteria). To do this, first press and hold
the shift key and then click on the desired column headings. The sorting will be carried out
according to the order in which you click on the column headings.

· Hide/show columns: Columns can be hidden/shown, see the next page.

· Column filters: Filters can be applied to columns, see section Apply log column filter .

· In the Shutdown Log window, there are dynamically created columns in addition to the stan-
dard columns. This is described under Dynamically created columns in the Shutdown Log .

· If you notice that the font of some entries in the log is not black but colored, they may have
been downloaded incorrectly from the SMU.

· If you right-click on a Shadow Impact Log event, you will open a window with further details,
see the following example:

Event Description window
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4.7.1.2.1 Hide/show log columns

To hide/show columns in the Operation Log/ Shadow Impact Log/ Shutdown Log windows, click
on the asterisk * at the top left of the Log tab. A list of possible column headings will then be
shown, see the following figure.

Hide/show log columns

Each column can be hidden/shown as desired by selecting and deselecting the individual column
headings.

4.7.1.2.2 Apply log column filter

The column headings of the log are provided with a filter function, which you can use as follows:

Move the mouse cursor to the top right-hand corner of a column heading until a small filter symbol
 appears. Click on the filter symbol. A list of possible entries will then be shown.

Column filter

Now set a checkmark next to the desired events. Only selected events are displayed afterwards.
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4.7.1.2.3 Dynamically created columns in the Shutdown Log

In the case of the Operating Log and Shadow Impact Log, the SMU determines which values
(readings) are logged in connection with an event. In the case of the Shutdown Log, on the other
hand, further reading points can be recorded in addition to these "standard values" in connection
with an event. The following reading points are available:

· Default reading points
These reading points are permanently stored in SM4 and cannot be changed or deleted by the
user. This ensures that the most important reading points are always recorded in the log.

· Condition reading points
These reading points were used when defining shutdown conditions and can only be edited the-
re. With the help of condition reading points, the log can show why a WTG was switched off at
a certain time, e.g. because the hygro-thermo sensor exceeded a certain temperature. This ma-
kes much more sense if there are several conditions: the log will then also reveal which of
conditions led to the stop (e.g. temperature or humidity or wind speed).

· User-defined reading points
The user can add these reading points as required. User-defined calculations (Switching & Mea-
surement > Calculations) can serve as a reading here. Reading points that are already included
in the default or condition reading points cannot be added again.

For the standard reading points there are fixed columns in the log display window Shutdown Log,
which are displayed in the table area Values. Condition reading points as well as User-defined
reading points are displayed under User Defined Reading points. These columns are created dy-
namically as required. See the following example:

The columns in the table area User Defined Reading points were created dynamically, because

· reading points of the same name are part of a defined special shutdown or night slice shutdown
or because they were added as User-defined reading points in the Events window, and

· values were actually logged in the selected period.
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4.7.2 Log Statistics Main Menu

Purpose Generate, display/export/print log data statistics

Path Logs > Local Log Files > Log Statistics button 

Usage type Display + dialog

Reference Project

Log Statistics can be used to answer the following and other questions:

How long was a WTG shut down during the analysis period and why (due to, e.g. shadow impact,
bat protection or bird protection)?

How long was a POI affected by shadow impact from which WTG?

How much kWh of loss of earnings occurred at a WTG and why (due to, e.g. shadow impact, bat
protection or bird protection)?

Which POI caused which downtimes?

The Log Statistics functionality analyzes log data for one or more months (analysis period). Wind
park operators can also use these evaluations to analyze the extent to which the yield report prepa-
red for the planning of their wind park corresponds to reality.

 Analysis period

· comprises at least one, but usually several monthly logs,

· always begins on the first day of its first month and always ends on the last day of its
last month, provided that log entries are available through to the last day of the month,

· may include more than one configuration, i.e., the configuration that was loaded on the
SMU at the beginning of the analysis period may have been replaced one or more
times by modified configurations during the course of the analysis period.

Basic operation

To prepare the generation of log statistics, proceed as follows:

8 Open the Logs from local LogPool window (Logs > Local log files).

8 Select a project at the top left of the window.

8 Click on List.

8 Define the analysis period in the lower half of the window (select one or more months).

8 Click on Log Statistics.

The Log Statistics Main Menu window now opens: The 6 steps that are carried out to generate
the log statistics are listed at the top. In the large area below, the display changes depending on
which of the 6 steps you are at. 

You will initially see the following view:
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Log Statistics Main Menu window – Step 4: Configuring analysis...

When the window opens, Step 4 is displayed (see screenshot above) because the first 3 steps run
automatically. 

In the simplest case, just click Next once. Step 5 then runs automatically, and you will next see the
results (Step 6) and can export and/or print them, see the following example:

Log Statistics window – Step 6: Results

This much for the general process of generating log statistics. Below you will find a brief description
of the individual steps.
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Step 1 Logs loaded

As soon as you have selected a project's monthly logs in the Logs from local LogPool window and
clicked on Log Statistics, the loading process runs automatically. The process can be waited for or
canceled. 

Step 2 Match of WTG counters

SM4 creates a unique counter (see info box below) for each object (each WTG), at which, e.g., all
downtimes of a WTG are totaled. If the analysis period covers more than one configuration, SM4
ensures in this step that the downtimes of a specific WTG are always totaled by the same (unique)
counter across all configurations. This process is called automatic matching.

NOTE

In many cases, automatic matching is completely sufficient. However, if, for example, the coordinate
format has been changed within the analysis period, it may be necessary to edit the automatic mat-
ching results manually. Further information on this can be found under Match of WTG Counters
(Step 2) .

Counters in the generation of Log Statistics

To generate Log Statistics, SM4 analyses one or more monthly logs (analysis period)
that you have previously downloaded from the SMU. To do this, SM4 creates a counter
for each object (each POI and each WTG), the number of which may or may not corre-
spond to the respective POI No. or WTG No. used in the configuration. SM4 then assigns
the relevant log values to the respective categories of a counter, e.g. shadow impact
load and preload for POI counters or shutdown duration and loss of earnings for
WTG counters. The values from the logs are summed up in these categories.

Step 3: Match of POI counters 

SM4 creates a unique counter (see info box above) for each object (each POI), at which, for exam-
ple, all load times of a POI are totaled. If the analysis period covers more than one configuration,
SM4 ensures that the load times of a specific POI are always totaled by the same (unique) counter
across all configurations. This process is called automatic matching.

NOTE
In many cases, automatic matching is completely sufficient. However, if, for example, a new wall
has been added to an POI within the analysis period, it may be necessary to edit the automatic
matching results manually. Further information on this can be found under Match of POI Counters
(Steps 3) .
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Step 4: Configuring analysis

User mode
Here you can activate the Expert mode in order to be able to go back to steps 2+3. Please note
the notes above.

Loss-of Earnings Calculation Method

Here you can select which method is to be used to calculate the current power values of the WTGs.

1. Use measured power at shutdown time
The simplest method: SM4 assumes that the power value measured before a shutdown re-
mains constant for the duration of the shutdown.

2. Use calculated power without cyclic wind logs
SM4 can adjust the power value measured before a shutdown according to changing wind
conditions during the course of the shutdown in order to achieve more accurate results.
Such an adjustment requires current wind values, which are measured and provided by so-
called intermediate events.

Possible intermediate events are 

· in addition to the original stop event, there is another cause for a stop

· a new night slice begins

Each intermediate event signals that the SMU is running and provides a current wind value.
SM4 then uses this wind value and the corresponding power value from the power curve to
calculate the future loss-of-earnings

3. Use calculated power with cyclic wind logs
The most accurate method: In addition to the wind values from the stop log entries, SM4 al-
so uses entries of the nacelle wind speed from a Single Data Recording and/or a Cyclic
Multi Data Recording to continuously update the "lost power" during a shutdown.

Method 1 may be sufficient for projects that only contain SW shutdowns.

Method 2 may be suitable for bat shutdowns with night windows. 

Method 3 is by far the most accurate method.

NOTE 1

To use methods 2 and 3, you must first enter or assign power curves. Further information on this
can be found in the Edit Power Curves  section.

NOTE 2

Single Data Recording or Cyclic Multi Data Recording must have been configured before the start
of the analysis period, see Single Data Recordings window  or Cyclic Multi Data Recordings
window .
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Step 5 Analysis

The analysis can be canceled in the same way as loading of the logs. The preceding steps may
then have to be repeated or modified.

Step 6 Show and export results

Information on Step 6 can be found directly below in the Analyisis results  section.

GENERAL NOTE

When creating log statistics, always ensure that each monthly log has been downloaded comple-
tely from the SMU, i.e., at the end of each month.

Reason: SM4 Log Statistics must take into account every configuration change made during a
month. This is the only way SM4 can assign log values to the counter of the correct object
(WTG/POI) and add them up correctly. Further information on matching counters can be found
under Match of WTG/POI Counters (Steps 2+3) .
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4.7.2.1 Log Statistics flowchart

The following flowchart shows how to generate the log statistics. Activities carried out by the user
are shown in green boxes, processes carried out by SM4 are shown in blue boxes. For further infor-
mation on individual sections of the process, please refer to the links below the chart (Ref. 1,
Ref. 2...)

Links to further information:  

 REF 1     REF 2    Ref. 3      REF 4    REF 5370 373 393 376 433
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4.7.2.2 Analysis results

Once you arrive at step 6 of the Log Statistics generation, you will see a window like the following:

Step 6, Analysis results (Fig. does not show all tabs)

You will find a description of the two buttons in the following table.

Field/ But-
ton

Explanation

Click here to export the data to as many CSV files as there are tabs.

When you click on this button, a window opens in which you can select or deselect
the tabs with the various analysis results. 

Beyond that, you can also choose to have the following information included:

 

Check this box if you want to print an overview of the event numbers used and
their replacement events.

Check this box if you want to print an explanation of the calculation method se-
lected in step 4 (Log Statistics Main Menu) .

Anything that is not self-explanatory in the tabs of the analysis results is explained in the following
sections.
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4.7.2.2.1 "Cover Page" tab

The cover page of the analysis results looks like this:

Step 6, Results: "Title page" tab

Notes on the "Cover Page" tab

The cover page first shows the analysis period (November 2017 in the example above). The num-
ber of POIs and WTGs shown below the wind park name (Casablanca) corresponds to the number
of unique counters:

Number of places of immission
(POI)*

= number of unique POI counters in the analysis period =
number of counters in the SI Load per POI tab

Number of wind turbines generators
(WTG)*

= number of unique WTG counters in the analysis period =
number of counters in the SI Downtimes tab

Preloading WTGs thereof = refers to the load from legacy or third-party WTGs (see
also info box below)

*The information may or may not correspond to the actual number of POIs/WTGs in the wind park.
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Example: 

A wind park comprises as much as 19 POIs at the start of an analysis period. Over the course of
the analysis period, one POI is removed and four new ones are added. Although there were never
more than twenty-two POIs at any time, the cover page in this case reads: 

Number of places of immission (POI): 23

Legacy WTG = WTG with priority right to claim shadow impact budget.

Third-party WTG = WTG from another wind park that can cause shadow impact at
POIs of your own wind park.
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4.7.2.2.2 "SI Load per POI" tab

The shadow impact at each POI is shown here. 

Below you will find an explanation of the individual  columns  of the tab.

Number of POI (No. of Counter)

= number according to the latest configuration in the full list of counters in the analysis period

If a POI number is marked with an asterisk, there have been changes in the Match History that have
been ignored. For further information on "matching", please refer to Match of WTG/POI Counters
(Steps 2+3) .

The ignored changes are listed in the WTG and POI Changes tab:

Note that often, the POI number and counter number are not identical. Hence you should use the
POI number as a guide in this tab. In this example, you would unfold counter No. 24 for POI No. 1
and see the following information:

 Street + Postal Code and City 

= Street + zip code and city according to the most recent configuration for easier identification
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NOTE

The times added up in the next columns of the SI Load at POI tab are based on the following
log events which relate to the actual shadow impact: 

117* Shadow impact occurs

118 Shadow impact leaves

If a POI is impacted by more than one WTG (multiple shading), this is counted once here.

*This and all subsequent three-digit event numbers may be shown with trailing zeros (e. g. 117.00000) in other parts of the
shadow impact and species conservation system.

 Load with Preload 

= total load duration of the POI accurate to the second

 Load without Preload 

= additional load = total load minus preload due to legacy or third-party WTGs.

NOTE

A mixed load of preload and additional load is also analysed as additional load. Reason for this: The
preloading WTGs could be shut down due to shadow impact – the additional load would then be the
deciding factor for the load duration.

 Preload 

= load caused by legacy or third-party WTGs

Legacy WTG = WTG with priority right to claim shadow impact budget.

Third-party WTG = WTG from another wind park that can cause shadow impact at
POIs of your own wind park.

Aborted SI Periods w or w/o Preload

= SI periods that were aborted by so-called replacement events (e. g. restart of the SMU). Since it
is not known as for how long a shadow impact event that was aborted by a restart of the SMU ac-
tually lasted, the times are added up in this separate counter category.

For this unclear load caused by replacement events, too, a distinction is made between total load
(with preload) on the one hand, and load without pure preload situations on the other. 

NOTE

If you check the Explanations of Event Numbers box in the Print Statistics window (Print Menu
button), you will find an explanation of the replacement events at the end of the preview or print
version. 
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4.7.2.2.3 "SI Downtimes" tab

The downtimes of the WTGs due to shadow impact are shown here – without reference to specific
POIs. 

Below you will find an explanation of the individual  columns  of the tab. 

 WTG No. (No. of Counter) 

= number according to the latest configuration in the total list of counters in the analysis period

If the WTG No. is marked with an asterisk, then there were changes in the match history that were
ignored. For further information on "matching", please refer to Match of WTG/POI Counters (Steps
2+3) .

The WTG and POI Changes tab lists the ignored changes, see the information on the latest WTG
No. 2 in the following example:

WTG No. and Counter No. are identical here, but often, this is not the case. Use the WTG num-
ber as a guide here. The asterisk in the first screenshot is a reference to the the fact that there was
a change which was ignored during automatic matching by SM4.

 Identifier  

= WTG identifier according to the latest configuration for easy identification

 Downtime  

The values in this column do not indicate as to how many or which POIs were affected by shadow
impact. Therefore, only the following events have been used:

151 WTG stop due to shadow impact occurs*
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152 WTG stop due to shadow impact leaves

These events do not relate to a specific POI.

*These and all subsequent three-digit event numbers may be displayed with trailing zeros (e.g. 117.00000) in other parts of the
shadow impact and species conservation system.

 Loss of Earnings [kWh] 

= calculation of the energy a WTG could have generated had it not been shut down

The method used by SM4 to calculate the loss of earnings depends on the option selected in step 4:

1. Use measured power at shutdown time
The simplest method: SM4 assumes that the power value measured before a shutdown re-
mains constant for the duration of the shutdown.

2. Use calculated power without cyclic wind logs
SM4 can adjust the power value measured before a shutdown according to changing wind
conditions during the course of the shutdown in order to achieve more accurate results.
Such an adjustment requires current wind values, which are measured and provided by so-
called intermediate events.

Possible intermediate events are 

· in addition to the original stop event, there is another cause for a stop

· a new night slice begins

Each intermediate event signals that the SMU is running and provides a current wind value.
SM4 then uses this wind value and the corresponding power value from the power curve to
calculate the future loss-of-earnings

3. Use calculated power with cyclic wind logs
The most accurate method: In addition to the wind values from the stop log entries, SM4 al-
so uses entries of the nacelle wind speed from a Single Data Recording and/or a Cyclic
Multi Data Recording to continuously update the "lost power" during a shutdown.

 Downtime –  Aborted Events 

Shutdown times due to events that were interrupted by so-called replacement events (e.g. restart of
the SMU).

As it is not known how long an event interrupted by a restart of the SMU actually lasted, the values
are summed up in these separate counter categories.

 Loss of Earnings due to Aborted Downtime Events 

Loss of earnings due to events that were interrupted by so-called replacement events (e.g. restart
of the SMU).

Since it is not known as to how long an event interrupted by a restart of the SMU actually lasted, the
values are summed up in these separate counter categories.
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 Source of Loss-of-Earnings Calculation 

Depending on the calculation method selected in Step 4, see also Loss of Earnings above, this
column contains one of the following entries:

meas. based only on measured power 

wind calculated power based on measured wind and power curve

mix calculated and measured power (only possible for shadow impact)
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4.7.2.2.4 "SI Load Matrix" tab

The individual pairs of the WTG-POI combination matrix are listed here one below the other. When
the rows are collapsed, the POI number plus address is shown (see explanation of the SI Load per
POI tab above); when a row is expanded, SM4 will list only those WTGs that actually contribute to
the load. 

Below you will find an explanation of the individual  columns  of the SI Load Matrix tab.

 WTG No. (No. of Counter) 

If a number is marked with an asterisk, then there have been changes in the match history that were
ignored here – these are listed in the WTG and POI Changes tab. For further information on "mat-
ching", please refer to Match of WTG/POI Counters (Steps 2+3) .

 Identifier  

The WTG identifier of the latest (most recent) configuration is specified here.

 Load per Pair  

The WTG and POI-related events 117/118 (Shadow impact occurs/leaves) are used for the load
duration. If a WTG has already been stopped for another reason at the time of the "occur" event
(117), there is no actual shadow impact.

 Downtime 

= POI-related downtimes of the WTGs

This is based on the following events: 

· 121/122 Shadow impact stop due to daily counter [occurs/leaves]*

· 123/124 Shadow impact stop due to annual counter [occurs/leaves]

· 125/126 Shadow impact stop due to daily counter with preload [occurs/leaves]

· 127/128 Shadow impact stop due to annual counter with preload [occurs/leaves]

· 129/130 Shadow impact stop due to power [occurs/leaves]

· 131/132 Shadow impact stop due to phone option [occurs/leaves]
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These events can accumulate if the stop has not yet been completed for some other reason. In this
case, the stop event begins with the first Shadow impact stop ... occurs and ends with the last
Shadow impact stop ... leaves.

*These and all subsequent three-digit event numbers may be displayed with trailing zeros (e.g. 117.00000) in other parts of the
shadow impact and species conservation system.

 Loss of Earnings [kWh]  

The time from the first "…Stop ... occurs" event to the last "…Stop ... leaves" event is used as the
duration for calculating the loss of earnings. 

The method used by SM4 to calculate the loss of earnings depends on the option selected in step 4:

1. Use measured power at shutdown time
The simplest method: SM4 assumes that the power value measured before a shutdown re-
mains constant for the duration of the shutdown.

2. Use calculated power without cyclic wind logs
SM4 can adjust the power value measured before a shutdown according to changing wind
conditions during the course of the shutdown in order to achieve more accurate results.
Such an adjustment requires current wind values, which are measured and provided by so-
called intermediate events.

Possible intermediate events are 

· in addition to the original stop event, there is another cause for a stop

· a new night slice begins

Each intermediate event signals that the SMU is running and provides a current wind value.
SM4 then uses this wind value and the corresponding power value from the power curve to
calculate the future loss-of-earnings

3. Use calculated power with cyclic wind logs
The most accurate method: In addition to the wind values from the stop log entries, SM4 al-
so uses entries of the nacelle wind speed from a Single Data Recording and/or a Cyclic
Multi Data Recording to continuously update the "lost power" during a shutdown.

 Duration of Aborted SI  

Shadow impact from events that were interrupted by so-called replacement events (e.g. restart of
the SMU).

As it is not known how long a shadow impact event interrupted by a restart of the SMU actually las-
ted, the values are summed up in this separate counter category.

 Downtime due to Aborted Events 

In the event of an abortion (e. g. restart of the SMU), the last accumulated duration of the ongoing
overall event is recorded by this counter. 

In the case of intermediate events, the previous duration is added up and recorded by the regular
counters (Downtime).

 Loss of Earnings due to Aborted Events  

In the event of an abortion (e. g. restart of the SMU), the last accumulated loss of earnings of the
ongoing overall event is recorded by this counter. 
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In the case of intermediate events, the previous loss of earnings is added up and recorded by the
regular counters (Loss of Earnings).

Total rows in the "SI Load Matrix" tab

At the end of each (expanded) detail block, the Total of all WTG is displayed, see the following ex-
ample:

· The Matrix Total of all POIs and WTGs is displayed at the bottom, see the following example:

Please also note the following information on the subject of totals rows.
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NOTE

The total specified in the totals rows (detail blocks and at the bottom of the tab) is a calculated
total.

If several WTGs cast shadow to one POI at the same time (multiple shading), the calculated
shadow impact (SI Load Matrix tab) can be greater than the actual load (SI Load per POI tab).

Example:

(Only the last three POIs of a wind park are shown in the two screenshots).

Explanation
The (calculated) total of the Load per Pair in the SI Load Matrix tab is greater here than the sum
of the actual Load with Preload in the SI Load per POI tab.

Reason
If a POI is shaded by two WTGs over a period of e.g. 15 minutes, then the counter category
Load with Preload in the SI Load per POI tab only records the effect, namely 1 x 15 minutes,
while the counter category Load per Pair in the SI Load Matrix tab records both causes and in-
creases the counter by 2 x 15 minutes.

Similarly, if a WTG shades more than one POI at the same time, the calculated downtime duration
can be longer than the actual downtime duration. See SI Downtimes tab.
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4.7.2.2.5 "Calendar Shutdown" tab

The downtime and loss of earnings of the WTGs due to a shutdown calendar are shown here.

The events 200.xxxxx and 201.xxxxx are purely WTG-related, the sub-events "xxxxx" are ignored. As
usual, the downtime and the loss of earnings are derived from the log entries that are triggered by a
shutdown calendar. Overlaps with other events are not checked.

NOTE
This tab will not be displayed if the underlying configuration does not contain any shutdown calendar
entries.

4.7.2.2.6 "Bat Shutdown" tab

The following events from the special shutdown log (SP log) are relevant here:

1.000.001/ 1.000.002 WTG stop due to bat protection occurs/leaves

1.000.011/ 1.000.012  WTG stop due to bat protection (time slice) [occurs/leaves] 

Aborted periods are listed separately (as in the other tabs).

For events with No. 1.000.011, the shutdown conditions vary according to the night time slice. In ad-
dition, night slice changes (1.000.041) are used as intermediate events to update the power loss.
Only for calculation methods 2 and 3, see above.
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4.7.2.2.7 "Bird Shutdown" tab

The following events from the special shutdown log (SP log) are relevant here:

2.000.001/ 2.000.002  WTG stop due to bird protection [occurs/leaves] 

2.000.011/ 2.000.012  WTG stop due to bird protection (time slice) [occurs/leaves] 

Aborted periods are listed separately (as in the other tabs).

The loss of earnings is determined in the same way as for bat protection. Here too, it is possible to
use the calculated power from the measured wind and power curve.
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4.7.2.2.8 "Match History WTG" tab

NOTE

This tab is only displayed if you have selected Expert mode in step 4.

You will initially see a list like the one below (extract only):

In this example, an asterisk (*) indicates that one or more changes have been made to the object
behind counter No. 3. To determine the type of difference in such a case, click on the small triangle
at the beginning of the row or on the Expand All button to see a list like the one in the following ex-
ample:

Here you can see, among other things:

· the ignored change refers to the WTG identifier (in configurations 21 to 24 it is "222224" while in
the latest configuration it is "111113")

· the WTG expanded here was added to the configuration later than others (configurations 1 to 20
are missing from the list)

If, unlike in the example above, the identifiers are identical for all configurations, then there must
have been some other change. In this case, or if more than one ignored changes are displayed, you
will find more information in the WTG and POI changes tab.
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4.7.2.2.9 "Match History POI" tab

NOTE

This tab is only displayed if you have selected the Expert mode in Step 4

In this table, you will first see a list like the following (extract only):

In this example, you can see that 2 changes have been ignored for counter No. 3. To determine the
type of changes, click on the small triangle at the beginning of the row to see a list like the one in
the following example:

Here you can recognize, among other things:

· the ignored changes refer to the name and address of the POI
· the POI shown here was added to the configuration later than others (configurations 1 to 9 are

not in the list)

If, unlike in the example above, the addresses are identical for all configurations, then there must be
some other change. In this case, or if more than two ignored changes are displayed, you will find
more information on this in the WTG and POI changes tab.
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4.7.2.2.10 "WTG and POI Changes" tab

In this tab, you will find further information on changes to the WTG and POI properties that were
detected during the matching process. Right-click to expand or collapse all sub-branches, see the
following example:

For example, you can see here that the WTG Identifier of WTG No. 3 was changed from "123456"
to "234567" in Configuration 12.
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4.7.2.3 Match of WTG/POI Counters (Steps 2+3)

In this chapter we will answer, e.g. the following questions:

· Why are there counters in the Log Statistics?

· Why do they have to be matched in some cases?

· How does the automatic matching carried out by SM4 work?

· How can I edit the matching of WTG counters manually?

· How can I edit the matching of POI counters manually?

Counters in the generation of Log Statistics

To generate Log Statistics, SM4 analyses one or more monthly logs (analysis period) that you
have previously downloaded from the SMU. To do this, SM4 creates a counter for each object
(each POI and each WTG), the number of which may or may not correspond to the respective POI
No. or WTG No. used in the configuration. SM4 then assigns the relevant log values to the respecti-
ve categories of a counter, e.g. shadow impact load and preload for POI counters or shutdown
duration and loss of earnings for WTG counters. The values from the logs are summed up in the-
se categories.

 Analysis period

· comprises at least one, but usually several monthly logs,

· always begins on the first day of its first month and always ends on the last day of its
last month, provided that log entries are available through to the last day of the month,

· may include more than one configuration, i.e., the configuration that was loaded on the
SMU at the beginning of the analysis period may have been replaced one or more
times by modified configurations during the course of the analysis period.

Why might it be necessary to match the counters?

If the SMU has not been reconfigured during the analysis period, matching of counters is neither
possible nor necessary (neither automatically nor manually).

If the SMU was not reconfigured during the analysis period, matching of the counters
is omitted: Even if you select Expert mode in step 4, you cannot go back to steps 2
or 3.

However, the analysis period often includes more than one configuration, i.e. the configuration
that was loaded on the SMU at the start of the analysis period was replaced one or more times by
edited configurations. To ensure that, e.g., the shutdown duration of a WTG is always recorded by
the same counter across all legends, even if the WTG number or another property has been
changed, it is crucial that the objects are correctly linked from configuration to configuration.

If the analysis period comprises several configurations, matching of the counters ensures
that, for example, the shutdown duration of a WTG, and the shadow impact of a POI are
recorded by one and the same counter across all configurations. 



394Reference part > Logs menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

How does SM4 carry out automatic matching?

As soon as you initiate the generation of Log Statistics by clicking on Log Statistics in the Logs
from Local LogPool window, SM4 will load the selected logs (Step 1). 

SM4 then creates a unique counter for each object (each WTG and each IO) of the latest configura-
tion. SM4 uses the parameters WTG number and IO number of this latest configuration as a gui-
de, as these are always unique within a configuration. If SM4 determines that the analysis period
comprises more than one configuration, it automatically matches the WTG counters (Step 2) and
the POI counters (Step 3) from one configuration to the next.

SM4 must ensure that the WTG or POI number of the latest configuration is actually the same
physical object as in the previous configuration. In other words, e.g. the following question arises:

Is WTG 1 of the latest configuration the same object as WTG 1 of the immediately preceding
configuration, or do these two objects only have the same WTG number?

To answer questions like this, SM4 compares the properties of the individual objects, i.e., configura-
tion pair by configuration pair, and preceeding backwards in time.

Example: 
In the analysis period from March to October of a year, a SMU was reconfigured twice: on
May 15 and August 15.

Analysis period March to October

March April May June July to Aug. Sept Oct.

Configuration 1: earliest
configuration, loaded before
March 1., valid from start of
analysis period to May 15.

Configuration 2: second earliest
configuration, loaded on May 15,

valid from May 15. to Aug 15.

Configuration. 3: latest
configuration, loaded on

Aug 15, valid from Aug. 15
to end of analysis period

This analysis period comprises 3 configurations, and there are 2 configuration pairs whose ob-
jects SM4 must compare: 

· the objects of configuration 3 to the objects of configuration 2

· the objects of configuration 2 to the objects of configuration 1

During automatic matching, SM4 compares the coordinates of the objects of each configuration
pair to each other. If they match, SM4 links, for example, WTG 1 from configuration 3 with
WTG 1 from configuration 2. 

The coordinates of two WTGs are considered to be the same if the deviation of the tower
center coordinates does not exceed the tolerated "snap radius" of 0.5 m.

The fact that SM4 evaluates backwards in time has the advantage that the counter num-
bers used by Log Statistics are as similar as possible to the WTG and POI numbers of the
latest configuration, regardless of whether properties have been changed or new counter
numbers have been created.
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Following this general description of the matching of WTG counters (Step 2) and POI counters
(Step 3), you will find a description of the individual areas for WTGs and POIs separately in the next
sections, each followed by examples. 

GENERAL NOTE

When creating log statistics, always ensure that each monthly log has been downloaded comple-
tely from the SMU, i.e., at the end of each month.

Reason: SM4 Log Statistics must take into account every configuration change made during a
month. This is the only way SM4 can assign log values to the counter of the correct object
(WTG/POI) and add them up correctly. Further information on matching counters can be found
under Match of WTG/POI Counters (Steps 2+3) .393
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4.7.2.3.1 Match of WTG Counters (Step 2)

To get to the Log Statistics Main Menu – Step 2 window, first activate Expert mode in Step 4
and then click twice on the Back button at the top right of the window.  

If the SMU was not reconfigured during the analysis period, matching of the counters
is omitted: Even if you select Expert mode in step 4, you cannot go back to steps 2
or 3.

Log Statistics Main Menu window, example: Step 2 – Match of WTG counters 

What is not self-explanatory in the four tables of step 2 Match of WTG counters is explained in the
following table using the example above.

Table A - Configurations within the Analysis Period

Column title Explanation

Config Pair No. = consecutive numbering of the configuration pairs in the analysis period

The timestamp of a configuration and the timestamp of the subsequent
configuration together form a configuration pair. The highest number in
this column corresponds to the number of configuration pairs the analy-
sis period comprises. This number + 1 in turn corresponds to the number
of configurations the analysis period comprises.

Timestamp of  
Config. A

Time stamp of  
Config. B

November 2018 was selected as the analysis period in the example
shown above. The Timestamp of Config. A of the first configuration pair
is not 2018-11-01, however, but has an earlier date (2018-09-05), which
corresponds to the time at which the SMU was last configured before
Nov. 1, 2018. 



397Reference part > Logs menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

The Timestamp of Config. B of the first configuration pair (2018-11-07)
corresponds to the time at which the SMU was configured for the first
time in November 2018. 

In the same way, the last timestamp in the Timestamp of Config. B
column does not date from the last day of the analysis period, but
corresponds to the date of the latest reconfiguration carried out within
the analysis period.

Total No. of 
Changes

= number of changed properties SM4 found while comparing all WTGs
from Config. A and Config. B. If you select a row in which a number of
changes found is specified in this column, the affected WTGs will be lis-
ted in Table B.

In the example above, the third configuration pair is focused – the num-
ber of changes (3) is also indicated in Table B under Total.

Number of Identical
WTGs

= number of WTGs for which SM4 did not find any differing properties
when comparing all WTGs from Config. A and Config. B.

Status There are four possible entries in this column - they provide a better
overview when the statistics are called up again:

autom.
con-
firmed

When automatically comparing all WTGs from Config. A and
Config. B, SM4 did not find any differing properties. (automa-
tically confirmed without user)

manually A user has manually re-matched a configuration pair in
tables B and C, see below.

un-
con-
firmed

SM4 has made an initial automatic matching, or a user has in-
itiated an automatic re-matching for the respective configura-
tion pair. (The latter is only possible after manual matching:
right-click in the respective line and select Auto-Match WTG
List anew, see further down).

manually
con-
firmed

A user has manually confirmed an "unconfirmed" matching.

Date of confirm. If a user manually edited the automatic matching as described above, the
date of execution is noted here.

User If a user manually edited or confirmed the automatic matching as descri-
bed above, their name and dongle number are noted here.

How to carry out re-matching in table A

If you have made manual changes to the automatic matching carried out by SM4, you can undo
these by right-clicking in the row of the desired configuration pair in Table A and selecting Auto-
Match WTG Lists anew. The automatic matching is then repeated based on coordinates compa-
rison.
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Table B – WTG Lists of configuration pair

If data is displayed here, a configuration pair is currently selected in Table A for which SM4 has
found differing properties; the corresponding WTGs are listed here.

The details of the WTGs of the WTG pair focused here are displayed in Table D. If you right-
click on a row in Table B, you can choose Unmatch WTG Pair.

Column Explanation

No. in Match List = internal consecutive number assigned by SM4 to the WTG pair during
automatic matching.

WTG No. from 
Config. A row x

= WTG number according to Config. A of the configuration pair focused
in table A.

WTG No. from 
Config. B row x

= WTG number according to Config. B of the configuration pair focused
in table A.

No. of Changes = number of changed properties; these are highlighted in yellow in
table D.

Table C – Unpaired WTGs

Unpaired elements of the more recent configuration B are listed here if any have been separated
in table B or new WTGs have been added.

An element listed here can be dragged 'n' dropped to an unpaired element in Table B and relea-
sed there to create a manual matching. 
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Table D -– Properties of WTGs of Focused Pair

The properties of the row focused in Table B are displayed here (in the example above those the
first row).

You can also place properties of a "possible pair" next to each other here as follows:

8 Select a row in table B in which the WTG No. from Config. B column is empty (unpaired),
and click on an unpaired element in table C.

The pairing will not yet be established, but be displayed in table D as a possible pairing.

Match Lists buttons

 

When you leave Step 2, you will be asked whether you want to save any changes you have made
(unless you have already clicked on this button). If you answer with No, the changes you have
made will still remain loaded. If you then save in Step 3, the changes from Step 2, which you may
have already exited without saving, will also be saved.

Saving here means that a file with all matches, whether automatically found and confirmed, or
made manually, is saved in the project directory of the LogPool so that they are retained for a
possible new run of the Log Statistics generation.

If you click on this button, a dialog box opens in which you can confirm or cancel the deletion of all
match lists. We strongly recommend deleting all match lists before you work on a new analysis
period.

Please remember that you must select an analysis period that comprises more than one configu-
ration in order to be able to go to Steps 2 and 3 (see also Match of WTG/POI Counters (Steps
2+3) ).

NOTE

The automatic or manual pairwise matching of POIs will result in a chaining that you can only view in
Step 6. For further information, please refer to the Analysis results  section.

393
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Example 1: WTG properties unchanged

Conditions

· The SMU was reconfigured once during the analysis period, but no WTG properties were
changed.

· The monthly logs from 2020/04 to 2020/08 were selected in the Logs from Local LogPool
window.

· After clicking on Log Statistics, selecting the Expert user mode (step 4) and clicking on Next,
the following is displayed in the Match History WTG tab of Step 6 (results):

Here you can see that four WTG counters have been created, each corresponding to the object's
WTG No. in the latest configuration, and no changes were made to the WTG properties in the
match history, i.e. between the two configurations (none of the counters are marked with an aste-
risk (*) and Number of Changes in the history = 0).

After clicking on Expand all, the following is displayed:

The only additional information of this expanded view: all 4 WTGs are included in both configurati-
ons.

You can now go to Step 2 by clicking Back 3 times to see the following:
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In this example, you can see in a different view what you have already recognized in the analysis re-
sults. However, you cannot edit anything here, as SM4 determined no changes when automatically
matching the WTGs. For a better understanding, however, here are a few explanations:

Configurations within Analysis Period area

· There is only 1 configuration pair because the SMU was reconfigured only once during the
analysis period from April to August 2020.

· At the beginning of the analysis period, the configuration dated on 2020-01-29 was active
on the SMU. The reconfiguration took place on 2020-07-09 and remained active until the
end of the analysis period (presumably also beyond).

· No WTG properties were changed during the reconfiguration, which is why the Total No.
of Changes = 0.

· Number of Identical WTGs = 4 means that the configuration only includes a total of
4 WTGs (as there are none with changed properties).

· Status: As there are no changed properties, SM4 automatically confirmed all assi-
gnments.
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Example 2: Disconnect WTG counters

Conditions

· The SMU was reconfigured 4 times during the analysis period, so that there are a total of 5 confi-
gurations.

· Only the monthly log 2018/11 was selected in the Logs from Local LogPool window.

After clicking on Log Statistics, selecting the user mode Expert (step 4) and clicking on Next, the
following is displayed in the Match History WTG tab of Step 6 (results):

Even in the view that is still collapsed, you can tell from the asterisks (*) that one change has been
determined for each of the counters 2, 3 and 4.

If you now expand counter No. 2, the following is displayed:

You can see that SM4 has assigned the WTG with the identifier 1112 from configurations 1 to 3 to
the same counter as the WTG with the identifier 11120 from configurations 4 and 5, presumably be-
cause their coordinates match.

If it is desired that the log values of the two WTGs (1112 and 11120) are totaled by one and the sa-
me counter, no further action is required. 

However, in some cases you may want to have the log values totaled by two different counters, for
example because the change in the identifier was based on a technical change to the WTG, the ef-
fects of which you would like to recognize. In this case, click Back 3 times to go to Step 2 – Match
of WTG counters:
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In the above view, configuration pair 3 has already been focused in area A, and No. 2 in the Match
List in area B, so that the WTG properties of the WTG for which you want to create a new counter
are displayed in area D.

Now right-click on the first row in area B and select Unmatch WTG Pair.

Areas B and C will then look like this:

The two WTG numbers have been separated. 

If you now click on Next, confirm the dialog for saving the match lists (in order to retain the separati-
on of the counters for future analyses), then click on Next twice more, the following will be dis-
played in the Match History WTG tab of Step 6 (results).

You can see here that a new counter (5) has now been created for the "old" WTG identifier (1112).
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4.7.2.3.2 Match of POI Counters (Steps 3)

To get to the Log Statistics Main Menu window – Step 3, first activate the Expert mode in Step 4
and then click on the Back button in the top right-hand corner of the window. 

If the SMU was not reconfigured during the analysis period, matching of the counters
is omitted: Even if you select Expert mode in step 4, you cannot go back to steps 2
or 3.

Log Statistics Main Menu window – example Step 3 



405Reference part > Logs menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

What is not self-explanatory in the four tables of step 3 Match of POI counters is explained in the
following table using the example above.

Table A - Configurations in the Analysis Period

Column Explanation

Config. Pair No. = Consecutive numbering of the configuration pairs in the analysis period

The timestamp of a configuration and the timestamp of the subsequent
configuration together form a configuration pair. The highest number in
this column corresponds to the number of configuration pairs the analy-
sis period covers. This number + 1 in turn corresponds to the number of
configurations the analysis period covers.

Timestamp of Config. A

Timestamp of Config. B

The month 11/2018 was selected as the analysis period for the example
shown above. The Timestamp of Config. A of the first configuration pair
is not dated on 2018-11-01, but has an earlier date (2018-09-05), which
corresponds to the time at which the SMU was last configured before
2018-11-01. 

The Timestamp of Config. B of the first configuration pair (2018-11-07)
corresponds to the time at which the SMU was configured for the first
time in November 2018. 

In the same way, the last timestamp in the Timestamp of Config. B
column does not date on the last day of the analysis period, but
corresponds to the date of the latest reconfiguration carried out within
the analysis period.

Total No. of 
Changes

= number of changed properties SM4 found when automatically compa-
ring all POIs from Config. A and Config. B. If you select a row in which
a number of differences found is specified in this column, the affected
POIs are listed in Table B.

In the example above, the second configuration pair is selected – the
number of changes can be found in Table B under Total.

Number of Identical POIs = number of POIs for which SM4 did not find any differing properties
when automatically comparing all POIs from Config. A and Config. B.

Status There are three possible entries in this column – they provide a better
overview when the Log Statistics are displayed again in the future:

autom.
con-
firmed

When automatically comparing all POIs from Config. A and
Config. B, SM4 did not find any differing properties. (automa-
tically confirmed without user)

manually A user has manually re-matched a configuration pair in
tables B and C, see description below.

un-
con-
firmed

SM4 carried out an initial automatic matching, or a user has
triggered an automatic re-matching for the respective configu-
ration pair (right-click in the respective line and select Auto-
Match POI Lists anew using…, see further information be-
low this table). 
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manually
con-
firmed

A user has manually confirmed an "unconfirmed" match.

Date of Confirm. If a user has manually edited the automatic matching as described abo-
ve, the date of execution is noted here.

User If a user has manually edited or confirmed the automatic matching as de-
scribed above, their name and dongle number are entered here.

Table B – POI Lists of Configuration Pair

If data is displayed here, a configuration pair is selected in Table A for which SM4 has found dif-
fering properties; the corresponding POIs are listed here.

The details of the POIs of the POI pair focused here are displayed in Table D.  If you right-click
on a row in Table B, you can select Unmatch POI pair.

Column Explanation

Match List Index = internal consecutive number assigned by SM4 to the POI pair during
automatic matching.

POI No. from Confg. A –
row x

= POI number according to Config. A of the configuration pair that is fo-
cused in Table A.

POI No. from Confg. V –
row x

= POI number according to Config. B of the configuration pair that is fo-
cused in table A.

No. of Changes = number of changed properties; these are highlighted in yellow in
Table D.

Table C – Unpaired POIs

Unpaired elements of the more recent configuration B are listed here if any have been separated
in table B, or if new POIs have been added.

An element listed here can be dragged 'n' dropped to an unpaired element in table B and in order
to create a manual match. 
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Table D – Properties of POIs of Focused Pair

The properties of the POI pair focused in Table B are displayed here, in the example above those
of pair 1.

You can also place properties of a "possible pair" next to each other here as follows:

8 Select a row in Table B in which the POI No. from Config B is empty, and click on an unpai-
red element in Table C .

The pairing will not yet be established, but is displayed in Table D as a possible pairing.

 Match Lists buttons

 

When you leave step 3, you will be asked whether you want to save any changes you have made
(unless you have already clicked on this button). If you answer with No, the changes you have
made will still remain loaded. If you then save in step 2, the changes from step 3, which you may
have already exited without saving, will also be saved.

Saving here means that a file with all matches, whether automatically found and confirmed or
made manually, is saved in the project directory of the LogPool so that they are retained for a
possible new run of the Log Statistics generations.

If you click on this button, a dialog box opens in which you can confirm or cancel the deletion of all
match lists. We strongly recommend deleting all match lists before you work on a new analysis
period.

Please remember that you must select an analysis period that comprises more than one configu-
ration in order to be able to go to Steps 2 and 3 (see also Match of WTG/POI Counters (Steps
2+3) ).

Re-Matching in table A

If you want to repeat the automatic matching carried out by SM4 based on different criteria, right-
click in Table A in the row of the desired configuration pair and select Auto-Match POI Lists anew
using... The following window then opens:

Used Properties for POI Match window

393
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SM4 uses the criteria activated in the above window as standard for automatic matching. You can
deselect or select the displayed criteria.

Example
When changing the coordinate system, the address can be the decisive match criterion. In this case,
deselect all criteria under 3D Position, then activate Street, Postal Code and City instead to ob-
tain a new list at the touch of a button without having to match manually.

NOTE

The automatic or manual pairwise matching of POI results in a concatenation that you can only view
in Step 6 (results). Further information can be found in the Analysis results  section.376
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Example 1: POI properties unchanged

Conditions

· The SMU was reconfigured once during the analysis period, but no POI properties were changed.

· The monthly logs from 2020/04 to 2020/08 were selected in the Logs from Local LogPool
window.

· After clicking on Log Statistics, selecting the Expert user mode (step 4) and clicking on Next,
the following is displayed in the Match History POI tab of Step 6 (results):

Here you can see that 3 POI counters have been created, each corresponding to the POI No. of the
latest configuration, and that there no changes were made to the POI properties in the match histo-
ry, i.e. between the two configurations (none of the counters are marked with an asterisk (*) and
Number of Changes in the history = 0).

After clicking on Expand all, the following is displayed:

The only additional information of this expanded view: all 3 POIs are included in both configurations.

You can now go to step 3 by clicking Back twice to see the following:
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In this area, you will see in a different display what you have already recognized in the results. Ho-
wever, you cannot change anything here, as no changes were determined during the automatic mat-
ching of the POIs. For a better understanding, here are a few explanations:

Configurations within Analysis Period

· There is only 1 configuration pair because the SMU was only reconfigured once in the ana-
lysis period from April to August.

· At the beginning of the analysis period, the configuration from 2020-01-29 was active on
the SMU. The reconfiguration took place on 2020-07-09 and was active until the end of the
analysis period (presumably also beyond).

· No POI properties were changed during the reconfiguration, which is why the Total No. of
Changes column indicates 0.

· Number of Identical POIs = 3 here means that the configuration only includes a total of
3 POIs (as there are none with changed properties).

· Status: As there are no changed properties, SM4 has automatically confirmed all matches.
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Example 2: Connect POI counters

Conditions

· The SMU was reconfigured 4 times during the analysis period, so that there are a total of 5 confi-
gurations

· Only the monthly log 2018/11 was selected in the Logs from local LogPool window.

· At POI 11 (no. according to the latest configuration), a wall was re-measured during the analysis
period, so that the average wall coordinate has changed.

After clicking on Log Statistics, selecting the Expert user mode (step 4) and clicking on Next, the
following is displayed in the Match History POI tab of Step 6 (results):

You will notice that there are two counters for POI 11: 11 and 24. The reason for this is probably
that the new coordinate deviates from the previous mean wall coordinate beyond the snap radius of
0.5 m.

If you expand one of the other counters, for example counter No. 1, you will see that all 5 configura-
tions have been assigned to one and the same counter:
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However, if you unfold counter No. 11, you will only see the latest configuration, as a new counter
was created for POI 11, as mentioned above.

And if you switch to the Changes WTG and POI tab and expand the Changes to the POI Proper-
ties, you will see that counter No. 11 is missing as there have been no changes (there can be no
changes within one configuration).

You now want the log values for POI 11 to be added up by one and the same counter since it refers
to one and the same POI.

Therefore, click Back twice to go to Step 3: Match of POI counters.

You will recognize the configuration pair in which SM4 separated the counters of the POI in the
Number of Identical POIs column, see red marking in the screenshot: In config pair 4 there are
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only 22 identical POIs instead of 23 like in pairs 1 and 3 (the reason why the number in config
pair 2 = 0 is due to the fact that an address change was detected for all POIs there).

To assign the "separated" POI 11 to one and the same counter, drag and drop the "11" from the
Unpaired POIs area into row "11" of the POI Lists of the Configuration Pair area as shown in
blue in the screenshot, so that the following is displayed there:

Now click on Save Match Lists of All Configs. to save the linking of the counters for future Log
statistics runs. 

If you now click Next twice to return to the results tables (Step 6), you will see in the Match Histo-
ry POI tab that there are only 23 counters in total:

Moreover, counter 11 is now marked with an asterisk (*), just like all other counters, because all
configurations are now assigned to this counter, including the address changes that were displayed
at counter 24 before (before the counters were connected manually). 
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4.7.3 Logs from the SMU window

Purpose Downloading logs from the SMU 

Path Logs > SMU 

Right group Read out logs

Prerequisites Online connection to the SMU

Type of use Interactive

Reference Project

The SMU generates the following 4 logs:

· Operation

· Shadow Impact

· Special Shutdown

· Single Data Recordings

In the Logs from the SMU window, you can download specific or all logs from the SMU. 
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Logs from the SMU window

NOTE

You can only download logs in the window above. Open the Logs from Local LogPool window
(Logs > Local Log Files) to display, filter, print out, etc.

The information, options or buttons are described in the following table

Element Explanation

or
This button is located at the right-hand-side window edge. It serves to
show or hide the Project window area.

LogPool path The file path to the folder in which you stored the .exe file for running
Shadow Manager 4 is displayed here. As soon as you run this .exe file,
the ShadowManager4Data\LogPool folder structure will be created in
the same directory, and, once you download logs from the SMU, these
will be automatically stored in the LogPool folder. It is also possible to
change this path, see the next table row.
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This button is used for calling up the display filter application settings,
where you can change the path, amongst other things, see section App-
lication Settings window, Display filters .

Project Information Information on the currently open project is shown here. Information on
the project selected on the left-hand side of the lists window is displayed
here. The input of coordinates (lat./lon.) respectively relate to the auto-
matically determined project center.

When you click on List, the SMU will notify SM4 about which logs are
available on the SMU and prepare these to send to SM4. The existing
logs will not yet be downloaded but merely listed in the bottom half of
the window in the Log area (this process can take several minutes). 

After "listing" all logs available in the SMU, all months (lines in the list)
and all logs (checkboxes) are automatically selected, so when you click
Download, all logs are downloaded. 

Log After clicking on List, the logs that are available on the SMU will be
highlighted in a color here. The colors have the following meaning:

green:  completely downloaded onto the local computer

yellow: incompletely/partly downloaded

red: there are more logs locally than exist on the SMU (this should be
avoided, and, in this case, it is advisable to delete the entire month and
download the logs again)

NOTE

This status is undesired; a user may have deleted, e.g., individual files
in the local directory. We strongly recommend leaving the local directory
untouched. Otherwise, log files could become irretrievably lost, since the
SMU automatically cleans up at some point for storage space reasons
and deletes older log files permanently. 

Operation Is selected to include the Operation log when downloading. 

Shadow impact Is selected to include the Shadow Impact log when downloading (the
Operation log is automatically selected at the same time).

Special shutdown Is selected to include the Special Shutdown log when downloading.

Measurement data
logging

Is selected to include the Single Data Recordings when downloading.

WCU Operation Is selected include the WCU's shadow impact log when downloading.

WCU Shadow Impact  Is selected include the WCU's operating protocol when downloading.

Click on this button click to start downloading the logs.

Following a successful download, a dialog appears, which you must con-
firm by clicking OK before you can continue working.

88
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Tools menu4.8

The following table provides you with an overview of the Toolsmenu. 

Menu item Purpose

Integrity Check Manually initiate an integrity check (it is checked whether the pro-
ject is coherent).

Set Plausibility Declare all shutdown conditions that violate the plausibility rules
as compliant in one step

Simulation Calculate the worst-case shadow impact scenario over a specific
period of time.

Power Curves Create/ edit/ assign/ remove power curves

Shadow Impact Visualization Visualize shadows impact over time

SMU Connectivity Identify at a glance whether the SMU is ready for a connection

Project Comparison window Clearly juxtapose two projects from different sources

WTG Types List possible WTG types

Window Reset window positions and screen detection

Click on a menu item to jump directly to more information.
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4.8.1 Project Integrity window

Purpose Manually initiate an integrity check

Path Tools > Integrity Check 

Shortcut SHIFT-CTRL-I

Prerequisites -

Type of use display only

Reference opened project

SM4 has an integrity module installed, which is used to test for integrity in a project (incomplete re-
ferences, missing parameters and other “errors”) prior to uploading to the SMU. The results of the
test are displayed in this window.

You can create a project or a project component (e.g. light sensor) in the SM4, even if not all the
required parameters are known, in order to prepare the project as far as possible. The following si-
tuations are conceivable:

· creating a new project without an IP address being assigned for the SMU

· adding a light sensor that is not yet connected to the hardware

· defining a WTG that refers to sensors that do not yet exist 

However, an incomplete project may not be transferred to the SMU (configured). The Configurati-
on Check window will open when the user selects Project > Configuration. You can click here on
Test Config. to initiate a test in this window for testing various aspects, including project integrity.
All incomplete references will be detected and clearly displayed to the user in the process. The pro-
ject is only complete when it is no longer possible to detect any unresolved items (only notes on un-
used objects can be ignored, see below). 

An integrity check can be called up manually at any time (Tools > Integrity Check) to determine
which items still need to be completed. The results will be displayed in the Project Integrity
window, see the example window below:
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Project Integrity window

Notes on the example window above

· A light sensor has been added here and already referenced in a special shutdown for WTG 1.
The connection from the light sensor to the hardware (in this case via an interface connector) to
enable it to operate on the SMU is missing.

· Moreover, an additional hygro-thermo sensor has been defined. Due to the fact that, however,
this is not referenced anywhere else, SM4 simply reports this as an “unused object”, which can
only be viewed as a note.
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4.8.1.1 Dependencies window

The Dependencies window is a part of the integrity module and will always open if a change plan-
ned by a user will have consequences for other parts of the project. 

Example A: A WTG needs to be removed from the wind park. 

Here it is necessary to check where reference has been made to this WTG in the current scenario,
for example in the following settings:

· Readings of the WTG in Shutdown conditions of Special and Night Slice Shutdowns

· Special and Night Slice Shutdowns for the WTG itself

· Readings and conditions of this WTG in Single Data Recordings 

The user is shown the consequences of removing the WTG in the Dependencies window; see the
example window below: 

Dependencies window (example A: deleting a WTG)

Notes on the example window above (example A)

· It is apparent that special shutdowns exist for this WTG – none of which will be useful after it
has been deleted.

· The Clear button is also always available for this type of report from the integrity module. If you
click on it, the action that is listed in square brackets after the affected object or objects will be
implemented. In this case all special shutdowns that exist for the WTG to be deleted will also be
deleted.

· If this window is closed by clicking on Close, however, nothing else will happen and the entire
process will be cancelled. This means that the planned deletion of the WTG will not take place.
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Example B: A light sensor needs to be removed.

Dependencies window (example B: deleting a light sensor)

Notes on the example window above (example B)

· If this sensor is deleted, this will have an impact on other sensors as well, due to the bypass
function.

· Furthermore, the light sensor serves as reference sensor for four WTGs.

· And it is assigned to an interface connector. These windows for dependencies are only dis-
played if an action would have real consequences.

 If you attempt to remove a digital input (DI) that is not referenced anywhere, for example, the dele-
ting process will be implemented directly by clicking on the Remove button in the Sensors and POI
Signals window.

 

The following actions could have consequences for other objects:

· delete WTG/POI

· delete analog/digital inputs/outputs

· delete sensor

· delete interface connectors

· delete interface cards

· new number assignment for /move a WTG/POI

· new number assignment for analog/digital inputs/outputs
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· new number assignment for sensors

· new number assignment for interface connectors 

The following objects could be affected by actions:

· conditions for special and night slice shutdowns

· actual special and night slice shutdowns

· conditions for single data recordings

· single data recordings

· shutdown calendars

· interface connectors

· hardware assignments

· bypass sensors
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4.8.2 Set Plausibility

Purpose Declare all shutdown conditions that violate the plausibility
rules as compliant in one step

Path Tools > Set Plausibility 

Reference Project

If you select this command, you must answer the following prompt to continue or cancel the operati-
on.
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4.8.3 Simulation window

Purpose
· Calculate, display, print, export worst-case shadow impact scenarios

over a specified period of time for the entire wind farm or specific
combinations of WTGs and POIs

· Display, print, export statistics with different perspectives and repre-
sentations

Path Tools > Simulation 

Prerequisites Dongle

Type of use Interactive

Reference Project

The currently loaded shadow impact scenario is calculated over a desired time period (max 1 year)
by a simulation. This calculation does not take place in the SMU but within SM4. 

Simulation window 
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General notes regarding the Simulation window

· According to the factory default, the system, when simulating a shadow impact scenario, al-
ways assumes the worst-case, i.e. there is always enough light during the day to cause shadow
impact, and the rotors of the wind turbine generators are always in a 90 °position with respect
to the sun. 

· Furthermore, it can be determined whether downtimes of the wind park’s own WTGs and of the
preloading WTGs (WTGs of other wind parks) should be taken into account.

· The same algorithm and the same temporal resolution are used as those used in the SMU. This
ensures the simulated results are comparable to the SMU’s Shadow impact log.

The information, options or buttons are described in the following table

Element Explanation

Increment Here you select the simulation period and the resolution – the latter is given
in square brackets.

Start date For example, if you select 01.05.2020 as the start date, the loaded shadow
impact scenario is calculated until 30.04.2021. A Today button is available
in the dropdown list for entering the date, so that you can simulate only the
current day with just a few clicks.

Rotor follows sun If this option is activated, the system assumes that the rotor always remains
in a 90 °angle with respect to the sun during the simulation (worst-case).

Fixed rotor angle If, for example, you want to calculate a scenario that corresponds to the
wind direction prevailing in the wind park instead of the worst-case, select
the Fixed rotor angle option instead of the Rotor follows sun option and
enter the desired angle: 0° = north, 90° = east, etc.

Consider WTG stand-
still time

If this option is activated, the daily and annual counters of all additional
loads (loads of the POIs caused by WTGs of your own wind park) are con-
sidered and in case of an overflow a stop event is generated.

If this option is not activated, only the geometrically possible shadow impact
will be simulated.

Consider WTG with
preload

Here it is determined whether WTGs that cannot be switched by your own
wind park (WTGs of another wind park) but still cause immission should be
included in the daily and annual counter calculation. You can recognize such
"preloads" by the fact that, for example, the first entry of a POI in the
column Daily load or Annual load does not begin with 0:00:00.

Information The information area displays current settings from the project configuration
(File > Application Settings > SMU > Shadow impact calculation). These
settings are required for the internal calculations of the simulation. Click on
the gear symbol to go directly to the setting options.

With this button you open a selection window in which you can choose the
combinations of WTGs to POIs to be simulated. You can select entire
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columns and rows at once by clicking a column or row title, or set each
combination individually by clicking it.

Click here to simulate the selected combination of WTGs and POIs
according to the defined settings. A progress bar is displayed at the bottom
of the window.

Click here to open the statistics window for a calculated simulation. A
detailed description of the window is given at the end of this section. 

Import / Export Here you can export the simulation result in CSV, XML, JSON or SM4SIM
format. Only the NorthTec proprietary SM4SIM format can be imported.

Print Here you can display a print preview, print the result or save it as a PDF do-
cument.   
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4.8.3.1 SI Log Statistics sub window

Purpose Display, print, export simulation statistics with different perspectives and
representations 

Path Tools > Simulation > Statistics 

Prerequisites Dongle

Type of use Interactive

Reference opened project

SI Log Statistik window (using the  Einzelpaarungsmatrixtab as an example)

General notes regarding the SI Log Statistics sub window

· The Show compare column option is only relevant for the tabs POI related and 
WTG related.

· All tabs can be exported by clicking the to Excel button.

· In the Print area you can choose between preview, PDF export or direct printing.

The tabs (lower edge of screen) are described in the following table 
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Tab Explanation

Simulation info Displays the settings and combination the current simulation is based on.

POI related Here the shadow impact duration of the POIs is displayed for each POI indi-
vidually, but also in total, with the following column headings:

Preload = shadow impact caused by non-switchable WTGs (not belonging
to your own wind park)

Additional load = shadow impact caused by your own WTGs

Total load = sum of preload and additional load

“counted once” means that for POIs at which 2 or more WTG cause
shadow impact simultaneously (multiple shading), these loads are only con-
sidered from the point of view of their effect and are therefore not added
up. 

You can use the Show compare column option to show a column that dis-
plays the Row total from the Matrix of single pairs tab page, that is, multi-
ple shading is added here (considered from the point of view of the cause).

Matrix of single pairs This the matrix of the individual pairings of WTGs and POIs. When calcula-
ting the shadow impact duration, all other WTGs are hidden here. In the row
total per POI, multiple shadings are counted several times (added up, consi-
deration from the point of view of the cause). The arithmetic column sum
per WTG counts the shading of several POIs simultaneously several times.
The calculated matrix sum corresponds to the park total shadow impact du-
ration if no multiple shading exists. 

If the option Consider WTG standstill time was activated, the shadow
events of the other POIs and their counter readings influence the result of
the single pairing.

WTG related Here the duration of shadow impact caused by the WTG is shown. For
"overlapping" events from neighboring POIs, the duration from the first
immission at the first POI to the last immission at the last POI is added up. 

You can use the Show compare column option to show a column that dis-
plays the Column total from the Matrix of single pairs tab page, that is,
multiple shading is added here (considered from the point of view of the
cause).

Standstill If the Consider WTG standstill time option was activated, the downtime
per WTG caused by an overflow of the annual or daily counter is displayed
here. For WTGs with preload, as a rule, no shutdown is assumed. If the op-
tion Consider WTGs with preload was deactivated, the corresponding
WTGs are treated as additional load.

Combinations matrix This tab shows which combinations of WTGs and POIs were set.
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4.8.4 Shadow Impact Visualization

Purpose Visualize shadows impact over time

Symbol

Path Tools > Shadow Impact Visualization

Prerequisites Dongle

Type of use Display + interactive

Reference Project

In the Shadow Impact Visualization (worst case) window, you can visualize the shadow impact of
the currently open project as it could occur in the worst case, i.e., assuming that the rotor points to-
wards the sun while at the same time the direct sunlight is so strong that shadow impact effects ac-
tually can occur. What is depicted here, not only refers to a specific point in time but shows the
shadow impact over the course time in user-selectable time steps, always assuming the rotor
follows the sun (worst case). In addition, you can make further settings, e.g., exclude individual
WTGs from the visualization.

If residents complain about shadow impact, this visualization can be very informative and may contri-
bute to discussions being held based on facts.  

 Shadow Impact Visualization window
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Notes on the window above 

· Click on the map and use the mouse wheel/touchpad or press the plus (+) or minus (-) key to
zoom in or out. 

· To move the map, hold down the left mouse button and drag the map in the desired direction or
use the arrow keys on the keyboard.

· If you zoom in strongly on the map and have selected the POI (detail) option, you can also see
the defined walls and areas. The small rectangular line on walls indicates their orientation.

The information, options or buttons are described in the following table

Option/ Button Explanation

Use these buttons to adjust the displayed time back or forward by one day
with each click.

Date (Project) Here you can see the date of the currently displayed shadow impact scena-
rio and change it by clicking on the small black arrow to open a drop-down
list.

Time (Project) Here you can see the time of the currently displayed shadow impact scena-
rio and can change it by clicking on the arrow keys or overwriting the
current time.

Elevation angle limit [°] Here you define the minimum elevation angle the sun must have so that
shadow impact effects are considered to be possible and are visualized he-
re.

Input range 0.1 to 15 degrees, default: depending on project

(Project > Project Settings > Shadow impact calculation)

If you click on this button, the map section is moved so that the project cen-
ter is displayed in the middle of the map.

Time (UTC) Shows the project time in universal time.

Azimuth [°] Azimuth of the sun as calculated by SM4.

Elevation angle [°] Elevation angle of the sun as calculated by SM4.

If you switch to OSM here, Open Street Map is displayed in the back-
ground.

NOTE

The computer must be connected to the internet to use the OSM. 
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Option/ Button Explanation

If you check the Zoom box, you can select a POI number in the selection
list below to center the map on this particular POI. 

Displays/hides the settings area on the right side of the screen.

Map layer

POIs (dot) Used to show/hide defined places of immission. Defined POIs are displayed

as green dots: 

POIs (detail) Used to show/hide defined walls and areas. Defined walls and areas are
displayed as black lines. The view needs to be greatly enlarged to be able
to detect them. The small rectangular line on walls indicates their orientati-
on.

WTGs Used to show/hide defined wind turbine generators. Defined WTGs are dis-

played as red squares. 

Frame Used to show/hide a black project frame. 

Center Used to show/hide the project center, i.e. the center of all WTGs according
to latitudes and longitudes from the project data. The project center is

shown as an orange circle. 

It is calculated automatically.

WTG

Zoom to WTG (dou-
ble-click)

If this field has been activated, you can click on a WTG in the table under-
neath to make it the center of the map.

Info The number corresponds to the respective WTG number in the Wind Tur-
bine Generators window. 

The identification corresponds to the respective Name from Shadow Fore-
cast in the Wind Turbine Generators window.

Display only

Shadow You can show or hide rotor shadows and tower shadows of a WTG by pla-
cing or removing the respective check mark. If you right-click the right to the
left or right of a check mark, a context menu opens in which you can apply
the respective setting to all other WTGs.

Nacelle angle If you check the Use box and enter, e.g., 45 at Value, the shadow impact
visualization will be based on the assumption that the nacelle, and therefore
the rotor, are oriented to north east.
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Option/ Button Explanation

If you do not check the Use box, the worst case will be assumed for the
shadow impacting visualization. 

0° = North, 90° = East, 180° = South, 270° = West

Application example: In the case of a specific complaint by a resident re-
garding a defined time period, you could take the corresponding nacelle po-
sition from the shadow Impacting log, enter it here and thus visually recon-
struct whether there was real shadow Impacting at the time in question.

Input range 0–359 degrees, default 0 degrees 

Animation

Animate If you set a check mark here, the shadow Impact is automatically displayed
over time, according to the following settings. If you do not check this box,
the settings in the Animation section will have no effect. 

Skip times without
shadowing

If you set a check mark here, times in which real shadows cannot be cast
(because the elevation angle has fallen below the limit) are automatically
skipped during animation.

Time steps/ Day steps For animation, you can choose time steps OR day steps. If you select the
Time Steps option, these correspond to the setting below (Time Steps
(minutes)).

Time steps (minutes) Setting for above option Time steps

Input range 1-120 min, default 3

Animation interval
(sec.)

Here you select the interval at which the display should change (jump to the
next time period or day).

Input range 1–60 s, default 1 s 

Project framework

North / South 

West / East 

Outside the project frame, the shadow impact ellipses are truncated.

Input range 0–10000 m, default 200 m

NOTE

There may be discrepancies between the visualized shadow impact (this window) and the simula-
ted shadow cast (Tools > Simulation window), as the visualization is only a two-dimensional repre-
sentation (top view). Example: The POI is a house wall with windows from a height of 5 m above
the ground. If the shadow hits the area below the windows, it does not yet cause real shadow
impact, only when the shadow travels further and finally actually hits the window. For more informa-
tion, refer to Edit Walls and Areas sub window .139
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4.8.5 Edit Power Curves window

Purpose Create/ edit/ assign/ remove power curves

Power curves are used when creating the SM4 log statistics in order to
calculate the loss of earnings due to WTG downtimes as accurately as
possible

Symbol

Path Tools > Power Curves > Edit power curves

Prerequisites Dongle

Usage type Display + dialog

Power curve of a WTG

A power curve indicates the relationship between power and wind speed – it is usually prepared and
provided by manufacturers in accordance with EN 61400-12. When creating Log Statistics (see
section Log Statistics Main Menu) , power curves enable a more precise calculation of the loss of
earnings that occurs when a WTG is at a standstill, e.g. due to shadow impact or for the purpose of
species conservation.

The unique name of a power curve is structured as follows in SM4:

Fig.: Power curve

Structure of the power curve

· The information in front of the square bracket is self-explanatory information on the WTG to which
a power curve is assigned.

· Although not technically relevant for SM4, the manufacturer's information in the brackets must still
be entered. 

air density = average air density (e.g. at sea level) for which a power curve ap-
plies

operat. mode = operating mode of WTG (e.g. for unthrottled or throttled operation
of the WTG)

power curve revision = version number of the respective power curve

 

In order for the power curve of a WTG to be used in Log Statistics, such a power curve must be
assigned to the identifier of the respective WTG.

370
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In SM4, a window for creating, editing, assigning and managing power curves is available via the
path Tools > Power Curves > Edit Power Curves:

Edit Power Curves window

This window is divided into the following four areas as described in the following

A Project name

Select a project from the local database (see info box below) of your SM4 installation for display

in area B OR remove a project from the local database

B Input of WTG identifiers

Display and edit WTG identifiers of the project selected in area A with any pairs (see info box

below) and power curves already assigned

C Input of pairs

Display/ assign/ edit/ remove/ replace/ add pairs (see info box below) from or respectively to

the local database

D Input of power curves

Display/ remove/ edit/ add/ assign power curves from or respectively to the local database, and

call up the editor 
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IMPORTANT TERMS

Local database

When SM4 is installed, a local database file is automatically created in which not only
the power curves themselves are stored, but also other data related to power curves.
Each SM4 installation has only one local database.

Pair

For some WTGs, there is a power curve that applies during the day and another one
that applies during the night, e.g. because they have to run at a reduced speed at night.
In this case, one power curve is required for normal operation and another for throttled
operation. The pair assigned to the WTG must then consist of two power curves, and a
start time must be defined for each power curve. For pairs with two power curves, the
name includes not just one, but two pairs of square brackets, see the following exam-
ple:

At the end of each pair is a hash followed by a number that has no direct impact on the
pair or power curve, but is related to the Range of validity and Start time of a pair.
Further details can be found at the end of Area C: Entering pairs .

An explanation of the information, options and buttons in areas A to D and a description of the
power curve editor can be found in the following sections.

If your local power curve database is still empty, there are 2 ways to fill it:

· Input as described in this section and the 5 subsections .

· Import an external power curve database as described in section Database mainte-
nance of performance curves .

A filled local database helps you to familiarize yourself with the power curve features.

440

458
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4.8.5.1 Area A: Project name

In this area, you can select a project contained in the local database of your SM4 installation for

display in area B, or remove it from the local database.

Area A is located at the top of the Edit Power Curves window, see the following illustration:

Edit Power Curves  window – Area A: Project name

When you open the Edit Power Curves window, SM4 first checks whether the WTG identifiers and
any assigned power curves of the project currently open in SM4 are already included in the local da-
tabase of the SM4 installation. If this is not the case, the following message appears:

If Yes is selected, the project and all WTG IDs included in the project will be added to the local da-
tabase. To switch to another project that is already part of the local database, select it from the
drop-down list.

Projects will not be available for selection in the drop-down list unless you have previously added
them individually, see (1), OR imported an external database with projects, see (2):

(1) Add project individually

8 Open project in SM4 

8 Open the Edit Power Curves window

8 Answer dialog with Yes 

(2) Import external database with projects

8 Open the Database Maintenance of Power Curves (Tools > Power Curves) window 

8 Click on Import Local Power Curve Database and select an external power curve database
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Click on Remove Project to delete a project and its WTG identifiers from the local database. Assi-
gned pairs and power curves will not be deleted from the database in this process.

NOTE

Please note that the Project name in the Edit Power Curves window does not correspond to the
file name of the project displayed in square brackets at the top of the SM4 window but to the Pro-
ject name entered under Project > Project Data.
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4.8.5.2 Area B: Input of identifiers

In area B, all WTG IDs of the project currently selected in area A are displayed and can be edited.

If the project currently open in SM4 already existed in the power curve database before the Edit
Power Curves window was opened, SM4 checks whether all of its identifiers are also included in
the database and automatically adds missing ones.

Expanding a WTG identifier reveals pairs that have already been assigned. Each pair in turn has at
least one and at the most two power curves assigned to it, see example:

Edit power curves  window - Area B: Input of WTG identifiers

The example above shows the following:

· The project selected in area A comprises three WTG identifiers (1000, 2000 and 3000).

· The expanded WTG ID 1000 was assigned a pair with two power cuves.

· A pair with one power curve was assigned to the expanded WTG identifier 2000.

· No pairing has yet been assigned to WTG identifier 3000.

If you want to check how two power curves of a pair differ from each other, you can click
on a power curve in area B to display the editor on the right-hand side of the window and
then click on the other power curve for comparison.

The prerequisite for this is that you have ticked the Show on selection box at the bottom
of area B.
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Move or copy pairs using drag & drop

You can move or copy pairs from one identifier to another:

move:  8 click on pair, hold, drag and drop

copy:  8 click on pair, hold, drag, hold down CTRL and drop.

 

More than one pair can be assigned to each identifier. Make sure that their Ranges of validity do
not overlap, see description for area C.

An explanation of the options/fields/buttons in area B can be found in the following table.

Option/
Field/
Button

Explanation

Show when
selected

If a check mark is set here, 

· a pair you select in the list is displayed in area C for editing.

· and you select a power curve in the list, the editor will be displayed on the
right, see description for D.

WEA
identifier

Here you can enter an identifier with which you want to replace an identifier selec-
ted in the list above or that you want to add to the list.

Deletes the identifier selected in the list above. 

Replaces the identifier selected in the list above with the value you entered in the
WEA identifier field.

Adds the identifier you entered in the WEA identifier field to the list above.
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4.8.5.3 Area C: Input of pairs

In area C, you can see the list of pairings already saved in the local database and can assign them
to a WTG identifier below the list (and remove an assignment) as well as clear the input boxes or
remove /replace or add a pair.

Fig.: Edit power curves window, area C: Input of pairs

If you select a pair at the top of this area, the associated data is displayed in the area below the list
for editing.

NOTE
This list also displays data records which, strictly speaking, are not a pair but only consist of one (1)
power curve. As long as no "partner" is assigned to a single power curve, it applies all 24 hours of a
day.

Assigning a pair to a WTG identifier

To assign a pair to a WTG identifier (area B), you can 

· drag and drop it from the Pair name list to a WTG identifier (area B) OR

· select it in the Pair name list and click on . 

Range of validity

More than one pair can be assigned to each WTG identifier, provided that the date ranges defined
under Range of validity do not overlap. 
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Please note that a Range of validity must be defined for each pair, whether it consists of one or
two power curves (see below). If you assign an identifier a second pair whose validity range over-
laps with that of the first pair, a corresponding error message will be displayed, see the following
example:

Explanation: An identifier that has already been assigned a pair with a validity range from
01/01/2020 to 12/31/2033 cannot be assigned a pair with a validity range from 01/01/2001 to
12/31/2035.

Start time
For pairs with two power curves, a start time must be defined for each power curve, example:

Start time 1 (power curve 1) = 08:00 AM

Start time 2 (power curve 2) = 10:00 PM

Result:

Power curve 2 applies from 00:00 AM to 07:59 AM.

Power curve 1 applies from 08:00 AM to 07:59 PM.

Power curve 2 applies from 08:00 PM to 11:59 PM.

Power curve 2 once again applies from 00:00 AM to 07:59 AM, etc.
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The input fields and buttons in area C are explained in the following table.

Field/
Button

Explanation

Pair name All pairs already included in the local database are displayed here.

Display only

Click on the blue arrow to display the data for the pair selected above in the in-
put fields. If, for example, you have clicked on Clear and would like to display
the data again or if there is only one (1) data record in the list of pairs, the but-
ton is helpful as the display is only updated when the selection is changed.

Range of validity Validity date range of a pair

DD.MM.YYYY* (mandatory field)

Power curve 1 Data of the first power curve from the pair selected in the list above 

Display only

If the Power curve 1 field is empty, e.g. because you have clicked on this but-
ton, you can copy a power curve from area D there using drag & drop.

Focuses on the corresponding power curve in the list in area D. This allows you
to see at a glance which of the existing curves is already assigned to a pair.

Start time 1 Start time of power curve 1

hh:ss* (this is a mandatory field if there are two power curves) 

Power curve 2 Data of second power curve from the pair selected in the list above

Display only

If the Power curve 2 field is empty, e.g. because you have clicked on this but-
ton, you can copy a power curve from area D there using drag & drop so that a
pair is created.

NOTE

If you want to assign a second power curve to a pair, it must be of the same
WTG type as power curve 1. This is one of the reasons why only those power
curves are displayed in area D that correspond to the data set selected in
area C (this applies only if one is focused there, otherwise all power curves re-
gistered in the local database are displayed in area D ).

See above.

Start time 2 Start time of power curve 2

hh:ss* (this is a mandatory field if there are two power curves) 

Assigns the pair displayed above to a WTG identifier selected in area B.

Releases the assignment of a pair to a WTG identifier. 
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Clears all data fields in area C.

Removes the displayed/selected pair. 

NOTE
If the pair is assigned to an identifier of the current project and/or another project
of the local database, a corresponding dialog box opens (see example below) in
which you can confirm (or cancel) the deletion.

If you have made changes to an existing pair, you must click on this button to
apply them before they take effect. 

NOTE
A corresponding confirmation dialog is also displayed here, see the description
of the Remove button above.

If you have made changes to a pair, you can add it as a new pair by clicking on
this button.

*The input format is based on the default setting in the Country-specific settingsinput area  (File > Program settings >
Shadow Manager 4 > General) and can be changed there at any time.
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The "#" at the end of pair designations

At the end of each pair there is a hash followed by a number. This relates to the validity range
and/or the start times of a pair, see the following illustration:

The number after the # is a database-internal counter without direct influence on the pairing or
the power curve.

Explanation: Two pairs can consist of identical power curves so that their names are also identi-
cal. However, their Range of validity and/or their Start times may differ.

If such pairs are created or saved in one and the same database (e.g. when synchronizing data-
bases), the internal counter is used to keep the pair name unique. However, the hash and its
counter are not a direct part of the pair name.

Example 1: The pair shown above with the ending "#1" is contained in a local database. The start
times assigned to it are 08:00 AM and 08:00 PM.

In an external database there is a second pair with an identical name, and the number behind the
hash is also identical, but different start times have been defined for this pair: 06:00 AM and
10:00 PM.

Ø If the second pair is now imported into the local database, it is given the suffix "#2" . 

Example 2: Employee A creates a new pair named XYZ on his computer with the start times
8:00 AM and 8:00 PM. Employee B also creates a new pair named XYZ on his computer, also
with the start times 8:00 AM and 8:00 PM. However, there is already a pair in his local database
with the name XYZ, but with the start times 07:00 AM and 11:00 PM. 

Ø In this case, the name of employee A's new pair is XYZ #1 

Ø Employee B also has a pair named XYZ #1 in his database but their start times are different. 

If employee A and B then talk about the pair XYZ #1, they are talking about different pairs.

Conclusion: When working with power curve in SM4,  always keep the following in mind:

· Each SM4 installation has its own local database. Depending on the order in which pairs with

identical names are entered or imported, they receive different internal counters (#).

· Pair XYZ #1 and pair XYZ #2 can be completely identical data records (with identical Ranges
of validity/Start times) that simply reside in different databases.

· Pair XYZ #1 and pair XYZ #1 may be "apparently" identical data records, however, they exist
in different databases and their validity ranges/start times may differ.
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4.8.5.4 Area D: Input of power curves

The power curves of the local database are displayed in this area. You can assign/ remove these
and/or call up the power curve editor to edit existing power curves or create a new one.

Fig.: Edit Power Curves window, area D: Input of power curves

If no pairing is focused in the list of pairs in area C, all power curves included in the local database
are displayed here. 

If a specific pair is focused in the list of pairs in area C, only the power curves that correspond to
the WTG type of the focused pair are displayed here (filter function).

To once again display all power curves included in the database, including those that are not
currently assigned to a pair, click on any identifier in area B (Input of identifiers).

In the right half of area D, you will see a window with the data of the power curve focused on the
left.

The input fields and buttons in area D are explained in the following table.
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Field/
Button

Explanation

Removes the focused power curve. 

NOTE
If you click here, a self-explanatory window like the following may open:

Opens the editor for editing the focused power curve. You can find a description
further below.

Opens the editor with empty input fields. A description can be found below.

Copies the focused power curve to the Power curve 1 or 2 field in editing area C, if
it has not already been assigned.

It can also be assigned using drag & drop.
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4.8.5.5 Power curve editor

You can do the following in the power curve editor:

· edit an existing power curve,

· create a new power curve manually, 

· create a new power curve using data in CSV format or 

· output the data of an existing power curve in CSV format.

How to open the power curve editor 

· In the Edit Power Curves window, click Edit or Add in the bottom center of the D area.

OR

· Click on a power curve in area B of the Edit Power Curves window (only if the Show when se-
lected option has been ticked in area B)

Power curve editor in the Edit Power Curves window
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Explanation of the example window above

a Manual input:

The unique designation a power curve is defined here. The first three input fields WTG type,

Rated power and Hub height define the turbine type. A pair may only ever consist of two

power curves of the same turbine type. The three remaining input fields Air density, Mode

and Revision are additional parameters that must also be unique; however, they are not re-

levant for the assignment of a pair (for more information, see Edit Power Curves window)

.

b Automatic display:

The full name of the power curve is displayed here. The additional parameters are shown in

square brackets [ ]. 

The colors have the following meaning:

The name entered is OK and does not yet exist in the local database.

The name entered is OK, but it already exists in the database.

The entry is not accepted due to an incorrect entry in area a.

The display is only updated when the cursor leaves an input field.

c Here you can define up to 50 grid points (Grid points 01–50). These describe the course of

the power curve. A small blue arrow indicates the grid point that is currently selected. You

can use the Move up and Move down buttons to move the active grid point.

Click on Compress inputs to sort the data by wind speed and delete empty and incorrect

fields.

d Use the To CSV/FromCSV buttons to export the data from area c in CSV format to the

white box or import it from there.

Transferring the data in the white box from or to "external" (outside SM4) is possible via

Ctrl+C and Ctrl+V.

e Graphical depiction of the power curve
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4.8.6 Synchronize Power Curve Databases

Purpose
· Display the contents of the local power curve database and an external

power curve database

· Synchronize all or part of the local power curve database with an exter-
nal power curve database

· Synchronize all or part of an external power curve database completely
with the local power curve database

Icon

Path Tools > Power Curves > Synchronize Power Curve Databases

Prerequisites Dongle

Usage type Display + dialog

In the Synchronize Power Curve Databases window, you can display the contents of the local and
an external power curve database and synchronize the two databases in whole or in part. 

To be able to work in the Synchronize Power Curve Databases window, first carry out the
following steps:

8 Select an external database by clicking on , or set up a new one by selecting Create new.

8 Once you have opened or created an external database, click on Projects, Pairs or Power
Curves on the left-hand side of the window to display the corresponding data, see the
following example:
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Synchronize Power Curve Databases window (Projects selected) 

· In the above example window, the Projects button has been clicked on at the left-hand edge of
the window.

· The Project names are listed in the two upper data windows of area C: those of the local data-

base are displayed on the left, those of the external database on the right.

· The WTG identifiers of the active project line (here: "Casablanca") are displayed in the two lower

display areas. WTG identifier "1000" has already been expanded in the example above, so that

the assigned pair with its two power curves is also displayed.

In the following table you will find a brief description of areas A to D

Button Explanation

A Select and open external power curve database

Create and open a new (empty) external power curve database

B Here you select which data from the local and external power curve database should be
displayed in area C – no synchronization process is triggered yet.

Display all projects, all identifiers created in the projects and all pairs
and power curves assigned to the identifiers. Unassigned pairs and un-
assigned power curves are not displayed.

Display all pairs of the two databases: both assigned and unassigned
ones.

Display all power curves of the two databases: both assigned and unas-
signed ones.

C Display depends on selection in area B

When Projects are displayed, the pairs and power curves assigned to the
identifiers can be expanded in the lower half, as shown in the example
screenshot above.

D Selects all projects/pairs/power curves displayed above.

Deselects all projects/pairs/power curves displayed above.

Click on one of the following two buttons to start the synchronization process. Synchroni-
zation only takes place in one direction at a time. You decide in which direction to syn-
chronize by selecting either Export or Import. Please pay attention to the NOTES in the
box at the end of this section.

Exports all projects/pairs/power curves displayed and selected above
from the local database to the external database.

Imports all selected projects/pairs/power curves displayed above from the
external database to the local database.
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This brief description of the window areas is followed by a quick guide to synchronization.

 Quick guide to the "Synchronize Power Curve Databases" window

8 Open the Synchronize Powere Curve Databases window  (Tools > Power Curves > Syn-
chronize Power Curve Databases).

8 Select or create an external database at the top in area A.

8 On the left-hand side of the window in area B, select whether Projects, Pairs or Power Cur-
ves should be displayed in area C .

8 Export:
In the left half of area C, select what you want to export by ticking one or more boxes 

OR 

Import:
In the right half of area C, select what you want to import by ticking one or more boxes. 

8  Click on Export or respectively Import.

Please note the following information before carrying out a synchronization process:



452Reference part > Tools menu

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

General notes
· We strongly recommend that you create a backup copy of important databases before

working with the synchronization window, for example as described in the Database Main-
tenance of Power Curves  section. 

· Data is adjusted or added during synchronization. Data is never removed from the target
database (exception: identifiers to which no pairs/power curves have been assigned). To
remove data, you should use the Database Maintenance Power Curves  window.

· During each synchronization process, SM4 checks whether exported/imported pairs
and/or power curves already exist in the target database. If so, the system checks whe-
ther there are any differences. If differences are found, you will be asked as to how SM4
should proceed with the data found. You then decide in one or more dialog windows with
the title Update project whether or not to replace despite differences.

· In the dialog windows titled Update project, there is the option All Yes or All No: If you
have selected several projects and answer the first query with All Yes, updating will be
carried out for all selected projects. You will not be asked again whether you also want to
replace the data in another project despite differences. So please be careful!  

· If you select the No option in dialog windows titled Update project, or if you click on  at
the top right of the window, the remaining synchronization process, in which no differences
were found, will be carried out nonetheless. 

Notes on synchronizing PROJECTS
· When synchronizing projects, the pairs and power curves assigned to the WTG identi-

fiers will also be synchronized.

· Please note that pairs/power curves that are not assigned to a WTG identifier will not be
taken into account when synchronizing projects.

· For example, to import or export all pairs stored in a database, first click on Pairs in
area B and then on Select all. 

Notes on synchronizing PAIRS
· When synchronizing pairs, any power curves assigned to the pairs are also synchroni-

zed.

· Please note that power curves that are not assigned to a pair are not taken into account
when synchronizing pairs.

· For example, to import or export all power curves stored in a database, first click on
Power Curves in area B and then on Select all. 

· Please also note the explanation of the hash with counter at the end of pair names .

If you have followed this section up to this point, you will have learned the most important informati-
on about the possibilities and limitations of the Synchronize Power Curve Databases window and
can explore them further by trying them out. We strongly recommend that you make a backup copy
of important databases beforehand, for example, as described in the section Database Mainte-
nance of Power Curves .
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If you prefer to use this manual to further familiarize yourself with synchronization, you will find prac-
tical examples with detailed explanations in the following sections:

Example 1: Local to external

Example 2: External to local

454
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4.8.6.1 Example 1: Local to External

Initial situation:

·  In the Casablanca project of your local database, you have changed Grid point 1 of the

"Power4000 4800kW 140m [1,225kg/m³ Mode 1 Rev. 1]" power curve from 2.6 m/s to 2.8 m/s.

· The Casablanca project already exists in the external database "SM4-External_2509.db".

· You want to update the modified Casablanca project in the external database

Steps:

8 Open the Synchronize Power Curve Databases window .

8 Click on  to open the external database.

8 Click on Projects on the left-hand side of the window .

8 In the Local database area, check the "Casablanca" box.

8  Click on Export.

The following will then be displayed:

Explanation:

SM4 has found the difference between the two databases with regard to the changed grid point

(yellow). You want the change to be transferred to the external database.

Step:

8 Click on Yes.

The following will then be displayed:
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Explanation:

The detected difference is displayed in detail in this view. 

Step:

8 Click on Yes.

Explanation:

SM4 has recognized that there is a pair that already exists in the external database. And it has also

recognized that grid point 1 in the local database differs from grid point 1 in the external database.

The power curve is updated in the external database. If you click on No, the original value is retai-

ned in the external database (no synchronization).
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4.8.6.2 Example 2: External to Local

Initial situation:

· There is an external version of your local database in which, in the Casablanca project, the grid

points of a power curve have been revised several times according to updated information from

the manufacturer.

· The latest version ends with "... Rev.3]". However, in your local database, you are still using

version "... Rev.0]"

· You want to transfer the current version Rev.3 to your local database.

Steps:

8 Open the Synchronize Power Curve Database window .

8  Click on  to open the external database.

8 Click on Projects on the left-hand side of the window .

8 In the External database area, check the "Casablanca" box.

8  Click on Import.

The following will now be displayed:

Explanation:

· Note that the data from the external database is shown here in the left half (Project source), as

you are synchronizing from "external to local".

· SM4 has recognized the difference (change from Rev 0 to Rev 3) in the name of the power curve

assigned to the pairs of identifiers 2000 and 3000.

· If you confirm with Yes, the original power curve will be replaced by the current one in the pairs

of identifiers 1000 and 2000. 
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· The original power curve is retained in the database, as it may still being used in other projects or

pairs or is to be used in the future, see the following screenshot:

Explanation:

· You can see the original version of the power curve and the current one in the local database. 

· The external database, on the other hand, also contains all intermediate versions. To transfer the-

se to the local database as well, you would have to select the intermediate versions here and

click on Import.
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4.8.7 Database Maintenance of Power Curves

Purpose Maintain local and/or external power curve database

Icon

Path Tools > Power Curves > Database Maintenance of Power Curves

Prerequisites Dongle

Usage type Display + dialog

In addition to the functions described in the Synchronize Power Curve Database  section, there
are various data maintenance options for both local and external databases.

Database Maintenance Power Curve window

The buttons in the upper half of the window only refer to the local database. 

To maintain data of an external database, first select one (  ) and then use the buttons in the

lower half of the window.

There are 5 different types of buttons in the Database Maintenance Power Curves window, all of

which have self-explanatory names – however, you will find a few explanations in the following

table: 
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Button Explanation

 Empty...
Removes all projects, identifiers, pairs and power curves so that you can
start with a "fresh" database. 

 Export...
Exports the local database to a location that you specify – a copy of the
local database is created by this process.

 Import...
Replaces the local database with any external database. To be on the
safe side, there is a query that must be confirmed.

 Regenerate...

Re-indexes the data and frees up disk space that is no longer required,
which improves the performance of the database after data has fre-
quently been added or removed.

Remove...

Allows you to select the projects or unassigned pairs/power curves
to be removed. An overview window opens (see example below).

NOTE

In the case of unassigned pairs/power curves, an overview window only opens if unassigned
pairs/power curves  actually exist.

Example: Unassigned Power Curves window
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4.8.8 SMU Connectivity window

Purpose Check the availability of the SMU via the SMU’s IP address

Path Tools > SMU Connectivity 

Type of use Display only

Reference Project

If you install a software update or a new project configuration on the SMU, it will automatically rest-
art, if applicable, sometimes twice. Every attempt to connect to the SMU during this period will be
unsuccessful. In this window you can identify at a glance whether the SMU is ready for a connecti-
on, which avoids unsuccessful connect retries.  

The connectivity window, on the other hand, obtains the information via the SMU website, and ac-
cess to this may be prevented by the park operator for security reasons. So if the website is not ac-
cessible, you can also get the information such as serial no., location, version, etc. from the SMU
Information window (SMU > SMU Information).

SMU Connectivity window

NOTE

HTTP port 80 must be accessible for this window to work. This may apply in particular to routers or
firewalls of wind parks.

The following table provides an explanation on the information contained in the SMU Connectivity
window.
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Information in the SMU Connectivity window:

Element Explanation

Serial No. Serial number of the SMU

Location Location of the SMU according to the Project Data window

Version Version of the SMU

Alarms Here, Yes/No indicates whether alarms are set. If Yes, you can check the
type of alarm in the Alarms window (SMU > Alarm).

Warning Yes/No indicates whether there are warnings here. If Yes, you can also
check the type of warning in the Alarms window (SMU > Alarm). 

Connectivity One of the following connectivity conditions will be displayed here:

Ready for connections A connection can now be established.

preparing The Shadow Manager interface is being prepa-
red.

Busy A connection already exists between a different
SM4 installation and the SMU.

SMU not available The SMU is currently starting up/ is switched off
/ cannot be accessed in the network/ faulty, or
similar.

SMU Status One of the following SMU conditions will be displayed here:

--- Status cannot be determined, e.g., because
SMU cannot be reached

Operational The SMU is ready for operation, an existing
shadow project is being processed

preparing The SMU is started, e.g., after an update 

Stop The SMU shuts down, e.g., before an update

Closes the window. 
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4.8.9 Visualization window

Purpose Visualize the currently defined installation (WCUs, SNUs, WTGs and/or sensors)

Path Tools > Windfarm Layout

Prerequisi-
tes Dongle

Type of use Display

Reference Project

How do I keep track of SMUs, SNUs and WCUs?

To get an overview of the many different connection options offered by the system for shadow
impact monitoring and species conservation, you can visualize the installation as it is currently defi-
ned in the project currently loaded in SM4: Go to Tools > Windfarm layout. You can also use this
function to visually check any changes made immediately (before configuring the SMU).

An example:
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4.8.10 Project Comparison window

Purpose To clearly juxtapose two projects (project versions)

Path Tools > Project comparison

Usage type Dialog + display

Reference Project

Changes usually occur frequently in every wind farm project, for example because a new POI has
come into life that needs to be protected, to name just one example. In this simplest case, the new
POI is first added to SM4, then the updated configuration is sent to the SMU. In this way, new ver-
sions of one project are created again and again over time, and in the Project Compare window,
two versions of the same project from different sources (see tabs in the top left of the following
screenshot) can be conveniently compared with each other. Depending on the type of change de-
tected in the process, the results area will either only show that something has been changed, or al-
so how something has been changed.

Practical example: A project was set up by NorthTec and delivered. It was then extended by the
customer, but is now to be reset to its original state. A project comparison shows what has been
changed at the push of a button, thus facilitating the reset.

 

NOTE

Please note that a project comparison always involves comparing two versions of one and the same
project. Thus, strictly speaking, "project" in this context means "version of a project".
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 Project Comparison window

Overview of the individual areas of the Project Comparison window

A In this area you select the two projects (version A+B) that you want to compare with each
other. According to the four tabs, there are four possible sources for A + B respectively:

· Project from file –  select an .smp4 project file stored on your own computer

· SM4 Project – if you select this tab for project A or project B, the project currently ope-
ned in SM4 will become a candidate for comparison. To enable comparison, you must
select a different tab for Project B or Project A, respectively.

· SMU Project – If you are connected to a SMU, you can load the current SMU project as
the comparison candidate at Project A or Project B. To enable a comparison, you must
select a different register at Project A or Project B, respectively. 

· Project from LogPool – Here you can use log data downloaded from a SMU for compa-
rison, since these also contain all data needed for a comparison in the form of a so-called
project file (ProjectInfo.dat). If there are several legends for a project (see glossary ),
the desired one can be selected.
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B Provided that the corresponding information is available, this area shows WHO (Registered
to) created the respective project with which DONGLE (Dongle Number) and then sent it at
what TIME (Configuration (UTC)) to SMU.

C In this area you can view, save, or print the comparison result as PDF.

D Here the comparison result is displayed as a tree structure. Depending on the type of
change detected, the result area will either only show that something has changed, or also
how something was changed.

In the example above, you can see the value by which the Max. daily and annual load was
changed for POI 15. For POIs 18 and 28, on the other hand, you can only see that the num-
ber of times with shadow impact monitoring have changed, but not how they have changed.

E After you have selected two projects in Area A, click this button to run the comparison.

F You can load an SM4 project set as project A or B either into the current SM4 instance or
into another instance by right-clicking in one of the white areas.
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4.8.11 WTG Types window

Purpose List possible WTG types 

Path Tools > WTG Types 

Prerequisites -

Type of use Display only

Reference Project

All WTG types that can be selected in the Add/Edit WTG window are listed in this window and can
be selected by pressing the corresponding button. 

WTG Types window (section)

Notes on the window above

· The same information that is displayed in this window is displayed in the WTG Types window
that can be called up in the Add/Edit WTG window via the WTG Types button.

· The Select WTG Type button is shaded in grey here, as this window is only for the purpose of
display.

· In the Add/Edit WTG window, it is used to quickly select the presets specified for the respecti-
ve types (values that are always the same for every WTG type).
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4.8.12 Windows menu item

Purpose Reset window positions and screen detection 

Path Tools > Windows 

Reference Project

The Window menu item offers access to both of the following functions:

Function Explanation

Reset Window Positions SM4 takes note of the last position of the window when you close
windows or the entire application. This means that the next time you
open the same window, they will also be displayed in their previous
position. 

This will enable you to permanently arrange your working area the
way that is most convenient to you. 

You should only select Reset Window Position if you want to reset
the position of all windows to their respective default position.

Reset Screen Detection SM4 detects the number of monitors used and the set resolution.
This thus generates a type of “fingerprint”. The stored window posi-
tions are arranged according to this fingerprint. 

This is an especially interesting SM4 feature if you use the portable
version on two different computers. If you work on a computer with
one monitor, for example, and on another with two monitors,
Shadow Manager will detect this and use the last applied window
position for the respective system. 

The Reset Screen Detection menu item deletes all “fingerprints”
and the SM4 will then begin the detection process again.
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Help menu4.9

Symbol Window Description

NorthTec Homepage NorthTec Homepage

Check for New Version When this menu entry is selected, the software will automati-
cally check whether updates for Shadow Manager 4 are
available.

About Shadow Manager 4 Display of information on the software version, on NorthTec
(telephone number, address etc.) and on the operating
system used. 
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5 Appendix

The appendix contains information relating to the entire software or respectively entire manual/online
help.

Troubleshooting5.1

Should you encounter any problems when using Shadow Manager, please read the information in
this chapter. You will probably find the cause and solution for your problem right here.

Problem/ error message Possible cause and solution

The SMU cannot be accessed once a project
has been transferred.

(under SMU Connectivity (Tools > SMU
Connectivity) the system indicates “SMU not
available“)

The SMU is starting up, is switched off/not
available in the network etc. If this lasts longer
than a few minutes, the IP address stored in the
SMU might have (accidentally) been altered. In
this event, a NorthTec service technician will
have to determine the IP address of the SMU
on site.

SM4 indicates an incorrect user name and/or
password when trying to connect to the SMU
(File > Connect).

User name and/or password were not entered
correctly. Entries are case-sensitive:

 User name “John Doe” is different from “john
doe”.

A menu item has not been activated, although I
have established a connection to the SMU and
been assigned the access rights to the menu
item.

For activities involving editing rights, e.g. SMU
update, you are required to log on with a
dongle.

The input window for the menu item I selected
is not displayed.

The size of the SM4 main window has possibly
been reduced and the input window has opened
outside of the visible part. 

Check whether a scroll-bar has appeared on the
right or at the bottom of the SM4 screen that
allows you to move the visible part.

The background remains white when I select
OSM on the overview map. 

To use the OSM (Open Street Map) function,
your computer must be connected to the
Internet.

Although I can see the active alarms in the
Alarms window, I can’t click on the buttons.

The buttons only function if you have been
assigned the Alarm rights group and you logged
on using a dongle.

If this is not the case, you may only view the
alarms. (Observer rights group).



470Appendix > Troubleshooting

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

Problem/ error message Possible cause and solution

Send Configuration

The Send Configuration button is not
available (grayed out).

You have to purchase a dongle from us in order
to be able to configure an SMU with SM4. 

Edit Walls and Areas

When I enter the coordinates for the length of
a wall or the side of an area in the Edit Walls
and Areas window, the field in which these
coordinates are shown in meters is highlighted
in yellow. 

If the field Length of a wall or area in meters
(last 
field of the line) is highlighted in yellow (instead
of green), the entered values are not plausible
or the maximum length of a wall or side of an
area according to the warning limit (File >
Application Settings > Warning limits) has been
exceeded. Check that you have entered the
coordinates correctly. For further information,
please refer to the Warning limits  section.

Edit Walls and Areas

The coordinates I entered in the Edit Walls
and Areas window to define the length of a
wall or an area side are not plausible.  

The coordinates of all WTGs and POIs must be
defined using the same metric coordinate
system. You may have used figures based on
different coordinate systems. For further
information refer to the Edit Walls and Areas
sub window  section .

SM4 is not functioning as expected (data is not
shown, values cannot be entered etc.)

If SM4 does not operate as expected, consider
whether the reason for this could be the
application settings (File > Application Settings)
or the project settings (Project > Project
Settings).

EXAMPLE

You enter the value “3.0” for the “Hub distance”
in the Add/Edit WTG window but SM4 does not
accept the value (the field remains highlighted in
red). You have probably selected the decimal
separator “,” (decimal comma) under the
Country-specific settings in the Application
Settings.

“Internal Error:...”

or

“Error: ...”

Error messages starting with these words are
fatal errors that you cannot resolve yourself:

In this case, please contact NorthTec.

„Internal Error: Unknown Response-ID by
command”

This is a fatal error. 

Please note down the two numbers (x, y) and
contact NorthTec.

“The registered user does not have the
authorization required”

After this error message the connection to the
SMU will be disconnected. You should ask your
administrator to assign you the required right
group. 

80

139



471Appendix > Troubleshooting

Manual SM4.2.43.0 Rev. 1.0 - Modifications and Errors Excepted

Problem/ error message Possible cause and solution

The Wind Turbine Generators window
(Project > Wind Turbine Generators) displays
more WTGs than the Live Data: WTG Status
window (Realtime Data > WTG Status).

In the Wind Turbine Generators window,
WTGs that do not belong to the project’s wind
park may have been created in the project
(Project > Wind Turbine Generators), as there
are places of immission in the project at which
these "foreign" WTGs may cause shadow
impact. They therefore represent a so-called
“preload.

However, the Live Data: WTG Status window
only displays the number of these “foreign”
WTGs (see WTGs with pre-load that are not
displayed), because the SMU cannot
communicate with these foreign WTGs.
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Glossary5.2

Configuration

SM4 derives the configuration data for the SMU from the project created by the user (for one or
more WTGs or a wind park). The configuration therefore contains processed data from a project,
which the system for shadow impact monitoring and species conservation needs to carry out its
monitoring functions. When preparing the project data for configuration, unneeded telephone
numbers and addresses, for example, are removed and some data are converted.

The project file and the SMU configuration contain the same information for the shadow impact
scenario.

External triggers

“External triggers” were introduced in SM4 as a way of allowing users to remotely control
shutdowns or other processes in a convenient yet IT-safe manner. In simple terms, external
triggers are software versions of digital inputs (hardware), as they perform the same function.
They are, therefore, also located in the same place in SM4 (Hardware > Sensors and IO Signals).
The best application example is the so-called mowing shutdown where farmers can use a
smartphone app to independently shut down WTGs during harvesting work that attracts large
birds. For this purpose, defined triggers are assigned user rights in SM4 and then included as
shutdown triggers in special shutdowns.

Legend

To be able to interpret log data correctly, SM4 always requires the respective SM4 project file.
This file contains, for example, street names, comments, and other information about a POI. The
information contained is not relevant to the SMU for calculating the shadow impact scenario but is
supplied to the SMU with every configuration process, nonetheless. The SMU does not touch the
SM4 project file but stores it as a file with the current timestamp, where the timestamp prevents
older project files from being overwritten. When logs are downloaded, these project files are
automatically included. They are called "legends" in SM4 and can be exported or printed together
with the log data if required (see also Operation Log/Shadow Impact Log/Shutdown Log sub
windows ).

Power Threshold

One of several ways to reduce revenue losses in SM4 is by defining a power threshold for every
combination consisting of a WTG and the surrounding buildings (places of immission). If a WTG is
operated below this power threshold while causing shadow impact in a place of immission, the
respective WTG is shut down immediately. While a WTG is running above the power threshold, the
permitted periods of shadow impact will be exploited. Thus, the shadow impact budget will be
reserved for times when the WTG can operate at a higher power output. See WTG Combinations
sub window.

365
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Place of Immission (POI)

Places of immission are buildings on which a wind turbine generator causes shadow impact; these
can be defined in Shadow Manager using co-ordinates.

Project

To ensure the system for shadow impact monitoring and species conservation can fulfill its most
important task, namely shutting down wind turbine generators because of shadow impact or bat
protection etc., it is necessary that data specific to the project is first created in SM4.

To do so, a project is created or an existing one is opened in SM4. The project contains all data
and settings relevant to a specific wind park or its SMU and the connected sensors (e.g., the
SMU’s port number/IP address, coordinates of the WTGs/POIs, shutdown periods). If a project is
complete and inherently consistent, SM4 is then able to derive the configuration data for the SMU.
The project and the configuration data are then encrypted and transferred to the SMU. Once it is
there, the SMU stores the project as a file and is then configured according to the configuration
data. Only then is it possible for it to fulfill its main task: shutting down and (restarting) WTGs
according to the specifications of the authorities and other factors (e.g., yield optimization).

Shadow range

The shadow range is the distance between a WTG and a POI up to which perceptible shadow
impact is deemed possible. If the distance between a WTG and a POI is greater than this range, it
is assumed that any shadow impact caused at the POI will not be perceived (as disturbing). When
determining shadow range, SM4 uses the blade data provided by the respective WTG
manufacturer to calculate the point at which 20% of the face of the sun will be obscured (German
20% obscuration criterion). According to the German guideline, the arithmetic mean between the
maximum blade depth and the blade depth at 90% of the  rotor radius is used as the mean blade
depth, since the blade depth decreases towards the rotor tip. As an alternative, a rectangular rotor
blade with a mean blade depth is calculated as follows:

Average blade depth = ½ (max. blade depth + min. blade depth at 0.9*rotor radius)

Shadow Impact Budget

Approving authorities usually require that daily and annual shadow impact limits are complied with
for buildings located in the vicinity of wind parks. In Germany for example, the actual shadow
impact duration for a POI is limited to 30 minutes per day or 8 hours per year. From a wind farm
operator's perspective, this duration is a budget that is to be fully exploited.

Shadow Master Unit (SMU)

The SMU is located in the WTG or in the hand-over station; it logs the calculated as well as the
actual shadow impact caused at the monitored buildings and also the shutdown periods of the
WTGs. The logs can be read out via a network interface. The SMU takes over the following tasks:

· calculates shadow impact periods on the buildings to be monitored
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· retrieves light sensor data

· communicates with wind turbine generators (WTG) 

· stops the relevant WTG if the shadow impact limit has been exceeded

· automatically shuts down WTGs according to specified time periods and meteorological
conditions (protection of bats)

· records all shadow impact and WTG shutdown events forecasts possible shadow impact

Sensor Node Units (SNU)

Optional hardware for connecting sensors by means of up to five RS485 cards per SNU; several
sensors can be connected to each bus. A SNU encrypts sensor data so that it can be transmitted
over existing connections (Internet) over long distances in a cost-effective AND cyber-secure man-
ner.

Watchdog

Time relay for external error notification. The watchdog is generally triggered by the master unit
and subsequently sends feedback signalizing that everything is ok. If, for example, the master unit
determines that a light sensor is defect, i.e., if it is not sending any data, it doesn’t trigger the
watchdog and subsequently this can externally signalize a defect. An entry is made to the log and
a red light flashes in the SMU cabinet. The following errors can be registered using this system:

· sensor defect

· WTG does not react to stop commands

· WTG is not sending any data

· the SMU is in a non-definable operating status (crashed) the SMU has been switched off by an
unauthorized party

Windfarm Communication Unit (WCU)

A mixture of SMU and SNU.

· Just like a SNU, a WCU can transmit data from up to five RS485 buses to the SMU via an IP
network; multiple sensors can be connected to each bus.

· A WCU summarizes and encrypts communication between individual segments (often individual
wind farms) so that data can be forwarded to a SMU in a cost-effective (Internet) AND cyber-
secure manner.

· A WCU features a backup shutdown calendar to ensure reliable compliance with e.g., the shut-
down conditions for species conservation in the event of communication failures without having
to shut down all WTGs completely.

· A WCU can write its own logs.
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Worst case 

With regard to the NorthTec system for shadow impact monitoring & species conservation, "worst
case" means that the rotor points towards the sun, or, when considering a time course, always
follows the sun, while the direct sunlight is so strong that shadow impact effects can occur. 
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