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Preface 
 

This document describes the tasks and functionality of the SMU Auto Logs  software. 

SMU Auto Logs is used to automatically download logs from the Shadow Master Unit V4 (SMU) of our 
system for shadow impact monitoring and species conservation and export the most important data to 
a CSV file.  

For more information on the SMU, please refer to the latest version of the Shadow Manager 4 manual, 
which you can download from our website. 

Since SMU Auto Logs provides a multitude of setting options, and although we have designed the 
user interface to be user friendly with intuitive operation, you will need to consult this manual from time 
to time, particularly as a beginner and maybe even as an experienced user. 

Please read the information in this manual that is relevant to you carefully so that you can use SMU 
Auto Logs the best way possible and as intended by the manufacturer.   

  



 

 

Status as of 09/2021 ï Modifications and Errors Excepted   

Table of Contents 

1. ABOUT THE MANUAL 5 

1.1 Manual conventions 5 
1.2 Abbreviations 5 
1.3 Digital navigation aids 5 
1.4 Trademarks 6 
1.5 Copyright and warranty 6 

2. INTRODUCTION 7 

2.1 Basic information on SMU Auto Logs 8 
2.1.1 The main window 8 
2.1.2 Requirements and installation 9 
2.1.3 Notes on the working environment 9 
2.1.4 General software properties 9 

3. MENUS, WINDOWS AND TABS 10 

3.1 File menu 11 
3.2 View menu 11 

3.2.1 Connections window 12 
3.2.1.1 Schedule tab 14 
3.2.1.2 Communication tab 15 
3.2.1.3 Download tab 20 
3.2.1.4 Export tab 21 
3.2.1.5 Filter tab 22 

3.2.2 Monitoring window 24 
3.2.2.1 Upper table in the Monitoring window 25 
3.2.2.2 Lower table in the Monitoring window 27 

3.2.3 Change Password window 29 
3.2.4 User Management window 30 

3.3 License menu 32 
3.3.1 License Management window 32 

3.4 Settings menu 33 
3.4.1 Program window 34 
3.4.2 Language menu item 35 

3.5 Help menu 36 
 
 



 
SMU Auto Logs 1.0.0.0 ï Manual, Rev. 1.3   
 

Status as of 09/2021 ï Modifications and Errors Excepted   5 

1. About the manual 

This manual documents the range of functions of SMU Auto Logs, a software for the automated 
readout, backup and export of logs from a Shadow Master Unit (SMU).  

We have designed the SMU Auto Logs user inte rface to be user friendly and intuitive to operate so 
that experienced users will be able to perform many tasks even without the manual.  

If you are not yet familiar with SMU Auto Logs, please carefully read through the relevant information 
in this manual to ensure that SMU Auto Logs always operates correctly.  

 

1.1 Manual conventions 

The following conventions apply in this manual: 

Designation Meaning 

Bold 
The names of menus, windows, buttons etc. are written in bold. 

Example: Open the Connections window.  

Bold type is also used to highlight important parts within a text block. 

Italics, blue 
Path names are written in blue and italics. 

Example: View > Connections > Schedule 

 
This symbol identifies a cross reference. Click on the text or the number after 
the red arrow to jump to the target of the cross reference.  

  

1.2 Abbreviations 

The following abbreviation is used in this manual: 

Fig. Term Meaning 

SMU Shadow Master Unit The central unit of the system for shadow impact 
monitoring and species conservation. 

 

1.3 Digital navigation aids 

If you read this manual in digital form on a screen, in many places you can click on a cross reference 
to jump directly to a section with further information. Cross references are marked with a red arrow . 
In PDF Reader, you can also display the content at the left-hand side of the window and use it to 
navigate.  
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1.4 Trademarks 

Windows, Microsoft, Microsoft Office and Excel are brands or registered brands of Microsoft 
Corporation in the USA and/or other countries. 

 

1.5 Copyright and warranty 

Copyright © 2021 NorthTec GmbH & Co. KG 

All rights reserved. 

We have prepared this manual with due care and checked it carefully, but we cannot guarantee that it 
is free of errors.  

Furthermore, NorthTec GmbH & Co. KG reserve the right to make changes to this manual or the 
products described therein at any time without notice. NorthTec GmbH & Co. KG will not be liable for 
any loss or damage arising directly or indirectly (including special, incidental or consequential loss or 
damage) from the use of this manual or the products described therein. 
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2. Introduction 

SMU Auto Logs is used to automatically download and backup available logs from the Shadow Master 
(SMU). The following logs can be downloaded depending on the SMU version used: 

 

SMU version Downloadable logs 

V.3.5 Shadow impact logs (plus bat and bird protection logs as far as available) 

V.4.0 ¶ Operation log 

¶ Shadow impact log 

¶ Bat protection 

¶ Bird protection 

¶ Sector shutdown 

¶ Noise protection 

¶ Special shutdown 

¶ Measurement data logging (customer-defined) 
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2.1 Basic information on SMU Auto Logs 

Here you will find basic information about the software, such as layout, menu structure and 
requirements for use. 

 

2.1.1 The main window  

SMU Auto Logs consists of a main window (see below), in which various subwindows can be loaded. 

 

  

 

Fig.: SMU Auto Logs main window  

 

Element Description 

A: Menu bar Access to all menus, menu items, functions and subwindows. 

B: Toolbar Access to frequently used functions and sub windows. 

C: Views Opened subwindows are displayed in this area. 

D: Status bar The status bar is always visible. It shows which user is logged on and how 
many minutes are left until they are automatically logged out. 

  

A 

B 

C 

D 
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2.1.2 Requirements and installation 

The latest version of SMU Auto Logs can be downloaded from our website (www.northtec.de). You 
can choose either the unzipped version (.exe) or the zipped version (.zip). 

The software runs as a desktop version. 

The following technical requirements must be fulfilled before using SMU Auto Logs: 
 

Requirement Description 

SMU Shadow Master Unit 3.5 or 4.0 or later 

PC ¶ a minimum of 2 GB RAM  

¶ at least 100 MB free hard disk space  
(depending on the size of the downloaded logs) 

¶ network port/internet connection 

Operating system SMU Auto Logs runs on computers with Windows 7 or later Microsoft 
operating systems  

Rights No administrator rights required 

License To enable the SMU Auto Logs to be used to its full extent, purchase a 
license file from us, which we will then send to you. 

To install SMU Auto Logs, double-click the downloaded .exe file and then follow the on-screen 
instructions. Once the installation is complete, the program will open with the Login window. 

Enter the credentials of the default user created automatically: 

User:  admin 

Password:  1234 

Now you can use SMU Auto Logs as described in this manual. 

 

2.1.3 Notes on the working environment 

The menu structure, the assignment of the mouse keys and the design of the application are based on 
the standard Windows interface and the corresponding operating elements. The operator should be 
familiar with this structure.  

If you are not familiar with using Windows, please get up to date with basic Windows operations (using 
a mouse, menu technique, changing sizes of windows etc.). 

 

 

2.1.4 General software properties 

If you enter an invalid value into an input field (incorrect value or incorrect input format), it will be 

displayed highlighted in red:  

You can press the Enter key or the Tab key to complete the current entry and jump to the next input 
field. 

Some buttons, such as Apply and Add, will not be activated in some windows until the mandatory 
fields of the window have been filled out correctly. 

 

http://www.northtec.de/
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3. Menus, windows and tabs 

The views in SMU Auto Logs are arranged in menus and can be called up through them. Some 
windows and functions can be opened directly by clicking the corresponding button in the toolbar of 
the main window. The function of individual symbols will be displayed if you hover the mouse cursor 
over them for a moment, see below figure.  

 

  

Fig.: Symbols in the SMU Auto Logs main window (with tool tip) 

 

The following table provides you with an overview of the content of the individual menus. 
 

Menu/ menu item   What you can do there 

File 

Exit 

 

¶ Exit program 

View  

Connections 

 

¶ Define download schedule 

¶ Display/edit a connection to the SMU 

¶ Select logs to be downloaded 

¶ Set storage destination for log export 

¶ Define filters for individual logs 

 

Monitoring 

 

¶ Monitor connection status and view logged events 

 

Change password 

 

¶ Change the password for unlocking SMU Auto Logs  

User Management ¶ Change, add or delete SMU Auto Logs  users, 
assign/delete admin rights 

License 

License Management 

 

¶ Display/load/close the license file 

Settings 

Program 

Language 

 

¶ Set session timeout, check for updates 

¶ Program language 

Help 

NorthTec Homepage 

Check for New Version* 

Info about SMU Auto Logs 

 

¶ Open NorthTec Homepage 

¶ Check for new version of SMU Auto Logs  

¶ Information about SMU Auto Logs, NorthTec contact 
details, system information and information about the  

memory usage 
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The menus are described in detail in the following sections. 

3.1 File menu 

 

Symbol  Menu item Purpose  

 
Exit Exit SMU Auto Logs 

 

 

3.2 View menu 

 

The following table provides you with an overview of the View menu.  

 

Symbol Menu item Purpose 

 

Connections  ¶ Define download schedule 

¶ Display/edit a connection to the SMU 

¶ Select logs to be downloaded 

¶ Set storage destination for log export 

¶ Define filters for individual logs 

 

Further information can be found on the next page. 

 

Monitoring Monitor status of connections and logged events, see 

section  3.2.2. 

 

Change password Change password to unlock SMU Auto Logs , see 

section  3.2.3. 

 
User Management Change, add or delete SMU Auto Logs  users, assign/delete 

the admin right, see section  3.2.4. 

 

The View menu windows are described in detail in the following sections. 
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3.2.1 Connections window 

Purpose ¶ Define the download schedule 

¶ Display/edit a connection to the SMU 

¶ Select logs to be downloaded 

¶ Set the storage destination for log export 

¶ Define filters for individual logs 

Symbol 
 

Path View > Connections 

Type of use Display + dialog 

Requirement Logged on user 

 

 

  

Fig.: Connections window 

Notes regarding the Connections window  

¶ Connections to SMUs that have already been set up are listed in area A. 

¶ The data of the connection currently selected in area A is displayed in area B (Connection data). 

Further information can be found in the table on the next page. 

¶ In area C, you can select the tabs for editing the readout provisions. For more information on the 

individual tabs, see the subsections on the following pages. 

  

A 

B 

C 
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Information and setting options in the Connection data area: 

In the explanation of the parameters, you will find information on default settings, input format, range, 
etc. as applicable (highlighted in green). 

Parameters Explanation 

SMU type V3.5 and V4.0 are supported.  

For SMU type V3.5, some settings are disabled (User name and 
Password, see below, as well as the Download and Filter tabs). 

Project name Can be entered individually, but must not be assigned twice; otherwise 
the field will be highlighted in red and the Apply button will be 
deactivated. 

NOTE 

"Project one" and "Project One" are considered to be different project 
names. 

SMU Serial Number Can be entered individually, but must not occur twice; otherwise the field 
will be highlighted in red and the Apply button will be deactivated. 

NOTE 

Serial numbers stored in a loaded license file can either be selected here 
or are automatically completed once the first characters have been 
entered. 

User name Must be stored at the SMU to be addressed. This input field is only 
available for SMU type V4.0. 

Password Must be stored at the SMU to be addressed. This input field is only 
available for SMU type V4.0. 

IP address IP address of the SMU you want to communicate with. 

4 numbers, separated by a point, example: 192.0.2.42 

Port The port number of the SMU you want to communicate with. 

number from 1 to 65535 

 

Used to remove the connection currently selected in the Connection area 
at the top of the window. 

 

In order for entries to be applied, you must click Apply before selecting 
another connection/window or before you exit SMU Auto Logs. 

 

This button for adding a new connection is only active if all fields 
described above have been filled in correctly. 
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3.2.1.1 Schedule tab 

Purpose Set/edit schedule for downloading and exporting logs 

Path View > Connections > Schedule 

Type of use Display + dialog 

Requirement Logged on user 

 

 

Fig.: Connections window, Schedule tab 

 

Information and setting options in the Schedule tab:  

In the explanation of the parameters, you will find information on default settings, input format, range, 
etc. as applicable (highlighted in green). 

Parameters Explanation 

Start time Here you define the time at which a procedure is to be started.  

Input format: 24-hour format 

Cycle Here you define the cycle at which a procedure is to be repeated. 

Value range: 4 to 23 

 

In order for entries to be applied, you must click Apply before selecting a 
different tab/connection or before you exit SMU Auto Logs. 

Daily schedule 
preview 

The result of the entries you made under Start time and Cycle is 
displayed here. 
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3.2.1.2 Communication tab 

Purpose View and edit data for the connection to the SMU 

Path View > Connections > Communication 

Type of use Display + dialog 

Requirement Logged on user, SMU type V4.0 

(Only the parameters Connection timeout, Connection retries and Read 
command timeout are available for SMU type V3.5). 

 

Fig.: Connections window, Communication tab 

 

The input fields available in the Communication tab are explained on the next page. 
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Input fields in the Communication tab:  

The parameters in this input area correspond to the connection that has been established between 
SMU Auto Logs and the SMU.  

In the explanation of the parameters, you will find information on default settings, input format, range, 
etc. as applicable (highlighted in green). 

Parameters Explanation 

Connection timeout This timeout is used to monitor the initial setup of a connection to a 
SMU. As soon as a time defined in the Schedule tab (View > 
Connections) has been reached, SMU Auto Logs will attempt to connect 
to the addressed SMU via the network, but only for as long as specified 
under Connection timeout. If a connection cannot be established 
during this time and the number of connect retries has been ñused upò, 
the attempt will be aborted. 

Factory default: 4000 ms 

 

Changing this value will take the following effects:  

INCREASE VALUE 

¶ SMU Auto Logs will try to connect to the SMU over a longer 
period of time. 

DECREASE VALUE 

¶ SMU Auto Logs will abort the attempt to establish a connection 
sooner. 

Connection retries When establishing a connection to the SMU, the connection attempt is 
retried for as many times as specified here and until a connection is 
actually established.  

Factory default: 1 

 

Changing this value will take the following effects: 

INCREASE VALUE 

¶ If a connection attempt fails, SMU Auto Logs automatically carries 
out the number of further attempts specified here. 

Time between 2 
attempts 

After an attempt to connect has failed, SMU Auto Logs will wait as long 
as specified here before a new attempt is made (provided that more 
than 1 attempt has been specified under Connection retries). 

Factory default: 4000 ms 

 

Changing this value will take the following effects:  

INCREASE VALUE 

¶ SMU Auto Logs will wait longer before a new attempt is started; 
this may reduce the number of unsuccessful attempts, however, it 
may take longer to re-establish a connection. 

DECREASE VALUE 

¶ After a connection attempt has failed, SMU Auto Logs will start a 
new attempt sooner; thus, the number of unsuccessful attempts 
may increase, but the connection may be restored faster. 
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Parameters Explanation 

Read command 
timeout 

This parameter is identical to the Connection timeout parameter in 
terms of its functionality, however, it applies to all other commands (all 
commands except the one for establishing a connection). 

This timeout monitors the time between sending a command to the SMU 
and receiving a response. The value should mainly depend on the 
commands with the longest processing times and on the transmission 
time of TCP packets from SMU Auto Logs to the SMU and back. 

If SMU Auto Logs, after sending a command, does not receive a 
response for the period specified here, SMU Auto Logs will assume that 
the connection to the SMU has been lost. 

Factory default: 16000 ms 

 

Changing this value will take the following effects:  

INCREASE VALUE 

¶ SMU Auto Logs will wait longer, after sending a command, until it 
assumes that the connection to the SMU has been lost due to the 
absence of a response.  

DECREASE VALUE 

¶ If SMU Auto Logs, after sending a command, does not receive a 
response, it will be quicker to assume that the connection to the 
SMU has been lost. 

Delay between 2 
commands 

This parameter determines as to how long SMU Auto Logs, after a 
command has been responded to, will wait until a new (different) 
command is sent. This will prevent the SMU from getting overloaded. 

Factory default: 100 ms 

 

Changing this value will take the following effects:  

INCREASE VALUE 

¶ After sending a command, you will have to wait longer before the 
next command can be executed. This way, you can avoid 
overloading the SMU. 

DECREASE VALUE 

¶ After sending a command, you can execute the next command 
sooner. However, this can lead to the SMU getting overloaded. 
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Parameters Explanation 

Login refresh interval The only way for SMU Auto Logs and the SMU to reliably determine 
whether the connection between them still exists is on the basis of "life 
signs" from their connection partner.  

However, if nothing has been transmitted over a certain period of time, 
SMU Auto Logs will start a mechanism that sends a ping command to 
the SMU at regular intervals and receives the corresponding ping 
response.  

This parameter is used to control as to when and how often this 
mechanism is activated. As long as no data commands are sent from 
SMU Auto Logs to the SMU, the sending of ping commands is repeated 
regularly at the interval specified here.  

This prevents the SMU from falsely assuming that it is still involved in a 
connection that has long been interrupted (e.g. termination due to a 
malfunction in the VPN tunnel) and that it is therefore not available for a 
new connection (only one connection can exist at a time). 

This parameter must match the Session timeout parameter, which 
controls as to how long the SMU will wait for an ñempty commandò: The 
value on the SMU side (Session timeout) must be higher than the 
value on the SMU Auto Logs side (Login refresh interval) to ensure 
that SMU Auto Logs definitely sends a command before the SMU 
assumes that the connection has been interrupted.  

 

Factory default: 3000 ms 

 

Changing this value will take the following effects:  

INCREASE VALUE 

¶ The monitoring mechanism starts later and the ping commands 
are sent at longer intervals. If a connection has been lost, the 
SMU will take longer to get ready for new connections.  

DECREASE VALUE 

¶ The monitoring mechanism starts earlier and the ping commands 
are sent at shorter intervals.  

Command repetitions This parameter determines as to how often the command is repeated.  
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Parameters Explanation 

Read file operation 
timeout 

Commands that affect the SMU file system (e.g. delete file, request 
directory) will trigger actions on the SMU that take some time to 
complete, which also means that it may take some time until a response 
is sent back to SMU Auto Logs. Therefore, with actions like these, SMU 
Auto Logs has to wait a relatively long time for a response. 

The Read file operation timeout parameter is used to make sure SMU 
Auto Logs waits for a response as long as file operations usually take to 
be completed. 

The value should be based on the maximum period of time the SMU 
takes to complete a file operation. The transmission time of the channel 
is so short that it can be neglected. 

 

Factory default: 360000 ms 

 

Changing this value will take the following effects:  

INCREASE VALUE 

¶ SMU Auto Logs, after having sent a file command and if there is 
no answer from the SMU, will wait longer before it assumes that 
its connection to the SMU has been lost.  

DECREASE VALUE 

¶ If SMU Auto Logs, after sending a file command, does not receive 
a response, it will be quicker to assume that the connection to the 
SMU has been lost. 

FSP timeout For data transfers (FSP: File Stream Protocol; download of files) there is 
a separate timeout as these tasks usually take longer to be completed 
than others.  

Here, too, the value should depend on how long the SMU takes to 
complete the respective action. Delays due to the connection channel 
do not play a major role. 

Factory default: 120000 ms 

 

Changing this value will take the following effects:  

INCREASE VALUE 

¶ SMU Auto Logs, after having sent an upload/download command 
and if there is no answer from the SMU, will wait longer before it 
assumes that its connection to the SMU has been lost.  

DECREASE VALUE 

¶ If SMU Auto Logs, after sending a an upload/download command, 
does not receive a response, it will be quicker to assume that its 
connection to the SMU has been lost. 

 

For entries to be applied, you must click Apply before selecting another 
tab/connection/window or before you exit SMU Auto Logs. 

 

  



 
SMU Auto Logs 1.0.0.0 ï Manual, Rev. 1.3   
 

Status as of 09/2021 ï Modifications and Errors Excepted   20 

3.2.1.3 Download tab 

Purpose Set/edit log download schedule 

Path View > Connections > Download 

Type of use Display + dialog 

Requirement Logged on user, SMU type V4.0 

 

Fig.: Connections window, Download tab 

 

Setting options in the Download tab:  

In the explanation of the parameters, you will find information on default settings, input format, range, 
etc. as applicable (highlighted in green). 

Parameters Explanation 

Selection behavior 
(months) 

Here you specify the months whose logs are to be downloaded. 

The drop-down list offers 3 options: 

 

¶ Current month only 

¶ Current and additional <X> months 

¶ All available months 

 

If you select the second option of the drop-down list, you must specify the 
value for X in the next input field. 

Number of additional 
months 

If you selected the second option in the drop-down list above (Current 
and additional <X> months), you must set the value for X here. 

Value range: 1 to 999 

 

For entries to be applied, you must click Apply before selecting another 
tab/connection/window or before you exit SMU Auto Logs. 
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3.2.1.4 Export tab 

Purpose Set storage destination/behavior for exported logs 

Path View > Connections > Export 

Type of use Display + dialog 

Requirement Logged on user 

 

 

Fig.: Connections window, Export tab 

 

 

Information and setting options in the Export tab  

Parameters Explanation 

Storage location Here you specify the path for the storage destination of the export files. If 
the specified directory does not exist, it will be created when the files are 
exported.  

The following default path will be selected if the directory cannot be 
created:  

 

<path to SMUAutoLogs.exe file/Export/<project name> 

 

Storage behavior The drop-down list offers 2 options: 

 

¶ Export files to one folder 

¶ Export files to subfolder 

 

If you choose the second option, you will have to create the Export folder 
yourself, while the subfolders will be created automatically (including the 
subfolders intended for each log). 

 

For entries to be applied, you must click Apply before selecting another 
tab/connection/window or before you exit SMU Auto Logs. 
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3.2.1.5 Filter tab 

Purpose Define event filters for the selected log type. 

The filter settings only apply to the SMU currently selected. 

Path View > Connections > Filter 

Type of use Display + dialog 

Requirement Logged on user, SMU type V4.0 

  

 

Fig.: Connections window, Filter tab 

 

 

Options in the Filter tab:  

Parameters Explanation 

Event filter Selection of the log type whose event filter is to be changed: 

¶ Shadow impact log 

¶ Bat protection 

¶ Bird protection 

¶ Sector shutdown 

¶ Noise protection 

¶ Special shutdown 

Default selection If you have changed one of the 6 predefined event filters, you can click 
this button to reset the currently selected event filter to its predefined 
state. 
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If you click this button, the Copy Event Filter subwindow opens: 

 

Here you can select filters of the current 
connection and easily copy them to other 
connections. 

 

To do this, place a check mark for the 
filters to be copied in the upper half and a 
check mark for the connections into which 
you want to copy the filters in the lower 
half. 

 

Then click on Copy. 

 

In order for entries to be applied, you must click Apply before selecting 
another tab/connection/window or SMU Auto Logs exit. 
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3.2.2 Monitoring window 

Purpose Monitor the status of connections and view logged events 

Symbol 
 

Path View > Monitoring 

Type of use Display + dialog 

Requirement none 

 

 

Fig.: Monitoring window (section) 

 

Notes regarding the window above 

¶ The upper table displays an overview of the added connections including their current status. 
Double-click on a connection to display the events logged for this connection in the table below. 

¶ The lower table displays the following depending on the selection: 

- the logged events of one active connection 

OR  

- all errors and warnings of all connections 

OR  

- notifications for all connections. 

 

The next page first explains the information in the upper table, followed by a description of the lower 
table and the buttons. 
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3.2.2.1 Upper table in the Monitoring window  

To access the Monitoring window, select View > Monitoring or click . 

The upper table displays an overview of the added connections including their current status.  

Double-click on a connection to display the logged events of this connection in the lower table. 

The following figure showed an example of a table with four connections added. 

 

 

 

Fig.: Upper table in the Monitoring window 

 

 

The individual columns of the table are explained in the following overview: 

Column Explanation 

Info SMU type, project name and SMU serial number as defined in the 
Connections window. 

Procedure 

(includes all work 
steps) 

Procedure refers to the set of steps (License, Connect, List, etc.) listed in 
the columns to the right of the Procedure column and explained later in this 
table. 

A procedure is triggered whenever a point of time specified in the schedule 
(View > Connections> Schedule) has been reached. 

The following can be displayed under Current Status: 

¶ Pending: Waiting for the next start of a procedure  

¶ Progress: Procedure or work step is currently active 

¶ Error: An error has occurred in one of the steps of the procedure (to 
determine the exact step, check for another column in which Error is also 
displayed). 

¶ Finished: This status is only displayed for a single work step that has 
been completed. 

The Start and End columns indicate as to when a procedure was started 
(depending on the schedule) and when the corresponding data was saved to 
CSV files or respectively when the procedure was terminated by an error. 

Once a procedure has been completed, the status messages of the work 
steps are retained so that you can see whether the last procedure was 
carried out successfully or, if not, the work step in which an error occurred. 

The individual steps are explained from here on ... 

License This step checks whether the license for the connection is valid or whether a 
license exists. 

Connect 

 

SMU Auto Logs attempts to connect to the SMU. 
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Column Explanation 

List* Downloadable log files are identified and prepared for selection. 

Select* Log files to be downloaded are selected. 

Download Log files are being downloaded. Once all files have been downloaded, SMU 
Auto Logs logs out of the SMU. 

Evaluate The downloaded log files are evaluated and exported month by month. 

Export The most important data of an evaluated monthly log file are stored in a CSV 
file. 

*With SMU type V3.5, the progress is always set to 100% immediately here.  



 
SMU Auto Logs 1.0.0.0 ï Manual, Rev. 1.3   
 

Status as of 09/2021 ï Modifications and Errors Excepted   27 

3.2.2.2 Lower table in the Monitoring window  

To access the Monitoring window, select View > Monitoring or click . 

¶ The lower table displays the following depending on the selection made: 

- the logged events of one active connection 

OR  

- all errors and warnings of all connections 

OR  

- notifications for all connections. 

 

Double-click on a connection to display the logged events in the lower table. 

The following figure shows an example of a table with four added connections. 

 

 

 

Fig.: Lower table in the Monitoring window 

 

The columns of the table carry self-explanatory names.  

The following overview explains the available buttons. 

Button Explanation 

 

This button displays the logged events of a connection. In order for the logged 
events to be displayed, a connection must be selected from the table above. 

Double-clicking on a connection in the upper half of the window takes the same 
effect. 

 

Displays all logged errors and warnings of all connections. No connection needs 
to be selected for this button to take effect. 

 

 

Notifications lists all errors and warnings that have been logged since the 
Reset button was last pressed. 

Clicking  in the menu bar takes the same effect. 



 
SMU Auto Logs 1.0.0.0 ï Manual, Rev. 1.3   
 

Status as of 09/2021 ï Modifications and Errors Excepted   28 

Button Explanation 

 

This button is used to "reset" the accumulated notifications. 

After clicking this button, the red circle with the exclamation mark display at the 

Notifications icon () in the toolbar will disappear. 

 

If you now click Notifications again, nothing will be displayed unless new errors 
or warnings have been logged since you clicked Reset. 
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3.2.3 Change Password window 

Purpose Change the password of the currently logged in user 

Path View > Change Password   

Type of use Dialog  

Requirement Logged on user 

 

In this window the currently logged in user can change their password.  

 

Fig.: Change Password window 

 

To change the password, first enter the old password, then enter the new password twice and click on 
Change. 
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3.2.4 User Management window 

Purpose Edit, add or delete SMU Auto Logs  users 

Assign/delete user rights  

Path View > User Management   

Type of use Display + dialog  

Requirement Admin right 

 

 

In this window, users with admin rights can add, edit or delete other users and also assign/delete the 
admin right. 

 

 
 

Fig.: User Management window  

 

Users that have already been assigned are displayed in the upper half of the window while editing 
takes place in the lower half. 

 

Information and setting options in the User Management window 

Input field/ 
button 

Explanation 

User Input any character 

Password Input any character; note the following information in the window: 

 

Description This field has no defined function, the text can be freely selected. 

Maximum number of characters: 80 

Admin If you check this box when creating a user, the future user will also be allowed to 
open the User Management window (= this window) and License 
Management window. 
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Input field/ 
button 

Explanation 

 

self-explanatory 

 
Removes the user selected in the list above 

 

Observe the following note in the window: 

 

 

see above 
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3.3 License menu 

The only item in the License menu is the License Management menu item. This item is explained in 
the following section. 

 

3.3.1 License Management window 

Purpose Display, load and close the license file 

Path View > User Management   

Type of use Display + dialog  

Requirement Admin right 

 

In this window you will find an overview of the licenses contained in the currently loaded license file. 
You can also close an "old" license file here and load a newly acquired one. 

 

 

 

Fig.: License Management window 

 

 

Notes on the above example 

¶ Numbers 1 and 9 expire shortly and cannot be renewed but must be replaced by new licences. 

¶ Licenses 2, 3, 7, 8 and 10 are licenses valid for an unlimited period. 

¶ Numbers 4, 5 and 6 are displayed in red because they have already expired. 

¶ Use the Open License File button to select a license file you want to load. 

¶ Use the Close License File button to remove the currently loaded license file. 
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3.4 Settings menu 

 

The following table provides you with an overview of the Settings menu.  

 

Menu item Purpose 

Program  ¶ Set session timeout 

¶ Check for updates 

Language ¶ Select the program language 

 

The Settings menu windows are described in detail in the following sections. 
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3.4.1 Program window 

Purpose Set session timeout, check for updates 

Path Settings > Program   

Type of use Display + dialog  

Requirement Logged on user 

 

 

 

 

Fig.: Program window 

 

Information and setting options in the Program window: 

In the explanation for the parameters, you will find information on default settings, input format, range, 
etc. as applicable (highlighted in green). 

Input field/ button Explanation 

Duration After the time specified here has elapsed, a logged-in user is logged out. 

Input: 5 to 60 minutes 

Active Only if a check mark has been set here, SMU Auto Logs automatically will 
check (in the background) every <x> hours whether a new version is 
available. 

All At the interval <x> specified here, the system automatically checks 
whether there are any updates for SMU Auto Logs. 

Input: 1 to 9000 hours  

 

  


